DuckDuckGo search icon is blurry, low resolution

Bug #1796397 reported by Wes on 2018-10-05
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Olivier Tilloy

Bug Description

Firefox 62.0+build2-0ubuntu0.18.04.5 amd64

To reproduce:
 - Set search engine to DDG
 - Go to the new tab page.

The DDG search icon is very low resolution and looks like it hasn't been updated with the new logo.

Expected: Use the icon built into Firefox

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: firefox 62.0+build2-0ubuntu0.18.04.5
ProcVersionSignature: User Name 4.15.0-34.37-generic 4.15.18
Uname: Linux 4.15.0-34-generic x86_64
AddonCompatCheckDisabled: False
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 1610 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 1610 F.... pulseaudio
BuildID: 20180913170256
Channel: Unavailable
CurrentDesktop: ubuntu:GNOME
Date: Fri Oct 5 15:46:16 2018
DefaultProfileExtensions: extensions.sqlite corrupt or missing
DefaultProfileIncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
DefaultProfileLocales: extensions.sqlite corrupt or missing
DefaultProfilePrefSources: prefs.js
DefaultProfileThemes: extensions.sqlite corrupt or missing
EcryptfsInUse: Yes
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2018-09-12 (23 days ago)
InstallationMedia: Ubuntu 16.04.5 LTS "Xenial Xerus" - Release amd64 (20180731)
IpRoute:
 default via 192.168.1.1 dev wlp3s0 proto dhcp metric 600
 169.254.0.0/16 dev wlp3s0 scope link metric 1000
 192.168.1.0/24 dev wlp3s0 proto kernel scope link src 192.168.1.224 metric 600
MostRecentCrashID: bp-5252eef0-71dd-4e49-8315-64d660180929
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Profile1Extensions: extensions.sqlite corrupt or missing
Profile1IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
Profile1Locales: extensions.sqlite corrupt or missing
Profile1PrefSources: prefs.js
Profile1Themes: extensions.sqlite corrupt or missing
Profiles:
 Profile0 (Default) - LastVersion=62.0/20180913170256 (In use)
 Profile1 - LastVersion=62.0/20180913170346 (Out of date)
RunningIncompatibleAddons: False
SourcePackage: firefox
SubmittedCrashIDs:
 bp-5252eef0-71dd-4e49-8315-64d660180929
 bp-57477e57-d8dd-4ea9-ba66-270d80180929
 bp-821e4afc-cb3c-4fe2-a7ba-586440180929
 bp-8b4ffe0f-54ef-4969-b8fa-7d6bd0180929
UpgradeStatus: Upgraded to bionic on 2018-09-28 (6 days ago)
dmi.bios.date: 07/09/2018
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A17
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA17:bd07/09/2018:svnDellInc.:pnLatitude3340:pvr00:rvnDellInc.:rn:rvr:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude 3340
dmi.product.version: 00
dmi.sys.vendor: Dell Inc.

Wes (wesinator) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

The icon is the 16×16 base64-encoded image provided by DuckDuckGo themselves at https://duckduckgo.com/opensearch.xml.

Olivier Tilloy (osomon) wrote :

I tried replacing the Image entry in /usr/lib/firefox/distribution/searchplugins/locale/*/ddg.xml with a higher resolution icon, but this didn't seem to make a difference.

Changed in firefox (Ubuntu):
importance: Undecided → Medium
Olivier Tilloy (osomon) wrote :

It did, after removing the cached search data from my profile directory (~/.mozilla/firefox/XXXXXXXX.default/search.json.mozlz4).

Olivier Tilloy (osomon) wrote :

The firefox snap is also affected by this issue. It appears to be an upstream bug. Would you mind filing a bug at https://bugzilla.mozilla.org/enter_bug.cgi#h=dupes%7CFirefox and sharing the link to that bug here?

Wes (wesinator) wrote :

@osomon are you sure ?

The icon in /usr/lib/firefox/distribution/searchplugins/ ddg.xml is different than the one in https://hg.mozilla.org/mozilla-central/raw-file/tip/browser/components/search/searchplugins/ddg.xml , and it looks normal in Fedora 29.

Could the snap be loading the icon from the distro locale that has the old icon ?

T F (sirtb) wrote :

Hey it’s been two years I’m wondering if anyone knows the solution to this

Olivier Tilloy (osomon) wrote :

Not an upstream bug after all. I downloaded the latest release build, unpacked it in a clean VM and observed that the icon for DDG in the new tab page is reasonably high resolution, unlike the one in the Ubuntu builds.

Olivier Tilloy (osomon) on 2020-01-20
Changed in firefox (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
status: Confirmed → In Progress
Olivier Tilloy (osomon) wrote :
Changed in firefox (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 73.0+build1-0ubuntu1

---------------
firefox (73.0+build1-0ubuntu1) focal; urgency=medium

  * New upstream stable release (73.0+build1)

  [ Olivier Tilloy ]
  * Use a higher resolution icon for DuckDuckGo (LP: #1796397)
    - debian/searchplugins/ddg.xml

  [ Rico Tzschichholz ]
  * Update cbindgen to 0.13.0
    - debian/build/create-tarball.py
  * Drop browser/chrome.manifest which is not available or required anymore
    - debian/firefox.install.in
  * Bump build-dep on rustc >= 1.39.0 and cargo >= 0.40
    - debian/control{,.in}
  * Update patches
    - debian/patches/support-coinstallable-trunk-build.patch
    - debian/patches/ubuntu-ua-string-changes.patch
  * Fix build with C++17 on ppc platforms
    - debian/patches/ppc-drop-register.patch

 -- Olivier Tilloy <email address hidden> Tue, 04 Feb 2020 16:07:56 +0100

Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers