Firefox: View > Toolbars is Missing "Bookmarks Toolbar"

Bug #1758107 reported by Lonnie Lee Best on 2018-03-22
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
High
Chris Coulson

Bug Description

The "Bookmarks Toolbar" toggler is missing from the View > Toolbars menu in Firefox 59 on Ubuntu 16.04.4.

Video:
https://youtu.be/Josm0VqtUDQ

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: firefox 59.0.1+build1-0ubuntu0.16.04.1
ProcVersionSignature: Ubuntu 4.13.0-37.42~16.04.1-generic 4.13.13
Uname: Linux 4.13.0-37-generic x86_64
AddonCompatCheckDisabled: False
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: lonnie 1902 F.... pulseaudio
 /dev/snd/pcmC0D0p: lonnie 1902 F...m pulseaudio
 /dev/snd/controlC0: lonnie 1902 F.... pulseaudio
BuildID: 20180316021607
Channel: Unavailable
CurrentDesktop: Unity
Date: Thu Mar 22 11:42:51 2018
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2018-02-09 (41 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
IpRoute:
 default via 192.168.77.1 dev enp3s0 proto static metric 100
 169.254.0.0/16 dev enp3s0 scope link metric 1000
 192.168.77.0/24 dev enp3s0 proto kernel scope link src 192.168.77.252 metric 100
NoProfiles: True
RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/31/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.25
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 7001
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 35.35
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.25:bd05/31/2010:svnHewlett-Packard:pnHPPaviliondv8NotebookPC:pvr0499220000241210001040000:rvnHewlett-Packard:rn7001:rvr35.35:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.family: 103C_5335KV
dmi.product.name: HP Pavilion dv8 Notebook PC
dmi.product.version: 0499220000241210001040000
dmi.sys.vendor: Hewlett-Packard

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed

Can someone please take a look at this. It is also happening on my Uncle's 16.04.4.

It also happens when you run the unity 7 desktop on Ubuntu 18.04.

I suspect this bug is due to the fact that more priority for Firefox is no place on the GNOME desktop, where the bug doesn't happen in 18.04 (but does with Unity 7 on 18.04).

However, in 16.04 LTS, this bug should be fixed.

David M. (dmeireles) wrote :

Affected user here as well (Ubuntu 16.04 x86_64, all updates installed as of writing this comment). Happy to provide any debugging information needed to get this pesky bug squashed.

One other thing I noticed is that, when on the "Customise" screen, on the bottom of the window there'll be 3 buttons, specifically "Toolbars", "Themes" and "Density". Clicking on the toolbars button shows what appears to be a futile effort to display a list of possible toolbars, including the bookmarks one. It appears that the whole toolbar thing is actually broken, but the most obvious symptom is the bookmark toolbar option.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
cement_head (andor-udel) wrote :

I found a fix for me: Scroll halfway down the page and click on the blue REFRESH button

URL: https://support.mozilla.org/en-US/kb/what-happened-to-the-file-edit-and-view-menus

Daniel van Vugt (vanvugt) wrote :

Great video, thanks.

The menu in the top bar is actually displayed by the shell, and communicated from Firefox via 'libdbusmenu'. So I'm moving this bug there. It's not a theme issue.

summary: - View > Toolbars is Missing "Bookmarks Toolbar"
+ Firefox: View > Toolbars is Missing "Bookmarks Toolbar"
affects: ubuntu-themes (Ubuntu) → libdbusmenu (Ubuntu)

The cause of this bug is the unity-menubar.patch file, which Ubuntu and various other distros use to integrate firefox's menubar with Unity's, was updated but the context around that patch changed (ie Firefox changed) and the patch did not take that into account.

https://github.com/archlinuxcn/repo/blob/master/firefox-kde-opensuse/unity-menubar.patch#L5381

shows that the patch is trying to run the 'filter' method on `toolbarNodes`, but as of 59, `toolbarNodes` is no longer an array, it's just a list of child nodes, and so it has no `filter` method, and the call throws an exception.

To get this fixed someone needs to update that patch to enforce that it's using an array.

(sorry for the arch link, pretty sure Ubuntu is using the same debian patch, but I just spent 15 minutes trying to find a source link (online vcs rather than, say, a tarball which I obviously can't link into) that's used for ubuntu's package and can't, so...)

FWIW, the relevant Mozilla change in the surrounding code is https://bugzilla.mozilla.org/show_bug.cgi?id=1428938 .

Chris Coulson (chrisccoulson) wrote :

Thanks, but I fixed and (attempted to) prepared updates for this yesterday, although the builds failed because I missed some files out of the updated patch

no longer affects: libdbusmenu (Ubuntu)
Changed in firefox (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → High
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 59.0.2+build1-0ubuntu0.14.04.4

---------------
firefox (59.0.2+build1-0ubuntu0.14.04.4) trusty-security; urgency=medium

  * Fix LP: #1758107 - Cannot customize toolbars in Unity

 -- Chris Coulson <email address hidden> Tue, 03 Apr 2018 14:40:08 +0100

Changed in firefox (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 59.0.2+build1-0ubuntu0.16.04.3

---------------
firefox (59.0.2+build1-0ubuntu0.16.04.3) xenial-security; urgency=medium

  * Fix LP: #1758107 - Cannot customize toolbars in Unity

 -- Chris Coulson <email address hidden> Tue, 03 Apr 2018 14:04:39 +0100

Changed in firefox (Ubuntu):
status: In Progress → Fix Released
Aimo Ella (aimo-ella) wrote :

I am not sure it is fixed properly yet. The menu now opens and shows the bookmarks toolbar, but no other entries in the menu. I seem to remember there was also another toolbar in the menu before the bug appeared?

These were the 3 toolbars listed previously:

1) Menu Bar
2) Bookmarks Toolbar
3) Customize

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers