Firefox/Thunderbird/Libreoffice suite busy wait at startup on Wayland

Bug #1747276 reported by Erkin Alp Güney on 2018-02-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Unknown
firefox (Ubuntu)
Undecided
Unassigned
libreoffice (Ubuntu)
Undecided
Unassigned
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

Package firefox:
i 57.0.1+build2-0ubuntu1 bionic 500 << offending (main)
p 58.0.1+build1-0ubuntu1 bionic-proposed 500 << maybe offending
p 59.0~b6+build1-0ubuntu0.18.04.1 bionic 500 << offending (PPA)

Package firefox:i386:
p 57.0.1+build2-0ubuntu1 bionic 500
p 58.0.1+build1-0ubuntu1 bionic-proposed 500
p 59.0~b6+build1-0ubuntu0.18.04.1 bionic 500

Firefox waits forever without a GUI at startup. I can not even start the profile manager.

summary: - Firefox Quantum busy waits at startup
+ Firefox/Thunderbird busy wait at startup

Cannot use apport either as it fails with "firefox has been upgraded since you reported" error since I have not done any upgrades at that time.

Erkin Alp Güney (erkinalp9035) wrote :

Happens even with a clean profile.

Erkin Alp Güney (erkinalp9035) wrote :

Apport output for firefox(manually entered here as apport fails):
firefox 59.0~b5+build1-0ubuntu0.18.04.1
Bug
AddonCompatCheckDisabled: False
Apport: 2.20.8-0ubuntu8
amd64
Audio: irrelevant as not a sound related bug
BuildID: 20180201215627
Channel: Beta
Desktop: GNOME
Extensions: Dark Mode, IPFS companion, Greasemonkey (apport fails to list them)
Plugins: Flash
DistroRelease: 18.04
InstallationMedia: irrelevant as the system is fully upgraded over it three times
ProcVersionSignature: Ubuntu 4.13.0-32.35-lowlatency 4.13.13
Tags: third-party-packages bionic wayland-session-beta-channel

Erkin Alp Güney (erkinalp9035) wrote :

Apport output for thunderbird(manually entered again, the lines which are identical are eliminated):
thunderbird 1:52.6.0+build1-0ubuntu1
Tags: bionic wayland-session
Extensions: none (apport fails to detect)

Erkin Alp Güney (erkinalp9035) wrote :

Happens even in a live cd or a fresh install produced from it.

madbiologist (me-again) on 2018-02-05
tags: added: bionic
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Changed in thunderbird (Ubuntu):
status: New → Confirmed
madbiologist (me-again) wrote :

Two firefox processes remain on the process list (ps -e) but they never produce a window, and are killable with sudo kill -9 <pid>

This bug also occurs with libreoffice.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
summary: - Firefox/Thunderbird busy wait at startup
+ Firefox/Thunderbird/Libreoffice suite busy wait at startup

Is this bug Gecko related? All three share Gecko as their HTML layout engine.

madbiologist (me-again) wrote :

Firefox and Libreoffice are working again for me after the latest updates. Possibly as a result of:

gnome-session (3.26.1-0ubuntu9) bionic; urgency=medium

  * debian/ubuntu-session.links, debian/patches/50_ubuntu_sessions.patch,
    debian/ubuntu-session.install:
    - Change ubuntu session to be running on Xorg by default. Added
      an optional ubuntu-wayland one.

 -- Didier Roche <email address hidden> Tue, 06 Feb 2018 10:57:16 +0100

Can you confirm the fix Erkin?

This is not fixed as long as it does not work correctly on Wayland.

It does work on X.org indeed. But not wayland.

madbiologist (me-again) on 2018-02-09
summary: - Firefox/Thunderbird/Libreoffice suite busy wait at startup
+ Firefox/Thunderbird/Libreoffice suite busy wait at startup on Wayland
tags: added: wayland
madbiologist (me-again) wrote :

I found an upstream bug report https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=885920 Does the workaround listed in it's description work for you?

It seems like we just need to wait for Firefox 59 for Wayland support.

Changed in firefox:
status: Unknown → New

>It seems like we just need to wait for Firefox 59 for Wayland support.

It also happens in 59 beta.

Olivier Tilloy (osomon) wrote :

The debian bug report suggests this happens only with AMD GPUs.

My laptop with an Intel GPU doesn't seem to be affected.

Everyone affected, what's your GPU ?

It is an AMD GPU.

Changed in firefox:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.