Firefox highligts textarea on mouse click (focus) in orange, it distracts user

Bug #1713347 reported by Norbert on 2017-08-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Medium
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Install Ubuntu 17.10.
2. Launch Firefox
3. Open website with textarea (for example launchpad).
4. Click on textarea to start typing.
5. Textarea fills with orange background color and it distracts user (see screenshot).

Expected results:
Textarea has white (or other defined background), which does not change on mouse click.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: firefox 50.1.0+build2-0ubuntu1
ProcVersionSignature: Ubuntu 4.12.0-11.12-generic 4.12.5
Uname: Linux 4.12.0-11-generic i686
AddonCompatCheckDisabled: False
ApportVersion: 2.20.6-0ubuntu7
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: artful 1762 F.... pulseaudio
BuildID: 20161213224650
Channel: Unavailable
CurrentDesktop: ubuntu:GNOME
Date: Sun Aug 27 20:29:36 2017
Extensions: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
InstallationDate: Installed on 2017-08-26 (0 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha i386 (20170826)
IpRoute:
 default via 192.168.3.1 dev wlp2s0 proto static metric 600
 169.254.0.0/16 dev wlp2s0 scope link metric 1000
 192.168.3.0/24 dev wlp2s0 proto kernel scope link src 192.168.3.15 metric 600
Locales: extensions.sqlite corrupt or missing
Plugins:
 GNOME Shell Integration - /usr/lib/mozilla/plugins/libgnome-shell-browser-plugin.so (gnome-shell)
 Shockwave Flash - /usr/lib/flashplugin-installer/libflashplayer.so
PrefSources:
 /usr/lib/firefox/defaults/pref/all-ubuntu-gnome.js
 prefs.js
Profiles: Profile0 (Default) - LastVersion=50.1.0/20161213224650 (In use)
RelatedPackageVersions: gnome-shell 3.24.3-0ubuntu4
RunningIncompatibleAddons: False
SourcePackage: firefox
Themes: extensions.sqlite corrupt or missing
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/12/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: UX32A.216
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UX32A
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrUX32A.216:bd02/12/2014:svnASUSTeKCOMPUTERINC.:pnUX32A:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX32A:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: UX
dmi.product.name: UX32A
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Norbert (nrbrtx) wrote :
Norbert (nrbrtx) wrote :

GNOME Classic does not affected.

Norbert (nrbrtx) wrote :

Ubuntu on Xorg session is affected.

Norbert (nrbrtx) wrote :

GNOME on Xorg session does not affected.

Norbert (nrbrtx) wrote :

gnome-flashback-metacity is affected.

Norbert (nrbrtx) wrote :

GNOME on Wayland session does not affected.

Norbert (nrbrtx) wrote :

Ubuntu on Wayland session is affected.

Norbert (nrbrtx) wrote :

So the final result:
* GNOME FlashBack on Metacity
* Unity on Wayland
* Unity on Xorg
has orange background in textarea.

Norbert (nrbrtx) wrote :

This behavior exists while launching Atrful as kvm-qemu guest with vga=std driver.

Norbert (nrbrtx) wrote :

This orange color in traditional Ubuntu's #f07746.

Changed in firefox:
importance: Unknown → Medium
status: Unknown → Fix Released
Doug McMahon (mc3man) on 2017-09-09
Changed in firefox (Ubuntu):
status: New → Confirmed
tags: added: xenial
Jeremy Bicha (jbicha) wrote :

This is already fixed in the current version of Firefox which will be available as a security update before Ubuntu 17.10 is released.

There are a few workarounds for now to get the current version of Firefox in Ubuntu 17.10 if you really need it.

One is to manually enable the zesty-security archive.

Another is to use the firefox-next PPA to try out the next (beta) version of Firefox.

Changed in firefox (Ubuntu):
status: Confirmed → Fix Released
Norbert (nrbrtx) wrote :

Ubuntu 17.10 with all updates - bug is fixed.

Norbert (nrbrtx) on 2017-10-21
tags: removed: artful
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.