Since the update to 55.0.1 firefox hangs frequently with 100% cpu usage

Bug #1710987 reported by Sergio Callegari on 2017-08-15
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Just received the upgrade. Unfortunately, firefox is hardly usable now. Rather frequently, CPU usage jumps up to 100% of a core, with the FF UI completely frozen. In some occasione, the hang is temporary. In others it is permanent and the application must be terminated.

I suggest reverting ubuntu to FF 54 until the FF 55 issues are resolved upstream.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: firefox 55.0.1+build2-0ubuntu0.17.04.2
ProcVersionSignature: Ubuntu 4.10.0-32.36-generic 4.10.17
Uname: Linux 4.10.0-32-generic x86_64
ApportVersion: 2.20.4-0ubuntu4.5
Architecture: amd64
BuildID: 20170814193419
CurrentDesktop: KDE
Date: Wed Aug 16 00:07:52 2017
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-12-12 (1342 days ago)
InstallationMedia: Kubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: firefox
UpgradeStatus: Upgraded to zesty on 2017-05-04 (103 days ago)

Sergio Callegari (callegar) wrote :
Sergio Callegari (callegar) wrote :

As an example, https://www.ilsoftware.it/articoli.asp?tag=Come-ottenere-IP-statico-Telecom_11308 is a page that seems to frequently trigger an extremely high resource usage and temporary hangs with FF 55 on linux.

Sergio Callegari (callegar) wrote :

Getting the feeling that the issue is caused by using adblockplus with FF 55...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Sergio Callegari (callegar) wrote :

After more testing, it is not adblockplus fault only. Without it the hangs become way less frequent, but I still see them.

Sergio Callegari (callegar) wrote :

Might likely be https://bugzilla.mozilla.org/show_bug.cgi?id=1389381

Please ship 55.0.2 which should fix the issue

Sergio Callegari (callegar) wrote :

Indeed, the firefox version available from the ubuntu-mozilla-security ppa, namely 55.0.2+build1-0ubuntu0.17.04.1 seems to fix the issue

Shadab Zafar (dufferzafar) wrote :

I have 55.0.2+build1-0ubuntu0.16.04.1 but am still seeing hangs quite similar to this.

I've been using Firefox for many years but this is the first time this has happened.

The hangs are usually permanent (maybe because I just don't wait) and I have to kill the process.

I use KDE Neon and am willing to provide any sort of logs that may be required for this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.