thunderbird not available in GNOME Software

Bug #1682455 reported by Staš Kotarac Guček on 2017-04-13
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Unassigned
gnome-software (Ubuntu)
Undecided
Unassigned
thunderbird (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu's firefox and thunderbird ship their app icons in /usr/share/pixmaps/

Please move them to /usr/share/icons/hicolor/*/apps/ instead so that these apps can be shown as available for install in GNOME Software.

References
----------
http://appstream.ubuntu.com/bionic/main/issues/thunderbird.html
http://appstream.ubuntu.com/bionic/main/issues/firefox.html
https://www.freedesktop.org/software/appstream/docs/chap-Metadata.html#tag-icon

Original Report
---------------
I am filing this against Thunderbird, even though it also concerns another package (GNOME Software).

Essentially, using a freshly installed Ubuntu GNOME 17.04, Thunderbird is not available in GNOME Software (the default software app for this flavour). You cannot find it via search or the packages browser.

The only way to install it is via apt-get and even then it doesn't show in Software (see attached picture).

Staš Kotarac Guček (skgucek) wrote :
description: updated
description: updated
Staš Kotarac Guček (skgucek) wrote :

Solved it by removing the local cache of GNOME Software and forcing it to re-download its data

$ killall gnome-software
$ rm -r ~/.local/share/gnome-software

... et voilà, Thunderbird magically appeared in the software catalogue.

Changed in thunderbird (Ubuntu):
status: New → Invalid

This bug should not be classified as invalid, in every Ubuntu 17.04 installation that I do on several computers, thunderbird is not in Gnome-Software, and yet the workaround shown above did not work.

Staš Kotarac Guček (skgucek) wrote :

Okay, changed it back to confirmed, since you requested that and confirmed its existence at the same time. It is up to someone else to decide if the real problem lies with thunderbird or gnome-software. Thanks!

Maybe my "fix" worked becase I installed thunderbird with apt first and then cleaned the cache, so it's not really a fix. Thunderbird did later appear in gnome-software, but did so in the installed state, not ready to install as it would be desired.

Changed in thunderbird (Ubuntu):
status: Invalid → Confirmed
Jeremy Bicha (jbicha) on 2018-03-09
description: updated
Changed in thunderbird (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in firefox (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Jeremy Bicha (jbicha) on 2018-03-13
Changed in firefox (Ubuntu):
status: Triaged → Fix Committed
Jeremy Bicha (jbicha) on 2018-03-18
Changed in firefox (Ubuntu):
status: Fix Committed → Triaged
Jeremy Bicha (jbicha) wrote :

Well our first try for Firefox didn't work. We had a 128x128 app icon in the appropriate hicolor folder. It's a symlink and the appstream issues page warns against using symlinks.

Somehow it works in Debian though and they appear to use symlinks. They also offer extra app icon sizes.

Maybe we need to put the original icons in /usr/share/icons/hicolor/ and use symlinks in the other location instead.

Will Cooke (willcooke) on 2018-04-06
tags: added: rls-bb-incoming
Iain Lane (laney) on 2018-04-10
tags: added: rls-bb-notfixing
removed: rls-bb-incoming
Jeremy Bicha (jbicha) wrote :

I noticed that yelp was also complaining about missing help-browser icon until today when it started using native AppStream metadata instead of letting appstream-generator create the basic metadata from its .desktop. So maybe we could fix this bug sooner by creating that metadata file and including it in the firefox and thunderbird binary packages.

Otherwise, I think this bug might be fixed when we get a newer version of appstream-generator installed in the Ubuntu server that provides the metadata downloads.

tags: added: appstream
hbchoong (hbchoong) wrote :

Also affecting latest 18.04.1 LTS, where Firefox is not installed OR when removed. No option to re-install non-snap version of Firefox.

Additional details:
- only snap version of Firefox is available searching in Ubuntu Software.
- non-snap version of Firefox not searchable once removed (i.e. can't reinstall via Ubuntu Software).

Appreciate it if we could know if this is currently being addressed. Thanks

Olivier Tilloy (osomon) wrote :

I can confirm what hbchoong is describing: after uninstalling the firefox deb, when searching for "firefox" in gnome-software, only the snap version is found. This affects both 18.04 and 18.10.

hbchoong (hbchoong) wrote :

Can I please try to understand what the next steps are, if this is being attended to or just simply going to be ignored due to the lack of resources or coordination at Canonical et al?

(I'm looking to understand the processes a little better...)

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers