mouse scroll wheel rolled up/back causes context menu to appear

Bug #162790 reported by Scot on 2007-11-15
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)

Bug Description

Binary package hint: firefox

When scrolling through any webpage that is longer than the visible frame using the mouse scroll button -

1. scrolling down the page works perfectly, no strange effects. :)

2. scrolling up the page works except that when you stop motion with the scroll wheel you get the context menu for the page exactly as if you'd just hit the right mouse button. This happens every time I scroll backwards or up a long page, no matter how far

ProblemType: Bug
Architecture: i386
Date: Wed Nov 14 15:42:35 2007
DistroRelease: Ubuntu 7.10
Package: firefox
PackageArchitecture: i386
SourcePackage: firefox
Uname: Linux doubu 2.6.22-14-386 #1 Sun Oct 14 22:36:54 GMT 2007 i686 GNU/Linux

Scot (4c5gysq02) wrote :
zZyXx (wim-borghs) wrote :

I have the same problem but:
- I have it in all programs I tried where there is a context-menu:, gedit, gnome terminal, nautilus
- it often also causes a clipboard paste, as if I clicked the scroll-button (I take care not to accidentally click; I never have this while scrolling down)
- I have this problem from time to time; not sure what makes it go away or reappear: rebooting? updates? an update to which package then?
- I'm not sure but I think I also experienced it in PCLinuxOS

by the way: it's very annoying!

zZyXx (wim-borghs) wrote :

I rebooted -> problem is gone for now
hope it stays away a long time...

Scot (4c5gysq02) wrote :

I can't believe I hadn't noticed this in other apps - guess that shows I don't use the scroll wheel all that much.

This does indeed occur in pretty much any application so it is NOT a specific firefox issue but rather a far more general problem. Reboots do nothing for me. It is a very consistent and reproducible problem.

I can produce it in Firefox, Evolution, heck even just the desktop, so probably everywhere

linfidel (linfidel) wrote :

I have also had this problem from time to time. I am using a Logitech Connect Mouse (RF), and a KVM switch (with USB to PS/2 adapter), which may actually make a difference.

Following a tip in the Ubuntu forums, I entered these two line in a terminal when it was misbehaving:
sudo rmmod psmouse (here you will lose the mouse, so don't expect to copy/paste the next line)
sudo modprobe psmouse rate=100 proto=imps

This made the mouse behave normally.

I then changed the mouse type in /etc/X11/xorg.conf to ExplorerPS/2 (from ImPS/2), and restarted X using Ctrl-Alt-Backspace. It's working OK now, but I can't be sure this last change fixed anything, as it seems to be intermittent.

Hope this helps.

Marty Fried

zZyXx (wim-borghs) wrote :

- I also use a KVM switch (model: D-Link DKVM-2KU)
- I also use a Logitech mouse (model: Value Optical Mouse (wired)), attached to the KVM using a USB to PS/2 adapter
- also: the terminal commands "sudo rmmod psmouse && sudo modprobe psmouse rate=100 proto=imps" restore the normal behaviour
- also: my /etc/X11/xorg.conf has mouse protocol "ImPS/2" set

Thanks for your post Marty Fried!

Scot (4c5gysq02) wrote :

For what it's worth I have the

- IOGEAR G-CS-14 KVM switch

and I'm using am using a wired

- Microsoft Trackball Explorer 1.0 with the USB to PS2 adapter to the KVM switch.

My xorg.conf already had the ImPS/2 setting so I left it alone. Executing the commands Marty mentioned does seem to have corrected the problem for me ie.

"sudo rmmod psmouse && sudo modprobe psmouse rate=100 proto=imps"

Thanks from me too Marty, now maybe I can get used to using the scroll wheel. :)

zZyXx (wim-borghs) wrote :

I googled some more:

It seems to be an issue with many but not all kvm-types and any ps/2 mouse that's beyond the simple 2-button mouse.
So a possible solution would be a better kvm or a usb-mouse which may also need another kvm.

For the current hardware I think we may need to add the following 2 lines:
     #Fix mouse for KVM
     options psmouse proto=imps
to the /etc/modprobe.d/options or /etc/modprobe.conf file.

John Vivirito (gnomefreak) wrote :

Sorry but Firefox-2 is getting near EOS and they wont be fixing anything but major issues security issues mainly. Please try to reproduce this with Firefox-3.0 if you can reproduce this bug please click on Help > Report a problem and file the bug that way. This does not mean that it wasn't already fixed.

Changed in firefox:
status: New → Won't Fix
zZyXx (wim-borghs) wrote :

The wontfix because firefox-2 is getting near EOS is invalid because this issue arises in any application I tried as I reported in comment #2 and Scott confirmed this in comment #4. I'm sorry I don't see how to change this bug's attributes to reflect this.
I fixed it for my box as I stated in comment #8.

anjilslaire (anjilslaire) wrote :

This fix works appears to work in Intrepid as well, thanks :)

I'm so glad I found this bug entry.

I recently started experiencing this problem with Firefox 3 on 8.10. I wasn't having any luck figuring out a solution. Some of the suggested solutions required changes to xorg.conf which I find really confusing because my xorg.conf file doesn't have a mouse entry.

For some reason I never thought it might have been related to the KVM (Linkskey LKV-SO4SK).

As I said, I don't understand the configuration very well so I don't know if this can be included for a standard install. However, it would be great if there was some way to deal with this out of the box.

I too experience this with a Sybex Switchview 2port KVM (PS/2) in Jaunty. Seems to be only in Firefox, not in Epiphany or in other app's. The 'sudo rmmod psmouse && sudo modprobe psmouse rate=100 proto=imps' does help when issued in the terminal. Where should I put this line so it will be executed at startup? The suggestions done before seem not to exist in Jaunty. I tried to add it in System > Preferences > Startup as a command line but then it won't execute.

cwsupport (netsupport) wrote :

This affects many applications as commented. The decision to change to 'won't fix' was incorrect. It is clearly a larger issue.

I can reproduce this on Kubuntu Karmic with Firefox 3.5.4 and it makes Firefox impossible to use.

The workaround I have on my system (thanks to previous comments) is to add the following 2 lines:
     #Fix mouse for KVM
     options psmouse proto=imps
to /etc/modprobe.d/options

Changed in firefox (Ubuntu):
status: Won't Fix → Confirmed
cwsupport (netsupport) on 2009-11-10
Changed in firefox (Ubuntu):
status: Confirmed → Invalid

The problem still exisits in Lucid Lynx but here too, creating the options file in /etc/modprobe.d still helps.

Just as cwsupport said, the only thing I added for my case is the rate=100, so doing:
sudo gedit /etc/modprobe.d/options

add the following 2 lines in the editor:

     #Fix mouse for KVM
     options psmouse rate=100 proto=imps

save the file.

after a reboot the scrollwheel behaves as expected in Firefox, at least for my kvm it does...

Sal Valente (svalente) wrote :

I'm running Lucid Lynx. I have a PS/2 mouse hooked up to a "PS/2 to USB" converter (my keyboard is hooked up to the same converter) to my PC's USB. Here's a simple way to verify the bug without running Firefox or any other application:

Open "Mouse Preferences". Position the cursor over the little light bulb that tests double clicks. Scroll the mouse wheel up exactly once. It is not necessary to click the wheel or to scroll wildly or to move the mouse. Just scroll the wheel up once. The light bulb lights up as if you double clicked. This shows that the mouse is sending signals that are not interpreted simply as "scroll up". I don't know exactly how the signals are interpreted, but I don't like the way that various applications (including Firefox and Chromium) interpret it.

modprobe did not solve the problem for me. I've seen suggestions that the problem can be solved in xorg.conf, but of course, Lucid Lynx's X server does not have an xorg.conf.

Did you actually create that options file in /etc/modprobe.d with the line suggested above?

As you too use some interface between your PC and the mouse/keyboard, it must have a relation to the translation of the mouse signals in the converter. Don't you have a USB mouse that can be connected directly to a USB port and see it the problem persists? If I remove the options file and connect the PS/2 keyboard and the Logitech USB mouse directly to the PC, everything works fine. When I use the 2 port KVM, I have to use an adapter USB>PS/2 for the mouse. The KVM itself has only PS/2 cables. Omitting the file immediately recreates the problem, albeit only in Firefox. I use the KVM because I often need to host a PC to the other set of cables on the KVM and I do not want to disconnect end reconnect all the time. In fact the complete bunch of cables, including video, network and audo lays bundled on the floor waiting for the next victim PC to solve whatever destructive action an owner could do...:-) The other port is for my Linux PC that cold boots in 30 seconds to a working Lucid.
Cheers, Peter

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers