Firefox > 44 is broken on all big-endian architectures

Bug #1583849 reported by Fritz Hudnut on 2016-05-20
48
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Confirmed
Medium
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

OK, the reason I'm posting back here, running Lu 16.04 on an PPC iBook, and MATE/XFCE 16.04 on a PM ST. . . did a dist-upgrade today, so it now running the new "22" kernel and saw in the list of upgrades new updates to FF and T-bird . . . on both machines after reboot FF window frame loads . . . and then crashes . . . no data is ever filled into the browser window.

The iBook error says it "doesn't have enough memory to report the problem" . . . and on the PM . . . apparently it says the error report was "corrupted" . . . no launchpad window opened in the browser when I clicked on the "report the problem."

Tried to revert to the old kernel in the iBook several times, seemingly failed to boot the old one . . . shut it down.

I went to the PM running 16.04 U-MATE and tried the same dist-upgrade via console there, that upgrade was much larger than the Lu system, but subsequently FF also then failed to launch w/o crashing . . . installed Midori to make an apple user post, but when I tried to start a new thread there Midori crashed as well.

I ran "apt-get -f install" in both the iBook & the PM . . . nothing showed up. No "comment" in the terminal during the upgrade asking any questions or reporting "problems" . . . but FF is kaput!!!!

I'm back in OSX 10.5 side until things cool down for the browsers in 16.04 PPC Lu & U-MATE/XFCE.

e...

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1583849/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → firefox (Ubuntu)
Changed in firefox:
importance: Unknown → Medium
status: Unknown → Confirmed

As you can see in the linked upstream bug report, Firefox is currently broken on all big-endian architectures. The only known workaround for this is currently downgrading to Firefox 44.

Adrian

@John:

Thanks for the follow-up . . . appreciate the suggestion on downgrading;
however it seemed that there was some problem with Midori as well . . .
??? Not a whole lot of options for browsers in PPC . . . hopefully FF will
pull itself together.

F

On Fri, May 20, 2016 at 6:20 AM, John Paul Adrian Glaubitz <
<email address hidden>> wrote:

> As you can see in the linked upstream bug report, Firefox is currently
> broken on all big-endian architectures. The only known workaround for
> this is currently downgrading to Firefox 44.
>
> Adrian
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1583849
>
> Title:
> dist-upgrade & FF upgrade breaks FF & Midori 16.04 PPC
>
> Status in Mozilla Firefox:
> Confirmed
> Status in firefox package in Ubuntu:
> New
>
> Bug description:
> OK, the reason I'm posting back here, running Lu 16.04 on an PPC
> iBook, and MATE/XFCE 16.04 on a PM ST. . . did a dist-upgrade today,
> so it now running the new "22" kernel and saw in the list of upgrades
> new updates to FF and T-bird . . . on both machines after reboot FF
> window frame loads . . . and then crashes . . . no data is ever filled
> into the browser window.
>
> The iBook error says it "doesn't have enough memory to report the
> problem" . . . and on the PM . . . apparently it says the error report
> was "corrupted" . . . no launchpad window opened in the browser when I
> clicked on the "report the problem."
>
> Tried to revert to the old kernel in the iBook several times,
> seemingly failed to boot the old one . . . shut it down.
>
> I went to the PM running 16.04 U-MATE and tried the same dist-upgrade
> via console there, that upgrade was much larger than the Lu system,
> but subsequently FF also then failed to launch w/o crashing . . .
> installed Midori to make an apple user post, but when I tried to start
> a new thread there Midori crashed as well.
>
> I ran "apt-get -f install" in both the iBook & the PM . . . nothing
> showed up. No "comment" in the terminal during the upgrade asking any
> questions or reporting "problems" . . . but FF is kaput!!!!
>
> I'm back in OSX 10.5 side until things cool down for the browsers in
> 16.04 PPC Lu & U-MATE/XFCE.
>
> e...
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/firefox/+bug/1583849/+subscriptions
>

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
elvisplatini (regis-etourmy) wrote :

Hi,
On my powermac G5, running Lubuntu 16.04, I downgraded firefox to 45.02, and it worked again (I'm currently using it). I used:

sudo apt-get install firefox=45.0.2+build1-0ubuntu1
sudo apt-mark hold firefox

I know it's not really satisfactory, that it would be better to try to fix the 46 version bug, but until I manage to succeed in this skill (maybe in 150 years), it allows me to avoid going back to macOS 10.5.

Fritz Hudnut (este-el-paz) wrote :

@elvisplatini:

Thanks for the post, I was hoping that since this issue is "significant" . . . that it would have been patched by now . . . but apparently not. I did try to look in synaptic to see if the history of FF versions would be listed, but, nope . . . only the 46 . . . . In 16.04 I have been using Qupzilla, it's OK, but function is a bit "limited" and/or even "slow" . . . like trying to log into LP here the cursor wouldn't load into the email user box . . . for several minutes . . . then, I went back to it, and it was there . . . .

I might get around to trying out your commands . . . but, if it is marked as "hold" . . . if and when the patched version shows up (hard to know when that might happen) . . . how would I "un-hold" it?

F

ernsteiswuerfel (erhard-f) wrote :

Firefox 47 works again.

yep. Have so many bug reports out on stuff, didn't remember to post here
about it . . . .

On Sat, Jun 18, 2016 at 3:57 PM, ernsteiswuerfel <email address hidden>
wrote:

> Firefox 47 works again.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1583849
>
> Title:
> dist-upgrade & FF upgrade breaks FF & Midori 16.04 PPC
>
> Status in Mozilla Firefox:
> Confirmed
> Status in firefox package in Ubuntu:
> Confirmed
>
> Bug description:
> OK, the reason I'm posting back here, running Lu 16.04 on an PPC
> iBook, and MATE/XFCE 16.04 on a PM ST. . . did a dist-upgrade today,
> so it now running the new "22" kernel and saw in the list of upgrades
> new updates to FF and T-bird . . . on both machines after reboot FF
> window frame loads . . . and then crashes . . . no data is ever filled
> into the browser window.
>
> The iBook error says it "doesn't have enough memory to report the
> problem" . . . and on the PM . . . apparently it says the error report
> was "corrupted" . . . no launchpad window opened in the browser when I
> clicked on the "report the problem."
>
> Tried to revert to the old kernel in the iBook several times,
> seemingly failed to boot the old one . . . shut it down.
>
> I went to the PM running 16.04 U-MATE and tried the same dist-upgrade
> via console there, that upgrade was much larger than the Lu system,
> but subsequently FF also then failed to launch w/o crashing . . .
> installed Midori to make an apple user post, but when I tried to start
> a new thread there Midori crashed as well.
>
> I ran "apt-get -f install" in both the iBook & the PM . . . nothing
> showed up. No "comment" in the terminal during the upgrade asking any
> questions or reporting "problems" . . . but FF is kaput!!!!
>
> I'm back in OSX 10.5 side until things cool down for the browsers in
> 16.04 PPC Lu & U-MATE/XFCE.
>
> e...
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/firefox/+bug/1583849/+subscriptions
>

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1583849

tags: added: iso-testing
summary: - dist-upgrade & FF upgrade breaks FF & Midori 16.04 PPC
+ Firefox crashes on PowerPC
summary: - Firefox crashes on PowerPC
+ Firefox > 44 is broken on all big-endian architectures
ernsteiswuerfel (erhard-f) wrote :

No longer an issue since Firefox is no longer on Yakkety's daily iso?

K1773R (k1773r) wrote :

yes this still is an issue!

K1773R (k1773r) wrote :

btw, this bug should be extended. firefox 48 and firefox 49 cant be build on big endian systems too, their internal toolchain is broken. see the builder logs

ernsteiswuerfel (erhard-f) wrote :

@K1773R:
What I was trying to point out is, that Firefox is not part of the daily iso of Ubuntu MATE 16.10 of today (12.10.2016). An error or is it gone for sure?

Unlike yesterdays Xenial daily iso where Firefox 47 lives quite happily and works fine.

Changed in firefox:
status: Confirmed → Fix Released
ernsteiswuerfel (erhard-f) wrote :

Nice to see that bug fixed upstream! Will there be new PPC-builds of Firefox? ATM there are none in the repository...

On Monday, December 12, 2016 4:21:38 AM MST you wrote:
> Nice to see that bug fixed upstream! Will there be new PPC-builds of
> Firefox? ATM there are none in the repository...
It would be nice!

Herminio

Fritz Hudnut (este-el-paz) wrote :

I just updated/graded my PPC units yesterday, didn't look too closely over
the whole list, it was large, 60 packages plus a kernel. Obviously since
this bug was posted FF was repaired, but, we know that the various ubuntu
distros are phasing PPC out . . . the browser is what needs the most
maintenance.

Don't know if it's possible to find a distro that is going to continue to
support PPC and get the FF package from there?? Most everybody uses
Debian, but the plan is for them to drop PPC as well. Personally my PPC
computers are RAM challenged, as well as cpu challenged and my use is
intermittent; I spent a few minutes checking another distro a couple days
ago, but the "server was down" for downloads . . . after several tries I
moved on.

If I get a moment to boot my PPC computer I'll try to check what version of
FF I have; I definitely launched FF in both of them yesterday, and . . . it
worked, so did Qupzilla . . . .

F

On Sun, Dec 11, 2016 at 8:21 PM, ernsteiswuerfel <email address hidden>
wrote:

> Nice to see that bug fixed upstream! Will there be new PPC-builds of
> Firefox? ATM there are none in the repository...
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1583849
>
> Title:
> Firefox > 44 is broken on all big-endian architectures
>
> Status in Mozilla Firefox:
> Fix Released
> Status in firefox package in Ubuntu:
> Confirmed
>
> Bug description:
> OK, the reason I'm posting back here, running Lu 16.04 on an PPC
> iBook, and MATE/XFCE 16.04 on a PM ST. . . did a dist-upgrade today,
> so it now running the new "22" kernel and saw in the list of upgrades
> new updates to FF and T-bird . . . on both machines after reboot FF
> window frame loads . . . and then crashes . . . no data is ever filled
> into the browser window.
>
> The iBook error says it "doesn't have enough memory to report the
> problem" . . . and on the PM . . . apparently it says the error report
> was "corrupted" . . . no launchpad window opened in the browser when I
> clicked on the "report the problem."
>
> Tried to revert to the old kernel in the iBook several times,
> seemingly failed to boot the old one . . . shut it down.
>
> I went to the PM running 16.04 U-MATE and tried the same dist-upgrade
> via console there, that upgrade was much larger than the Lu system,
> but subsequently FF also then failed to launch w/o crashing . . .
> installed Midori to make an apple user post, but when I tried to start
> a new thread there Midori crashed as well.
>
> I ran "apt-get -f install" in both the iBook & the PM . . . nothing
> showed up. No "comment" in the terminal during the upgrade asking any
> questions or reporting "problems" . . . but FF is kaput!!!!
>
> I'm back in OSX 10.5 side until things cool down for the browsers in
> 16.04 PPC Lu & U-MATE/XFCE.
>
> e...
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/firefox/+bug/1583849/+subscriptions
>

Fritz Hudnut (este-el-paz) wrote :

Just checked my iBook/Lu 16.04, and Powermac/U-MATE 16.04, both have FF
47.0+build3-Oubur "installed" and shown as "latest version" . . . in my
MacPro/10.9 I have FF 50.0.2 "up to date." Usually PPC is a couple
versions back, so, it looks like a tad bit more than that . . . it's fading
awaaaaaayyyyyy . . . .

F

On Sun, Dec 11, 2016 at 9:02 PM, Herminio <email address hidden>
wrote:

> On Monday, December 12, 2016 4:21:38 AM MST you wrote:
> > Nice to see that bug fixed upstream! Will there be new PPC-builds of
> > Firefox? ATM there are none in the repository...
> It would be nice!
>
> Herminio
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1583849
>
> Title:
> Firefox > 44 is broken on all big-endian architectures
>
> Status in Mozilla Firefox:
> Fix Released
> Status in firefox package in Ubuntu:
> Confirmed
>
> Bug description:
> OK, the reason I'm posting back here, running Lu 16.04 on an PPC
> iBook, and MATE/XFCE 16.04 on a PM ST. . . did a dist-upgrade today,
> so it now running the new "22" kernel and saw in the list of upgrades
> new updates to FF and T-bird . . . on both machines after reboot FF
> window frame loads . . . and then crashes . . . no data is ever filled
> into the browser window.
>
> The iBook error says it "doesn't have enough memory to report the
> problem" . . . and on the PM . . . apparently it says the error report
> was "corrupted" . . . no launchpad window opened in the browser when I
> clicked on the "report the problem."
>
> Tried to revert to the old kernel in the iBook several times,
> seemingly failed to boot the old one . . . shut it down.
>
> I went to the PM running 16.04 U-MATE and tried the same dist-upgrade
> via console there, that upgrade was much larger than the Lu system,
> but subsequently FF also then failed to launch w/o crashing . . .
> installed Midori to make an apple user post, but when I tried to start
> a new thread there Midori crashed as well.
>
> I ran "apt-get -f install" in both the iBook & the PM . . . nothing
> showed up. No "comment" in the terminal during the upgrade asking any
> questions or reporting "problems" . . . but FF is kaput!!!!
>
> I'm back in OSX 10.5 side until things cool down for the browsers in
> 16.04 PPC Lu & U-MATE/XFCE.
>
> e...
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/firefox/+bug/1583849/+subscriptions
>

ernsteiswuerfel (erhard-f) wrote :
Fritz Hudnut (este-el-paz) wrote :

For my PPC machines I'm thinking Xenial is the "final destination" . . . on
my 933 MHz iBook, everything loads very slowly . . . not even thinking
about non-LTS options for them.

On Mon, Dec 12, 2016 at 10:36 AM, ernsteiswuerfel <email address hidden>
wrote:

> Yes, Firefox is in Xenial's repository but not in Yakkety's or Zesty's:
> http://packages.ubuntu.com/search?suite=zesty&arch=
> powerpc&mode=exactfilename&searchon=contents&keywords=firefox
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1583849
>
> Title:
> Firefox > 44 is broken on all big-endian architectures
>
> Status in Mozilla Firefox:
> Fix Released
> Status in firefox package in Ubuntu:
> Confirmed
>
> Bug description:
> OK, the reason I'm posting back here, running Lu 16.04 on an PPC
> iBook, and MATE/XFCE 16.04 on a PM ST. . . did a dist-upgrade today,
> so it now running the new "22" kernel and saw in the list of upgrades
> new updates to FF and T-bird . . . on both machines after reboot FF
> window frame loads . . . and then crashes . . . no data is ever filled
> into the browser window.
>
> The iBook error says it "doesn't have enough memory to report the
> problem" . . . and on the PM . . . apparently it says the error report
> was "corrupted" . . . no launchpad window opened in the browser when I
> clicked on the "report the problem."
>
> Tried to revert to the old kernel in the iBook several times,
> seemingly failed to boot the old one . . . shut it down.
>
> I went to the PM running 16.04 U-MATE and tried the same dist-upgrade
> via console there, that upgrade was much larger than the Lu system,
> but subsequently FF also then failed to launch w/o crashing . . .
> installed Midori to make an apple user post, but when I tried to start
> a new thread there Midori crashed as well.
>
> I ran "apt-get -f install" in both the iBook & the PM . . . nothing
> showed up. No "comment" in the terminal during the upgrade asking any
> questions or reporting "problems" . . . but FF is kaput!!!!
>
> I'm back in OSX 10.5 side until things cool down for the browsers in
> 16.04 PPC Lu & U-MATE/XFCE.
>
> e...
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/firefox/+bug/1583849/+subscriptions
>

Changed in firefox:
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.