firefox launching at start up can't purge

Bug #1574645 reported by userDepth on 2016-04-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
firefox (Ubuntu)
High
Unassigned

Bug Description

My problem is simple. Firefox is launching by itself at startup. I can't disable this and if I try to purge it then it tries to also uninstall MATE desktop WTF ??!!

sudo apt-get purge firefox && sudo apt-get install -y firefox
[sudo] password for mateuser:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  firefox* ubuntu-mate-core* ubuntu-mate-desktop*
0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
After this operation, 107 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.

I don't get what's happening here, Firefox is not part of a DE. I was considering to donate to the project but with this FOSS radical attitude I wouldn't.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: firefox 45.0.2+build1-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
AddonCompatCheckDisabled: False
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ccheco 2483 F.... pulseaudio
BuildID: 20160414065514
Channel: Unavailable
CurrentDesktop: MATE
Date: Mon Apr 25 09:26:27 2016
EcryptfsInUse: Yes
Extensions: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
InstallationDate: Installed on 2016-04-21 (3 days ago)
InstallationMedia: Ubuntu-MATE 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
IpRoute:
 default via 192.168.1.1 dev enp1s0 proto static metric 100
 169.254.0.0/16 dev enp1s0 scope link metric 1000
 192.168.1.0/24 dev enp1s0 proto kernel scope link src 192.168.1.10 metric 100
Locales: extensions.sqlite corrupt or missing
Plugins: Shockwave Flash - /usr/lib/flashplugin-installer/libflashplayer.so
PrefSources: prefs.js
Profiles: Profile0 (Default) - LastVersion=45.0.2/20160414065514
RunningIncompatibleAddons: False
SourcePackage: firefox
Themes: extensions.sqlite corrupt or missing
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/16/2011
dmi.bios.vendor: INSYDE
dmi.bios.version: V1.25
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: JM51_CP
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrV1.25:bd03/16/2011:svnAcer:pnAspire5820T:pvrV1.25:rvnAcer:rnJM51_CP:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: Aspire 5820T
dmi.product.version: V1.25
dmi.sys.vendor: Acer

userDepth (markonuvo) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Jason Pell (jason-pellcorp) wrote :

I need to install an older version of firefox because of compatibility issues with selenium, and trying to uninstall firefox also uninstalls ubuntu-mate-core, wtf.

Changed in firefox (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High
Paul White (paulw2u) wrote :

Bug 1510589 was closed as "Fixed Released" on 2016-09-14
Closing this one too.

Changed in hundredpapercuts:
status: Confirmed → Fix Released
Changed in firefox (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers