Ubuntu

login hotmail.com

Reported by phirestalker on 2007-10-21
4
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Low
Mozilla Bugs

Bug Description

Binary package hint: firefox

when I type in www.hotmail.com I am redirected to:
https://login.live.com/login.srf?wa=wsignin1.0&rpsnv=10&rver=4.5.2130.0&wp=MBI&wreply=http:%2F%2Fmail.live.com%2Fdefault.aspx&id=64855&bk=64554967

this site has a login form. however firefox does not recognize it as a login form. there are some other sites that have a similar issue but I can't remember them at the moment.

ProblemType: Bug
Architecture: i386
Date: Sun Oct 21 12:56:57 2007
DistroRelease: Ubuntu 7.04
Package: firefox 2.0.0.6+1-0ubuntu1
PackageArchitecture: i386
SourcePackage: firefox
Uname: Linux phirestalker 2.6.20-16-generic #2 SMP Sun Sep 23 19:50:39 UTC 2007 i686 GNU/Linux

Mario Young (mayeco) wrote :

Hey there!

Can you please upload a screenshot I don't understand what you mean by "firefox does not recognize it as a login form"

Thank you!

Changed in firefox:
status: New → In Progress

I would but I really don't think a screenshot will help. What I mean is
that when I log in to this form firefox does not ask me to remember the
password, which led me to believe it doesn't recognize it.

On Mon, 2007-10-22 at 23:56 +0000, Mario Young wrote:
> Hey there!
>
> Can you please upload a screenshot I don't understand what you mean by
> "firefox does not recognize it as a login form"
>
> Thank you!
>
>
> ** Changed in: firefox (Ubuntu)
> Status: New => In Progress
>

Mario Young (mayeco) wrote :

Hii!

I still don't understand why firefox "doesn't recognize you"

Changed in firefox:
status: In Progress → Incomplete

I'll try to explain it step by step. I go to www.hotmail.com which takes
me to a login page. I put in my username and password. I then click
submit or whatever the button says. Firefox DOES NOT, like it does on
most other pages, ask me if I would like to remember the password. so
for this form I have to manually type in the username and password every
time. If however I go to gmail and type in the username and password the
box pops up to ask me if I would like to remember the password. I can't
possibly explain it any simpler

On Tue, 2007-10-23 at 06:46 +0000, Mario Young wrote:
> Hii!
>
> I still don't understand why firefox "doesn't recognize you"
>
>
> ** Changed in: firefox (Ubuntu)
> Status: In Progress => Incomplete
>

Mario Young (mayeco) wrote :

Hey!!

do you have this 2 checkbox?

 if yes > Do you check it both?
 if no > tell me what version do you have to try to reproduce this bug

firefox v2.0.0.6

Thank you!

yes I have the two checkboxes I keep them unchecked so that I have to
fill in the username and password. I do not want to use cookies to
remember me, I want my password stored in the same place as all my
others.
Yes my firefox version in 2.0.0.6 although this problem has been there
ever since they switched their login page to the new LIVE mail.
I noticed there is a version 2.0.0.8 that I can upgrade to today, I will
do that and let you know if this problem still exists.

Thank you

On Tue, 2007-10-23 at 07:52 +0000, Mario Young wrote:
> Hey!!
>
> do you have this 2 checkbox?
>
> if yes > Do you check it both?
> if no > tell me what version do you have to try to reproduce this bug
>
> firefox v2.0.0.6
>
> Thank you!
>
>
> ** Attachment added: "kdesu1.png"
> http://launchpadlibrarian.net/10126165/kdesu1.png
>

I have just upgraded to 2.0.0.8 and the problem is still there

Mario Young (mayeco) wrote :

heyy There!

Can you please go to your firefox setting here:

Preferences -> Security > Passwords -> Check the "remember passwords" and see the Exeptions
and check if the hotmail website is there, if is there remove it

Thank you!

Changed in firefox:
status: Incomplete → Invalid

it isn't there

On Tue, 2007-10-23 at 19:17 +0000, Mario Young wrote:
> heyy There!
>
> Can you please go to your firefox setting here:
>
> Preferences -> Security > Passwords -> Check the "remember passwords" and see the Exeptions
> and check if the hotmail website is there, if is there remove it
>
> Thank you!
>
>
> ** Changed in: firefox (Ubuntu)
> Status: Incomplete => Invalid
>

Mario Young (mayeco) wrote :

I can't confirm this bug, i'll reopen the bug as NEW

Thank you!

Changed in firefox:
status: Invalid → New
Alexander Sack (asac) wrote :

we need someone to verify your case. Tagging this bug accordingly.

Thanks,
 - Alexander

Changed in firefox:
assignee: nobody → mozilla-bugs
importance: Undecided → Low
status: New → Incomplete
MiK (kimlop) wrote :

i have the same problem, i can't login to hotmail and others microsoft passport sites.

there is a big problem, i love linux, but i not hate ms...

i have a ireless connection encrypted with wpa2 personal (linksys router), firefox 2.0.0.8, ubuntu 7.10. I tested this problem with ephifany, firefox gran paradiso alpha8, opera 9.10 and others browser. I think that problem is ubuntu problem, this is not verified with opensuse 10.3 and the same soft and hardware condition

help me please!

Mario Young (mayeco) wrote :

this bug is Confirmed by MiK
Thank you!

Changed in firefox:
status: Incomplete → Confirmed
Alexander Sack (asac) wrote :

On Sun, Oct 28, 2007 at 10:19:20PM -0000, Mario Young wrote:
> this bug is Confirmed by MiK
> Thank you!
>
>

Can someone provide a test login so I cantry to reproduce?

 - Alexander

Changed in firefox:
status: Confirmed → Incomplete

<email address hidden>
password: thisisapassword

On Tue, 2007-11-06 at 22:12 +0000, Alexander Sack wrote:
> On Sun, Oct 28, 2007 at 10:19:20PM -0000, Mario Young wrote:
> > this bug is Confirmed by MiK
> > Thank you!
> >
> >
>
> Can someone provide a test login so I cantry to reproduce?
>
> - Alexander
>
>
> ** Changed in: firefox (Ubuntu)
> Status: Confirmed => Incomplete
>
> ** Tags added: mt-needtestcase
>
> ** Tags removed: mt-needtester
>

Alexander Sack (asac) wrote :

On Fri, Nov 09, 2007 at 03:59:05AM -0000, phirestalker wrote:
> On Tue, 2007-11-06 at 22:12 +0000, Alexander Sack wrote:
> > On Sun, Oct 28, 2007 at 10:19:20PM -0000, Mario Young wrote:
> > > this bug is Confirmed by MiK
> > > Thank you!
> > >
> > >

does it work on windows firefox?
>

 - Alexander

Changed in firefox:
status: Incomplete → Confirmed
John Vivirito (gnomefreak) wrote :

I dont have an issue logging into my hotmail account from ubuntu feisty, gutsy, hardy, and windows firefox it works as well here.

John Vivirito (gnomefreak) wrote :
MiK (kimlop) wrote :

with last upgrade of windows live mail it's all functionally.

I'm not sure, as I do not use windows except in dire emergencies lol.
however someone earlier had said it does I believe if you look back on
the bug report posts.

On Fri, 2007-11-09 at 16:45 +0000, Alexander Sack wrote:
> On Fri, Nov 09, 2007 at 03:59:05AM -0000, phirestalker wrote:
> > On Tue, 2007-11-06 at 22:12 +0000, Alexander Sack wrote:
> > > On Sun, Oct 28, 2007 at 10:19:20PM -0000, Mario Young wrote:
> > > > this bug is Confirmed by MiK
> > > > Thank you!
> > > >
> > > >
>
> does it work on windows firefox?
> >
>
> - Alexander
>
>
> ** Changed in: firefox (Ubuntu)
> Status: Incomplete => Confirmed
>
> ** Tags added: mt-eval
>
> ** Tags removed: mt-needtestcase
>
> ** Tags added: mt-upstream
>

did you go to hotmail.com and then get redirected to a windows LIVE
login page????? because I can log in to MSN fine but NOT hotmail.com

On Fri, 2007-11-09 at 20:53 +0000, John Vivirito wrote:
> I dont have an issue logging into my hotmail account from ubuntu feisty,
> gutsy, hardy, and windows firefox it works as well here.
>

that's correct problem solved :D

On Sat, 2007-11-10 at 18:03 +0000, MiK wrote:
> with last upgrade of windows live mail it's all functionally.
>

John Vivirito (gnomefreak) wrote :

seems it was a microsoft bug.

Changed in firefox:
status: Confirmed → Invalid
Brook Harty (brookharty) wrote :

I seem to have this bug on Windows Firefox 2.0.0.11 for login.live.com also. Anyone duplicate?

MiK (kimlop) wrote :

This problem occurs only with wireless connection, with ethernet it's not verified

Matthew Koyle (mgkoyle) wrote :

I don't believe this is a bug. If I understand the complaint correctly, at least some users above are complaining that hotmail will not remember their username/password like most other sites.

The problem is that hotmail has disabled autocomplete for the login page. See http://www.raymond.cc/blog/archives/2007/07/16/firefox-dont-remember-yahoo-mail-and-hotmail-password/

Raymond posted a snippet of javascript code which will re-enable autocomplete on the page:

javascript:(function(){var ca,cea,cs,df,dfe,i,j,x,y;function n(i,what){return i+" "+what+((i==1)?"":"s")}ca=cea=cs=0;df=document.forms;for(i=0;i<df.length;++i){x=df[i];dfe=x.elements;if(x.onsubmit){x.onsubmit="";++cs;}if(x.attributes["autocomplete"]){x.attributes["autocomplete"].value="on";++ca;}for(j=0;j<dfe.length;++j){y=dfe[j];if(y.attributes["autocomplete"]){y.attributes["autocomplete"].value="on";++cea;}}}alert("Removed autocomplete=off from "+n(ca,"form")+" and from "+n(cea,"form element")+", and removed onsubmit from "+n(cs,"form")+". After you type your password and submit the form, the browser will offer to remember your password.")})();

MiK (kimlop) wrote :

but this bug is verified only with wireless connection active, with various browsers (opera, ff2, ff3, Epiphany, Links), but is not verified with ethernet connection and the same browsers

John Vivirito (gnomefreak) wrote :

MiK wrote:
> but this bug is verified only with wireless connection active, with
> various browsers (opera, ff2, ff3, Epiphany, Links), but is not verified
> with ethernet connection and the same browsers
>
>
It shouldnt matter wireless or wired, can you please test both if this
is a problem on your system and make a note. I dont have working GUi
browser atm so i cant bring up bug to test on hotmail, can you please
give me the link you are trying to log in at. it seems there are 3 or 4
different pages to log into hotmail live or new hotmail whatever it is
called now.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

MiK (kimlop) wrote :

the bug is verified only with wireless connection, i test login with address mail.live.com (login.live.com). The page for the microsoft login is the same for all microsoft webmails, these use windows live id sing-in system

i'm are expert user, i made several test before opening the byg.

so far I have tested various combinations:
from firefox 2.0.0.6 to firefox 3 rc
links
Epiphany
opera
from ubuntu 7.04 to ubuntu 8.04
i tested with wpa, wep, wpa2 (TKIP, AES, TKIP + AES)
various hardware: centrino, variuos usb wireless adapter, variuos access point (linksys, netgear, dlink...)

MiK (kimlop) wrote :

I want to correct my report, after last ubuntu update, the problem occurs only with wireless connection with the mode wpa2-personal (AES), all browser. With MS Windows the connection working with same configuration, hardware and same access point,

John Vivirito (gnomefreak) wrote :

MiK wrote:
> I want to correct my report, after last ubuntu update, the problem
> occurs only with wireless connection with the mode wpa2-personal (AES),
> all browser. With MS Windows the connection working with same
> configuration, hardware and same access point,
>
>
Please open a new bug on your issue as it is not the same issue as
everyone else was seeing. please also attach the full log files
/var/log/syslog to the new bug report so we can than decide what the
issue is, I'm assuming by your last comment that you have tested on
wired connection so this is more of a driver issue than Firefox issue so
we nee dthe log files to give us a better understanding

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers