Facebook's HTML5 Video No Sound Since last Kernel Update

Bug #1528268 reported by Mokie
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

December 20, 2015: Is there a fix in the works for this? Ever since the last Ubuntu Linux Kernel update; the audio portion specifically belonging to video's posted through Facebook and its associated pages on their New Proprietary player, Fails to produce anything but Loud Static. All other Audio/Video playback from all other sources/web sites do not have this problem. What I do know, is that the only response from either Facebook or Firefox help concerning this issue, is for them to completely Ignore any requests for assistance regarding this specific issue. ..I have tried to make sure all known Audio driver plug-in's are enabled for the default Firefox browser, but no joy. I suspect it might have something to do with that Facebook Proprietary Player being Specifically geared to Microsoft 10 and it's new browser flavour. To the Exclusion of all other O.S. Kernels. (My other FB 'friends' which use Windows 10 are not experiencing this issue) but Linux Distro users Are experiencing this issue. ..Here's the Issue: Apparently the latest Ubuntu Linux Kernel (Or the Firefox Browser) Is not adequately supporting the HTML5 Audio with Facebook's new proprietary video player.
https://www.facebook.com/topic/HTML5/116846568325351?source=whrt&position=3&trqid=-1
Ubuntu 12.04 LTS Which was installed a few dats before the 14.04LTS release: (Did not upgrade Because the necessary Mouse Cursor Acceleration Functions for proper functioning of Wacom Pen Tablet are GREYED OUT in 14.04 LTS and This is a CRITICAL user I/O Device.)

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Revision history for this message
Mokie (ghos282-b) wrote :

Found an old internet posting.. And messed with some of the Firefox 'about:config' settings.. Got Facebooks HTML5 Player AUDIO to work.
I found the solution here in an older Internet Article Posting. If it wasn't for the author's correction of the 'search term' to media.* it would not have worked. (sorry, I'm not a techie.)..
http://www.linuxveda.com/2015/04/02/enable-mse-native-html5-support-firefox-linux/

Revision history for this message
ghomem (gustavo) wrote :

The fix for this is setting

media.fragmented-mp4.gmp.enabled

to true (the default is false).

Firefox 43 on Ubuntu 12.04.

Revision history for this message
Mokie (ghos282-b) wrote : Re: [Bug 1528268] Re: Facebook's HTML5 Video No Sound Since last Kernel Update

Thank you ghomem for the Specific Toggle. -

Found an old internet posting.. And messed with some of the Firefox
'about:config' settings.. Got Facebooks HTML5 Player AUDIO to work.
I found the solution here in an older Internet Article Posting. If it
wasn't for the author's correction of the 'search term' to media.* it
would not have worked. (sorry, I'm not a techie.)..
http://www.linuxveda.com/2015/04/02/enable-mse-native-html5-support-firefox-linux/

On Wed, Dec 23, 2015 at 4:19 PM, ghomem <email address hidden> wrote:
> The fix for this is setting
>
> media.fragmented-mp4.gmp.enabled
>
> to true (the default is false).
>
> Firefox 43 on Ubuntu 12.04.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1528268
>
> Title:
> Facebook's HTML5 Video No Sound Since last Kernel Update
>
> Status in ubuntu-docs package in Ubuntu:
> Confirmed
>
> Bug description:
> December 20, 2015: Is there a fix in the works for this? Ever since the last Ubuntu Linux Kernel update; the audio portion specifically belonging to video's posted through Facebook and its associated pages on their New Proprietary player, Fails to produce anything but Loud Static. All other Audio/Video playback from all other sources/web sites do not have this problem. What I do know, is that the only response from either Facebook or Firefox help concerning this issue, is for them to completely Ignore any requests for assistance regarding this specific issue. ..I have tried to make sure all known Audio driver plug-in's are enabled for the default Firefox browser, but no joy. I suspect it might have something to do with that Facebook Proprietary Player being Specifically geared to Microsoft 10 and it's new browser flavour. To the Exclusion of all other O.S. Kernels. (My other FB 'friends' which use Windows 10 are not experiencing this issue) but Linux Distro users Are experiencing this issue. ..Here's the Issue: Apparently the latest Ubuntu Linux Kernel (Or the Firefox Browser) Is not adequately supporting the HTML5 Audio with Facebook's new proprietary video player.
> https://www.facebook.com/topic/HTML5/116846568325351?source=whrt&position=3&trqid=-1
> Ubuntu 12.04 LTS Which was installed a few dats before the 14.04LTS release: (Did not upgrade Because the necessary Mouse Cursor Acceleration Functions for proper functioning of Wacom Pen Tablet are GREYED OUT in 14.04 LTS and This is a CRITICAL user I/O Device.)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/ubuntu-docs/+bug/1528268/+subscriptions

Revision history for this message
qwerty (itbubbla) wrote :

Using the fix stated by ghomem

media.fragmented-mp4.gmp.enabled = true

solved the issue with Facebook.

However this opened another problem, now instagram vides doesnt work. Reverting it back to

media.fragmented-mp4.gmp.enabled = false

And instagram videos works again.

Revision history for this message
ghomem (gustavo) wrote :

Fixed on Firefox 44.

media.fragmented-mp4.gmp.enabled

should go back to False. Instagram, Facebook and mixcloud (that was affected too) are working again.

affects: ubuntu-docs (Ubuntu) → firefox (Ubuntu)
Changed in firefox (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers