Don't report plugin-container crashes with Apport

Bug #1512099 reported by Alexandre on 2015-11-01
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Unassigned
Wily
Undecided
Chris Coulson

Bug Description

Заебали

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: firefox 41.0.2+build2-0ubuntu0.14.04.1
ProcVersionSignature: Ubuntu 3.19.0-31.36~14.04.1-generic 3.19.8-ckt7
Uname: Linux 3.19.0-31-generic i686
AddonCompatCheckDisabled: False
ApportVersion: 2.14.4-0ubuntu1~ubuntu14.04.1~c42.ppa1
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: alex 1854 F.... pulseaudio
BuildID: 20151015172906
Channel: Unavailable
CurrentDesktop: XFCE
Date: Sun Nov 1 16:00:57 2015
ExecutablePath: /usr/lib/firefox/plugin-container
Extensions: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
InstallationDate: Installed on 2015-09-30 (31 days ago)
InstallationMedia: Xubuntu 14.04.3 LTS "Trusty Tahr" - Beta i386 (20150805)
IpRoute:
 default via 10.10.10.1 dev eth1 proto static
 10.10.10.0/24 dev eth1 proto kernel scope link src 10.10.10.3 metric 9
Locales: extensions.sqlite corrupt or missing
MostRecentCrashID: bp-fe84bf0f-8087-40f8-8220-f33f62151004
Plugins:
 Shockwave Flash - /usr/lib/flashplugin-installer/libflashplayer.so
 Java(TM) Plug-in 11.66.2 - /usr/lib/jvm/java-8-oracle/jre/lib/i386/libnpjp2.so
PrefSources: prefs.js
ProcCmdline: /usr/lib/firefox/plugin-container /usr/lib/flashplugin-installer/libflashplayer.so -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appdir /usr/lib/firefox/browser 2277 plugin
Profiles: Profile0 (Default) - LastVersion=41.0.2/20151015172906
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
RunningIncompatibleAddons: False
SegvAnalysis:
 Segfault happened at: 0xb774911e <_Z14mozalloc_abortPKc+58>: movl $0x21,0x0
 PC (0xb774911e) ok
 source "$0x21" ok
 destination "0x0" (0x00000000) not located in a known VMA region (needed writable region)!
 Stack memory exhausted (SP below stack segment)
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: firefox
StacktraceTop:
 mozalloc_abort(char const*) ()
 NS_DebugBreak () from /usr/lib/firefox/libxul.so
 ?? () from /usr/lib/firefox/libxul.so
 ?? () from /usr/lib/firefox/libxul.so
 ?? () from /usr/lib/firefox/libxul.so
SubmittedCrashIDs: bp-fe84bf0f-8087-40f8-8220-f33f62151004
Themes: extensions.sqlite corrupt or missing
Title: plugin-container crashed with SIGSEGV in mozalloc_abort()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom debian-tor dip lpadmin plugdev sambashare sudo
dmi.bios.date: 09/28/2005
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 0WF351
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd09/28/2005:svnDellInc.:pnInspiron6000:pvr:rvnDellInc.:rn0WF351:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Inspiron 6000
dmi.sys.vendor: Dell Inc.

Alexandre (alex-prince) wrote :
Changed in firefox (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Thanks for taking the time to report this bug and helping to make Ubuntu better. We appreciate the difficulties you are facing, but this appears to be a "regular" (non-security) bug. I have unmarked it as a security issue since this bug does not show evidence of allowing attackers to cross privilege boundaries nor directly cause loss of data/privacy. Please feel free to report any other bugs you may find.

information type: Private Security → Public

This is a crash in flash or similar, which we don't really have influence on. But actually apport isn't supposed to create crash reports for this in the first place -- can you please attach /var/log/apport.log and copy&paste the output of

   cat /etc/apport/blacklist.d/firefox

? Thanks!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

Nevermind, we found it. firefox ships a /etc/apport/blacklist.d/firefox file which should *always* at least contain /usr/lib/firefox/plugin-container . We don't want crash reports for that as that's non-Ubuntu software which we don't control anyway. Apparently this was just turned back on in https://launchpad.net/ubuntu/+source/firefox/42.0+build2-0ubuntu1, but in 15.10 and earlier releases that file is completely empty.

Dropping /usr/lib/firefox/firefox might be desirable if you want crash reports for firefox itself, but please always keep plugin-container blacklisted.

summary: - plugin-container crashed with SIGSEGV in mozalloc_abort()
+ Don't report plugin-container crashes with Apport
Changed in firefox (Ubuntu):
status: Confirmed → Fix Released
Changed in firefox (Ubuntu Wily):
assignee: nobody → Chris Coulson (chrisccoulson)
status: New → Triaged
Chris Coulson (chrisccoulson) wrote :

This is fixed with yesterdays release

Changed in firefox (Ubuntu Wily):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers