Possible high CPU usage by firefox while screen is locked

Bug #1508219 reported by LGB [Gábor Lénárt] on 2015-10-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

It's a bit fuzzy report, I have to admit, and more like a feeling, as I can't check it out too well, but I haven't experienced that in previous Ubuntu versions before upgrading to Wily.

I have firefox running with many tabs open. The CPU usage (without too much active pages, ie no videos etc) is about 10-30% at max. If I lock my computer I always hear the fan of the notebook switches onto a higher speed, which disappears if I unlock the screen. It's a bit hard to check it out, if it's really because of firefox, as I can only use "top" if my desktop is unlocked of course, but I can still notice that CPU usage of firefox is still about decreasing after unlocking.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: firefox 41.0.2+build2-0ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic i686
AddonCompatCheckDisabled: False
ApportVersion: 2.19.1-0ubuntu3
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lgb 2439 F.... pulseaudio
BuildID: 20151016093451
Channel: Unavailable
CurrentDesktop: Unity
Date: Tue Oct 20 23:48:56 2015
DefaultProfilePlugins:
 IcedTea-Web Plugin (using IcedTea-Web 1.5.2 (1.5.2-1ubuntu2)) - /usr/lib/jvm/java-7-openjdk-i386/jre/lib/i386/IcedTeaPlugin.so (icedtea-7-plugin)
 Google Talk Plugin Video Renderer - /opt/google/talkplugin/libnpo1d.so (google-talkplugin)
 iTunes Application Detector - /usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so (rhythmbox-mozilla)
 Shockwave Flash - /usr/lib/flashplugin-installer/libflashplayer.so
 Google Talk Plugin - /opt/google/talkplugin/libnpgoogletalk.so (google-talkplugin)
DefaultProfilePrefSources: prefs.js
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2012-03-03 (1326 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MostRecentCrashID: bp-c1602958-abcf-49cb-af9c-c95172151003
Profile1Extensions: extensions.sqlite corrupt or missing
Profile1IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
Profile1Locales: extensions.sqlite corrupt or missing
Profile1Plugins:
 IcedTea-Web Plugin (using IcedTea-Web 1.5.2 (1.5.2-1ubuntu2)) - /usr/lib/jvm/java-7-openjdk-i386/jre/lib/i386/IcedTeaPlugin.so (icedtea-7-plugin)
 Shockwave Flash - /usr/lib/flashplugin-installer/libflashplayer.so
 iTunes Application Detector - /usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so (rhythmbox-mozilla)
Profile1PrefSources: prefs.js
Profile1Themes: extensions.sqlite corrupt or missing
Profiles:
 Profile0 (Default) - LastVersion=41.0.2/20151016093451 (In use)
 Profile1 - LastVersion=39.0a2/20150414004003 (Out of date)
RelatedPackageVersions:
 icedtea-7-plugin 1.5.2-1ubuntu2
 google-talkplugin 5.41.0.0-1
 rhythmbox-mozilla 3.2.1-1ubuntu3
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
RunningIncompatibleAddons: True
SourcePackage: firefox
UpgradeStatus: Upgraded to wily on 2015-10-18 (2 days ago)
dmi.bios.date: 11/04/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8GET38WW (1.15 )
dmi.board.name: 5016NW6
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8GET38WW(1.15):bd11/04/2011:svnLENOVO:pn5016NW6:pvrThinkPadL520:rvnLENOVO:rn5016NW6:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 5016NW6
dmi.product.version: ThinkPad L520
dmi.sys.vendor: LENOVO

LGB [Gábor Lénárt] (lgb) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
LGB [Gábor Lénárt] (lgb) wrote :

I'm sorry but now it *seems* for me, that it's not firefox, but maybe compiz related (hmmm, or both?), please read the newer bug report of mine: bug 1516308

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers