firefox and xgl cause 100% CPU

Bug #145696 reported by justin on 2007-09-27
26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

when running the desktop effects. Launching firefox causes XGL to take up 100% of the CPU. killing the desktop effects fixed this for me. Not sure if this is a firefox, driver, or Xorg problem.

My Specs:
Dell Inspiron 6000
ATI Radeon X300

Shaved Wookie (shavedwookie) wrote :

I'm having this, too, with the only exception being that Xorg seems to hog resources when I'm running Firefox whether I'm using desktop (Compiz Fusion) effects or not (Kwin).

To a lesser degree I get a similar thing in Opera, but only a fraction as much as FF.

My System is as Follows:
- Kubuntu Gutsy 32 bit (fully updated every day)
- Nvidia 8600 GT card (with driver installed from Restricted Manager)
- 3.2 gHz Intel processor
- 4 gig ram
- Firefox 2.0.0.6+2-0ubuntu4
- Compiz 1:0.5.2+git20070918-0ubuntu5
- emerald 0.3~git20070717-0ubuntu1

There's also a post on ubuntuforums here:
http://ubuntuforums.org/showthread.php?t=559774

It seems to me that in some strange way this bug might be linked to:
https://bugs.launchpad.net/ubuntu/+source/strigi/+bug/128876

As the amount of CPU my Xorg uses, drops dramatically when I close either Firefox OR strigi-daemon. But then maybe it's just that my systems decent enough to not choke with this bug alone, but combine the two and BAM!

Alexi Helligar (alexih) wrote :

Firefox using 100% of CUP is occurring on my system as well. I have Desktop Effects turned on. I am using the latest build of Gutsy. This bug is more pronounced under the user account that has permission to change the system. Also, this bug appears on only certain web pages like gmail and igoogle. I have run Firefox without extensions and the problem still occurs.

Interestingly, I have noticed high CPU utilization by Firefox on my Windows Vista build. This leads me to think it is a problem with Firefox.

I( suspect it's firefox, too, although the interesting thing is that
if you open FF in win XP with nothing open it uses about 22mb of ram
Vs in Ubuntu, it opens using over 150mb?! On my machine I also see
Xorg usage jump super high as much as FF, but usually only when I'm
using FF on the kinds of pages you mentioned (Google services, and
ironically linuxactionshow.com).

Would be good to know what everyone's running to see if we can find
any commonalities. I'm finding that using FF3 beta 8 (Gran Paradiso)
the problem still seems to occur although not nearly as much.
Hmmmmmmm.....

justin (justin-griggs) wrote :

I'm running FF 2.0.0.6 with Adblock Plus and FasterFox extensions. It's been happening less lately, but still crashes when I'm on youtube.

Sean Harshbarger (harshy) wrote :

Just from a brief look at things...looks like a Firefox related issue. Epiphany does not see to suffer from this issue even with java/flash enabled sites.

Shaved Wookie (shavedwookie) wrote :

Sort of. The strange thing is that when I look at the what's taking
CPU, it reports with Xorg usually higher than FF... but then the
problem mainly just occurs when running FF.

On 10/2/07, Sean Harshbarger <email address hidden> wrote:
> Just from a brief look at things...looks like a Firefox related issue.
> Epiphany does not see to suffer from this issue even with java/flash
> enabled sites.
>
> --
> firefox and xgl cause 100% CPU
> https://bugs.launchpad.net/bugs/145696
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Hi,

I'm seeing the same problem here (I think). I'm using Xgl with Gnome without desktop effects. I have the problem that the url bar in firefox is responding very slowly sometimes (typing in a character in the url bar takes a noticeable delay until it's displayed). The only "fix" for me is to reboot.

After a reboot the problem is gone. The problem usually occurs when I log out of my X session and leave my computer running overnight or longer (with the gdm screen displayed).

justin (justin-griggs) wrote :

ahhh. It just happened to me again, but this time I was just leaving firefox open on facebook in the background. it was fine for about 10 minutes, then I tried to move the window and it started with the 100% CPU again! had to restart to fix it.

Qilz (mail-qilanto) wrote :

Same problem.

Ubuntu 7.10
ATI 9600 gfx card with Ati driver installed and propriarity driver enabled.
on an Intel Centrino 1.7Ghz laptop

Firefox off:
   Xgl uses about 0.5% - 2% cpu,
Firefox on:
   Xgl climbs to a near 100% cpu usage.

What I don't understand is that this problem started for me today, without any new upgrades.

In addition: If I kill Xgl or do a "hard" restart of the x-server, my system hangs either before loginscreen or just after. With no posibility to escape. (cant go to one of the other virtual consoles).

Qilz (mail-qilanto) wrote :

My own post made me think:

I disabled the desktop effects as an attempt to fix my other problem.
So now I discovered:

Effects on -> no unusual cpu usage
Effects off -> Xgl 100% with firefox

Teo (teo420) wrote :

Hello all,

I am new to ubuntu/linux, so please bear with me :). I too am having this (or a very similar) problem.

System:
Ubuntu 7.10, fully updated
ATI Mobility 9700 with ATI restricted driver
Dell Inspiron 9100 (3.0 ghz desktop processor)
1gb RAM

Here's what I've noticed so far... when Firefox is opened, Xgl starts taking up all available CPU. Once I go to a website and leave the address bar, Xgl calms down and Firefox runs normally. Whenever I go to a text box on a web page (or back to the address bar), Xgl will peak the CPU again.

Note: I just read the last post by Qilz, and I've noticed the same thing (e.g., Effects on -> Xgl runs fine; effects off -> Xgl peaks the CPU).

I hope this helps,
-Teo

Qilz (mail-qilanto) wrote :

I have actually had one incident with Xgl peaking with effects on (and firefox open, dont know what it was doing though).

But no solution found yet, and also no haven't found a fix for my additional problem (and more problematic...) But I haven't put much effort in it yet either :)

But If you do have a solution, be kind enough to post...

/Qilz

Arul (aselvan) wrote :

Qilz,

If xgl is hogging CPU, then you don't have OpenGL direct rendering turned on or your driver does not support it. Try the following and see if you have direct rendering on.

home@panther:~$ glxinfo |grep direct
direct rendering: Yes

If it is "No" and you believe your driver supports it, then enable it on xorg.conf
Section "Module"
        Load "glx"
EndSection
---------------------------------------
I have a similar issue where firefox hangs using up max CPU, mostly it happens when you right click to open a link on a new window consistently. Has anyone experienced this on fresh install of gusty with latest firefox?.

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
5679 home 25 0 249m 91m 25m R 97.4 9.1 2:53.94 firefox-bin

-Arul

vincewebb (vincewebb) wrote :

I have an AMD 64 x2 and an ATI Radeon X300. Ubuntu 7.10 with all the updates as and when they appear.

I had the desktop effects enabled and working nicely but today, the desktop effects disabled themselves and I got the problem with Xgl using 100% CPU whilst using Firefox, particularly when scrolling.

Desktop effects refused to re-enable.

I disabled the restricted ATI driver and re-booted, then re-enabled the restricted ATI driver and re-booted again. I was then able to re-enable the desktop effects and the Firefox / Xgl problem was cured.

iMouse (mickey-hancharenko) wrote :

Same issue here. Seems to appear when Firefox is open and I lock the screen for the night. If I don't lock the screen, it appears to be fine...however, the problem appears to be rather intermittent...so...

Dell Dimension 4300
P4/2.4 Socket 478/400/512
1GB of PC133 SDRAM
Diamond ATI Radeon 9550/256 AGP (drivers installed by Envy)
Ubuntu Gutsy w/XGL enabled

 PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 5633 mickey 25 0 354m 185m 11m R 91.9 18.4 2012:29 Xgl

Qilz (mail-qilanto) wrote :

aselvan:
I don't have direct rendering on, but I did have Load "glx" in the module section i xorg.conf.
I found this: http://ubuntuforums.org/showthread.php?t=610924dd - and after doing: export DISPLAY=:0 it did say direct rendering on.
Not really sure why - or what it going on.. I think I need to make sure what all those damn parts in xorg.conf mean ;)

I also tried the disable-reboot-enable-reboot of the restricted driver, and now my second problem (not being able to restart my x-server or use suspend mode) is fixed. ! :)
Notice: I was not able to start my x-server after i disabled the restricted driver - so I had to do this: sudo apt-get install xserver-xgl (at least I think that was it... found it somewhere), and after that I had to edit my xorg.conf screen section to fix the resolution....(screen/display/virtual)

Although thinks are working fine, the original problem doesn't seem fixed. When running Firefox in full-screen mode and trying to edit the address, Xgl uses up all cpu again. But if the direct rendering stuff is wrong .. I guess that is the reason?

I'm posting more questions then answers .. sorry :)

wolfger (wolfger) wrote :

Marking confirmed due to the number of people reporting the problem.
Can somebody please confirm if the problem also exists under Firefox-3.0?

ziggyh (ziggyh) wrote :

XGL goes to 100%.

Ubuntu 2.6.24-21-rt #1 SMP PREEMPT RT Wed Oct 22 01:36:03 UTC 2008 i686 GNU/Linux
nvidia-glx-new-dev-envy 173.14.12 + 2.6.24.503-503.31
Firefox 3.0.3

Happens when an opaque div covers the browser window.
When div is closed, XGL and Firefox are still at the top of "top", but not hogging CPU.

glxinfo |grep dire
direct rendering: Yes

Section "Module"
 Load "glx"
EndSection

Advanced desktop effects are on.

Cathal Mooney (cmooney-iol) wrote :

Having the same thing here. New to Ubuntu/Linux as of yesterday so can't shed much light.

AMD Athlon processor I think (few years old), ATI Radeon 9200 Graphics.

Following above advice I can see that:

cathal@cathal:~$ glxinfo | grep direct
direct rendering: Yes

As soon as I fire up firefox, even on the simple google.com page "X" Server starts to use 100% of cpu, or at least as much as is left after firefox (which varies in cpu, low on simple pages higher for more complex stuff, as you'd expect). Tried turning visual effects off but doesn't seem to make a difference.

Using Ubuntu 8.10 and Firefox 3.0.6 (latest I think).

Despite the CPU usage firefox is fairly responsive to use when the problem is present I must say.

Can you test this with a supported Ubuntu version please and give us the results? Thank you!

Changed in firefox (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for firefox (Ubuntu) because there has been no activity for 60 days.]

Changed in firefox (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers