Multiple issues on firefox in powerpc

Bug #1448359 reported by Herminio on 2015-04-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Whenever I try to install an extension I get this error "firefox cannot modify the needed file"

I tried resetting firfox, deleting the .mozilla directory, setting extensions.alwaysUnpack to true and nothing worked

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: firefox 37.0.2+build1-0ubuntu0.14.04.1
ProcVersionSignature: Ubuntu 3.13.0-49.83-powerpc-smp 3.13.11-ckt17
Uname: Linux 3.13.0-49-powerpc-smp ppc
AddonCompatCheckDisabled: False
ApportVersion: 2.14.1-0ubuntu3.10
Architecture: powerpc
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: rican-linux 1518 F.... lxpanel
BuildID: 20150417181958
CRDA: Error: [Errno 2] No such file or directory: 'iw'
Channel: Unavailable
CurrentDesktop: LXDE
CurrentDmesg: [ 41.998029] init: plymouth-upstart-bridge main process ended, respawning
Date: Fri Apr 24 20:15:42 2015
Extensions: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
InstallationDate: Installed on 2015-04-24 (0 days ago)
InstallationMedia: Lubuntu 14.04.1 LTS "Trusty Tahr" - Release powerpc (20140722.2)
IpRoute:
 default via 192.168.1.254 dev wlan0 proto static
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.127 metric 9
Locales: extensions.sqlite corrupt or missing
Plugins:
 mplayerplug-in is now gecko-mediaplayer 1.0.8 - /usr/lib/mozilla/plugins/gecko-mediaplayer.so (gecko-mediaplayer)
 QuickTime Plug-in 7.6.9 - /usr/lib/mozilla/plugins/gecko-mediaplayer-qt.so (gecko-mediaplayer)
 DivX Browser Plug-In - /usr/lib/mozilla/plugins/gecko-mediaplayer-dvx.so (gecko-mediaplayer)
 Windows Media Player Plug-in - /usr/lib/mozilla/plugins/gecko-mediaplayer-wmp.so (gecko-mediaplayer)
 RealPlayer 9 - /usr/lib/mozilla/plugins/gecko-mediaplayer-rm.so (gecko-mediaplayer)
PrefSources: prefs.js
Profiles: Profile0 (Default) - LastVersion=37.0.2/20150417181958 (In use)
RelatedPackageVersions: gecko-mediaplayer 1.0.8-4ubuntu1
RunningIncompatibleAddons: False
SourcePackage: firefox
Themes: extensions.sqlite corrupt or missing
UpgradeStatus: No upgrade log present (probably fresh install)

Herminio (herminio-hernandezjr) wrote :
Herminio (herminio-hernandezjr) wrote :

There are a number of other issues with firefox on 14.04 PPC

-search bar is broken
-downloading from the browser is not working (need to use wget)
-search field on the new tab is broken.

summary: - extensions will not install
+ Multiple issues on firefox in powerpc

Hi All,

I tested Firefox 37.0.2 on Lubuntu 12.04.5 PowerPC and on ubuntu MATE 15.04 PowerPC today. The search bar beside the URL field doesn't work. The search field on the New Tab page doesn't work either. I have to use a search engine directly. I can't copy a link with the right-click context menu.

Rgds,

Christian

luigiburdo (intermediadc) wrote :

Confirm here on Quad G5 with Lubuntu 14.04.2 and last Firefox the download fail ... better say it download but fail when make the transofrmation from .part to .exention file ... if i rename the part i have the file working. the issue come if i try to download an image but in this case i dont have a part and cant recover the file.

caesar753 (quirino2) wrote :

Confirmed on ibook g4 1.2 GHz. Same as Christian and luigiburdo, but sometimes i cannot get the file downloaded at all...

luigiburdo (intermediadc) wrote :

probably can help the dev

luigi@luigi-desktop:~$ firefox

(process:2061): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
1430379834884 DeferredSave.extensions.json WARN Write failed: Error: Promise.all() expects an iterable. (resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:521) JS Stack trace: <email address hidden>:521:1 < <email address hidden>:266:38 < <email address hidden>:314:40 < <email address hidden>:275:3 < <email address hidden>:249:14 < <email address hidden>:164:12 < <email address hidden>:263:1 < post/<@osfile_async_front.jsm:421:25 < <email address hidden>:314:40 < <email address hidden>:275:3 < <email address hidden>:249:14 < <email address hidden>:870:23 < <email address hidden>:749:7 < this.PromiseWalker.scheduleWalkerLoop/<@Promise-backend.js:691:37
1430379834886 addons.xpi-utils WARN Failed to save XPI database: Error: Promise.all() expects an iterable. (resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:521) JS Stack trace: <email address hidden>:521:1 < <email address hidden>:266:38 < <email address hidden>:314:40 < <email address hidden>:275:3 < <email address hidden>:249:14 < <email address hidden>:164:12 < <email address hidden>:263:1 < post/<@osfile_async_front.jsm:421:25 < <email address hidden>:314:40 < <email address hidden>:275:3 < <email address hidden>:249:14 < <email address hidden>:870:23 < <email address hidden>:749:7 < this.PromiseWalker.scheduleWalkerLoop/<@Promise-backend.js:691:37

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Jockel (joro-2013) wrote :

I had the problems described above on a Mac Mini G4 running Precise.

Upgrading the firefox package to version 38 provided by the mozilla-security PPA

https://launchpad.net/~ubuntu-mozilla-security/+archive/ubuntu/ppa

solved the problems.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers