MASTER firefox crashed on print preview [@IA__gdk_window_get_toplevel] [@gdk_window_is_toplevel_frozen]

Bug #144326 reported by Adam on 2007-09-24
324
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Critical
firefox (Ubuntu)
High
Alexander Sack
gtk+2.0 (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: firefox

... firefox-bin crashed with SIGSEGV in __kernel_vsyscall()

Tried to open a Print Preview.

Test case:
- Open a browser window (my home page is iGoogle -- http://www.google.com.br/ig?hl=pt-BR)
- File > Print Preview
- The browser crash.

ProblemType: Crash
Architecture: i386
Date: Sun Sep 23 12:07:42 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/lib/firefox/firefox-bin
NonfreeKernelModules: fglrx
Package: firefox 2.0.0.6+2-0ubuntu4
PackageArchitecture: i386
ProcCmdline: /usr/lib/firefox/firefox-bin
ProcCwd: /home/adam
ProcEnviron:
 PATH=/home/adam/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: firefox
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libpthread.so.0
 ?? ()
 ?? ()
 ?? ()
Title: firefox-bin crashed with SIGSEGV in __kernel_vsyscall()
Uname: Linux saxhokie-gomek 2.6.22-12-generic #1 SMP Sat Sep 22 18:14:28 GMT 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lp lpadmin netdev plugdev powerdev scanner video

Extracted from symbolized stacktrace:
(file: http://launchpadlibrarian.net/9475970/Stacktrace.txt)
...
#3 <signal handler called>
#4 IA__gdk_window_get_toplevel (window=0x89f5538) at /build/buildd/gtk+2.0-2.12.0/gdk/gdkwindow.c:617
#5 gdk_window_is_toplevel_frozen (window=0x0) at /build/buildd/gtk+2.0-2.12.0/gdk/gdkwindow.c:2298
#6 IA__gdk_window_process_all_updates () at /build/buildd/gtk+2.0-2.12.0/gdk/gdkwindow.c:2438
#7 gdk_window_update_idle (data=0x0) at /build/buildd/gtk+2.0-2.12.0/gdk/gdkwindow.c:2288
#8 gdk_threads_dispatch (data=0xa2bcfc0) at /build/buildd/gtk+2.0-2.12.0/gdk/gdk.c:470
#9 g_idle_dispatch (source=0x8fc9b50, callback=0x807e8f8, user_data=0xa2bcfc0)
#10 IA__g_main_context_dispatch (context=0x80837a0) at /build/buildd/glib2.0-2.14.1/glib/gmain.c:2061
#11 g_main_context_iterate (context=0x80837a0, block=1, dispatch=1, self=0x81580f8)
#12 IA__g_main_loop_run (loop=0x8684810) at /build/buildd/glib2.0-2.14.1/glib/gmain.c:2898
...

Related branches

Adam (adam.russell) wrote :

StacktraceTop:gdk_window_is_toplevel_frozen (window=0x0) at /build/buildd/gtk+2.0-2.12.0/gdk/gdkwindow.c:2298
IA__gdk_window_process_all_updates () at /build/buildd/gtk+2.0-2.12.0/gdk/gdkwindow.c:2438
gdk_window_update_idle (data=0x0) at /build/buildd/gtk+2.0-2.12.0/gdk/gdkwindow.c:2288
gdk_threads_dispatch (data=0xa2bcfc0) at /build/buildd/gtk+2.0-2.12.0/gdk/gdk.c:470
g_idle_dispatch (source=0x8fc9b50, callback=0x807e8f8, user_data=0xa2bcfc0)

Changed in firefox:
importance: Undecided → Medium

Thank you for your report,

Is the crash always reproducible? Can you provide an step by step test case?

Please, can you indicate which gtk theme were you using when firefox crashed? was the default?

Thanks in advance.

description: updated
Changed in firefox:
assignee: nobody → mozilla-bugs
importance: Medium → High
status: New → Incomplete
status: Incomplete → Confirmed

Em Sex, 2007-09-28 às 19:06 +0000, Hilario J. Montoliu (hjmf) escreveu:
> Thank you for your report,
>
> Is the crash always reproducible? Can you provide an step by step test
> case?

- Open a browser window (my home page is iGoogle --
http://www.google.com.br/ig?hl=pt-BR)
- File > Print Preview
- The browser crash.

>
> Please, can you indicate which gtk theme were you using when firefox
> crashed? was the default?

Yes. is the default one (whitout eyecandies)

One note: I have two printers: an network ipp printer (hp deskjet 1300
series; the default) and the cups pdf printer.

--
Rodrigo de Avila <email address hidden>

Adam (adam.russell) wrote :

Yep...

File -> Print Preview
every time.

Default theme.
One printer.

description: updated
Erica Rosalle (erosalle) wrote :

Per information request in Bug 147097: I am using the system default GTK theme for Ubuntu: Human. I also have Compiz enabled by default.

houstonbofh (leesharp) wrote :

I just submitted a dupe. It was a clean install of Gutsy from the 9.24 daily. Default theme, and compiz on an nvidia 7950 card with restricted driver. It is a new machine. Gigabyte GA-P35-DS3L with a 2.33 Core2duo and 2 gig of ram. All SATA system.

Gabriel de Perthuis (g2p) wrote :

I am using the Glossy theme (clearlooks theme engine, same as Human); I have normal desktop effects enabled, no restricted drivers.

Alexander Sack (asac) wrote :

this is a regression not present in gtk+2.0 2.11.6-1ubuntu4 ... apparently it was introduced with first 2.11.7 upload done on sep 17.

seb, any idea?

Changed in gtk+2.0:
assignee: nobody → desktop-bugs
importance: Undecided → High
status: New → Confirmed
Alexander Sack (asac) wrote :

sorry, of course i ment that this regressed due to gtk+ 2.12.0-0ubuntu1

Alexander Sack (asac) wrote :

ok, here a gtk patch to fix this.

Alexander Sack (asac) wrote :

gtk 2.12 introduced gdk_window_is_toplevel_frozen (window) and makes use of it in gdk_window_process_all_updates; this introduces crashes when there are NULL pointers in update_windows list; in addition gdk_window_get_toplevel crashes when there is no TOPLEVEL ancestor.

Both cases appear to happen in this firefox "print preview" crash.

This patch adds some NULL checks to make gdkwindow more failsafe in these cases.

Alexander Sack (asac) wrote :

fix provided for gtk ...

Changed in firefox:
assignee: mozilla-bugs → asac
status: Confirmed → Triaged
status: Triaged → Invalid
status: Invalid → Won't Fix
Changed in gtk+2.0:
status: Confirmed → Fix Committed
Changed in gtk:
status: Unknown → New
Sebastien Bacher (seb128) wrote :

gtk+2.0 (2.12.0-1ubuntu3) gutsy; urgency=low

  * debian/patches/071_fix_gdk_window_null_crasher.patch:
    - patch from Alexander Sack, fix firefox crashing on print preview due
      due to gdk_window NULL values (LP: #144326)

 -- Sebastien Bacher <email address hidden> Fri, 05 Oct 2007 14:10:06 +0200

Changed in gtk+2.0:
status: Fix Committed → Fix Released
Changed in gtk:
status: New → Confirmed
Fred Hermanns (fintan) wrote :

I can confirm this issue in Kubuntu 7.10 as well.

Does the above patch apply to KDE as well? Is so how is it implemented?

Samnsparky (samnsparky) wrote :

The problem has been fixed (without the patch). I just updated Firefox and it seems to have gone away.

Nanley Chery (nanoman) wrote :

Don't have this problem anymore. Is this still a problem in the "gtk" package?

Changed in gtk:
status: Confirmed → Fix Released
Fred Hermanns (fintan) wrote :

I have installed FF 2.0.0.11 with ubuntuzilla. I still have the printpreview issue Kubuntu 7.10.

Alexander Sack (asac) wrote :

On Tue, Dec 04, 2007 at 08:38:32AM -0000, Fred Hermanns wrote:
> I have installed FF 2.0.0.11 with ubuntuzilla. I still have the
> printpreview issue Kubuntu 7.10.
>

Please don't use ubuntuzilla. This can cause several issues.

 - Alexander

Hello Alexander,

I had to reinstall the full distro again. One thing I worked out was that the problem was the screensaver/power management was the thing making it crash. I turned off the screensaver part in the new install and I have had no problems.

Best wishes,
Peter

Peter Rowan
Nawor International Development Experts
Geopolitics, Finance, Energy

6 Impasse Vassou, 75012 Paris, France
Tel (Paris): +33 (0)1 43 47 37 47
Tel (London mobile): +44 (0)7793 140 017
Email: <email address hidden>
Skype: Payteer Gtalk: Peter Rowan

-----Message d'origine-----
De : <email address hidden> [mailto:<email address hidden>] De la part de Alexander Sack
Envoyé : vendredi 4 janvier 2008 01:24
À : <email address hidden>
Objet : Re: [Bug 144326] Re: MASTER firefox crashed on print preview [@IA__gdk_window_get_toplevel] [@gdk_window_is_toplevel_frozen]

On Tue, Dec 04, 2007 at 08:38:32AM -0000, Fred Hermanns wrote:
> I have installed FF 2.0.0.11 with ubuntuzilla. I still have the
> printpreview issue Kubuntu 7.10.
>

Please don't use ubuntuzilla. This can cause several issues.

 - Alexander

--
MASTER firefox crashed on print preview [@IA__gdk_window_get_toplevel] [@gdk_window_is_toplevel_frozen]
https://bugs.launchpad.net/bugs/144326
You received this bug notification because you are a direct subscriber
of a duplicate bug.

No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.516 / Virus Database: 269.17.13/1208 - Release Date: 03/01/2008 15:52

No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.516 / Virus Database: 269.17.13/1208 - Release Date: 03/01/2008 15:52

Changed in gtk:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.