[gutsy] flash plugin reported as installed when it actually failed

Bug #139138 reported by Michael DePaulo on 2007-09-12
28
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apturl (Ubuntu)
Undecided
Unassigned
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

System:
gutsy x64 from Sept 12th
firefox 2.0.0.6+0ubuntu3

There are a number of reasons why the adobe flash plugin (flashplugin-nonfree) will not install, but here is the easiest way to reproduce it failing:

Open up an aptitude-based program like synaptic. Then browse to a flash animation in firefox and click on the prompt to install flash player. It will fail to install because of the apt-based program already being opened. Yet it will then report it as a being installed successfully.

This is a minor bug because it is not a bug that breaks functionality, but rather misinforms the user.

description: updated
Scott Ritchie (scottritchie) wrote :

Confirmed. Also happens when running apt-get in a terminal in the background.

It's not that big of a deal, since reloading a page with flash will prompt you to install it again.

Changed in firefox:
status: New → Confirmed
searayman (mikejones3) wrote :

happens to me when firefox tries to install missing plugins....

HetaUma (baziliz) wrote :

confirmed on x86 too

manny (estelar57) wrote :

also, it will not install from the live-cd (says it can't find it)

it should be included in the live-cd...

Gnash will install, but is still very beta (not really an option right now). It confuses more in my opinion. If someone wanted to install gnash they would do it throu synaptic or add/remove progr.

we want flash non-free prompted and installable by default...

we're *not* sticking flashplugin-nonfree on the cd. Just. No.

Alexander Sack (asac) wrote :

this was fixed in one of the recent flashplugin-nonfree uploads to gutsy. If you still see this after reinstalling flashplugin-nonfree, pleaes reopen.

Changed in firefox:
status: Confirmed → Fix Released
Andrew Melo (andrew-melo) wrote :

Alexander-

I don't have flashplugin-nonfree installed (I have a vanilla install of the RC cd), but firefox doesn't prompt me to install it, it just bombs out with the error "Can not find 'flashplugin-nonfree'". Is that the desired behavior?

On Tue, Oct 16, 2007 at 06:38:51PM -0000, Andrew Melo wrote:
> Alexander-
>
> I don't have flashplugin-nonfree installed (I have a vanilla install of
> the RC cd), but firefox doesn't prompt me to install it, it just bombs
> out with the error "Can not find 'flashplugin-nonfree'". Is that the
> desired behavior?
>

Can you get a screenshot of that situation?

 - Alexander

Andrew Melo (andrew-melo) wrote :

here's some screenshots

Andrew Melo (andrew-melo) wrote :

more

Andrew Melo (andrew-melo) wrote :

final one

liorda (liorda) wrote :

I confirm this bug on Gutsy final release (x86).

If there's a fix, why not explaining it as a comment?

Sudhanshu (sudhanshuraheja) wrote :

I am a newbie and have never replied on launchpad yet. But since I was able to fix this problem, I though I would add it in here. Since most newbies like me land up on this page looking for a solution, I thought it would be a good idea. Do let me know if this is not the place for such stuff, I would not do it again.

Here is how I got flash working on my machine
1. aptitude remove flashplugin-nonfree
    This is to get rid of the previously installed plugin. It didn't show us any flash so we are going to be merciless with it. If it asks to get rid of ubuntu-restricted-extras, make sure you remove that too.
2. rm ~/.mozilla/plugins/*flash*
    This is to get rid of the local profiles of flash already present on the system.
3. wget -c http://fpdownload.macromedia.com/get/ flashplayer/current/install_flash_player_9_linux.tar.gz
    Now, we download the actual file from the macromedia site to install flash player.
4. tar -xvzf install_flash_player_9_linux.tar.gz
    Ok, now that we have the file, we need to unzip it, and add the files to the required folders.
5. sudo cp install_flash_player_9_linux/libflashplayer.so /usr/lib/firefox/plugins/
sudo cp install_flash_player_9_linux/flashplayer.xpt /usr/lib/firefox/plugins/
    First, we copy these two files to the /usr/lib/firefox folders. Sometimes it starts working here, but if you're as unlucky as me it won't. Which is why we have a few more steps.
6. ps -aef | grep firefox
    This is where we check where firefox is really installed. If you see /usr/local/bin/firefox anywhere around, follow step 7, otherwise goto step 8
7. sudo cp flashplayer.xpt /usr/local/firefox/plugins/
sudo cp libflashplayer.so /usr/local/firefox/plugins/
   Now we move the same files to the /usr/local/firefox folder, so that the flash files are available on that profile too. If it still doesn't work, don't worry, we still have one more trick up our sleeve.
8. mkdir ~/.mozilla/plugins/
   Finally, the last trick, we create a completely local profile for flash. It won't be visible to other users on the machine.
9. cp flashplayer.xpt /root/.mozilla/plugins/
cp libflashplayer.so /root/.mozilla/plugins/
    Finally, we add the files to your local profile.
11. close firefox and restart it
    Now we're all done. Open any flash enabled site, and watch the fireworks.

Andrew Melo (andrew-melo) wrote :

Sudhanshu-
We might be taking about different problems, the bug I ran into was that flashplugin-nonfree wasn't installed at all. Then, when firefox asked to install it, the installer bombed out because of a bug (I think because when I installed, I didn't have an internet connection, so there were no repositories configured that had flashplugin-nonfree (many were commented out)). However, firefox misread the installer return value and said the installation was successful when it actually failed.

Your method will work fine, but there might be problems down the line if another program tries to reinstall flashplugin-nonfree. I don't know if the install script is smart enough to remove the old libraries before installing. If so, you might run into conflicts.

Alexander Sack (asac) wrote :

in comment https://bugs.edge.launchpad.net/ubuntu/+source/apturl/+bug/139138/comments/14 the outlines that:

"Then, when firefox asked to install it, the installer bombed out because of a bug (I think because when I installed, I didn't have an internet connection, so there were no repositories configured that had flashplugin-nonfree (many were commented out)). However, firefox misread the installer return value and said the installation was successful when it actually failed."

this appears to be an apturl bug. if its not the wrong return value its probably a not honoured section (multiverse) hint.

Changed in apturl:
status: New → Confirmed
leebojammin (codeofjustice) wrote :

I have the same problem on youtube, whats up with this bug ??

thx

Barry K. Nathan (barryn) wrote :

leebojammin, since your comment is much more recent than anything else on this bug, you may actually be experiencing bug #174709, as opposed to this bug. This bug (139138) is that firefox and/or apturl is failing to install the flashplugin-nonfree package properly and/or failing to properly report errors to the user (maybe I'm being a bit imprecise, but I scanned through the comments here rather quickly).

In contrast, bug 174709 is that the flashplugin-nonfree package is getting installed properly by the Ubuntu package management infrastructure, but that the flashplugin-nonfree package itself is failing to properly download and install files from Adobe's Flash player download. (It downloads the tarball from Adobe but notices that the MD5 sum does not match, so it does not proceed to install the files. The reason the MD5 sum does not match is because Adobe recently released a new version of the Flash player.)

carlosm7 (carlosm7) wrote :

Hi.

I am not sure if this is related to this bug, but I was having the same symptom.

In my case, Firefox was showing something to the effect of "click here to install plugin" instead of the video, but the installation would respond "plugin already installed".

When I was installing "ubuntu-restricted-extras" something went wrong, but it still was reported as successful. Uninstalling and reinstalling the restricted extras either with apt-get or "Add/remove" would not change anything.

I had to go to Synaptic, remove completelly "flashplugin-nonfree", reinstall it from Firefox, and now it is fixed.

Siegfried Gevatter (rainct) wrote :

I'm closing the apturl task, as as far as I know the issue about ubufox incorrectly reporting a success has been fixed (and if not, it's not a problem with apturl, as it now returns proper exit codes which can be checked against).

If you are experiencing some other issue than the one described above, and it is reproducible in Intrepid, please file a new bug against apturl. Thanks.

Changed in apturl:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers