Ubuntu

tooltips dont work in sidebar

Reported by Yves Orton on 2007-08-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Medium
firefox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: firefox

I have a page that is meant to be used as a firefox sidebar. When I have img input control with tooltips associated to them (alt or title) i do not see the tooltips when i hover over the img'es when loaded in a sidebar. When the same page is loaded in a normal tab the tooltips are visible.

ProblemType: Bug
Architecture: i386
Date: Thu Aug 16 16:10:34 2007
DistroRelease: Ubuntu 7.04
Package: firefox 2.0.0.6+1-0ubuntu1
PackageArchitecture: i386
SourcePackage: firefox
Uname: Linux gemini 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

Steps to Reproduce:
This is just one example, as it's the main sidebar I use which would have
tooltips on it.
1. Go to http://sitebar.org/sitebar3/ .
2. Click on the link "SiteBar" in "Mozillazine topic describes how to use
SiteBar sidebar extension" which will install the sitebar extension.
3. Click on the link "SiteBar" and hover over some of the buttons up the top to
confirm that the tooltips are there.
4. Open the SiteBar sidebar and hover over the same buttons.

Actual Results:
Nothing happens while hovering over the buttons.

Expected Results:
Tooltips should have been displayed, the same as if the page were loaded in the
main frame.

Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040911 Firefox/0.10
Same problem here.
Try opening e.g. this page: http://www.mozilla.org/products/firefox/ in the
sidebar, and when hovering the mouse over the mozilla logo at the top you should
see the text [Return to homepage] in a tooltip. This works fine in a normal
window, but the tooltip doesn't show up if the page is loaded in a sidebar.

Reproducible: Always
Steps to Reproduce:
1. Add this link as an bookmark: http://www.mozilla.org/products/firefox/
2. Go to Bookmarks|Manage Bookmarks and right click on the bookmark you added
and select properties
3. Click the "Load this link in the sidebar" checkbox
4. Close the Bookmarks Manager
5. Select the bookmark you added in your bookmark menu and watch the link open
in a sidebar
6. Try to hoover the mouse over the mozilla logo

Actual Results:
Nothing happens when hoovering the logo

Expected Results:
Tooltips should have been displayed, the same as if the page were loaded in the
main frame.

Created an attachment (id=159272)
Simple oneline patch that would fix this bug

This simple patch adds the attribute tooltip="aHTMLTooltip" to the <browser
id="sidebar"> sidebar component

this is a duplicate of 229831

confirming based on comment 1. Havar, please don't set blocking-aviary1.0 flag
to + if you don't have the privileges to do so. For your patch to have chances
for review, you must set the appropriate flag and check guidelines at
http://www.mozilla.org/hacking/code-review-faq.html

*** Bug 229831 has been marked as a duplicate of this bug. ***

forgot to say that you can still nominateitfor aviary by setting the associated
flag to "?"

(From update of attachment 159272)
first, this isn't the same tooltip as the bookmarks toolbar, second, it doesn't
 quite seem to work right, and third, I don't think we want every sidebar to
have this.

I thought it should be possible in any sidebar, but really I'm easy, as long
as custom sidebars like Sitebar work properly.

(In reply to comment #7)
> first, this isn't the same tooltip as the bookmarks toolbar, second,

Why should this be the same tooltip as in bookmarks-toolbar? It should be the same like on any other webpage. FYI, I can see no difference between the tooltips in the bookmarks toolbar an the tooltips from this patch.

> it doesn't quite seem to work right,

I have no problems with this patch. What does not work right?

> and third, I don't think we want every sidebar to have this.

Why not? For example an this ( http://de.selfhtml.org/navigation/sidebars/html.htm
 ) sidebar, this is really annoying, because, you can't see the tooltips from the red X'es, when hoovering them.
There is no reason, why we would hide the tooltips from the user intentional. This is like saying: "It's not a bug, it's a feature, we want wo hide these evil tooltips from the user".

Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8) Gecko/20051107 Firefox/1.5

*** Bug 383834 has been marked as a duplicate of this bug. ***

I posted Bug 383834, which is a duplicate of this bug. Is it fixed in the current build (2.x)?

2.0.0.5 certainly still exhibits the problem. It's pretty easy to verify.

2.0.0.6 still exhibits this problem.

On my linux box making the change as described by Jonathon Haas makes them work as expected. Please can his patch be applied for the next release?

Whoops I meant Håvar I. Henriksen's patch resolves this issue.

Yves Orton (demerphq) wrote :

Binary package hint: firefox

I have a page that is meant to be used as a firefox sidebar. When I have img input control with tooltips associated to them (alt or title) i do not see the tooltips when i hover over the img'es when loaded in a sidebar. When the same page is loaded in a normal tab the tooltips are visible.

ProblemType: Bug
Architecture: i386
Date: Thu Aug 16 16:10:34 2007
DistroRelease: Ubuntu 7.04
Package: firefox 2.0.0.6+1-0ubuntu1
PackageArchitecture: i386
SourcePackage: firefox
Uname: Linux gemini 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

Yves Orton (demerphq) wrote :

On Thu, Aug 16, 2007 at 02:13:56PM -0000, Yves Orton wrote:
> Public bug reported:
>
> Binary package hint: firefox
>
> I have a page that is meant to be used as a firefox sidebar. When I have
> img input control with tooltips associated to them (alt or title) i do
> not see the tooltips when i hover over the img'es when loaded in a
> sidebar. When the same page is loaded in a normal tab the tooltips are
> visible.

So how did you get that html page in there? A step by step instruction
on how to do that would be much appreciated.

 - Alexander

Yves Orton (demerphq) wrote :

On 8/17/07, Alexander Sack <email address hidden> wrote:
> On Thu, Aug 16, 2007 at 02:13:56PM -0000, Yves Orton wrote:
> > Public bug reported:
> >
> > Binary package hint: firefox
> >
> > I have a page that is meant to be used as a firefox sidebar. When I have
> > img input control with tooltips associated to them (alt or title) i do
> > not see the tooltips when i hover over the img'es when loaded in a
> > sidebar. When the same page is loaded in a normal tab the tooltips are
> > visible.
>
> So how did you get that html page in there? A step by step instruction
> on how to do that would be much appreciated.
> --
> tooltips dont work in sidebar
> https://bugs.launchpad.net/bugs/132938
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Ok, this is Mozzila 259199, whcih has an attached functional patch
which for some reason the mozilla team has not applied.

https://bugzilla.mozilla.org/show_bug.cgi?id=259199

The way to get a page to open in the sidebar is:

Bookmark a page.
View properties on the bookmark.
Turn on the checkbox marked "Load this bookmark in the sidebar".
Hover over an object that normally has a tooltip, note the tooltip doesnt show.
Right click on the side bar, in the "This Frame" submenu click on
"open frame in new tab"
Hover over an object on the tab and note the tooltip does show.

The patch in https://bugzilla.mozilla.org/attachment.cgi?id=159272
when applied to firefox 2.0.0.6 resolves this issue.

Yves

--
perl -Mre=debug -e "/just|another|perl|hacker/"

Changed in firefox:
assignee: nobody → mozilla-bugs
description: updated
Changed in firefox:
status: Unknown → Confirmed
Alexander Sack (asac) wrote :

this is dealt with in the mozilla bugtracker. The mozilla bug is properly marked in this bug report.

Changed in firefox:
status: New → In Progress

*** Bug 401630 has been marked as a duplicate of this bug. ***

Alexander Sack (asac) on 2008-11-01
Changed in firefox:
importance: Undecided → Low
status: In Progress → Triaged
assignee: mozilla-bugs → nobody

*** This bug has been marked as a duplicate of bug 244371 ***

Changed in firefox:
status: Confirmed → Invalid

This bug is about displaying a webpage in the sidebar, and not allowing showing tooltips (/titles).

This is not a duplicate of bug 244371 which is strictly for bookmarks and history.

This bug see comment #1 which is not about looking at bookmarks in the sidebar, but about the sidebar brought up when using option in a bookmark to display the bookmarked webpage into the sidebar. See comment #7 from Mike Conner specifically stating that this is NOT the same as tooltips on the bookmarks toolbar; therefore, this should not be resolved by pointing to bug pertaining to bookmarks.

Other bugs about use of webpages in side bar have been pointed to this bug.

Created an attachment (id=367471)
Working patch

This patch fixes the problem and Mike's review (comment #7).

It displays a tooltip over webpages only, it doesn't display a tooltip over any other sidebar (e.g.: bookmarks and history sidebar bug 244371)

Changed in firefox:
status: Invalid → Confirmed

(From update of attachment 367471)
Review -> land on trunk -> then ask for approval.

*** Bug 480446 has been marked as a duplicate of this bug. ***

(From update of attachment 367471)
Dao, can you take a look? I'm still way behind on my queue...

Changed in firefox:
status: Confirmed → Fix Released
Micah Gersten (micahg) wrote :

Firefox 3.0 is only receiving Security Updates and major bug fixes at this point.

Changed in firefox-3.5 (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in firefox-3.0 (Ubuntu):
status: Triaged → Won't Fix
Micah Gersten (micahg) wrote :

This might be added to Firefox 3.5 at some point. It will definitely be in Firefox 3.6.

Micah Gersten (micahg) on 2009-08-14
tags: added: fixed-3.6
Micah Gersten (micahg) on 2009-11-26
Changed in firefox:
milestone: none → 3.6
Micah Gersten (micahg) wrote :

Firefox will be the source for Firefox 3.6, so reopening this task

affects: firefox-3.0 (Ubuntu) → firefox (Ubuntu)
Changed in firefox (Ubuntu):
status: Won't Fix → Triaged
Launchpad Janitor (janitor) wrote :
Download full text (9.6 KiB)

This bug was fixed in the package firefox - 3.6+nobinonly-0ubuntu1

---------------
firefox (3.6+nobinonly-0ubuntu1) lucid; urgency=low

  * New upstream release v3.6 (FIREFOX_3_6_RELEASE)
    + fix LP: #449744 - Firefox crashes when attempting to load Firebug 1.5
    + fix LP: #66015 - Duplicate spell checking dictionaries for every entry
    + fix LP: #132938 - tooltips dont work in sidebar
    + fix LP: #195698 - Password asked separately for each tab that requires it
                        (proxy)
    + fix LP: #239462 - tooltips disappear too fast
    + fix LP: #385816 - Resize corner grab stays visible after maximize
    + fix LP: #429476 - firefox crash on javascript page
    + fix LP: #432876 - Icons missing in Firefox searchbox drop down list
    + fix LP: #486284 - maxlength on input box can be overriden by autocomplete
    + fix LP: #501393 - Integrate Firefox notifications with notify-osd bling

  [ H. Montoliu <email address hidden> ]
  * fix LP: #361052 - firefox apport hook fails to retrieve pluginreg.dat file
  * update debian/apport/firefox-3.6.py - removed unused code and minor refactoring.

  [ Fabien Tassin <email address hidden> ]
  * Update the location of the upsteam branch now that 3.6/Namoroka has its own
    branch, and trunk moved on to 3.7
    - update debian/mozclient/firefox-3.6.conf
  * Use Namoroka instead of Shiretoko as brand name and use it for snapshots.
    Name it Namoroka in the Preferred Application UI too
    - update debian/firefox-3.6-shiretoko.desktop => debian/firefox-3.6-namoroka.desktop
    - update debian/firefox-3.6.xml
    - update debian/rules
  * Target the 'default' branch instead of tip
    - add debian/moz-rev.sh
    - update debian/mozclient/firefox-3.6.conf
  * Add firefox 3.6 to the list of Preferred Applications in Gnome
    - add debian/firefox-3.6.xml
    - update debian/firefox-3.6-gnome-support.install
  * Add ${misc:Depends} to all non-transitional packages, make firefox-3.6-dbg
    depend on firefox-3.6 with the exact same version, move -dbg packges to
    priority extra and add firefox-3.6-gnome-support-dbg
    - update debian/control
  * Update diverged patches:
    - update debian/patches/browser_branding.patch
    - update debian/patches/firefox-profilename
    - update debian/patches/ubuntu_bookmarks.patch
    - update debian/patches/lp185622_system_path_default_browser.patch
    - update debian/patches/dont_depend_on_nspr_sources.patch

  [ Alexander Sack <email address hidden> ]
  * add libnotify-dev to build-depends
    - update debian/control
  * add libiw-dev to build-depends to fix build failure
    - update debian/control
  * until we move searchplugins to a separate package provided only by the current default
    firefox, we need to make firefox-3.6 replace all the older firefox binary packages:
    firefox-3.5, firefox-3.2, firefox-3.1, firefox-3.0
    - update debian/control
  * implement MIN_SYS_DEPS approach that does not use system xulrunner
    and only a minimal set of system dependencies.
    + drop patches not required anymore:
      - delete debian/patches/dont_depend_on_nspr_sources.patch
      - update debian/patches/series
    + update browser directory provider...

Read more...

Changed in firefox (Ubuntu):
status: Triaged → Fix Released
Changed in firefox:
importance: Unknown → Medium
no longer affects: firefox-3.5 (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.