firefox adress bar black on pentium processor with integrated graphics

Bug #1316250 reported by Lyn Perrine
This bug affects 20 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)

Bug Description

On an old pentium 4 machine with i386 Upgrade to firefox 29 by sudo apt-get update && sudo apt-get dist-upgrade. Then close any open firefox and restart it. I get a firefox dark gray and black bar in the address bar showing up in all pages. on firefox 29 with the new interface. This makes it impossible to see what website you are currently on in the address bar.
If I open a new tab the adress bar appears blank and I can then enter the text. I am also unable to copy the current address bar with this black bar which can make sharing links difficult. This bug is not present on my

Description: Ubuntu 14.04 LTS
Release: 14.04
  Installed: 29.0+build1-0ubuntu0.14.04.2
  Candidate: 29.0+build1-0ubuntu0.14.04.2
  Version table:
 *** 29.0+build1-0ubuntu0.14.04.2 0
        500 trusty-updates/main i386 Packages
        500 trusty-security/main i386 Packages
        100 /var/lib/dpkg/status
     28.0+build2-0ubuntu2 0
        500 trusty/main i386 Packages
Graphics card information
Graphics:  Card: Intel 82865G Integrated Graphics Controller
  X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x768@60.0hz
  GLX Renderer: Mesa DRI Intel 865G x86/MMX/SSE2 GLX Version: 1.3 Mesa 10.1.0

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: firefox 29.0+build1-0ubuntu0.14.04.2
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic i686
AddonCompatCheckDisabled: False
ApportVersion: 2.14.1-0ubuntu3
Architecture: i386
 /dev/snd/controlC0: brendan 1718 F.... pulseaudio
BuildID: 20140428194004
CRDA: Error: [Errno 2] No such file or directory: 'iw'
Channel: Unavailable
CurrentDesktop: LXDE
Date: Mon May 5 10:19:03 2014
ForcedLayersAccel: False
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
 English (GB) Language Pack - <email address hidden>
 English (South Africa) Language Pack - <email address hidden>
 Default - {972ce4c6-7e08-4474-a285-3208198ce6fd}
InstallationDate: Installed on 2013-07-12 (297 days ago)
InstallationMedia: Lubuntu 13.04 "Raring Ringtail" - Release i386 (20130423.1)
 default via dev eth0 proto static dev eth0 proto kernel scope link src metric 1
 lo no wireless extensions.

 eth0 no wireless extensions.
 Windows Media Player Plug-in - /usr/lib/mozilla/plugins/ (gecko-mediaplayer)
 RealPlayer 9 - /usr/lib/mozilla/plugins/ (gecko-mediaplayer)
 QuickTime Plug-in 7.6.9 - /usr/lib/mozilla/plugins/ (gecko-mediaplayer)
 mplayerplug-in is now gecko-mediaplayer 1.0.8 - /usr/lib/mozilla/plugins/ (gecko-mediaplayer)
 DivX Browser Plug-In - /usr/lib/mozilla/plugins/ (gecko-mediaplayer)
PrefSources: prefs.js
Profiles: Profile0 (Default) - LastVersion=29.0/20140428194004 (In use)
RelatedPackageVersions: gecko-mediaplayer 1.0.8-4ubuntu1

RunningIncompatibleAddons: True
SourcePackage: firefox
UpgradeStatus: Upgraded to trusty on 2014-02-26 (68 days ago) 11/08/2004
dmi.bios.vendor: Dell Computer Corporation
dmi.bios.version: A02 0TC667
dmi.board.vendor: Dell Computer Corp.
dmi.chassis.type: 6
dmi.chassis.vendor: Dell Computer Corporation
dmi.modalias: dmi:bvnDellComputerCorporation:bvrA02:bd11/08/2004:svnDellComputerCorporation:pnDimension3000:pvr:rvnDellComputerCorp.:rn0TC667:rvr:cvnDellComputerCorporation:ct6:cvr: Dimension 3000
dmi.sys.vendor: Dell Computer Corporation

Revision history for this message
Lyn Perrine (walterorlin) wrote :
Revision history for this message
Lyn Perrine (walterorlin) wrote :

I should also note it works perfectly fine on my core 2 duo 64 bit machine on lubuntu.

Revision history for this message
Lyn Perrine (walterorlin) wrote :

One workaround to get to the url you currently are on is to open the history on firefox 29 as then it still shows the correct page.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Revision history for this message
John Hupp (john.hupp) wrote :

I do not have the problem on a Lenovo 3000 C200 running Lubuntu 14.04 32-bit/Firefox 29.

It has an Intel T2080 dual-core processor and Intel Mobile 945GM Express Chipset video controller.

Revision history for this message
kalehrl (kalehrl) wrote :

My dell latitude d505 with 82852/855GM Integrated Graphics exhibits the same behaviour.
There was no problem with Firefox 28.

Revision history for this message
Lyn Perrine (walterorlin) wrote :

MY drive with lubuntu on it on the pentium 4 machine is on an external hard drive? Would it be helpful if I moved the hardrive to a laptop or other computer and booted it and see if it is a problem with different graphics with all other things equal?

Revision history for this message
Redwolf (viking.redwolf) wrote :

No problems with nVidia proprietary drivers. Maybe Firefox is doing something weird with GPU acceleration.

Revision history for this message
Lyn Perrine (walterorlin) wrote :

I previously tried turning off gpu accelaration in prefrences it did not seem to change anything but do I need to restart firefox?

Revision history for this message
kalehrl (kalehrl) wrote :

Don't bother.
Turning off hw acceleration and restarting Firefox doesn't fix the issue.

Revision history for this message
C4C (ericbradshaw) wrote :

To fix in Firefox 29:
type about:config[Enter]
Promise to be careful
In the Search Bar type gfx.xrender.enabled
Right-click (F12) and Toggle to make it false
Exit Firefox. Open Firefox again.

Whew! I like the new look of Firefox 29, but this had spoiled it in a Dell Dimension 2400, Dell OptiPlex GX520 and HP d220 MT. It would have been a show-stopper if it had not been for the suggestion by Benoit Jacob [:bjacob] found here:

Revision history for this message
drewvt (drewvt) wrote :

Also on Lubuntu 12.04 with Gnome 3.4.2.

Revision history for this message
jorgelucho (jorgelucho-q) wrote :

I confirm this bug with an old IBM NetVista Pentium IV, I'v solved temporally installing another complete theme, only some theme working, turning off hw acceleration do not solve the problem,

Revision history for this message
dllud (dllud) wrote :

Also have the bug on a Pentium 4 with Intel 82865G Integrated Graphics. The workaround by C4C (setting gfx.xrender.enabled to false) worked here. Thanks for sharing.

Revision history for this message
Mike (web-g) wrote :

Same problem on two old Pentium 4 boxes with Ubuntu 14.04.

Revision history for this message
My name (plmalternate) wrote :

Toggling gfx.xrender.enabled didn't work for me. Same problem. Just started happening sometime in the last week or so. Url field is a uniform black while the search field on the same toolbar is normal. If I double click in the field to select the text there it becomes visible If I press "home" or "end" to bring the cursor to either end of the line it gets black on black again. This really sucks. If somebody forks Firefox and makes a commitment to stability I'm out of here. This "bug du jour" business is getting really old.
Firefox 36.0.4
Ubuntu 14.04 Trusty, 64 bit, built from the mini.iso without all the glitter crap.
Plain Openbox, no further DE.
Nvidia graphics card.
AMD cpu, I forget the model, but dual core anyway.
4 giB RAM

I have 4 themes installed. The problem occurs on 3 of them:
It does NOT occure on one:
Metal Lion Australis
but that theme ignores much of my customisation of the toolbars and has absurdly awful colors.

Revision history for this message
Jaap Woldringh (jjhwoldringh) wrote :

I had this bug and fixed it as in comment #11.
This was fine, on a Pentium M Toshiba laptop, using Lubuntu 14.04.

However, after the latest update of Firefox (40.0) Firefox stops loading before the URL-bar appears, and pages can be loaded. Just the main frame appears, with the heading with the name of the start page.

I found the setting " gfx.xrender.enabled" to False is the culprit, so I had to undo this setting.

So: now what should I do?

Jaap Woldringh

Revision history for this message
madluther (madluther) wrote :


I had the same problem in firefox 40.0.3 if I set "layers.offmainthreadcomposition.enabled" to false in about:config, then I can also set gfx.xrender.enabled to false as well, it also seems to have stabilized firefox, with "layers.offmainthreadcomposition.enabled" set to true FF was *very* unstable.



Revision history for this message
john (drjohncrabtree) wrote :

Same problem with fujitsu fmv biblo NB75G pentium M. Fixed following C4C (#11) suggestion.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.