Your Firefox profile cannot be loaded. It may be missing or inaccessible.

Bug #1310680 reported by Huck-bernhard on 2014-04-21
58
This bug affects 12 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned
synaptic (Ubuntu)
Undecided
Unassigned

Bug Description

when you klick a link "Visit Homepage" in Synaptic do you get this error message (Firefox not runing)

messagebox:
Your Firefox profile cannot be loaded. It may be missing or inaccessible.

if firefox already open link "Visit Homepage" is working.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: firefox 28.0+build2-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic i686
AddonCompatCheckDisabled: False
ApportVersion: 2.14.1-0ubuntu3
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bernhard 1657 F.... pulseaudio
BuildID: 20140410211157
Channel: Unavailable
Date: Mon Apr 21 17:38:57 2014
ExecutablePath: /usr/lib/firefox/firefox
Extensions: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
InstallationDate: Installed on 2014-04-18 (2 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20140417)
IpRoute:
 default via 192.168.0.1 dev eth0 proto static
 192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.101 metric 1
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Locales: extensions.sqlite corrupt or missing
PrefSources: prefs.js
ProcEnviron:
 LANGUAGE=de_DE
 TERM=unknown
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=28.0/20140410211157
RfKill:

RunningIncompatibleAddons: False
SourcePackage: firefox
Themes: extensions.sqlite corrupt or missing
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

Huck-bernhard (huck-bernhard) wrote :
description: updated

I don't see any option to click the link when running Synaptic in Xubuntu (I'm looking in Help -> About). Maybe Unity makes this link clickable?

I'm guessing what's happening is that Synaptic is starting firefox with root permissions if it's not already open.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Changed in synaptic (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1310680

tags: added: package-qa-testing
Tomi Urankar (tomi0) wrote :

Are there any workaround until this issue is resolved?

Tomi Urankar (tomi0) wrote :

I am using Kubuntu 15.10

Tomi Urankar (tomi0) wrote :

Running Synaptic using from command line using 'sudo' instead of 'kdesudo' makes it work.
But it still will not open Chrome which is my default browse, but it will open Firefox instead.

Piet Starreveld (pstarrev) wrote :

@tomi0: Synaptic uses xdg-open for visiting URL's and when you set your personal default browser to chrome, root's default still remains firefox. Additionally, the xdg-open man-page says 'xdg-open is for use inside a desktop session only. It is not recommended to use xdg-open as root', but anyway, here goes a workaround :-)

Steps 1 thru 4 below are one-time only. Note that the workaround ONLY works when using sudo to run synaptic from the command line (step 5). It's not required start synaptic in the background - that's just my personal preference.

# 1. confirm root's web-browser is reported as 'firefox.desktop'
sudo xdg-settings get default-web-browser

# 2. create dirs missing for chrome to be able to become root's default web-browser
sudo mkdir -p /root/.config /root/.pki/nssdb

# 3. change root's default web-browser to chrome
sudo xdg-settings set default-web-browser google-chrome.desktop

# 4. ensure newly created dirs have proper access
sudo chmod 700 /root/.config /root/.local /root/.pki

# 5. run synaptic in background from command line using sudo
sudo synaptic &>/dev/null &

Here's the relevant /var/log/syslog entries before (and when using Synaptic's 'authentication' dialogue):

synaptic.desktop[6148]: Error: Access was denied while trying to open files in your profile directory.
synaptic.desktop[6148]: (firefox:7212): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
synaptic.desktop[6148]: Failed to connect to socket /tmp/dbus-19wsCpfYwj: Connection refused
synaptic.desktop[6148]: mkdir: cannot create directory ‘/root’: Permission denied
synaptic.desktop[6148]: touch: cannot touch '/root/.local/share/applications/mimeapps.list': Permission denied
synaptic.desktop[6148]: [0513/081219:ERROR:nss_util.cc(98)] Failed to create /root/.pki/nssdb directory.
kernel: [ 3701.124769] traps: chrome[7261] general protection ip:7f30c819a186 sp:7ffed3d45840 error:0 in libc-2.23.so[7f30c8163000+1c0000]
synaptic.desktop[6148]: [0513/081219:ERROR:nss_util.cc(98)] Failed to create /root/.pki/nssdb directory.
synaptic.desktop[6148]: Error: Access was denied while trying to open files in your profile directory.
synaptic.desktop[6148]: (firefox:7324): GConf-WARNING **: Client failed to connect to the D-BUS daemon:

And here's the relevant entry remaining after (i.e. step 1 thru 4 completed and starting synaptic using sudo):
google-chrome.desktop[11464]: context mismatch in svga_sampler_view_destroy

Btw: I am using Ubuntu Gnome 16.04 LTS

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers