Ubuntu

"Recently closed tabs" is always greyed-out

Reported by Can Kaya on 2007-08-01
8
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Mozilla Bugs

Bug Description

Binary package hint: firefox

Firefox 2.0.0.6's Recently Closed Tabs function doesn't seem to remember the tabs I recently closed.

ProblemType: Bug
Architecture: i386
Date: Wed Aug 1 20:32:44 2007
DistroRelease: Ubuntu 7.04
Package: firefox 2.0.0.6+1-0ubuntu1
PackageArchitecture: i386
SourcePackage: firefox
Uname: Linux can1 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux

Can Kaya (ckaya) wrote :
Jan Eppo Jonker (j-e-jonker) wrote :

On Gutsy,
Uname: Linux janeppo-desktop2 2.6.22-8-generic #1 SMP Thu Jul 12 16:09:47 GMT 2007 x86_64 GNU/Linux
Firefox 2.0.0.6
'Recently Closed Tabs' in 'History' menu is initially grey and becomes black (functional) after closing of some tab

It is still grey after closing some tabs. The bug mentioned was this.

John Vivirito (gnomefreak) wrote :

I am unable to reproduce this on gutsy, Jan can you please list all themes, extensions, and plugins you have.
I am able to reproduce this on feisty. Jan can you please file a seperate bug report using the firefox menu, help>report a problem as this will give us most info needed.

John Vivirito (gnomefreak) wrote :

sorry on my last comment i asked jan to list themes and stuff, that should have been for the original reporter: ckaya

Changed in firefox:
assignee: nobody → mozilla-bugs
status: New → Incomplete
John Vivirito (gnomefreak) wrote :

While playing around with it i am not able to reproduce this on feisty i had forgotten to open tab and close tab. it works as expected here.

Can Kaya (ckaya) wrote :

The only add-on I use is Download Statusbar -version 0.9.5- and the
only theme installed is Firefox (default) 2.0. Here is my bug-report:

"Public bug reported:

Binary package hint: firefox

Firefox 2.0.0.6's Recently Closed Tabs function doesn't seem to remember
the tabs I recently closed.

ProblemType: Bug
Architecture: i386
Date: Wed Aug 1 20:32:44 2007
DistroRelease: Ubuntu 7.04
Package: firefox 2.0.0.6+1-0ubuntu1
PackageArchitecture: i386
SourcePackage: firefox
Uname: Linux can1 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007
i686 GNU/Linux

** Affects: firefox (Ubuntu)
    Importance: Undecided
        Status: New"

Thanks for your interest!

Rivo Laks (rivol) wrote :

The same bug happens here as well, after installing the Estonian language pack extension.
Problem seems to be caused by the extension resetting Firefox homepage to blank page which causes history not to work.

I can reproduce it like this:
* Create new profile
* Install Locale Switcher 2.1 (https://addons.mozilla.org/en-US/firefox/addon/356)
At this point everything is still functional.
* Install Estonian language pack 2.0.12 (https://addons.mozilla.org/en-US/firefox/addon/4194)

After Firefox is restarted I have following problems:
* the History menu doesn't contain any history entries anymore (history sidebar still works though).
* Recently Closed Tabs entry is there but always grayed out.
* homepage seems to be changed to nothing (blank page).

When opening History menu, the Firefox's error console shows following:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIStringBundle.GetStringFromName]" nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)" location: "JS frame :: chrome://browser/content/browser.js :: anonymous :: line 3890" data: no]

Error: this._windows[aWindow.__SSi] has no properties
Sourc file: file:///usr/lib/firefox/components/nsSessionStore.js
Line: 671

Error: uncaught exception: [Exception... "'[JavaScript Error: "this._windows[aWindow.__SSi] has no properties" {file: "file:///usr/lib/firefox/components/nsSessionStore.js" line: 671}]' when calling method: [nsISessionStore::getClosedTabCount]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: chrome://browser/content/browser.js :: PHM_toggleRecentlyClosedTabs :: line 6353" data: yes]

First one comes when firefox is started, the other two come every time I open History menu.

As said, the problem seems to be the blank homepage because when I set it to something else, the history starts working as well. So the question is why do some extensions reset firefox's homepage in Ubuntu. It doesn't happen in Firefox installed from tarball (everything works as expected there).

FWIW, tested Firefox version was 2.0.0.6+1-0ubuntu1 for i386 (but it happened in 2.0.0.3 as well) in Kubuntu Feisty.

Rivo Laks (rivol) wrote :

Same bug is reproducible like this:
1) In preferences, change "When Firefox starts" to "Show a blank page" and delete content of the "Home Page" lineedit.
2) Close preferences and restart firefox
Now you get a blank page and history doesn't work.
Firefox installed from tarball also starts up with blank page at this point, but it's history works.

Note that if you don't clear the "Home Page" address line then it works even with "Show a blank page" selected.
And the bug also happens when you choose "Show a home page" but leave the "Home Page" line empty (note that you first have to set it to blank page and delete home page address, then restart firefox, select "Show my home page" but leave its address empty. Otherwise firefox resets homepage address).
And with Firefox from tarball, everything still works well and the bug does not occur.

Laur Mõtus (vprints) wrote :

Same thing as Rivo described happens here with my Estonian language pack.
Since Rivo provided so detailed information i am changing the status from 'Invalid' to 'Confirmed'.

Changed in firefox:
status: Incomplete → Confirmed
hirak99 (hirak99) wrote :

1) I just had the same problem in a Windows PC. So it seems like a Firefox problem. Am using FF3 with Windows XP SP3.

2) The following configuration change seemed to have solved it:

browser.sessionstore.enabled = true

The value was false when the problem was occurring. You can change that from about:config.

Please confirm if it solves the problem.

Thanks!

shableep (shableep) wrote :

Ditto, Hirak99. Same OS, same Firefox, same problem. Thanks for the heads up on the fix. Though, in my case, 'browser.sessionstore.max_tabs_undo' was set to '0'.

Seems like some extensions might be messing with the 'browser.sessionstore' settings.

Hi,

    is this still an issue with newer versions of FF i.e. 3.5 on Karmic or 3.6 on Lucid?

This error no longer occurs on newer version of FF, therefore closing. Please re-open if this is found on FF3.6.

Changed in firefox (Ubuntu):
status: Confirmed → Fix Released
Brad Lang (lontra-provocax) wrote :

Not sure what addon might have triggered it, but after I upgraded to Firefox 13, browser.sessionstore.max_tabs_undo was set to 0, so I bumped it up to 9

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers