gtk-qt-engine crashes Firefox with preferencies/downloads/save as dialogs

Bug #122167 reported by Alexander Butenko on 2007-06-25
6
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Mozilla Bugs
gtk-qt-engine (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

When i'm trying to download a file with firefox download manager firefox crashes
When i'm trying to go to Edit->Preferencies it crashes too.
When i'm trying to 'save page as..' it crashed too.

The bug is like libnss problem. It was happend long time ago on debian.
This problem was exist in 2.0.0.4+2-0ubuntu1 and 2.0.0.4+2-0ubuntu2 revisions.

Package: firefox
Priority: optional
Section: web
Installed-Size: 26228
Maintainer: Alexander Sack <email address hidden>
Architecture: i386
Version: 2.0.0.4+2-0ubuntu2
Replaces: libnss3
Provides: www-browser
Depends: fontconfig, psmisc, debianutils (>= 1.16), libatk1.0-0 (>= 1.13.2), libc6 (>= 2.5-5), libcairo2 (>= 1.4.0), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.2), libgcc1 (>= 1:4.2-20070516), libglib2.0-0 (>= 2.13.5), libgtk2.0-0 (>= 2.11.4), libhunspell-1.1-0 (>= 1.1.5-1), libjpeg62, libnspr4-0d (>= 1.8.0.10), libnss3-0d (>= 1.8.0.10), libpango1.0-0 (>= 1.17.3), libpng12-0 (>= 1.2.13-4), libstdc++6 (>= 4.2-20070516), libx11-6, libxcomposite1 (>= 1:0.3-1), libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3 (>= 1:4.0.1), libxft2 (>> 2.1.1), libxi6, libxinerama1, libxrandr2 (>= 2:1.2.0), libxrender1, libxt6, zlib1g (>= 1:1.2.1)
Suggests: firefox-gnome-support (= 2.0.0.4+2-0ubuntu2), latex-xft-fonts
Conflicts: libnss3
Filename: pool/main/f/firefox/firefox_2.0.0.4+2-0ubuntu2_i386.deb
Size: 9209834
MD5sum: 7844e79f9cb70d9ff1a6b1ee49b4d030
SHA1: c9f38dfcd48e4367b58c38b5153c970a2c466b6a
SHA256: d4a16a978fa6ac957c8aff7481541ba9536e52fe60bdc8a4b4dc882caa76af19

Alexander Butenko (avb) wrote :
Justin Payne (neolithium82) wrote :

Thank you for the bug report. Could you please try to obtain a backtrace by following the instructions on https://wiki.ubuntu.com/MozillaTeam/Bugs, or upload the crash report from /var/crash/.

Also, please answer these questions:
Which flash package do you have installed?
Which Java package do you have installed?
Which firefox extensions do you have installed?

This will greatly aid us in tracking down your problem.

Thanks again,
Justin

Changed in firefox:
assignee: nobody → jbeerwart
status: New → Incomplete
Justin Payne (neolithium82) wrote :

This bug seems like it MAY be related to https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/71691 however I'll leave this one as incomplete until the logs from the debug are posted and we can narrow it down.

Regards,
Justin

Changed in firefox:
assignee: jbeerwart → mozilla-bugs
importance: Undecided → High
Changed in firefox:
importance: High → Medium
Alexander Butenko (avb) wrote :

i moved ~/.mozilla to ~/.mozilla.old, moved all plugins from /usr/lib/firefox/plugins/ and restart firefox. Same problem happend.

$ dpkg -l|grep 'firefox\|mozilla'
ii firefox 2.0.0.4+2-0ubuntu2 lightweight web browser based on Mozilla
ii firefox-gnome-support 2.0.0.4+2-0ubuntu2 Support for Gnome in Mozilla Firefox
ii j2re1.4-mozilla-plugin 1:0ubuntu6 Java plugin for firefox
ii mozilla-firefox-adblock 0.5.3.043-1ubuntu1 AdBlock extension for the Firefox web browse
ii totem-mozilla 2.19.4-0ubuntu3 Totem Mozilla plugin

no more additional plugins installed. No firefox themes is used.

xfiler (ciccettino) wrote :

I've the same problem as described, both with latest firefox and swiftfox 2.0.0.5pre.
No solutioo found yet?
Bye

xfiler (ciccettino) wrote :

I solved the problem: searching on the internet I found one who suggested to remove the package gtk-qt-engine and that worked. I don't know more about.
package version was 0.71-svn20070224-0ubuntu3.
Bye

Alexander Butenko (avb) wrote :

Wow. Realy, I changed my 'Candido' gtk theme to 'Human' and bug dissapeared. :( I dont want to change my theme.
Will try to findout what is the problem in theme.

Justin, what do u think what we need to do with a bug? Is it still a firefox bug in gtk theme handling, or just a theme bug?
Its strange, but theme was always working for more then a year.

Justin Payne (neolithium82) wrote :

Hi Avb,
Thanks for the additional information. With this being a reproducable bug, can you please visit https://wiki.ubuntu.com/MozillaTeam/Bugs and obtain the relevant logs with their section on Crash and Backtrace? It would be beneficial for the Mozilla team to help them track down the relevant part that causes the issue.

Thank you again for your assistance,
Regards,
Justin

Alexander Sack (asac) wrote :

gtk-qt-engine is known to cause crashes. I added gtk-qt-engine task so it can be dealt with by gtk-qt-engine maintainers.

Firefox part is invalid.

Thanks for pointing out,

 - Alexander

Changed in firefox:
status: Incomplete → Invalid
Alexander Butenko (avb) wrote :

Just to note. I was NOT using gtk-qt-theme-engine. I was using regular gtk theme 'Candido'. So i can't comfirm that gtk-qt engine can be cause of this problem.

If needed i can attach theme.

Changed in gtk-qt-engine:
status: New → Incomplete
Alexander Butenko (avb) wrote :

This problem is still have place when i'm using firefox and any gtk theme which use pixbuf engine.
I think this is a bug in firefox packages according ubuntu look'n'feel patch.

On Sat, Aug 04, 2007 at 09:09:05PM -0000, avb wrote:
> This problem is still have place when i'm using firefox and any gtk theme which use pixbuf engine.
> I think this is a bug in firefox packages according ubuntu look'n'feel patch.
>

Can you list a few themes that use pixbuf engine, so others can
verify if there are crashes ... ?

 - Alexander

Alexander Butenko (avb) wrote :

avb@ds:~/.themes$ grep -r pixmap *|awk -F':' '{print $1}'|grep gtkrc$|uniq
aqua-i/gtk-2.0/gtkrc
AquaTunes/gtk-2.0/gtkrc
Candido/gtk-2.0/gtkrc
Candido-Light/gtk-2.0/gtkrc
GAIA/gtk-2.0/gtkrc

All themes is from gnome-look.org

Alexander Sack (asac) wrote :

On Sun, Aug 05, 2007 at 06:32:57PM -0000, avb wrote:
> avb@ds:~/.themes$ grep -r pixmap *|awk -F':' '{print $1}'|grep gtkrc$|uniq
> aqua-i/gtk-2.0/gtkrc
> AquaTunes/gtk-2.0/gtkrc
> Candido/gtk-2.0/gtkrc
> Candido-Light/gtk-2.0/gtkrc
> GAIA/gtk-2.0/gtkrc
>

Thanks ... so do you see the crash with all those?

 - Alexander

Alexander Butenko (avb) wrote :

yes. same described symptoms in this bug appears with all themes which use pixmap engines.
just for a check i download another one pixmap theme 'imetal' from gnome-look and find same
problem.

Alexander Sack (asac) wrote :

ok ... reopening firefox part of this bug ... next: we need a retrace of this crash ... tagging accordingly.

Changed in firefox:
status: Invalid → Incomplete

hmm, that crash report doesn't have a coredump file attached.

Please avb can you attach a full crash report?

Thank you.

Tagging the report as mt-needreport

Janne Koponen (jkoponen) wrote :

This seems to affect Thunderbird (and probably other XUL apps too) and
 both Ubuntu packages and packages directly from Mozilla.org.
Both are working fine when using Human theme, but crash (usually from modal windows) when using Pixbuf themes.

Alexander Sack (asac) wrote :

we appear still not to have a backtrace for this crash. Can we get one?

Launchpad Janitor (janitor) wrote :

[Expired for gtk-qt-engine (Ubuntu) because there has been no activity for 60 days.]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers