orig.tar.gz has binary-only files

Bug #121734 reported by Martin Pitt on 2007-06-22
10
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Confirmed
Medium
firefox (Ubuntu)
Critical
Alexander Sack
firefox-3.0 (Ubuntu)
High
Alexander Sack
lightning-sunbird (Ubuntu)
High
John Vivirito
midbrowser (Ubuntu)
High
Alexander Sack
thunderbird (Ubuntu)
High
Alexander Sack

Bug Description

Binary package hint: firefox

The orig.tar.gz's of Mozilla products have some binary-only files (Windows DLLs and MacOS) without accompanying source code. Thus they do not fulfill the 'preferred form of modification' requirements of GPL/MPL. They either need to be removed, accompanied by source, or distributed under another license (such as BSD).

Martin Pitt (pitti) on 2007-06-22
Changed in firefox:
assignee: nobody → asac
importance: Undecided → High
Alexander Sack (asac) on 2007-06-22
Changed in firefox:
status: New → Confirmed
Alexander Sack (asac) wrote :

this needs upstream work. Maybe we can help by assembling a list of such files, but lets wait for their initial feedback first.

Changed in firefox-granparadiso:
assignee: nobody → asac
importance: Undecided → High
status: New → Confirmed
Changed in thunderbird:
assignee: nobody → asac
importance: Undecided → High
status: New → Confirmed
Alexander Sack (asac) wrote :

as a start here the scripts that removes files for debian

Changed in midbrowser:
status: New → Confirmed
Changed in lightning-sunbird:
status: New → Confirmed
assignee: nobody → asac
Changed in midbrowser:
assignee: nobody → asac
Alexander Sack (asac) on 2007-08-28
Changed in lightning-sunbird:
importance: Undecided → High
Changed in midbrowser:
importance: Undecided → High

From Ubuntu Bug: https://bugs.edge.launchpad.net/ubuntu/+source/firefox/+bug/121734

===
The orig.tar.gz's of Mozilla products have some binary-only files (Windows DLLs and MacOS) without accompanying source code. Thus they do not fulfill the 'preferred form of modification' requirements of GPL/MPL. They either need to be removed, accompanied by source, or distributed under another license (such as BSD).
===

As a starter (probably not complete) a file list that appear to be binary-only can be found in the script:

  http://launchpadlibrarian.net/8648794/remove.nonfree

Possible resolutions:
 1. ship sources for the binary only files in produce tarball
 2. remove binary only files from distributed source tarball

Martin Pitt (pitti) wrote :

This has been dragged way too long. It needs to get fixed ASAP now.

Changed in firefox:
importance: High → Critical
Alexander Sack (asac) wrote :

ping send to upstream

Reed Loden (reed) wrote :

<asac> "ping send [sic] to upstream"

Is there a particular bug upstream you are tracking this in?

Alexander Sack (asac) wrote :

Reed, now done!

This is not actually a legal problem, although it may be a practical problem. To appreciate why, it's necessary to think about exactly what it means for something to be multiply-licensed.

It means two things:

1) Anyone distributing any of the code must obey at least one of the sets of terms applicable to it

2) Anyone receiving any of the code may use it under any of the terms applicable to each part

The Mozilla Project distributes the source tarballs (case 1) under MPL terms.

The Debian project takes those tarballs (case 2), and wishes to use a subset of the code/data therein under the GPL. That's absolutely fine, because all of the code they want to use is available under GPL terms too. However, in this case it happens to mean that the tarballs are not redistributable under those terms unmodified.

One solution, therefore, seems to be for Debian to modify the tarball before distributing it. However, perhaps this is a practical problem for Debian. Is it?

One further point: some of the files in the remove.nonfree script are in fact in the preferred form for modification. Examples:
rm -fv ./extensions/universalchardet/doc/UniversalCharsetDetection.doc
rm -fv ./xpinstall/wizard/os2/setuprsc/box_ch_d.bmp
rm -fv ./embedding/minimo/mozconfig
I'm fairly sure .rsrc are in the preferred form for modification as well, even though they are binary. If not, what are they compiled from?

Gerv

Changed in firefox:
status: Unknown → Confirmed

Debian != Ubuntu, fyi.

Alexander Sack (asac) wrote :

firefox (2.0.0.6+2nobinonly-0ubuntu1) gutsy; urgency=low

  * Reupload source tarball without binaries (LP: #121734) - sanitized using
    debian/remove.binonly.sh
  * debian/remove.binonly.sh: add script to strip original tarball from
    binary only cruft.
  * debian/debsearch.src: debsearch plugin now searches for gutsy packages
    (LP: #150503).

 -- Alexander Sack <email address hidden> Mon, 08 Oct 2007 13:04:06 +0200

Changed in firefox:
status: Confirmed → Fix Released
Alexander Sack (asac) wrote :

thunderbird (2.0.0.6+nobinonly-0ubuntu1) gutsy; urgency=low

  * repack orig.tar.gz to not contain binary only files found in LP: #121734
  * debian/remove.binonly.sh: debian/remove.binonly.sh import script to
    remove binary-only files

 -- Alexander Sack <email address hidden> Mon, 08 Oct 2007 18:36:36 +0200

Changed in thunderbird:
status: Confirmed → Fix Released
Alexander Sack (asac) wrote :

firefox-3.0 (3.0~alpha8+nobinonly-0ubuntu1) gutsy; urgency=low

  RELEASE: 3.0~alpha8+nobinonly-0ubuntu1 to gutsy/universe.
  * new orig.tar.gz without binary only files (LP: #121734).
  * debian/firefox.sh: fix typo in firefox.sh profile migration code
    (LP: #150529).

 -- Alexander Sack <email address hidden> Tue, 09 Oct 2007 10:48:36 +0200

Changed in firefox-3.0:
status: Confirmed → Fix Released
Alexander Sack (asac) wrote :

midbrowser (0.1.6c-0ubuntu1) gutsy; urgency=low

  * New upstream release 0.1.6c-0ubuntu1 with stripped binary-only files
    (LP: #121734). Noteworthy improvements:
    - main menu hildonization finished.
    - reworked the set and arrangement of main menu entries to match the
      midbrowser spec.
    - a local default startpage is used.
    - external and internal links are opened in tabs now.
    - a stripped down preferences dialog.
    - some stability improvements and general code-cleanup in
      nsXHildonEventService.
    - hildon component api now provides a function to peek the get the top-left
      corner coordinates of the gdk toplevel window associated with a certain
      xul element.
  * add debian/remove.binonly.sh script used to sanitize the git source
    tarball.

 -- Alexander Sack <email address hidden> Wed, 10 Oct 2007 02:10:33 +0200

Changed in midbrowser:
status: Confirmed → Fix Released

If any progress is to be made on this bug, we need to know why each file (or group of files, if files have been listed because they are of a particular file type) has been deemed as unsuitable. We can then analyse that and see if we can fix the problems.

I note that the corresponding Ubuntu bug seems to have some impatience in it. Let it not be said that we are being unresponsive here.

Gerv

Gerv (gerv-launchpad) wrote :

The corresponding bug in the Mozilla bug system is https://bugzilla.mozilla.org/show_bug.cgi?id=398728 .

Gerv

John Vivirito (gnomefreak) wrote :

Ill take care of sunbird since i have 0.7 almost ready for hardy anyway

Changed in lightning-sunbird:
assignee: asac → gnomefreak
John Vivirito (gnomefreak) wrote :

lightning-sunbird (0.7+nobinonly-0ubuntu1) hardy; urgency=low

  * Upstream release 0.7
  * Made use of upstream tarball
  * Full list of changes can be found at:
    http://weblogs.mozillazine.org/rumblingedge/archives/2007/07/sb_0-7.html
    - Too many to list here.
  * debian/patches/configure-autoconf2-13-reconfigure.patch: Ran
    autoconf2.13 to update patch
  * debian/patches/bz399589_fix_missing_symbol_with_new_nss.patch: Added
    patch to fix FTBFS with error <E2><80><98>SECAlgorithmIDTemplate<E2><80><99> was not declared
    in this scope"
  * debian/patches/series: Updated for
    bz399589_fix_missing_symbol_with_new_nss.patch
  * Reupload source tarball without binaries (LP: #121734) - sanitized
    using debian/remove.binonly.sh
  * debian/remove.binonly.sh: add script to strip original tarball from
    binary only cruft.

 -- John Vivirito <email address hidden> Thu, 12 Nov 2007 20:01:15 -0400

John Vivirito (gnomefreak) wrote :

lightning-sunbird (0.7+nobinonly-0ubuntu1) hardy; urgency=low

  * Upstream release 0.7
  * Made use of upstream tarball
  * Full list of changes can be found at:
    http://weblogs.mozillazine.org/rumblingedge/archives/2007/07/sb_0-7.html
    - Too many to list here.
  * debian/control: Removed ${Source-Version} from depends of sunbird-dev
    and just using sunbird as depend
  * debian/patches/configure-autoconf2-13-reconfigure.patch: Ran
    autoconf2.13 to update patch
  * debian/patches/bz399589_fix_missing_symbol_with_new_nss.patch: Added
    patch to fix FTBFS with error ‘SECAlgorithmIDTemplate’ was not declared
    in this scope"
  * debian/patches/series: Updated for
    bz399589_fix_missing_symbol_with_new_nss.patch
  * Reupload source tarball without binaries (LP: #121734) - sanitized
    using debian/remove.binonly.sh
  * debian/remove.binonly.sh: add script to strip original tarball from
    binary only cruft.

  [ Alexander Sack ]
  * debian/rules: fix DEBIAN_MOZ_UPSTREAM_APPLICATION.
  * debian/remove.binonly.sh: add script to remove binary only files.

 -- John Vivirito <email address hidden> Thu, 15 Nov 2007 18:57:23 -0500

Changed in lightning-sunbird:
status: Confirmed → Fix Released

Been almost a year, and there still hasn't been an answer to Gerv's request. Can somebody from Debian or Ubuntu please do so?

Going through our remove.nonfree script is on my TODO list. I know a bunch of the files there are actually source. Some others are definitely not, such as, iirc, some WinCE .dlls, or various binaries (NSIS ones being one set among others).

Anyways, it's better for us to have false negatives than false positives, which is why we are still removing the same files ; plus the fact that they aren't used during build.

Created an attachment (id=344136)
REMOVED+nobinonly log from Ubuntu on trunk

In Ubuntu, we provide a log of what has actually been removed.
Our script does "no binary only", not "no non-free" like Debian.

Changed in firefox (Ubuntu):
status: Fix Released → Confirmed
Changed in firefox-3.0 (Ubuntu):
status: Fix Released → Confirmed
Draycen DeCator (ddecator) wrote :

@edikarsidi
Please do not change the status of a bug report without explaining why you are doing so. If you are experiencing this bug on your system, then please file a new bug report since this has been marked as having a fix released. The best way to do this would be to go to Help -> Report A Problem from within Firefox. Thanks!

Changed in firefox (Ubuntu):
status: Confirmed → Fix Released
Changed in firefox-3.0 (Ubuntu):
status: Confirmed → Fix Released
Changed in firefox:
importance: Unknown → Medium
Changed in firefox:
status: Confirmed → Unknown
Changed in firefox:
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.