js/xpconnect/tests/mochitest/test_sameOriginPolicy.html mochitest failure since about 24.0~a1~hg20130612r134700

Bug #1194448 reported by Chris Coulson on 2013-06-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

238231 INFO TEST-START | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html
238232 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | 0 is correctly (in)accessible for read
238233 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | window is correctly (in)accessible for read
238234 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | document is correctly (in)accessible for read
238235 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | InstallTrigger is correctly (in)accessible for read
238236 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | SpecialPowers is correctly (in)accessible for read
238237 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | SimpleTest is correctly (in)accessible for read
238238 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | parentRunner is correctly (in)accessible for read
238239 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | isPrimaryTestWindow is correctly (in)accessible for read
238240 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | createEl is correctly (in)accessible for read
238241 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | ok is correctly (in)accessible for read
238242 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | is is correctly (in)accessible for read
238243 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | isnot is correctly (in)accessible for read
238244 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | ise is correctly (in)accessible for read
238245 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | todo is correctly (in)accessible for read
238246 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | todo_is is correctly (in)accessible for read
238247 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | todo_isnot is correctly (in)accessible for read
238248 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | isDeeply is correctly (in)accessible for read
238249 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | info is correctly (in)accessible for read
238250 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | gOldOnError is correctly (in)accessible for read
238251 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | repr is correctly (in)accessible for read
238252 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | partial is correctly (in)accessible for read
238253 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | getElement is correctly (in)accessible for read
238254 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | $ is correctly (in)accessible for read
238255 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | addLoadEvent is correctly (in)accessible for read
238256 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | computedStyle is correctly (in)accessible for read
238257 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | check is correctly (in)accessible for read
238258 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | crossOriginReadableWindowProps is correctly (in)accessible for read
238259 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | isCrossOriginReadable is correctly (in)accessible for read
238260 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | isCrossOriginWritable is correctly (in)accessible for read
238261 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | testAll is correctly (in)accessible for read
238262 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | loadCount is correctly (in)accessible for read
238263 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | go is correctly (in)accessible for read
238264 INFO TEST-PASS | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | external is correctly (in)accessible for read
238265 ERROR TEST-UNEXPECTED-FAIL | /tests/js/xpconnect/tests/mochitest/test_sameOriginPolicy.html | testSNSM is correctly (in)accessible for read - got false, expected true

Note that window.testSNSM comes from a previous test (dom/tests/mochitest/bugs/test_bug597809)

tags: added: moz-test-regression
Changed in firefox (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 25.0+build3-0ubuntu0.13.10.1

---------------
firefox (25.0+build3-0ubuntu0.13.10.1) saucy-security; urgency=low

  * New upstream stable release (FIREFOX_25_0_BUILD3)
    - see LP: #1245414 for USN information

  [ Chris Coulson <email address hidden> ]
  * Refresh patches
    - update d/p/test-fixes/xpcshell-docshell-no-writes-to-appdir.patch
    - update d/p/test-integration/xpcshell-write-time-for-failed-test.patch
    - update debian/patches/ubuntu-ua-string-changes.patch
    - update d/p/test-fixes/xpcshell-exthandler-no-writes-to-appdir.patch
    - update d/p/test-integration/automation-output-junit-xml.patch
    - update d/p/test-integration/mochitest-allow-test-manifest-for-browser-chrome.patch
    - update d/p/test-integration/xpcshell-disable-tests-which-need-appdir-write-access.patch
    - update debian/patches/unity-menubar.patch
  * Drop patches
    - remove d/p/test-fixes/xpcshell-docshell-no-writes-to-appdir.patch
    - remove d/p/test-fixes/xpcshell-contentprefs-no-writes-to-appdir.patch
    - remove d/p/test-fixes/mochitest-browser-plugincrash-with-no-crashreporter.patch
    - update debian/patches/series
  * Refactor the test results post-process script a bit so that it can use
    regular expressions in the configuration
    - update debian/testing/filter_results
    - update debian/testing/results-filter-manifest.json
    - update debian/tests/post-process
  * Run mochitest-plain in 5 chunks, similar to upstream. This should fix
    some test failures we see that seem to be caused by some tests not
    cleaning up properly (seems to fix LP: #1158781 and LP: #1194448)
    - update debian/testing/run_mochitest.in
    - update debian/tests/control
    - move debian/tests/mochitest => debian/tests/mochitest-1
    - add debian/tests/mochitest-2
    - add debian/tests/mochitest-3
    - add debian/tests/mochitest-4
    - add debian/tests/mochitest-5
  * Drop d/p/test-integration/test-sameoriginpolicy-debug.patch now that
    we run mochitest-plain in chunks
  * Add OCSPStaplingServer binary to testsuite
    - update debian/firefox-testsuite.install.in
    - update debian/build/rules.mk
  * Don't let make check failures fail the build for now, as there are some
    jit test failures
    - update debian/build/testsuite.mk
  * Try to stop the buildd's from terminating the build during long links
    (use a hack based on the one for the Chromium package)
    - add debian/build/keepalive-wrapper.py
    - update debian/build/rules.mk

  [ Jamie Strandboge <email address hidden> ]
  * add debian/usr.bin.firefox.apparmor.13.10 for dbus policy
  * debian/rules: conditionally use usr.bin.firefox.apparmor.13.10 on saucy
    and higher, otherwise usr.bin.firefox.apparmor.12.04
  * debian/usr.bin.firefox.apparmor.12.04: use ibus abstraction
 -- Chris Coulson <email address hidden> Mon, 28 Oct 2013 10:16:16 +0000

Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers