jnlp support in Firefox

Bug #119175 reported by finalbeta on 2007-06-07
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Mozilla Bugs

Bug Description

Binary package hint: firefox

Firefox should know what jnlp files are. (They are Java web start files)

When clicking a jnlp link firefox opens a dialog where I can browse to a program to open it with, or save it to the disk.
Firefox should know it opens with /usr/bin/javaws

You can't expect end users to know this. It's the same for konqueror

Siegfried Gevatter (rainct) wrote :

I've found on [1] that Firefox can be configured to use it adding following entry to file `~/.mozilla/firefox/*.default/mimeTypes.rdf':

<RDF:Description
   RDF:about="urn:mimetype:externalApplication:application/x-java-jnlp-file"
   NC:path="/usr/bin/javaws"
   NC:prettyName="javaws" />

But I don't see any change with and without that, on both it asks to use either `Java Web Start application' or download it.

[1] http://www.redhat.com/archives/nahant-list/2006-February/msg00315.html

On Thu, Jun 07, 2007 at 07:29:36PM -0000, RainCT wrote:
> I've found on [1] that Firefox can be configured to use it adding
> following entry to file `~/.mozilla/firefox/*.default/mimeTypes.rdf':
>
> <RDF:Description
> RDF:about="urn:mimetype:externalApplication:application/x-java-jnlp-file"
> NC:path="/usr/bin/javaws"
> NC:prettyName="javaws" />
>
> But I don't see any change with and without that, on both it asks to use
> either `Java Web Start application' or download it.
>
> [1] http://www.redhat.com/archives/nahant-
> list/2006-February/msg00315.html
>

javaws should be available as a package (most likely just
sun-java6-bin or something). If it still doesn't work then most likely
that package should register the mimetype properly.

 - Alexander

John Vivirito (gnomefreak) wrote :

Did you try setting it in update-alternatives

sudo update-alternatives --config javaws

What java package and version is installed and what version is system set to use (to check: java -version
Can you please provide us with a step by step set of instructions on how to reproduce (including a link to a jnlp file.

Changed in firefox:
assignee: nobody → mozilla-bugs
status: Unconfirmed → Needs Info
finalbeta (j-greenhouse) wrote :

VERSION:

finalbeta@finalbeta-desktop:~$ java -version
java version "1.4.2"
gij (GNU libgcj) version 4.1.2 (Ubuntu 4.1.2-0ubuntu5)

Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
-------------------------

Example of a Java Web Start Application:

http://users.telenet.be/greenhouse/foldersync/releases/0.1/foldersync.jnlp
------------------------
Updating alternatives:
sudo update-alternatives --config javaws
This command does not work, there is no javaws

One can configure sudo update-alternatives --config java
But this doesn't change anything for the browser.

The problem is that the browser doesn't know what to do with the file. Open it with "browse program", or save to disk. (See attached image).
What Firefox should do it simply start Java and let Java ask the user what should happen.

PS: a jnlp file is just an xml file that should be passed to /usr/bin/javaws

John Vivirito (gnomefreak) wrote :

Please install sun-java5-plugin or sun-java6-plugin and please run sudo update-alternatives --config javaws and choose the one you want to use. java 1.4 that comes with ubuntu is not a full version of java.

It should change the browser as well since after installing java you will have an app to use for javaws.

John Vivirito (gnomefreak) wrote :

This is a not a firefox issue as you didnt have javaws set in update-alternatives. To include this by default if java devels will even think about this is when java becomes fully opensource. Please feel free to file a bug on java about adding it by default

Changed in firefox:
status: Needs Info → Rejected
Alexander Kosenkov (a-kosenkov) wrote :

This could help you:

http://dmartin.org/weblog/running-java-web-start-apps-on-ubuntu-linux-for-amd-64

"The solution is to install the 32 bit Java 1.5. I realize Java 1.6 is available, but it won't work for some reason (I couldn't really tell why, the app just never comes up, but shows no errors). The installation is pretty simple."

Alex Mauer (hawke) on 2012-02-03
Changed in firefox (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Alex Mauer (hawke) wrote :

This is a problem again/still now that Ubuntu doesn’t distribute Sun Java.

$ update-alternatives --list javaws
/usr/lib/jvm/java-6-openjdk/jre/bin/javaws

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers