Ubuntu

Firefox after upgrade cannot load profile

Reported by Sziráki Tamás on 2013-05-15
This bug report is a duplicate of:  Bug #1180227: Missing AppArmor rule for Firefox 21. Edit Remove
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

After uograde I tried to start Firefox, but this error popped up:
"Your Firefox profile cannot be loaded. It may be missing or inaccessible."

First time it happend when uprgaded from Ubuntu 12.10 to 13.04. At that time I managed to repair but I think it is not normal state that every Firefox upgrade I do this process. With the same content of ./.mozilla/firefox and ./.mozilla/firefox-trunk Firefox Nightly build 24.0a1 (2013-05-14) start without any problem, Firefox stable does not.

lsb_release -rd
Description: Ubuntu 13.04
Release: 13.04

apt-cache policy firefox
firefox:
  Telepítve: 21.0+build2-0ubuntu0.13.04.2
  Jelölt: 21.0+build2-0ubuntu0.13.04.2
  Verziótáblázat:
 *** 21.0+build2-0ubuntu0.13.04.2 0
        500 http://archive.ubuntu.com/ubuntu/ raring-updates/main i386 Packages
        500 http://archive.ubuntu.com/ubuntu/ raring-security/main i386 Packages
        100 /var/lib/dpkg/status
     20.0+build1-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main i386 Packages

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: firefox 21.0+build2-0ubuntu0.13.04.2
ProcVersionSignature: Ubuntu 3.8.0-19.30-generic 3.8.8
Uname: Linux 3.8.0-19-generic i686
AddonCompatCheckDisabled: False
ApportVersion: 2.9.2-0ubuntu8
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tom 15874 F.... pulseaudio
BuildID: 20130512193902
Channel: Unavailable
Date: Wed May 15 06:22:43 2013
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2010-05-01 (1109 days ago)
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
IpRoute:
 default via 192.168.1.1 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.102 metric 9
MarkForUpload: True
NoProfiles: True
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: Upgraded to raring on 2013-04-26 (18 days ago)
dmi.bios.date: 09/05/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: X51HAS.206
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: X51H
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX51HAS.206:bd09/05/2007:svnASUSTeKComputerInc.:pnX51H:pvr1.0:rvnASUSTeKComputerInc.:rnX51H:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr:
dmi.product.name: X51H
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
modified.conffile..etc.apparmor.d.usr.bin.firefox: [deleted]

Sziráki Tamás (sziraki.tamas) wrote :
Sziráki Tamás (sziraki.tamas) wrote :

Tried ti start from console/terminal:

:~$ firefox

(process:1322): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Error: Access was denied while trying to open files in your profile directory.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.

locutus@Unimatrix01-Raring:~ $ firefox

(process:20335): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Error: Access was denied while trying to open files in your profile directory.

clean install, just upgraded firefox this morning, so a regression since firefox 20 release

Changed in firefox (Ubuntu):
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :

This is a duplicate of bug 1180227.

See the note in bug 1178277

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers