Kubuntu Raring - Kubuntu-firefox-installer blocks the install of Firefox

Bug #1165408 reported by Shiki
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

I tried to install Firefox by Konsole.
"sudo apt-get install firefox"

Then I got this error:
trying to overwrite '/usr/share/applications/firefox.desktop', which is also in package kubuntu-firefox-installer 13.04ubuntu2

Seemingly this error have been reported already back 2 years ago, but it got fixed then.
Now it's bugged again.

- I can't remove kubuntu-firefox-installer
- I can't install firefox
- I can't fix the dependency hell
- APT is totally stuck because of the kubuntu-firefox-installer file.

Basically if you try this, you break your system. (well, it's Beta 2.)

x@xxx:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libgconf2-4
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
  firefox
Suggested packages:
  latex-xft-fonts firefox-gnome-support
The following NEW packages will be installed:
  firefox
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
14 not fully installed or removed.
Need to get 0 B/24,8 MB of archives.
After this operation, 55,2 MB of additional disk space will be used.
Do you want to continue [Y/n]?
(Reading database ... 122341 files and directories currently installed.)
Unpacking firefox (from .../firefox_20.0+build1-0ubuntu1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/firefox_20.0+build1-0ubuntu1_amd64.deb (--unpack):
 trying to overwrite '/usr/share/applications/firefox.desktop', which is also in package kubuntu-firefox-installer 13.04ubuntu2
No apport report written because MaxReports is reached already
                                                              Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 /var/cache/apt/archives/firefox_20.0+build1-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
x@xxx:~$

Revision history for this message
Shiki (shiki) wrote :

Possible fix if you run into the problem is:
sudo dpkg --force-all -P kubuntu-firefox-installer

affects: kubuntu-firefox-installer (Ubuntu) → firefox (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Revision history for this message
Andras (andrew-majosi) wrote :

I had the same problem. Shiki's suggestion was a good workaround. After removing the kubuntu-firefox-installer, I installed Firefox fine.

Jonathan Riddell (jr)
Changed in firefox (Ubuntu):
milestone: none → ubuntu-13.04
Revision history for this message
Jonathan Riddell (jr) wrote :

missing a Replaces: kubuntu-firefox-installer

Revision history for this message
Shiki (shiki) wrote :

This bug also affects Kubuntu 12.10 as of now.
I did install the Backports (KDE) PPA, but I don't think that's causing the problem.

If I try to install the package via the gui client, it gives me an error with the same problem.
The icon file exists.

Revision history for this message
Shiki (shiki) wrote :

Also: How can my bug be a DUPLICATE of a later reported bug that comes with no information?
How does this work?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 20.0+build1-0ubuntu2

---------------
firefox (20.0+build1-0ubuntu2) raring; urgency=low

  * Update globalmenu-extension to 4.0
    - Fix LP: #1169873 - Crash in uGlobalMenuObject::ShouldShowIcon()
    - Turn a nullptr deref in to a runtime abort for now, to try and get a
      better idea of what is happening (LP: #1169874)
  * Fix empty Replaces on 12.10 and later (LP: #1165408)
    - update debian/rules
 -- Chris Coulson <email address hidden> Wed, 17 Apr 2013 09:29:49 +0100

Changed in firefox (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers