Tried to install firefox on kubuntu raring using the muon firefox installer on virtualbox-4.2

Bug #1164821 reported by Istimsak on 2013-04-05
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
High
Unassigned
Saucy
High
Unassigned

Bug Description

After installation of kubuntu 13.04 on virtualbox-4.2, executed the installation of firefox. Application muon software center crashed. Repeated steps returned the same result.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: firefox (not installed)
ProcVersionSignature: Ubuntu 3.8.0-16.26-generic 3.8.5
Uname: Linux 3.8.0-16-generic i686
ApportVersion: 2.9.2-0ubuntu5
Architecture: i386
Date: Thu Apr 4 23:55:18 2013
InstallationDate: Installed on 2013-04-05 (0 days ago)
InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Alpha i386 (20130402.1)
MarkForUpload: True
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)

Istimsak (saqman2060) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1164821

tags: added: iso-testing
affects: firefox (Ubuntu) → ubuntu
tags: added: needs-reassignment
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Erfan Tabatabaei (erta) wrote :

I tried to install Firefox using the 'Mozilla Firefox Browser Installer' in the menu, but whenever I click on it, a window appears showing that Muon Software Center is crashed. Then I tried to install it from the command line, but I get the following error:

Unpacking firefox (from .../firefox_20.0+build1-0ubuntu1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/firefox_20.0+build1-0ubuntu1_amd64.deb (--unpack):
 trying to overwrite '/usr/share/applications/firefox.desktop', which is also in package kubuntu-firefox-installer 13.04ubuntu2
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/firefox_20.0+build1-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Looks like dpkg can't extract the package.

Some sysinfo:

Kernel 3.8.0-16-generic
Kubuntu 13.04 beta 2 (x86_64) - Fresh install

Erfan Tabatabaei (erta) wrote :

Forgot to mention that this is a bare metal install, no virtualization.

affects: ubuntu → firefox (Ubuntu)

I had the exact same experience as Erfan. Muon package manager lists "firefox-globalmenu" as broken. Not sure if this is relevant or not.

Nick (icekool666) wrote :

I also have this exact problem, it seems impossible to install firefox by any means

electromage (electromage) wrote :

I've tried installing it as well. It partially installed firefox-globalmenu, which broke installation of other packages until I removed it.

Dario (cippu) wrote :

I was able to install it on Kubuntu 13.04 beta using:

sudo apt-get install --no-install-recommends firefox

So it didn't install globalmenu (useless in Kubuntu)

Changed in firefox (Ubuntu Saucy):
importance: Undecided → High
Chris Coulson (chrisccoulson) wrote :

This was fixed some time ago

Changed in firefox (Ubuntu Saucy):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments