dom/plugins/test/test_crashing.html and dom/plugins/test/test_hanging.html mochitest failures

Bug #1158781 reported by Chris Coulson on 2013-03-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Unassigned

Bug Description

189207 INFO TEST-START | /tests/dom/plugins/test/test_crashing.html
[Parent 21760] WARNING: waitpid failed pid:21808 errno:10: file /build/buildd/firefox-20.0~b4+build1/ipc/chromium/src/base/process_util_posix.cc, line 260
Xlib: extension "RANDR" missing on display ":99".
XPCOM_MEM_BLOAT_LOG: /tmp/tmp.oc17p3auwn/dsc0t-mochitest-testtmp/tmpdir/tmpr2x0HL/runtests_leaks.log
Writing to log: /tmp/tmp.oc17p3auwn/dsc0t-mochitest-testtmp/tmpdir/tmpr2x0HL/runtests_leaks_plugin_pid23781.log
[Parent 21760] WARNING: waitpid failed pid:21808 errno:10: file /build/buildd/firefox-20.0~b4+build1/ipc/chromium/src/base/process_util_posix.cc, line 260
[Parent 21760] WARNING: waitpid failed pid:21808 errno:10: file /build/buildd/firefox-20.0~b4+build1/ipc/chromium/src/base/process_util_posix.cc, line 260

###!!! [Parent][RPCChannel] Error: Channel error: cannot send/recv

189208 INFO TEST-PASS | /tests/dom/plugins/test/test_crashing.html | p.crash() should throw an exception

###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv

###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv

189209 INFO TEST-PASS | /tests/dom/plugins/test/test_crashing.html | unknown identifier in crashed plugin should fail silently

###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv

###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv

189210 INFO TEST-PASS | /tests/dom/plugins/test/test_crashing.html | unknown identifier in crashed plugin should fail silently

###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv

###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv

189211 INFO TEST-PASS | /tests/dom/plugins/test/test_crashing.html | unknown identifier in crashed plugin should fail silently

###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv

###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv

189212 INFO TEST-PASS | /tests/dom/plugins/test/test_crashing.html | unknown identifier in crashed plugin should fail silently

###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv

###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv

189213 INFO TEST-PASS | /tests/dom/plugins/test/test_crashing.html | unknown identifier in crashed plugin should fail silently

###!!! [Parent][RPCChannel] Error: Channel error: cannot send/recv

###!!! [Parent][RPCChannel] Error: Channel error: cannot send/recv

189214 INFO TEST-PASS | /tests/dom/plugins/test/test_crashing.html | p.setColor should throw after the plugin crashes
[Parent 21760] WARNING: waitpid failed pid:21808 errno:10: file /build/buildd/firefox-20.0~b4+build1/ipc/chromium/src/base/process_util_posix.cc, line 260
Xlib: extension "RANDR" missing on display ":99".
189215 INFO TEST-PASS | /tests/dom/plugins/test/test_crashing.html | Reloading worked
189216 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/plugins/test/test_crashing.html | This test did not leave any crash dumps behind, but we were expecting some!
189217 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/plugins/test/test_crashing.html | This test left crash dumps behind, but we weren't expecting it to!
189218 INFO TEST-INFO | Found unexpected crash dump file /tmp/tmp.oc17p3auwn/dsc0t-mochitest-testtmp/tmpdir/tmpr2x0HL/minidumps/635160c8-3f0b-e3a4-296a1862-204f9545.dmp.
189219 INFO TEST-INFO | Found unexpected crash dump file /tmp/tmp.oc17p3auwn/dsc0t-mochitest-testtmp/tmpdir/tmpr2x0HL/minidumps/635160c8-3f0b-e3a4-296a1862-204f9545.extra.
189220 INFO TEST-END | /tests/dom/plugins/test/test_crashing.html | finished in 687ms

189513 INFO TEST-START | /tests/dom/plugins/test/test_hanging.html
XPCOM_MEM_BLOAT_LOG: /tmp/tmp.oc17p3auwn/dsc0t-mochitest-testtmp/tmpdir/tmpr2x0HL/runtests_leaks.log
Writing to log: /tmp/tmp.oc17p3auwn/dsc0t-mochitest-testtmp/tmpdir/tmpr2x0HL/runtests_leaks_plugin_pid23784.log
[Parent 21760] WARNING: waitpid failed pid:21808 errno:10: file /build/buildd/firefox-20.0~b4+build1/ipc/chromium/src/base/process_util_posix.cc, line 260
[Parent 21760] WARNING: Failed to deliver SIGKILL to 21808!(3).: file /build/buildd/firefox-20.0~b4+build1/ipc/chromium/src/chrome/common/process_watcher_posix_sigchld.cc, line 118
189514 INFO TEST-PASS | /tests/dom/plugins/test/test_hanging.html | p.hang() should throw an exception

###!!! [Parent][RPCChannel] Error: Channel timeout: cannot send/recv

###!!! [Parent][RPCChannel] Error: Channel timeout: cannot send/recv

189515 INFO TEST-PASS | /tests/dom/plugins/test/test_hanging.html | p.setColor should throw after the plugin crashes

###!!! [Parent][RPCChannel] Error: Channel timeout: cannot send/recv

###!!! [Parent][RPCChannel] Error: Channel timeout: cannot send/recv

[Parent 21760] WARNING: waitpid failed pid:23784 errno:10: file /build/buildd/firefox-20.0~b4+build1/ipc/chromium/src/base/process_util_posix.cc, line 260
Xlib: extension "RANDR" missing on display ":99".
189516 INFO TEST-PASS | /tests/dom/plugins/test/test_hanging.html | Reloading worked
189517 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/plugins/test/test_hanging.html | This test did not leave any crash dumps behind, but we were expecting some!
189518 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/plugins/test/test_hanging.html | This test left crash dumps behind, but we weren't expecting it to!
189519 INFO TEST-INFO | Found unexpected crash dump file /tmp/tmp.oc17p3auwn/dsc0t-mochitest-testtmp/tmpdir/tmpr2x0HL/minidumps/50333acd-936c-be23-7ec9fef9-636d5b80-browser.dmp.
189520 INFO TEST-INFO | Found unexpected crash dump file /tmp/tmp.oc17p3auwn/dsc0t-mochitest-testtmp/tmpdir/tmpr2x0HL/minidumps/50333acd-936c-be23-7ec9fef9-636d5b80.dmp.
189521 INFO TEST-INFO | Found unexpected crash dump file /tmp/tmp.oc17p3auwn/dsc0t-mochitest-testtmp/tmpdir/tmpr2x0HL/minidumps/50333acd-936c-be23-7ec9fef9-636d5b80.extra.
189522 INFO TEST-END | /tests/dom/plugins/test/test_hanging.html | finished in 5834ms

summary: - test_crashing.html / test_hanging.html test failures
+ dom/plugins/test/test_crashing.html and
+ dom/plugins/test/test_hanging.html mochitest failures
Changed in firefox (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: moz-test-failure
Changed in firefox (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 25.0+build3-0ubuntu0.13.10.1

---------------
firefox (25.0+build3-0ubuntu0.13.10.1) saucy-security; urgency=low

  * New upstream stable release (FIREFOX_25_0_BUILD3)
    - see LP: #1245414 for USN information

  [ Chris Coulson <email address hidden> ]
  * Refresh patches
    - update d/p/test-fixes/xpcshell-docshell-no-writes-to-appdir.patch
    - update d/p/test-integration/xpcshell-write-time-for-failed-test.patch
    - update debian/patches/ubuntu-ua-string-changes.patch
    - update d/p/test-fixes/xpcshell-exthandler-no-writes-to-appdir.patch
    - update d/p/test-integration/automation-output-junit-xml.patch
    - update d/p/test-integration/mochitest-allow-test-manifest-for-browser-chrome.patch
    - update d/p/test-integration/xpcshell-disable-tests-which-need-appdir-write-access.patch
    - update debian/patches/unity-menubar.patch
  * Drop patches
    - remove d/p/test-fixes/xpcshell-docshell-no-writes-to-appdir.patch
    - remove d/p/test-fixes/xpcshell-contentprefs-no-writes-to-appdir.patch
    - remove d/p/test-fixes/mochitest-browser-plugincrash-with-no-crashreporter.patch
    - update debian/patches/series
  * Refactor the test results post-process script a bit so that it can use
    regular expressions in the configuration
    - update debian/testing/filter_results
    - update debian/testing/results-filter-manifest.json
    - update debian/tests/post-process
  * Run mochitest-plain in 5 chunks, similar to upstream. This should fix
    some test failures we see that seem to be caused by some tests not
    cleaning up properly (seems to fix LP: #1158781 and LP: #1194448)
    - update debian/testing/run_mochitest.in
    - update debian/tests/control
    - move debian/tests/mochitest => debian/tests/mochitest-1
    - add debian/tests/mochitest-2
    - add debian/tests/mochitest-3
    - add debian/tests/mochitest-4
    - add debian/tests/mochitest-5
  * Drop d/p/test-integration/test-sameoriginpolicy-debug.patch now that
    we run mochitest-plain in chunks
  * Add OCSPStaplingServer binary to testsuite
    - update debian/firefox-testsuite.install.in
    - update debian/build/rules.mk
  * Don't let make check failures fail the build for now, as there are some
    jit test failures
    - update debian/build/testsuite.mk
  * Try to stop the buildd's from terminating the build during long links
    (use a hack based on the one for the Chromium package)
    - add debian/build/keepalive-wrapper.py
    - update debian/build/rules.mk

  [ Jamie Strandboge <email address hidden> ]
  * add debian/usr.bin.firefox.apparmor.13.10 for dbus policy
  * debian/rules: conditionally use usr.bin.firefox.apparmor.13.10 on saucy
    and higher, otherwise usr.bin.firefox.apparmor.12.04
  * debian/usr.bin.firefox.apparmor.12.04: use ibus abstraction
 -- Chris Coulson <email address hidden> Mon, 28 Oct 2013 10:16:16 +0000

Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 25.0+build3-0ubuntu0.12.04.1

---------------
firefox (25.0+build3-0ubuntu0.12.04.1) precise-security; urgency=low

  * New upstream stable release (FIREFOX_25_0_BUILD3)
    - see LP: #1245414 for USN information

  * Refresh patches
    - update d/p/test-fixes/xpcshell-docshell-no-writes-to-appdir.patch
    - update d/p/test-integration/xpcshell-write-time-for-failed-test.patch
    - update debian/patches/ubuntu-ua-string-changes.patch
    - update d/p/test-fixes/xpcshell-exthandler-no-writes-to-appdir.patch
    - update d/p/test-integration/automation-output-junit-xml.patch
    - update d/p/test-integration/mochitest-allow-test-manifest-for-browser-chrome.patch
    - update d/p/test-integration/xpcshell-disable-tests-which-need-appdir-write-access.patch
    - update debian/patches/unity-menubar.patch
  * Drop patches
    - remove d/p/test-fixes/xpcshell-docshell-no-writes-to-appdir.patch
    - remove d/p/test-fixes/xpcshell-contentprefs-no-writes-to-appdir.patch
    - remove d/p/test-fixes/mochitest-browser-plugincrash-with-no-crashreporter.patch
    - update debian/patches/series
  * Refactor the test results post-process script a bit so that it can use
    regular expressions in the configuration
    - update debian/testing/filter_results
    - update debian/testing/results-filter-manifest.json
    - update debian/tests/post-process
  * Run mochitest-plain in 5 chunks, similar to upstream. This should fix
    some test failures we see that seem to be caused by some tests not
    cleaning up properly (seems to fix LP: #1158781 and LP: #1194448)
    - update debian/testing/run_mochitest.in
    - update debian/tests/control
    - move debian/tests/mochitest => debian/tests/mochitest-1
    - add debian/tests/mochitest-2
    - add debian/tests/mochitest-3
    - add debian/tests/mochitest-4
    - add debian/tests/mochitest-5
  * Drop d/p/test-integration/test-sameoriginpolicy-debug.patch now that
    we run mochitest-plain in chunks
  * Add OCSPStaplingServer binary to testsuite
    - update debian/firefox-testsuite.install.in
    - update debian/build/rules.mk
  * Don't let make check failures fail the build for now, as there are some
    jit test failures
    - update debian/build/testsuite.mk
  * Try to stop the buildd's from terminating the build during long links
    (use a hack based on the one for the Chromium package)
    - add debian/build/keepalive-wrapper.py
    - update debian/build/rules.mk
 -- Chris Coulson <email address hidden> Mon, 28 Oct 2013 10:23:27 +0000

Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 25.0+build3-0ubuntu0.12.10.1

---------------
firefox (25.0+build3-0ubuntu0.12.10.1) quantal-security; urgency=low

  * New upstream stable release (FIREFOX_25_0_BUILD3)
    - see LP: #1245414 for USN information

  * Refresh patches
    - update d/p/test-fixes/xpcshell-docshell-no-writes-to-appdir.patch
    - update d/p/test-integration/xpcshell-write-time-for-failed-test.patch
    - update debian/patches/ubuntu-ua-string-changes.patch
    - update d/p/test-fixes/xpcshell-exthandler-no-writes-to-appdir.patch
    - update d/p/test-integration/automation-output-junit-xml.patch
    - update d/p/test-integration/mochitest-allow-test-manifest-for-browser-chrome.patch
    - update d/p/test-integration/xpcshell-disable-tests-which-need-appdir-write-access.patch
    - update debian/patches/unity-menubar.patch
  * Drop patches
    - remove d/p/test-fixes/xpcshell-docshell-no-writes-to-appdir.patch
    - remove d/p/test-fixes/xpcshell-contentprefs-no-writes-to-appdir.patch
    - remove d/p/test-fixes/mochitest-browser-plugincrash-with-no-crashreporter.patch
    - update debian/patches/series
  * Refactor the test results post-process script a bit so that it can use
    regular expressions in the configuration
    - update debian/testing/filter_results
    - update debian/testing/results-filter-manifest.json
    - update debian/tests/post-process
  * Run mochitest-plain in 5 chunks, similar to upstream. This should fix
    some test failures we see that seem to be caused by some tests not
    cleaning up properly (seems to fix LP: #1158781 and LP: #1194448)
    - update debian/testing/run_mochitest.in
    - update debian/tests/control
    - move debian/tests/mochitest => debian/tests/mochitest-1
    - add debian/tests/mochitest-2
    - add debian/tests/mochitest-3
    - add debian/tests/mochitest-4
    - add debian/tests/mochitest-5
  * Drop d/p/test-integration/test-sameoriginpolicy-debug.patch now that
    we run mochitest-plain in chunks
  * Add OCSPStaplingServer binary to testsuite
    - update debian/firefox-testsuite.install.in
    - update debian/build/rules.mk
  * Don't let make check failures fail the build for now, as there are some
    jit test failures
    - update debian/build/testsuite.mk
  * Try to stop the buildd's from terminating the build during long links
    (use a hack based on the one for the Chromium package)
    - add debian/build/keepalive-wrapper.py
    - update debian/build/rules.mk
 -- Chris Coulson <email address hidden> Mon, 28 Oct 2013 10:22:06 +0000

Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers