Firefox segfaults when opening some webpages

Bug #11567 reported by Johannes H. Jensen on 2005-01-01
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Thom May

Bug Description

Mozilla Firefox segfaults when opening some webpages. This happens on many webpages.
I'm running hoary.

$ firefox
Segmentation fault

I've tried to debug this with gdb, but without success. If someone could give me
some instructions on how to debug firefox, I will gladly help.
Also, I've tried this on other ubuntu hoary systems, where firefox does not
crash at all. This leads me to think that this is a problem caused by a library
firefox is linked with.

These are the dynamic libraries my firefox-bin is linked with:
$ ldd /usr/lib/mozilla-firefox/firefox-bin => /usr/lib/ (0x40026000) => /usr/lib/ (0x400a6000) => /usr/lib/ (0x4015e000) => /usr/lib/ (0x40161000) => /usr/lib/ (0x40167000) => /lib/tls/i686/cmov/ (0x4019b000) => /lib/tls/i686/cmov/ (0x401ab000) => /usr/lib/ (0x401ae000) => /usr/lib/ (0x40471000) => /usr/lib/ (0x404db000) => /usr/lib/ (0x404f8000) => /usr/lib/ (0x4050d000) => /usr/lib/ (0x40514000) => /usr/lib/ (0x4051f000) => /usr/lib/ (0x40556000) => /usr/lib/ (0x40587000) => /usr/lib/ (0x4058c000) => /usr/X11R6/lib/ (0x40608000) => /lib/tls/i686/cmov/ (0x406cd000) => /usr/lib/ (0x406ee000) => /lib/ (0x407a8000) => /lib/tls/i686/cmov/ (0x407b1000)
        /lib/ => /lib/ (0x40000000) => /usr/X11R6/lib/ (0x408df000) => /usr/X11R6/lib/ (0x408e3000) => /usr/X11R6/lib/ (0x408eb000) => /usr/lib/ (0x408f8000) => /usr/lib/ (0x4090a000) => /usr/lib/ (0x40977000) => /usr/lib/ (0x40989000) => /usr/lib/ (0x409b0000) => /usr/lib/ (0x409b9000) => /usr/lib/ (0x409c1000) => /usr/lib/ (0x409e7000)

If you want, I can give you any information regarding the versions/etc of these
libraries I have installed.

Thank you,
Johannes H. Jensen

Johannes H. Jensen (joh-pub) wrote :
Download full text (4.6 KiB)

Found that this also happens with mozilla.

I managed to debug mozilla (found instructions here: and it appears this is a
problem with the library. The backtrace from gdb follows below:

#0 0x40f38edc in nsHTMLReflowState::UseComputedHeight ()
   from /usr/lib/mozilla/components/
#1 0x40f39022 in nsHTMLReflowState::UseComputedHeight ()
   from /usr/lib/mozilla/components/
#2 0x40f39101 in nsHTMLReflowState::CalcLineHeight ()
   from /usr/lib/mozilla/components/
#3 0x40f1d7f8 in nsBlockReflowState::nsBlockReflowState ()
   from /usr/lib/mozilla/components/
#4 0x40f135cf in nsBlockFrame::IsContainingBlock ()
   from /usr/lib/mozilla/components/
#5 0x40f1ca20 in nsBlockReflowContext::ReflowBlock ()
   from /usr/lib/mozilla/components/
#6 0x40f16944 in nsBlockFrame::ReflowBlockFrame () from
#7 0x40f159c2 in nsBlockFrame::ReflowLine () from
#8 0x40f154a3 in nsBlockFrame::ReflowDirtyLines () from
#9 0x40f13676 in nsBlockFrame::IsContainingBlock ()
   from /usr/lib/mozilla/components/
#10 0x40f23638 in nsContainerFrame::ReflowChild () from
#11 0x40f353c2 in NS_NewCanvasFrame () from
#12 0x41006f99 in nsBoxToBlockAdaptor::Reflow () from
#13 0x41006b1a in nsBoxToBlockAdaptor::RefreshSizeCache ()
   from /usr/lib/mozilla/components/
#14 0x40ffe120 in nsBox::UnCollapseChild () from
---Type <return> to continue, or q <return> to quit---
#15 0x40ffa65b in nsScrollBoxFrame::CreateScrollingView ()
   from /usr/lib/mozilla/components/
#16 0x40ffe120 in nsBox::UnCollapseChild () from
#17 0x41008b08 in nsContainerBox::LayoutChildAt () from
#18 0x40f326dd in nsGfxScrollFrameInner::LayoutBox ()
   from /usr/lib/mozilla/components/
#19 0x40f329ae in nsGfxScrollFrameInner::Layout () from
#20 0x40f32741 in nsGfxScrollFrameInner::LayoutBox ()
   from /usr/lib/mozilla/components/
#21 0x40ffe120 in nsBox::UnCollapseChild () from
#22 0x41001d20 in nsBoxFrame::IsInitialReflowForPrintPreview ()
   from /usr/lib/mozilla/components/
#23 0x40f31998 in nsGfxScrollFrame::GetScrollbarStyles ()
   from /usr/lib/mozilla/components/
#24 0x40f23638 in nsContainerFrame::ReflowChild () from
#25 0x40f79488 in ViewportFrame::AdjustReflowStateForScrollbars ()
   from /usr/lib/mozilla/components/
#26 0x40f58607 in IncrementalReflow::Dispatch () from
#27 0x40f64b94 in PresShell::ProcessReflowCommands ()
   from /usr/lib/mozilla/components/
#28 0x40f65ef1...


Johannes H. Jensen (joh-pub) wrote :

Created an attachment (id=974)
md5sum of all libraries /usr/lib/mozilla/mozilla-bin is linked with.

These are the md5sums of all libraries /usr/lib/mozilla/mozilla-bin is linked
with. The list was created with the following command:

IFS=$'\n'; for l in `ldd /usr/lib/mozilla/mozilla-bin | awk '{print $3}' |
sort`; do md5sum $l >> mozilla-bin-dl.md5sum; done

Johannes H. Jensen (joh-pub) wrote :

I found that the page firefox segfaulted on was,
so I downloaded it along with images and css files. After removing all images
and removed line after line from the css file, I discovered that firefox crashed
on the following line:

font-family: tahoma, verdana, arial, sans-serif;

I tried removing the "tahoma, " bit, which fixed the problem.
I found out that I had put a tahoma.ttf in /usr/share/fonts/truetype/ some time
back when testing something in wine. Moving tahoma.ttf away also fixed the
problem. The problem is: I'm now unable to reproduce the segfault after moving
tahoma.ttf back!

Thom May (thombot) wrote :

It's possible that your fontserver had not fully installed your font file, and
this was causing firefox problems.
Anyway, now that you can't reproduce this problem and I can't, I'm going to
close this bug. If you can reproduce this with a simpler (and reproducible) test
case (ie, a trivial gtk app, since IIRC firefox uses gtk's font loader support),
please feel free to reopen this bug.

I too am getting lots and lots of crashes when using firefox.
the example above
works for me, but
always crashes instantly (with a segmentation fault as well)

I'm using firefox -versions 3.6.3 Mozilla Firefox for Ubuntu canonical - 1.0

I've already tried removing the
 sudo apt-get purge moonlight-plugin-core moonlight-plugin-mozilla (posted elsewhere as a fix)
but since it wasn't installed it couldn't be removed,so that wasn't the issue.
firefox itself reported a conflict with the "flashblock" package so I un-installed it and still get the error.
I'm using the shockwave flash package, which works great before lucid (on heron).
I don't want to start randomly trying new packages, so am waiting for some kind of fix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.