The sync request protocol (_NET_WM_SYNC_REQUEST in the EWMH spec) is not supported in some GTK apps

Bug #113086 reported by Sergio Zanchetta
14
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Confirmed
Medium
Ubuntu
Invalid
Undecided
Unassigned
Declined for Gutsy by Henrik Nilsen Omma
Declined for Hardy by Steve Langasek
amarok (Ubuntu)
Invalid
Undecided
Unassigned
Declined for Gutsy by Henrik Nilsen Omma
Declined for Hardy by Steve Langasek
evolution (Ubuntu)
Invalid
Low
Unassigned
Declined for Gutsy by Henrik Nilsen Omma
Declined for Hardy by Steve Langasek
firefox (Ubuntu)
Invalid
Medium
Mozilla Bugs
Declined for Gutsy by Henrik Nilsen Omma
Declined for Hardy by Steve Langasek
mozilla-thunderbird (Ubuntu)
Invalid
Undecided
Unassigned
Declined for Gutsy by Henrik Nilsen Omma
Declined for Hardy by Steve Langasek

Bug Description

With Desktop Effects, I get black on some part of Firefox and Thunderbird windows.
Some time is the menu bar, other time is the main window (in thunderbird it happens randomly on each part of it)
It lasts few seconds, then it's ok.
I think it's a refresh problem.

P.S.: I got a black screen for 4-5 seconds even when I log in.

Video Card: ATI IGP 340M on Compaq Presario 2136EA

Firefox, Thunderbird, Evolution are the confirmed apps that dont support the protocol

Revision history for this message
In , Erkin Bahceci (cornelius1) wrote :

Created attachment 262361
bug in firefox-2.0.0.3

Revision history for this message
In , Erkin Bahceci (cornelius1) wrote :

Created attachment 262362
bug in firefox-3.0a4pre

Revision history for this message
In , Erkin Bahceci (cornelius1) wrote :

Created attachment 262363
bug in thunderbird-1.5.0.10

Revision history for this message
In , Erkin Bahceci (cornelius1) wrote :

Created attachment 262366
bug in thunderbird-1.5.0.10

Revision history for this message
In , Erkin Bahceci (cornelius1) wrote :

Comment on attachment 262363
bug in thunderbird-1.5.0.10

><HTML><BODY></BODY></HTML>

Revision history for this message
Sergio Zanchetta (primes2h) wrote : Enabling Desktop Effects, some part of firefox and thunderbird windows are black for few seconds when I deminimize them.

With Desktop Effects, I get black on some part of Firefox and Thunderbird windows.
Some time is the menu bar, other time is the main window (in thunderbird it happens randomly on each part of it)
It lasts few seconds, then it's ok.
I think it's a refresh problem.

P.S.: I got a black screen for 4-5 seconds even when I log in.

Video Card: ATI IGP 340M on Compaq Presario 2136EA

Revision history for this message
Sergio Zanchetta (primes2h) wrote :

Just one important thing:
It happens only with Firefox and Thunderbird.

Revision history for this message
William Grant (wgrant) wrote :

This is likely a bug in compiz. Please don't confirm your own bugs!

Revision history for this message
Sergio Zanchetta (primes2h) wrote :

OPS! Sorry...
It's a mistake.

Revision history for this message
Sergio Zanchetta (primes2h) wrote :

This is the same bug reported here on compiz forum:

http://forum.compiz.org/viewtopic.php?t=566&start=0&postdays=0&postorder=asc

Revision history for this message
Travis Watkins (amaranth) wrote :

This is actually a bug in firefox and thunderbird. I can't remember the details but David Reveman explained it once.

Revision history for this message
John Vivirito (gnomefreak) wrote :

Thank you for the bug report,
Can you please give us step by step instruction on how to reproduce this?
Is this only seen with desktop-effects/compiz/beryl?
To be honest i think this is an ATI driver issue.
What drivers are you using for you ATI card?

Changed in firefox:
assignee: nobody → mozilla-bugs
status: New → Incomplete
Revision history for this message
Sergio Zanchetta (primes2h) wrote :

It's simple.
It happens when i deminimize firefox or thunderbird window (previously minimized).
I use "ati" open source driver, but it happens with "radeon" open source driver too.

P.S.: About black screen when I log in, wallpaper gets black not all screen.

Revision history for this message
Sergio Zanchetta (primes2h) wrote :

P.S.: It's identical to this (as I reported just above)

http://forum.compiz.org/viewtopic.php?t=566&start=0&postdays=0&postorder=asc

Revision history for this message
Alexander Sack (asac) wrote :

until evidence arises that this is somehow a firefox issue ... or something that firefox could work around, I invalidate this bug for firefox. In turn I added compiz so this bug can be evaluated on their behalf.

Thanks,

 - Alexander

Changed in firefox:
status: Incomplete → Invalid
Revision history for this message
Travis Watkins (amaranth) wrote :

I found the information I was looking for from David Reveman. It really is a firefox issue.

Changed in compiz:
status: New → Invalid
Changed in firefox:
importance: Undecided → Medium
status: Invalid → Confirmed
Changed in wow-pro:
status: Unknown → New
Revision history for this message
Alexander Sack (asac) wrote :

i don't see an upstream comments that confirms your claim that this is a firefox issue.

Changed in firefox:
status: Confirmed → Incomplete
Revision history for this message
Alexander Sack (asac) wrote :

reopening for compiz ... until we know for sure

Changed in compiz:
status: Invalid → Incomplete
Revision history for this message
In , Alexander Sack (asac) wrote :

looks indeed like a feature worth considering for gecko ... can't tell how hard it would be to support that feature though

Changed in firefox:
status: Unknown → Confirmed
Changed in wow-pro:
status: New → Confirmed
Changed in compiz:
status: Incomplete → Invalid
Changed in firefox:
status: Incomplete → Confirmed
Revision history for this message
Alexander Sack (asac) wrote : Re: Enabling Desktop Effects, some part of firefox and thunderbird windows are black for few seconds when I deminimize them.

anyone subscribed to this bug who can build debian packages and can reproduce this issue? I would need someone in #ubuntu-mozillateam channel on freenode to test a patch (my nick is 'asac') ... thanks!

Revision history for this message
Freddy Martinez (freddymartinez9) wrote :

I've just tested on Fesity and Ubuntu with Firefox 2.0.0.5 and Thunderbird 1.5.0.12. I am unable to reproduce with the desktop effects available for Ubuntu (Compiz) in either case. Can someone please post a screenshot of some kind to show where this behavior is occuring. The "some parts of windows are black" doesn't really explain well enought. Btw, I am using an intergraded Intel chip with the xserver-xorg-video-i810 installed.

Revision history for this message
Sergio Zanchetta (primes2h) wrote :

Here is a video. It's a bit slower than real speed because recording desktop with 3d eats a lot of cpu in my laptop.
But you can see behavior anyway.

Revision history for this message
Sergio Zanchetta (primes2h) wrote :

The strangest thing is that it doesn't always occur in same part of the firefox/thunderbird window. Sometime in the main window, sometime on the lateral window (thunderbird obviously), sometime on menu part (where are bookmarks, menus, url etc...)

Revision history for this message
Saša Bodiroža (jazzva) wrote :

Confirmed for Firefox (I don't use Thunderbird). I thought it's a refresh problem with compiz and my computer being too slow :). It also happens when a window "unshades".

Revision history for this message
Isak Savo (isak-savo) wrote :

I had a similar(?) issue, but for me the entire firefox window was black (everything except the window decorations). The blackness depended on the size of the window, so when I resized the firefox window the contents showed for certain sizes.

I managed to solve it, by using nvidia-settings and turning on "sync to vblank" for everything (there are three or four of these checkboxes) and then restart X. Now firefox works.

This is ubuntu 7.04, with compiz-fusion installed according to http://ubuntuforums.org/showthread.php?t=481314

Revision history for this message
Isak Savo (isak-savo) wrote :

Ok, scratch that.. the VBlank sync setting may have fixed it for firefox, but I still see the same issue for other apps: azureus (using sun's java) aswell as rhythmbox.

Revision history for this message
Travis Watkins (amaranth) wrote :

Isak: You have a different issue. It's most likely bug 125566

Revision history for this message
Sergio Zanchetta (primes2h) wrote :

UPDATE:
Evolution has the same problem.

I start using it in Gutsy, don't know in Feisty.

Revision history for this message
Sergio Zanchetta (primes2h) wrote : Re: Enabling Desktop Effects, some part of firefox, thunderbird and evolution windows are black for few seconds when I deminimize them.

So I don't know if it's a firefox (or mozilla in general) problem.

I reopen for compiz.

Changed in compiz:
status: Invalid → Confirmed
Revision history for this message
Danny Baumann (dannybaumann) wrote :
Revision history for this message
Sergio Zanchetta (primes2h) wrote :

@Danny

I don't use xgl or fglrx.
I use ati Open Source driver.

Revision history for this message
Travis Watkins (amaranth) wrote :

This is a problem with the application not supporting the sync request protocol. Compiz is not as fault and can't do anything to work around it, as mentioned in the mailing list post.

Changed in compiz:
status: Confirmed → Invalid
Revision history for this message
Sergio Zanchetta (primes2h) wrote : Re: [Bug 113086] Re: Enabling Desktop Effects, some part of firefox, thunderbird and evolution windows are black for few seconds when I deminimize them.

do you mean that Evolution don't support that protocol too?
In the post it's mentioned that Gtk apps should support it.

If not I add Evolution as affected too.

2007/10/19, Travis Watkins <email address hidden>:
>
> This is a problem with the application not supporting the sync request
> protocol. Compiz is not as fault and can't do anything to work around
> it, as mentioned in the mailing list post.
>
> ** Changed in: compiz (Ubuntu)
> Status: Confirmed => Invalid
>
> --
> Enabling Desktop Effects, some part of firefox, thunderbird and evolution
> windows are black for few seconds when I deminimize them.
> https://bugs.launchpad.net/bugs/113086
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Changed in evolution:
status: New → Confirmed
Changed in mozilla-thunderbird:
status: New → Confirmed
Revision history for this message
In , Matthew Gregan (kinetik) wrote :

Alexander, I noticed you have a patch to call gdk_window_enable_synchronized_configure and gdk_window_configure_finished in a bunch of appropriate looking places up at http://people.ubuntu.com/~asac/patches/ffox/firefox-compiz.patch. It looks good to me, but I haven't had a chance to test it yet. Is it worth trying to get this into the tree, or are there known problems with that patch?

Revision history for this message
Henrik Nilsen Omma (henrik) wrote : Re: Enabling Desktop Effects, some part of firefox, thunderbird and evolution windows are black for few seconds when I deminimize them.

This bug was nominated for Gutsy but does currently not qualify for a 7.10 stable release update (SRU) and the nomination is therefore declined. According the the SRU policy, the fix should already be deployed and tested in the current development version before an update to the stable releases will be considered. With 7.10 now released, that policy applies to this bug. See: https://wiki.ubuntu.com/StableReleaseUpdates .

The bug is not being closed as work will continue on fixing it for the next release, Hardy Heron (8.04). To help improve the state of this bug see: https://wiki.ubuntu.com/Bugs/HowToTriage and https://wiki.ubuntu.com/DebuggingProcedures .

Revision history for this message
In , Alexander Sack (asac) wrote :

unfortunately, I couldn't reproduce this bug on my own. I asked someone to test it and he said it wasn't fixed.

However, it might just be that this patch misses a few places. If someone has an idea which places I might be missing, I would be happy to extend that patch.

Revision history for this message
In , Erkin Bahceci (cornelius1) wrote :

I can confirm that this patch doesn't fix the problem (when applied to mozilla sources as of 2008-01-31).

Revision history for this message
Sergio Zanchetta (primes2h) wrote : Re: Enabling Desktop Effects, some part of firefox, thunderbird and evolution windows are black for few seconds when I deminimize them.

I'm using Hardy Alpha 6 (live cd) and I can still reproduce this bug with firefox and evolution.
I don't know about amarok, thunderbird and wow.

Revision history for this message
C de-Avillez (hggdh2) wrote :

I am setting Evolution as incomplete, since we are now running unstable 2.21.92 on Hardy. Can this be reproduced on current evo on Hardy? I cannot reproduce it, but I do not run compiz.

Changed in evolution:
importance: Undecided → Low
status: Confirmed → Incomplete
Revision history for this message
Sergio Zanchetta (primes2h) wrote : Re: [Bug 113086] Re: Enabling Desktop Effects, some part of firefox, thunderbird and evolution windows are black for few seconds when I deminimize them.

As I said, I can reproduce it in Evolution and Firefox using Hardy Alpha 6
(live cd) with compiz enabled (it enables it automatically on startup:
radeon IGP 340M, open source "ati" driver).

2008/3/9, hggdh <email address hidden>:
>
> I am setting Evolution as incomplete, since we are now running unstable
> 2.21.92 on Hardy. Can this be reproduced on current evo on Hardy? I
> cannot reproduce it, but I do not run compiz.
>
> ** Changed in: evolution (Ubuntu)
> Importance: Undecided => Low
> Status: Confirmed => Incomplete
>
>
> --
> Enabling Desktop Effects, some part of firefox, thunderbird and evolution
> windows are black for few seconds when I deminimize them.
> https://bugs.launchpad.net/bugs/113086
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Changed in evolution:
status: Incomplete → Confirmed
Revision history for this message
Yuriy Kozlov (yuriy-kozlov) wrote : Re: Enabling Desktop Effects, some part of firefox, thunderbird and evolution windows are black for few seconds when I deminimize them.

I don't see anything here about a bug in amarok, so I'm closing the assignment to amarok.

Changed in amarok:
status: New → Invalid
Revision history for this message
Pausanias (pausanias) wrote :

I'd like to add my voice to those confirming this bug for evolution and firefox. Latest hardy install, everything updated. I'm experiencing exactly what's described in the original bug report.

Is there a workaround?

Revision history for this message
Pausanias (pausanias) wrote :

I'd like to add that I'm experiencing this with an NVIDIA card (Quadro FX Go1400) and with *metacity composite*, not compiz. So the bug seems to span both ATI and NVIDIA cards as well as metacity and compiz. This would appear to support the idea that it's a bug in the applications themselves.

Revision history for this message
Pausanias (pausanias) wrote :

Clarification: when I use compiz instead of metacity composite, I still get the buggy behavior.

Revision history for this message
Åskar (olskar) wrote :

I suffer from this too, please fix this :)

Revision history for this message
John Vivirito (gnomefreak) wrote :

Has anyone seen this issue in other browsers than firefox example: firefox-3.0, epiphany, galeon,kopq. ect...? Im seeing this as being all over the map with different apps and would like to come up with a base other than Firefox and Thunderbird if possible.

Revision history for this message
John Vivirito (gnomefreak) wrote :

so far only official reports ive seen have to do with Mozilla apps, if this is case why do i see bugs open for non-Mozilla apps? Can this be confirmed on other apps?

Revision history for this message
Pausanias (pausanias) wrote :

If you read the comments, you'll see at least two of us experience this bug with Evolution as well.

I still experience it with Evolution and Firefox on a fully updated hardy install, using the default nvidia driver and with metacity (not compiz) as the composite manager.

Revision history for this message
John Vivirito (gnomefreak) wrote :

Pausanias, That was my point how can it be Mozilla if other apps have this issue. im wondering if its not just GTK that is doing this more so than anything else. Other than those packages listed in package section that are still valid is this seen in other packages? Maybe evo is in same boat Mozilla is in but than i would expect there to be an upstream evo bug on this. All of the official docs that this bug points to is only Mozilla apps and that bothers me since we know its not just Mozilla having this issue.

Revision history for this message
Pausanias (pausanias) wrote :

Well, I'm fairly sure that this is not purely a GTK issue. I've tested many other GTK apps with complicated multi-panel windows (rhythmbox, pidgin), and they don't have this issue. As far as I can tell, this is only a problem with Evolution and Mozilla.

The David Reveman post linked to above suggests that it might be incorrect implementation of a sync protocol in these applications. But it also says that no GTK apps should have this problem, so I'm not sure what the issue is.

I'll leave it to someone more experienced than myself to open a bug upstream with the evolution developers.

Revision history for this message
John Vivirito (gnomefreak) wrote :

Pausanisa that is my point if no GTK apps should have this issue and its not just mozilla seeing this issue than its not purely a Mozilla related issue. It would be nice if there was a more general way of fixing this than in each app but either way lets see what happens if mozilla fixes it upstream.
I dont use evolution so i wouldnt be helpful to file the bug there.

Revision history for this message
John Vivirito (gnomefreak) wrote :

Can someone please test this is seamonkey(iceape) whatever one you have installed from repos, as well as sunbird stand-alone.

description: updated
Revision history for this message
Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in intrepid or jaunty?

Changed in firefox:
importance: Unknown → Medium
Changed in wow-pro:
importance: Unknown → Medium
Revision history for this message
Jörg Frings-Fürst (jff-de) wrote :

bug from 2007 - version not longer supported
change status to invalid

Changed in evolution (Ubuntu):
status: Confirmed → Invalid
Changed in firefox (Ubuntu):
status: Confirmed → Invalid
Changed in mozilla-thunderbird (Ubuntu):
status: Confirmed → Invalid
Changed in firefox:
status: Confirmed → Unknown
Changed in wow-pro:
status: Confirmed → Unknown
Changed in firefox:
status: Unknown → Confirmed
Changed in wow-pro:
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.