[GUTSY] MASTER firefox crashed in spellchecker with undefined symbol: _ZN8Hunspell5spellEPKc [@ mozSpellChecker::GetCurrentDictionary] [@ mozSpellI18NManagerConstructor]

Bug #107340 reported by Davide on 2007-04-17
44
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
High
Alexander Sack

Bug Description

Workaround 1: disable spellchecker (like in about:config -> layout.spellcheckDefault=0)

Workaround 2: downgrade libhunspell

Firefox close the session when i make a reply in a forum. Close the session when i press the button "SPACE" and return me this error:

mozilubuntu@darklab:~$ mozilla-firefox
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
/usr/lib/firefox/firefox-bin: symbol lookup error: /usr/lib/firefox/components/libmyspell.so: undefined symbol: _ZN8Hunspell5spellEPKc

Marco Rodrigues (gothicx) wrote :

Do you have the log of crash at /var/crash ? Attach it here...

Changed in firefox:
status: Unconfirmed → Needs Info

Thank you for the bug report.

Could you please try to obtain a backtrace by following the instructions on
[1], or upload the crash report that probably was generated during the crash
and that should be located at /var/crash/ to [2]. Also, Indicate which
extensions/plugins do you have enabled, and please if this crash is
reproducible describe the steps that lead to it. This will greatly aid us in
tracking down your problem.

Thanks in advance

[1] https://wiki.ubuntu.com/MozillaTeam/Bugs
[2] https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/107340/+addcomment

Changed in firefox:
assignee: nobody → hmontoliu
importance: Undecided → Medium
Will Farrington (wcfarrington) wrote :

I can confirm this. Attached is the gdb stuff from [1] in the above comment.

This is reproduced by going to any site with a text field, and typing in that text field. I believe it's related to spell-checking.

Changed in firefox:
status: Needs Info → Confirmed
Will Farrington (wcfarrington) wrote :

Also, attached is the log from /var/crash/

Will Farrington (wcfarrington) wrote :

A temporary fix has been found. For some reason, my version of libhunspell-1.1-0 was 1.1.5-6, and it should be 1.1.4-7.

Rolling back appears to have fixed it.

Retrace done on Will Farrington's reported crash.

Extract from retraced stacktrace:
...
#3 <signal handler called>
#4 mozSpellChecker::GetCurrentDictionary (this=0x8cb7210,
#5 mozSpellI18NManagerConstructor (aOuter=0x0,
#6 NS_InitXPCOM3_P (result=0x8cb71f8, binDirectory=0x0,
#7 nsStaticComponentLoader::RegisterDeferredComponents (
#8 nsGenericFactory (this=0x3, info=0xbf899ed8)
#9 ~nsGenericFactory (this=0xb7dc63e4)
#10 nsIDHashKey::HashKey (id=0xbf899ef0) at nsTHashtable.cpp:118
#11 nsEditorSpellCheck::~nsEditorSpellCheck ()
#12 ~mozInlineSpellChecker (this=0x8084804)
...

Tagging as mt-confirm for further processing. Maybe the bug was caused by the library mismatch but I'll leave it opened for further evaluation. Thank you Will Farrington.

Changed in firefox:
importance: Medium → High
status: Confirmed → Needs Info
assignee: hmontoliu → mozilla-bugs

I can confirm that reverting to feisty (1.1.4-7) version fix the problem

will be fixed with next upload. Workarounds in bug description.

description: updated
Changed in firefox:
assignee: mozilla-bugs → asac
status: Needs Info → In Progress
description: updated
matt felser (mfelser) wrote :

This same error occurs in OpenOffice and other programs that use the spell checker.

Alexander Sack (asac) wrote :

new package 2.0.0.3+3-0ubuntu1 has been uploaded and will bring the needed rebuild in order to fix this annoying issue.

Changed in firefox:
status: In Progress → Fix Released

On Fri, May 04, 2007 at 08:58:27AM -0000, Alexander Sack wrote:
> new package 2.0.0.3+3-0ubuntu1 has been uploaded and will bring the
> needed rebuild in order to fix this annoying issue.

What's the long-term fix for hunspell, as the trouble with it also affects
OpenOffice.org?

--
 - mdz

Alexander Sack (asac) wrote :

On Fri, May 04, 2007 at 09:23:52AM -0000, Matt Zimmerman wrote:
> On Fri, May 04, 2007 at 08:58:27AM -0000, Alexander Sack wrote:
> > new package 2.0.0.3+3-0ubuntu1 has been uploaded and will bring the
> > needed rebuild in order to fix this annoying issue.
>
> What's the long-term fix for hunspell, as the trouble with it also affects
> OpenOffice.org?
>

The fix is to just respin all dependents of libhunspell once and hope
that debian will not break abi anymore.

Of course, right solution would be a soname bump ... but I am
unsure if debian will do it; remember that we synched an
experimental package to feisty :).

 - Alexander

Anderson (amg1127) wrote :

I know Hardy's development just begun, but... The bug is back in my system:

$ firefox http://www.htmlref.com/examples/chapter12/textarea.html
/usr/lib/firefox/firefox-bin: symbol lookup error: /usr/lib/firefox/components/libmyspell.so: undefined symbol: _ZN8Hunspell5spellEPKc

$ firefox -safe-mode http://www.htmlref.com/examples/chapter12/textarea.html
/usr/lib/firefox/firefox-bin: symbol lookup error: /usr/lib/firefox/components/libmyspell.so: undefined symbol: _ZN8Hunspell5spellEPKc

OpenOffice didn't reproduce the problem.

Downgrading libhunspell doesn't fix the problem. I had to remove libhunspell by hand:
# rm -fv /usr/lib/libhunspell-1.1.so.0*
Unfortunately, that actions removes speel checking capabilities from OpenOffice.

$ dpkg -l 'openoffice.org' 'firefox' 'libhunspell-1.1-0'
ii firefox 2.0.0.8+1nobinonly-0ubuntu1 lightweight web browser based on Mozilla
ii libhunspell-1.1-0 1.1.9-1 spell checker and morphological analyzer (shared library)
ii openoffice.org 1:2.3.0-1ubuntu5 OpenOffice.org Office suite

Using Ubuntu Harder Heron upgraded 2 hours ago.

Anderson (amg1127) wrote :

Well... I should apply a better workaround:

# echo 'pref("layout.spellcheckDefault", 0);' >> /etc/firefox/pref/firefox.js

Alexander Sack (asac) wrote :

On Thu, Oct 25, 2007 at 10:18:38AM -0000, Anderson wrote:
> Well... I should apply a better workaround:
>
> # echo 'pref("layout.spellcheckDefault", 0);' >>
> /etc/firefox/pref/firefox.js
>

You probably have a dictionary extensions installed ... uninstall that
and install a dictionary package through ubuntu language support in
System -> Preferences.

 - Alexander

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers