Ubuntu

Firefox high cpu usage

Reported by Ahmed Toulan on 2012-10-09
110
This bug affects 23 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

Firefox uses 76% of the cpu with no apparent reason. No flash or anything fancy, just by opening Google search page.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: firefox 15.0.1+build1-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.27-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: fglrx
AddonCompatCheckDisabled: False
ApportVersion: 2.6.1-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: atoulan 2588 F.... pulseaudio
 /dev/snd/controlC0: atoulan 2588 F.... pulseaudio
BuildID: 20120907073726
Channel: Unavailable
Date: Tue Oct 9 17:13:28 2012
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
IpRoute:
 default via 192.168.1.1 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.15 metric 9
PrefSources:
 prefs.js
 [Profile]/extensions/{b9db16a4-6edc-47ec-a1f4-b86292ed211d}/defaults/preferences/prefs-dwhelper.js
 [Profile]/<email address hidden>/defaults/preferences/prefs.js
Profiles: Profile0 (Default) - LastVersion=15.0.1/20120907073726 (In use)
RelatedPackageVersions:
 gecko-mediaplayer 1.0.6-1ubuntu2
 totem-mozilla 3.4.3-0ubuntu4
 icedtea-7-plugin 1.3-1ubuntu1
 adobe-flashplugin 11.2.202.238-0precise1
 google-talkplugin 2.8.5.0-1
RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: Upgraded to quantal on 2012-10-08 (0 days ago)
dmi.bios.date: 04/21/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A13
dmi.board.name: 03C6YH
dmi.board.vendor: Dell Inc.
dmi.board.version: A13
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A13
dmi.modalias: dmi:bvnDellInc.:bvrA13:bd04/21/2011:svnDellInc.:pnInspironN5010:pvrA13:rvnDellInc.:rn03C6YH:rvrA13:cvnDellInc.:ct8:cvrA13:
dmi.product.name: Inspiron N5010
dmi.product.version: A13
dmi.sys.vendor: Dell Inc.

Ahmed Toulan (thelinuxer) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Neil Burgin (nburgin) wrote :

not sure if this is the same bug or if I should report a new one, but I get gradually increasing CPU usage the longer I have the program open. At first I thought it was from having too many tabs open but even after closing all of them, it was still sucking a massive amount of CPU. Then I close and restart firefox and it's fine. I'm not sure if this is an upstream programmer error on the part of Mozilla or if it's just firefox's ubuntu packager using far too aggressive optimization flags that screwed something up subtly. (about:buildconfig reveals a startling amount of optimization flags, including that it used -Os instead of -O2)

Mind you, Firefox's performance doesn't slow down any. I can only detect that it's happening by monitoring my CPU usage.

It's a very subtle problem. It only appears after a long session in which firefox has not been closed and restarted.

Simon P. (simpre) wrote :

I suffer from the high CPU-usage of firefox too, especially when using my netbook. This is the least responsive and slowest firefox experience under Ubuntu for me so far.
Sometimes while loading a page, firefox freezes for a few seconds, the page gets grey and I can see the desktop background where the address bar was before.

gorgo (filter-my) wrote :

Same as nburgin. I was used to have many firefox windows with many tabs open but the longer the firefox is running the more CPU usage it consumes. Even after closing tabs / windows. Restart temporarily solves the problem - in my case I have to restart it once a day.

Using Firefox 17.0 on my Kubuntu 12.04 with KDE 4.9.3.

+1

Ubuntu 12.04 LTS with all current updates. Firefox and/or Xorg using 94% according to 'top' command in console because desktop became unresponsive.

Eduard (hotadd) wrote :

I have same problem.
Full info - http://pastebin.com/nuUAuNQK

Tom (tom-lorinthe) wrote :

+1 CPU often at 100% on most simple sites. Firebug disabled.

Tom (tom-lorinthe) wrote :

In safe mode, FF 18 was running fine on 12.04LTS.

So, disabling all addons, it became clear that "Global Menu Bar 3.6.4" is the culprit... Just disable that add on and FF is snappy again.

Firekage (firekage) wrote :

@ Tom, your suggestion didn't help. In fact, if the global menu bar is switched on, than firefox in my case is not useable at all because it just stops whenewer i want to go from bookmarks to a desired webpage. It just stops not only firefox but all Unity on Ubuntu 12.xx (04/10).

So, i had to disable it earlier but it just helped only for a bit with bookmarks (i have about 6.000), Unity doesen't froze now but just like the others wrote, with time firefox is just slower and slower, and there is a point where i have to close it because it can load my cpu to a 70-80%, and i see that scrolling page is not smooth at all, it's just laggy, very laggy to a point where it just gives me mad, what is funny? I have Quad Core CPU named X4 955 running at 3GHz...I have also Windows Vista and on Vista i have never seen such behaviour, no matter how many tabs are opened (even with for an example: 50 tabs), no matter what i run, what i selected in firefox, which page im on (Youtube and moves from it even with 720p or 1080 running) or how many firefox instances are opened - it's just always smooth.

Under ubuntu, not. No matter which version of Ubuntu or Firefox. I have checked it also on Lubuntu, Kubuntu, Xbuntu, Slackware - everything works...exept Ubuntu.

Firekage (firekage) wrote :

I nearly forget: it's just funny, or not funny at all. 4GB ram, powerfull processor and such behaviour? Firefox has become some "lazy", sluggish thing to a point when i have to look for different web browser because on powerful processor and computer it is barely usable - or i have to switch off it, and restart it again, and again after time.

Jarno Suni (jarnos) wrote :

@Ahmed Toulan , does it do it every time or occasionally?

I keep having the problem nburgin described. I don't use Unity, but Xfce/LXDE. A Firefox thread runs 195% and a couple threads run about 95% of CPU power according to htop. My laptop fans are crying.

Jarno Suni (jarnos) wrote :

Except that closing Firefox did not work: UI was gone, but firefox process kept running in background. Killing by signal 1 closed firefox finally. After restart (with same tabs) CPU usage is much lower, at about 10%.

Ahmed Toulan (thelinuxer) wrote :

The behavior I described in this bug stopped a long time ago (the bug is more than a year old) . Sorry I can't remember if it got fixed or I managed to find a work around.

Jarno Suni (jarnos) wrote :

The original bug does not exist anymore. Please add a new bug report using "ubuntu-bug firefox", if you have a CPU usage problem with firefox.

Changed in firefox (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers