firefox license change not reflected in /usr/share/doc/firefox/copyright

Bug #1028266 reported by Janne Blomqvist on 2012-07-24
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Low
Unassigned

Bug Description

Now that firefox (and thunderbird) have switched from the MPLv1/GPL/LGPL tri-license to MPL 2.0, /usr/share/doc/firefox/copyright should reflect this. Also, /usr/share/doc/firefox/MPL.gz should be updated, or removed if the MPL 2.0 would be included in /usr/share/doc/firefox/copyright.

Also, based on a quick look, the license list in this file seem to lack quite a few of the licenses in the list one can see at about:license (help -> about firefox -> licensing information).

This is for firefox 14.01 in Ubuntu 10.04 and 12.04.

Chris Coulson (chrisccoulson) wrote :

If somebody else wants to do this, then they are more than welcome to. Although, I can think of more productive things to do than editing a copyright file....

Changed in firefox (Ubuntu):
importance: Undecided → Low

As far as I'm personally concerned, the easiest way would be to just remove the copyright and MPL.gz files from the package. But if you're going to have them (if you have some policy requiring it, for instance), shouldn't they then match the actual licenses? Anyway, since I'm not the package maintainer it's not my call.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :

Well, we can't remove the copyright file, as it's against Debian policy. Yes, it probably should be correct, but that's not a trivial task with something as complicated as Firefox. Personally, I'd rather work on fixing bugs and implementing things users actually care about rather than spending that time on updating a copyright file. Of course, that doesn't stop anybody else from updating it, although you'll be hard pressed to find somebody who wants to do something as soul destroying as updating a copyright file

Legimet (legimet) wrote :

Debian updated the copyright file for Iceweasel, so it should be easy to include, along with the MPL-2.0 file.

This bug seems to have been fixed. Based on /usr/share/doc/firefox/changelog.Debian.gz this might have happened for the release of firefox 58 in January 2018.

Changed in firefox (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers