no choice of folder for bookmarks

Bug #1010580 reported by Christophe NAUD on 2012-06-08
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Global menubar extension
Low
Unassigned
3.2
Low
Unassigned
firefox (Ubuntu)
Low
Unassigned
Natty
Low
Unassigned
Oneiric
Low
Unassigned
Precise
Low
Unassigned
Quantal
Low
Unassigned

Bug Description

Firefox no longer lets me choose to which folder I want to bookmark a webpage. I really do not understand why. A few days ago, this feature was available. what has happened?

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: firefox 13.0+build1-0ubuntu0.12.04.1
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic-pae 3.2.16
Uname: Linux 3.2.0-24-generic-pae i686
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: christon74 1785 F.... pulseaudio
BuildID: 20120601173917
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfea78000 irq 44'
   Mixer name : 'Realtek ALC662 rev1'
   Components : 'HDA:10ec0662,105b0d55,00100101'
   Controls : 39
   Simple ctrls : 21
Channel: release
Date: Fri Jun 8 19:17:22 2012
ForcedLayersAccel: False
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120327.1)
IpRoute:
 default via 192.168.1.1 dev eth0 proto static
 169.254.0.0/16 dev eth0 scope link metric 1000
 192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.64 metric 1
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MostRecentCrashID: bp-f3507111-d8c1-4c52-8e02-1182f2120528
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=13.0/20120601173917 (In use)
RelatedPackageVersions:
 icedtea-6-plugin 1.2-2ubuntu1
 rhythmbox-mozilla 2.96-0ubuntu4
 totem-mozilla 3.0.1-0ubuntu21
RfKill:

RunningIncompatibleAddons: False
SourcePackage: firefox
SubmittedCrashIDs: bp-f3507111-d8c1-4c52-8e02-1182f2120528
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/07/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080015
dmi.board.name: TPS01
dmi.board.vendor: FOXCONN
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080015:bd06/07/2010:svnFOXCONN:pnTPS01:pvr1.0:rvnFOXCONN:rnTPS01:rvr1.0:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: TPS01
dmi.product.version: 1.0
dmi.sys.vendor: FOXCONN

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Changed in firefox (Ubuntu Quantal):
importance: Undecided → Low
Changed in firefox (Ubuntu Oneiric):
importance: Undecided → Low
Changed in firefox (Ubuntu Lucid):
importance: Undecided → Low
Changed in firefox (Ubuntu Precise):
importance: Undecided → Low
Changed in firefox (Ubuntu Natty):
importance: Undecided → Low
Changed in globalmenu-extension:
importance: Undecided → Low
Changed in globalmenu-extension:
status: New → Fix Released

Hi Chris,

I'm not sure what I have to do. Can you help?

Paul

On 18/06/12 16:29, Chris Coulson wrote:
> ** Changed in: globalmenu-extension/3.2
> Status: New => Fix Released
>

affects: globalmenu-extension → mozilla-build-system
Dan (fester225) wrote :
Download full text (4.2 KiB)

Paul,

I believe this means you're not the only one experiencing this
behavior. Apparently there is no solution at the moment.

At some point in the next couple of months there will probably be an
update that fixes the problem.

Fester

On Tue, Jun 19, 2012 at 8:52 AM, Paul Low <email address hidden> wrote:
> Hi Chris,
>
> I'm not sure what I have to do.  Can you help?
>
> Paul
>
> On 18/06/12 16:29, Chris Coulson wrote:
>> ** Changed in: globalmenu-extension/3.2
>>         Status: New =>  Fix Released
>>
>
>
> ** Project changed: globalmenu-extension => mozilla-build-system
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1011298).
> https://bugs.launchpad.net/bugs/1010580
>
> Title:
>  no choice of folder for bookmarks
>
> Status in Global menubar extension 3.2 series:
>  Fix Released
> Status in Mozilla build system:
>  Fix Released
> Status in “firefox” package in Ubuntu:
>  Confirmed
> Status in “firefox” source package in Lucid:
>  New
> Status in “firefox” source package in Natty:
>  New
> Status in “firefox” source package in Oneiric:
>  New
> Status in “firefox” source package in Precise:
>  New
> Status in “firefox” source package in Quantal:
>  Confirmed
>
> Bug description:
>  Firefox no longer lets me choose to which folder I want to bookmark a
>  webpage. I really do not understand why. A few days ago, this feature
>  was available. what has happened?
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 12.04
>  Package: firefox 13.0+build1-0ubuntu0.12.04.1
>  ProcVersionSignature: Ubuntu 3.2.0-24.39-generic-pae 3.2.16
>  Uname: Linux 3.2.0-24-generic-pae i686
>  AddonCompatCheckDisabled: False
>  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
>  ApportVersion: 2.0.1-0ubuntu8
>  Architecture: i386
>  AudioDevicesInUse:
>   USER        PID ACCESS COMMAND
>   /dev/snd/controlC0:  christon74   1785 F.... pulseaudio
>  BuildID: 20120601173917
>  CRDA: Error: [Errno 2] No such file or directory
>  Card0.Amixer.info:
>   Card hw:0 'Intel'/'HDA Intel at 0xfea78000 irq 44'
>     Mixer name : 'Realtek ALC662 rev1'
>     Components : 'HDA:10ec0662,105b0d55,00100101'
>     Controls      : 39
>     Simple ctrls  : 21
>  Channel: release
>  Date: Fri Jun  8 19:17:22 2012
>  ForcedLayersAccel: False
>  InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120327.1)
>  IpRoute:
>   default via 192.168.1.1 dev eth0  proto static
>   169.254.0.0/16 dev eth0  scope link  metric 1000
>   192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.64  metric 1
>  IwConfig:
>   lo        no wireless extensions.
>
>   eth0      no wireless extensions.
>  MostRecentCrashID: bp-f3507111-d8c1-4c52-8e02-1182f2120528
>  ProcEnviron:
>   LANGUAGE=en_GB:en
>   PATH=(custom, no user)
>   LANG=en_GB.UTF-8
>   SHELL=/bin/bash
>  Profiles: Profile0 (Default) - LastVersion=13.0/20120601173917 (In use)
>  RelatedPackageVersions:
>   icedtea-6-plugin  1.2-2ubuntu1
>   rhythmbox-mozilla 2.96-0ubuntu4
>   totem-mozilla     3.0.1-0ubuntu21
>  RfKill:
>
>  RunningIncompatibleAddons: False
>  SourcePackage: firefox
>  SubmittedCrashIDs: bp-f3507111-d8c1-4c52-8e02-1182f21205...

Read more...

Paul Low (paul-low) wrote :
Download full text (4.2 KiB)

Hi Fester,

Thanks for making that clear.

Best wishes,

Paul

On 19/06/12 16:04, Dan wrote:
> Paul,
>
> I believe this means you're not the only one experiencing this
> behavior. Apparently there is no solution at the moment.
>
> At some point in the next couple of months there will probably be an
> update that fixes the problem.
>
> Fester
>
>
> On Tue, Jun 19, 2012 at 8:52 AM, Paul Low<email address hidden> wrote:
>> Hi Chris,
>>
>> I'm not sure what I have to do. Can you help?
>>
>> Paul
>>
>> On 18/06/12 16:29, Chris Coulson wrote:
>>> ** Changed in: globalmenu-extension/3.2
>>> Status: New => Fix Released
>>>
>>
>> ** Project changed: globalmenu-extension => mozilla-build-system
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (1011298).
>> https://bugs.launchpad.net/bugs/1010580
>>
>> Title:
>> no choice of folder for bookmarks
>>
>> Status in Global menubar extension 3.2 series:
>> Fix Released
>> Status in Mozilla build system:
>> Fix Released
>> Status in “firefox” package in Ubuntu:
>> Confirmed
>> Status in “firefox” source package in Lucid:
>> New
>> Status in “firefox” source package in Natty:
>> New
>> Status in “firefox” source package in Oneiric:
>> New
>> Status in “firefox” source package in Precise:
>> New
>> Status in “firefox” source package in Quantal:
>> Confirmed
>>
>> Bug description:
>> Firefox no longer lets me choose to which folder I want to bookmark a
>> webpage. I really do not understand why. A few days ago, this feature
>> was available. what has happened?
>>
>> ProblemType: Bug
>> DistroRelease: Ubuntu 12.04
>> Package: firefox 13.0+build1-0ubuntu0.12.04.1
>> ProcVersionSignature: Ubuntu 3.2.0-24.39-generic-pae 3.2.16
>> Uname: Linux 3.2.0-24-generic-pae i686
>> AddonCompatCheckDisabled: False
>> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
>> ApportVersion: 2.0.1-0ubuntu8
>> Architecture: i386
>> AudioDevicesInUse:
>> USER PID ACCESS COMMAND
>> /dev/snd/controlC0: christon74 1785 F.... pulseaudio
>> BuildID: 20120601173917
>> CRDA: Error: [Errno 2] No such file or directory
>> Card0.Amixer.info:
>> Card hw:0 'Intel'/'HDA Intel at 0xfea78000 irq 44'
>> Mixer name : 'Realtek ALC662 rev1'
>> Components : 'HDA:10ec0662,105b0d55,00100101'
>> Controls : 39
>> Simple ctrls : 21
>> Channel: release
>> Date: Fri Jun 8 19:17:22 2012
>> ForcedLayersAccel: False
>> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120327.1)
>> IpRoute:
>> default via 192.168.1.1 dev eth0 proto static
>> 169.254.0.0/16 dev eth0 scope link metric 1000
>> 192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.64 metric 1
>> IwConfig:
>> lo no wireless extensions.
>>
>> eth0 no wireless extensions.
>> MostRecentCrashID: bp-f3507111-d8c1-4c52-8e02-1182f2120528
>> ProcEnviron:
>> LANGUAGE=en_GB:en
>> PATH=(custom, no user)
>> LANG=en_GB.UTF-8
>> SHELL=/bin/bash
>> Profiles: Profile0 (Default) - LastVersion=13.0/20120601173917 (In use)
>> RelatedPackageVersio...

Read more...

Chris Coulson (chrisccoulson) wrote :

Why did you change that?

affects: mozilla-build-system → globalmenu-extension
Paul Low (paul-low) wrote :

Sorry, mistake. Was looking through options and didn't change back
before I left.

On 19/06/12 20:13, Chris Coulson wrote:
> Why did you change that?
>
> ** Project changed: mozilla-build-system => globalmenu-extension
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 14.0~b8+build1-0ubuntu1

---------------
firefox (14.0~b8+build1-0ubuntu1) quantal; urgency=low

  * New upstream release from the beta channel (FIREFOX_14_0b8_BUILD1)

  * Update globalmenu-extension to 3.3 prerelease r369
    - Fix LP: #1010580 - No choice of folder when adding a bookmark from
      the bookmark menu
    - Fix LP: #775080 - Thunderbird with Firetray/MinimizeToTray -
      Global menu disappears
    - Fix LP: #813775 - Hitting an assertion in dbusmenu
    - Fix LP: #861565 - No buttons in the "Show All Bookmarks" dialog
 -- Chris Coulson <email address hidden> Wed, 20 Jun 2012 18:17:11 +0100

Changed in firefox (Ubuntu Quantal):
status: Confirmed → Fix Released
Chris Coulson (chrisccoulson) wrote :

Fixed in the next 14.0 beta build

no longer affects: firefox (Ubuntu Lucid)
Changed in firefox (Ubuntu Natty):
status: New → Fix Committed
Changed in firefox (Ubuntu Oneiric):
status: New → Fix Committed
Changed in firefox (Ubuntu Precise):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package firefox - 14.0.1+build1-0ubuntu0.12.04.1

---------------
firefox (14.0.1+build1-0ubuntu0.12.04.1) precise-security; urgency=low

  * New upstream stable release (FIREFOX_14_0_1_BUILD1)
    - see LP: #1024562 for USN information

  [ Chris Coulson <email address hidden> ]
  * Update globalmenu-extension to 3.2.5
    - Fix LP: #1010580 - No choice of folder when adding a bookmark from
      the bookmark menu
    - Fix a crash in uGlobalMenu::RecycleList::~RecycleList()
  * Refresh patches
    - update debian/patches/ubuntu-codes-google.patch
    - update debian/patches/allow-lockPref-everywhere.patch
    - update debian/patches/plugin-for-mimetype-pref.patch
    - update debian/patches/add-syspref-dir.patch
  * Drop patches fixed upstream
    - remove debian/patches/revert-bmo621446-investigation.patch
  * Add Keywords to the desktop file
    - update debian/firefox.desktop.in
  * Update desktop file translations
    - update debian/firefox.sh.in
  * Ensure that additional actions in the desktop file match the fd.o spec
    in precise and newer
    - update debian/firefox.desktop.in
    - update debian/rules
  * Drop the application/vnd.mozilla.xul+xml mimetype from the desktop file.
    Firefox hasn't been able to view XUL files from non-chrome URI's since
    version 4.0
    - update debian/firefox.desktop.in
  * Add application/x-xpinstall to the MimeType field of the desktop file
    - update debian/firefox.desktop.in
  * Drop the ability to select between tree/system libraries using a single
    option in debian/rules. It adds additional complexity and was never used
    - update debian/config/mozconfig.in
    - update debian/control.in
    - update debian/firefox-dev.install.in
    - update debian/firefox-dev.links.in
    - update debian/pkgconfig/libxul.pc.in
    - update debian/rules
  * Fix make-makefile test failure when the build directory contains
    perl regexp control characters
    - add debian/patches/make-makefile-test-fix.patch
    - update debian/patches/series
  * Shuffle the order of google-breakpad/src/common/dwarf/Makefile.in to fix a
    variable substitution issue, which was causing some objects to be built with
    the wrong compiler flags, resulting in dump_syms crashing (LP: #1002590)
    - add debian/patches/fix-makefile-substitution-bug.patch
  * Update StartupWMClass to the correct name
    - update debian/firefox.desktop.in
    - update debian/rules
  * Add search plugin for DuckDuckGo
  * Fix LP: #1000820 - firefox-dev conflicts with xulrunner-1.9-dev for
    people with the latter still installed
    - update debian/control{,.in}
  * Add Fulah to locales.blacklist
  * Fix LP: #1013186 - install our vendor preferences as application
    defaults rather than GRE defaults, so that they are loaded after
    the upstream defaults again. The upstream defaults were also moved
    as part of the webapp runtime work (which has it's own application
    defaults)
    - update debian/firefox.install.in
    - update debian/firefox.links.in
  * Apport hook improvements:
    - Sort preferences alphabetically in the apport data
    - Treat preferences set in default addons as default ...

Read more...

Changed in firefox (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.7 KiB)

This bug was fixed in the package firefox - 14.0.1+build1-0ubuntu0.11.04.1

---------------
firefox (14.0.1+build1-0ubuntu0.11.04.1) natty-security; urgency=low

  * New upstream stable release (FIREFOX_14_0_1_BUILD1)
    - see LP: #1024562 for USN information

  [ Chris Coulson <email address hidden> ]
  * Update globalmenu-extension to 3.2.5
    - Fix LP: #1010580 - No choice of folder when adding a bookmark from
      the bookmark menu
    - Fix a crash in uGlobalMenu::RecycleList::~RecycleList()
  * Refresh patches
    - update debian/patches/ubuntu-codes-google.patch
    - update debian/patches/allow-lockPref-everywhere.patch
    - update debian/patches/plugin-for-mimetype-pref.patch
    - update debian/patches/firefox-kde.patch
  * Drop patches fixed upstream
    - remove debian/patches/revert-bmo-621446-investigation.patch
    - update debian/patches/series
  * Update desktop file translations
    - update debian/firefox.sh.in
  * Drop the application/vnd.mozilla.xul+xml mimetype from the desktop file.
    Firefox hasn't been able to view XUL files from non-chrome URI's since
    version 4.0
    - update debian/firefox.desktop.in
  * Add application/x-xpinstall to the MimeType field of the desktop file
    - update debian/firefox.desktop.in
  * Drop the ability to select between tree/system libraries using a single
    option in debian/rules. It adds additional complexity and was never used
    - update debian/config/mozconfig.in
    - update debian/control.in
    - update debian/firefox-dev.install.in
    - update debian/firefox-dev.links.in
    - update debian/pkgconfig/libxul.pc.in
    - update debian/rules
  * Fix make-makefile test failure when the build directory contains
    perl regexp control characters
    - add debian/patches/make-makefile-test-fix.patch
    - update debian/patches/series
  * Shuffle the order of google-breakpad/src/common/dwarf/Makefile.in to fix a
    variable substitution issue, which was causing some objects to be built with
    the wrong compiler flags, resulting in dump_syms crashing (LP: #1002590)
    - add debian/patches/fix-makefile-substitution-bug.patch
  * Update StartupWMClass to the correct name
    - update debian/firefox.desktop.in
    - update debian/rules
  * Add search plugin for DuckDuckGo
  * Fix LP: #1000820 - firefox-dev conflicts with xulrunner-1.9-dev for
    people with the latter still installed
    - update debian/control{,.in}
  * Add Fulah to locales.blacklist
  * Fix LP: #1013186 - install our vendor preferences as application
    defaults rather than GRE defaults, so that they are loaded after
    the upstream defaults again. The upstream defaults were also moved
    as part of the webapp runtime work (which has it's own application
    defaults)
    - update debian/firefox.install.in
    - update debian/firefox.links.in
  * Apport hook improvements:
    - Sort preferences alphabetically in the apport data
    - Treat preferences set in default addons as default prefs so that
      they don't show up in apport data, unless the preference files have
      been modified
    - Support random pref files dropped in to the Firefox install folder, and
      preferences from ap...

Read more...

Changed in firefox (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.7 KiB)

This bug was fixed in the package firefox - 14.0.1+build1-0ubuntu0.11.10.1

---------------
firefox (14.0.1+build1-0ubuntu0.11.10.1) oneiric-security; urgency=low

  * New upstream stable release (FIREFOX_14_0_1_BUILD1)
    - see LP: #1024562 for USN information

  [ Chris Coulson <email address hidden> ]
  * Update globalmenu-extension to 3.2.5
    - Fix LP: #1010580 - No choice of folder when adding a bookmark from
      the bookmark menu
    - Fix a crash in uGlobalMenu::RecycleList::~RecycleList()
  * Refresh patches
    - update debian/patches/ubuntu-codes-google.patch
    - update debian/patches/allow-lockPref-everywhere.patch
    - update debian/patches/plugin-for-mimetype-pref.patch
    - update debian/patches/firefox-kde.patch
  * Dropped patches fixed upstream
    - remove debian/patches/revert-bmo621446-investigation.patch
    - update debian/patches/series
  * Update desktop file translations
    - update debian/firefox.sh.in
  * Drop the application/vnd.mozilla.xul+xml mimetype from the desktop file.
    Firefox hasn't been able to view XUL files from non-chrome URI's since
    version 4.0
    - update debian/firefox.desktop.in
  * Add application/x-xpinstall to the MimeType field of the desktop file
    - update debian/firefox.desktop.in
  * Drop the ability to select between tree/system libraries using a single
    option in debian/rules. It adds additional complexity and was never used
    - update debian/config/mozconfig.in
    - update debian/control.in
    - update debian/firefox-dev.install.in
    - update debian/firefox-dev.links.in
    - update debian/pkgconfig/libxul.pc.in
    - update debian/rules
  * Fix make-makefile test failure when the build directory contains
    perl regexp control characters
    - add debian/patches/make-makefile-test-fix.patch
    - update debian/patches/series
  * Shuffle the order of google-breakpad/src/common/dwarf/Makefile.in to fix a
    variable substitution issue, which was causing some objects to be built with
    the wrong compiler flags, resulting in dump_syms crashing (LP: #1002590)
    - add debian/patches/fix-makefile-substitution-bug.patch
  * Update StartupWMClass to the correct name
    - update debian/firefox.desktop.in
    - update debian/rules
  * Add search plugin for DuckDuckGo
  * Fix LP: #1000820 - firefox-dev conflicts with xulrunner-1.9-dev for
    people with the latter still installed
    - update debian/control{,.in}
  * Add Fulah to locales.blacklist
  * Fix LP: #1013186 - install our vendor preferences as application
    defaults rather than GRE defaults, so that they are loaded after
    the upstream defaults again. The upstream defaults were also moved
    as part of the webapp runtime work (which has it's own application
    defaults)
    - update debian/firefox.install.in
    - update debian/firefox.links.in
  * Apport hook improvements:
    - Sort preferences alphabetically in the apport data
    - Treat preferences set in default addons as default prefs so that
      they don't show up in apport data, unless the preference files have
      been modified
    - Support random pref files dropped in to the Firefox install folder, and
      preferences fro...

Read more...

Changed in firefox (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers