gutsy/amd64: ftbfs / autopkgtest failure

Bug #127200 reported by Ian Jackson on 2007-07-20
2
Affects Status Importance Assigned to Milestone
firefox-themes-ubuntu (Ubuntu)
High
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects /ubuntu/firefox-themes-ubuntu

An instance of autopkgtest (an automatic package testing system) has
found that this package either failed to build from source - or that
it declared some tests in its debian/tests/control and that at least
one of these tests failed.

A human has briefly looked at the transcript and concluded that the
fault is a bug in the package or one of its build-dependencies.

The test environment is an amd64 Xen guest with limited amounts of
memory. The relevant dependencies are installed for each test but
very few other packages.

The top and bottom of the mail sent by the autopkgtest instance to its
administrator is included below:

| Test executed for: gutsy source firefox-themes-ubuntu
| Outcome: erroneous package!
| blame: arg:tmp/firefox-themes-ubuntu/src/firefox-themes-ubuntu_0.5.4.1.dsc dsc:firefox-themes-ubuntu
| badpkg: rules build failed with exit code 2
| quitting: erroneous package: rules build failed with exit code 2
|
| erroneous package!
...
| I: Purging /etc/pango/pango.modules
| Cleaning up font configuration of pango...
| Updating font configuration of pango...
| Cleaning up category xfont..
| Updating category xfont..
|
| Creating config file /etc/gconf/2/path with new version
|
| Creating config file /etc/php5/cli/php.ini with new version
| adt-run: trace: $ dsc0-build: sh -ec <SCRIPT> x /root/adt-downtmp/dsc0-build/tmpdir /root/adt-downtmp/dsc0-build/firefox-themes-ubuntu-0.5.4.1
| + TMPDIR=/root/adt-downtmp/dsc0-build/tmpdir
| + rm -rf -- /root/adt-downtmp/dsc0-build/tmpdir
| + export TMPDIR
| + su adtxenu -c mkdir -- "$TMPDIR"
| + cd /root/adt-downtmp/dsc0-build/firefox-themes-ubuntu-0.5.4.1
| + dpkg-checkbuilddeps
| + su adtxenu -c debian/rules build
| dh_testdir
| /usr/bin/make -C src all
| make[1]: Entering directory `/root/adt-downtmp/dsc0-build/firefox-themes-ubuntu-0.5.4.1/src'
| chmod +x ./createtheme.php
| ./createtheme.php
| /usr/bin/convert
| Imagemagick convert: /usr/bin/convert
| /usr/bin/montage
| Imagemagick montage: /usr/bin/montage
| /usr/bin/composite
| Imagemagick composite: /usr/bin/composite
| /usr/bin/inkscape
| Inkscape Vector Illustrator: /usr/bin/inkscape
| /usr/bin/jar
| Java Archive generator: /usr/bin/jar
| /usr/bin/file
| File type identifier: /usr/bin/file
| Fatal error: default theme source directory /usr/share/firefox/chrome/classic not found
| make[1]: *** [all] Error 1
| make[1]: Leaving directory `/root/adt-downtmp/dsc0-build/firefox-themes-ubuntu-0.5.4.1/src'
| make: *** [build-stamp] Error 2
| blame: arg:tmp/firefox-themes-ubuntu/src/firefox-themes-ubuntu_0.5.4.1.dsc dsc:firefox-themes-ubuntu
| badpkg: rules build failed with exit code 2
| adt-run: erroneous package: rules build failed with exit code 2
| adt-run: trace: ** stop
| adt-run: trace: ** close, scratch=tb-scratch~/root/adt-downtmp:-/|/root/adt-downtmp/!
| ++++++ RESULTS erroneous package! ++++++
| ++++++ bundling ++++++
| ++++++ uploading ++++++
| ++++++ contacting maintainer_email_override ++++++
| ++++++ tested. ++++++
|
|
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFGoNSv05QTisYqw/QRAoECAJ9QLpSRk/U3Xuw4gU3H9joIr9cO2wCdHFIZ
KJE/xY3KC/Ln5203LXaLr/s=
=IBZT
-----END PGP SIGNATURE-----

Ian Jackson (ijackson) wrote :

This appears to be due to the ubuntu firefox package now jarring its themes:

root@gutsy:~/build/firefox-themes-ubuntu-0.5.4.1# ls -al /usr/share/firefox/chrome/classic*
-rw-r--r-- 1 root root 766704 Sep 19 17:55 /usr/share/firefox/chrome/classic.jar
-rw-r--r-- 1 root root 322 Sep 19 17:55 /usr/share/firefox/chrome/classic.manifest
root@gutsy:~/build/firefox-themes-ubuntu-0.5.4.1#

It isn't exactly clear to me how this should be fixed. Does f-t-u have any facilities at the moment for unbundling jars at package build time ?

Changed in firefox-themes-ubuntu:
importance: Undecided → High
status: New → Confirmed
Steve Langasek (vorlon) wrote :

f-t-u build-depends on java-gcj-compat, so it can unbundle jars as well as creating them; but unlike "tar", the -C option to "jar" doesn't work right, so I found it easier to add a build-dep on unzip anyway since I trust unzip's behavior a bit more.

I've attached a debdiff which I believe gets this package building right again. Alternatively, a signed source package is available at http://people.ubuntu.com/~vorlon/firefox-ubuntu-themes/ if someone would care to sponsor it into main.

Steve Langasek writes ("[Bug 127200] Re: gutsy/amd64: ftbfs / autopkgtest failure"):
> I've attached a debdiff which I believe gets this package building right
> again. Alternatively, a signed source package is available at
> http://people.ubuntu.com/~vorlon/firefox-ubuntu-themes/ if someone would
> care to sponsor it into main.

That's great, thanks. I've done that.

(I had to rebuild your upload because you didn't pass -S to
dpkg-buildpackage.)

Ian.

Steve Langasek (vorlon) wrote :

firefox-themes-ubuntu (0.5.4.2) gutsy; urgency=low

  * Handle theme sources as either a jar or a directory; adds a
    build-dependency on "unzip", since fastjar has annoying semantics
    for jar extraction. LP: #127200.

 -- Steve Langasek <email address hidden> Tue, 02 Oct 2007 18:08:41 -0700

Changed in firefox-themes-ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers