DNS lookup slow

Bug #467987 reported by JLotspeich on 2009-11-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox-3.5 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.5

After upgrade to 9.10, nslookup was fine, but firefox, galeum, and epiphany were all slow to look up pages. After about 10 minutes, all lookups failed, including nslookup. Other computers on the network were unaffected (Mac OSX).

ipv6 is disabled

I tried the following configurations:
Static IP with linksys router set as DNS server
DHCP for addresses only with ISP DNS servers added manually
DHCP only

Static IP is what I had setup in 9.04 prior to upgrading with no issues.

With static IP and DHCP only, lookups would work sporadic and ultimately fail completely after about 10 minutes. Network information shows that DHCP only resulted in linksys router as primary DNS server, with ISP DNS server set as secondary.

It appears that the linksys router is the culprit to DNS slowness, however this was not a problem until upgrading. I can't get wireshark working to confirm, but I believe that the order of DNS lookups, the format, or some other thing related to DNS lookups has changed from 9.04 to 9.10 and is causing instability in the router's DNS relay functionality My router is:

Linksys WRT54G, firmware v1.02.5

Workaround is to use DHCP for address, and set ISP DNS server as primary. This resulted in 5 to 10x lookup speedup with no instability over time.

The Mac is setup to use ISP routers and not the linksys router for DNS lookup.

Setup I need to have:
Static IP, using ISP DNS servers. Since router gets DNS servers from the ISP via DHCP, I can't hard-code the DNS servers into my static IP setup. Using DHCP in my ubuntu machine is not a solution. Buying a new router is not a solution. Everything worked in this configuration in 9.04 and was only broken by upgrading to 9.10. This problem was reported during testing by a number of members with no resolution. Please look into it now that 9.10 has gone mainstream.

This problem affects all browsers.

uname - a:
Linux yoda 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009 x86_64 GNU/Linux

ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:24:8c:80:1b:35
          inet addr:192.168.1.104 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::224:8cff:fe80:1b35/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:1116571 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2278713 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:161930719 (161.9 MB) TX bytes:3352896436 (3.3 GB)
          Interrupt:27 Base address:0x4000

/etc/resolv.conf (working configuration)
# Generated by NetworkManager
nameserver 68.87.76.182

/etc/nsswitch.conf
# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd: compat
group: compat
shadow: compat

hosts: files dns
#hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4
networks: files

protocols: db files
services: db files
ethers: db files
rpc: db files

netgroup: nis

ProblemType: Bug
Architecture: amd64
Date: Sat Oct 31 23:38:32 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: fglrx
Package: firefox-3.5 3.5.4+nobinonly-0ubuntu0.9.10.1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: firefox-3.5
Uname: Linux 2.6.31-14-generic x86_64

JLotspeich (jlotspeich34) wrote :
Micah Gersten (micahg) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 417757, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers