Firefox 3.5.3 has been slow to respone after upgrading to Ubuntu 9.10

Bug #456038 reported by Ferdaus on 2009-10-20
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
firefox-3.5 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.5

Browsing with Firefox 3.5.3 has become slow after I'd upgraded from Ubuntu 9.04 to Ubuntu 9.10. Even scrolling is slow compared to previous experience with versions 8.04; 8.10; 9.04

ProblemType: Bug
Architecture: i386
Date: Tue Oct 20 12:13:11 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: wl
Package: firefox 3.5.3+build1+nobinonly-0ubuntu4
PackageArchitecture: all
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.27-11.31-generic
SourcePackage: firefox-3.5
Uname: Linux 2.6.27-11-generic i686
XsessionErrors:
 (gnome-settings-daemon:5384): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:5510): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:5472): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gnome-panel:5470): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.2/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window
 (gdu-notification-daemon:5495): GduNotification-WARNING **: No notification area. Notification bubbles will not be displayed.

Ferdaus (ferdausalamin) wrote :
John Rood (akajfreak) wrote :

and I don't think this is just a firefox problem because synaptic has the same type of slowness for me now

nigo045 (nigo045) wrote :

solution :

in Firefox address bar:
about:config

and change the following lines like this :

browser.turbo.enabled: true

network.dns.disableIPv6: true

network.http.pipelining: true
network.http.proxy.pipelining: true
network.http.pipelining.maxrequests: 4

reboot firefox

Livebox slow firefox on Karmic

http://forum.ubuntu-fr.org/viewtopic.php?pid=3012639
http://forum.ubuntu-fr.org/viewtopic.php?pid=57437#p57437

Michael Hasenstein (hasenstein) wrote :

I'd like to add: I was using FF3.5 even before upgrading to 9.10. After the upgrade - and I see this on two systems - the AdBlocker add-on does not seem to work any more, or at least not fully, I now see lots of ads where there should not be any, even though the add-on is enabled and there are no error reports.

Also, DNS name resolution seems to take a very long time - but ONLY in Firefox, and I think in Epiphany as well (I just tried that browser and it was just as painful). A few minutes ago basically the same browser, FF 3.5.3 on Ubuntu 9.04, worked flawlessly.

Also strange: if I enter "about:" in the URL section Firefox reports itsels as version 1.9.1.3 (under the FF logo)!!! It does call itself 3.5.3 in all other places.

Michael Hasenstein (hasenstein) wrote :

EDIT (my last comment): The settings suggested by nigo045 solve the slow-DNS-response issue - great!

However, my Adblock Plus add-on still does not work, and that is very unlikely to be a problem of that add-on: 1st) it worked on the same version FF 3.5.3 before I upgraded Ubuntu, 2nd) it works (same version 1.1.1, same filter subscription) on FF 3.5.3 in Windows.

So something more is going on than just the network issue!

Micah Gersten (micahg) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 417757, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Michael Hasenstein (hasenstein) wrote :

EDIT-2: Hmm, my other machine (i.e. my other Ubuntu-inside-VMware system) does not have the issue with the add-on. Very peculiar. Maybe it IS my own problem, although it just worked an hour ago...

I don't think the duplicate status is correct. For example, this talks of slowness in scrolling - while the other bug is specifically about DNS lookups. I have this issue too, and the problem is with Firefox painting the screen (at least for me). For a few seconds Firefox goes into a "I will not update my screen" mode, where all my mouse clicks and key presses are registered and processed correctly, but the screen will not be updated. Then for a few seconds it's fine, and then a few seconds of frozen screen again. I'm on Kubuntu 9.10, and this happens both with Kwin compositing enabled and disabled. I have an Intel GM965/GL960 graphics card.

jf (j-email-fields) wrote :

browser.turbo.enabled is not in firefox fo me.
To add, navigate to about:config and right click , select New -> boolean .

Also, there are more comments at the top right of page on the Duplicate of bug link.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers