Ubuntu

Flash hangs on any cbc.ca/video site

Reported by George Farris on 2009-10-19
116
This bug affects 20 people
Affects Status Importance Assigned to Milestone
firefox-3.5 (Ubuntu)
Medium
Micah Gersten

Bug Description

Binary package hint: firefox-3.5

Flash does not work on the CBC site.

Navigate to http://www.cbc.ca/video scroll down a bit and choose any of the shows. The flash plays comes up but hangs. You can right click in the player window and see that it is flash but it doesn't play. This is a big site in Canada, not good.

This is the same in Jaunty and Karmic as of today 2009/10/19
Firefox 3.5 or in 9.04 Firefox 3.0 and flash version Mozilla, Firefox, SeaMonkey 10.0.32.18

Other sites such as Youtube and BBC seem to play.

ProblemType: Bug
Architecture: i386
Date: Mon Oct 19 14:54:38 2009
DistroRelease: Ubuntu 9.10
Package: firefox-3.5 3.5.3+build1+nobinonly-0ubuntu4
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: firefox-3.5
Uname: Linux 2.6.31-14-generic i686

George Farris (george-gmsys) wrote :
Evan Huus (eapache) wrote :

I can confirm this in Jaunty and Karmic 64-bit. Setting status to confirmed.

Changed in firefox-3.5 (Ubuntu):
status: New → Confirmed
Micah Gersten (micahg) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as Triaged and let them handle it from here. Thanks for taking the time to make Ubuntu better! Please report any other issues you may find.

Changed in firefox-3.5 (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Medium
status: Confirmed → Triaged
Jan Claeys (janc) wrote :

If you have any extensions installed, please try again without those enabled ('firefox -safe-mode' runs firefox without extensions)?

I have found that some extensions like NoScript implement a more strict "same origin policy" than most other browsers, and this breaks a lot of sites.

Or try with Midori or another webkit-based browser?

Daniel Robitaille (robitaille) wrote :

I have the same problem in Google Chrome. And using Flash 9 instead of Flash 10 also didn't make a difference.

Daniel Robitaille (robitaille) wrote :

I just tried it using Firefox 3.0.14 on an Ubuntu 8.04.3 system, using Flash 10, and the videos on that web site didn't play. Could it be that cbc.ca is blocking video access for people using OS not named Windows and OSX?

George Farris (george-gmsys) wrote :

I just tried all sorts of user agent strings with this and it doesn't make any difference.

These are what I tried:
"Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20091020 Ubuntu/9.10 (karmic) Firefox/3.5.3"

"Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3"

"Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1)"

None of them work on Ubuntu 9.10. Firefox on a Windows or a Mac machine does work.

Darcy Casselman (dscassel) wrote :

Confirmed using Midori and Firefox 3.5 on Ubuntu 9.10 amd64.

The flash "Uberplayer.swf" component starts. It just doesn't show a video. I'm inclined to call this a Flash problem, not a Firefox problem. Flash doesn't exactly "hang" as the volume indicator still works.

I sent a note to CBC via http://www.cbc.ca/contact/ and pointed them to this bug. I noted to them that other video sites (Such as ctv.ca -- a competitor ;-) works fine. I would suspect the problem is coding within their flash that has inadvertently become platform dependent. This will be one of the many benefits of HTML5 for these types of sites as there will be no need for flash player and all its oddball issues.

Funny -- I watch a fair number of videos at http://www.spacecast.com/ , but didn't notice when the CBC site broke. Guess I'm too geeky. My favorite CBC show is audio-only http://www.cbc.ca/spark/ :-)

Tarek Loubani (tareko) wrote :

This bug seems to have gone from bad to worse. Initially, I could at least see the flash site, and would not be able to see video played. Now, I don't see anything but black. I also contacted the CBC as Russell did.

For now, I use firefox via wine, and that works fine.

tarek : )

The folks at Spark gave me the name of Jeff Ulster as someone who might be in the right group to fix this. I've now sent him a message as well. Will report back (or maybe Jeff will on this site).

confirmed in Intrepid Ibex as well...

Kat (uniquegeek) wrote :

I see the control buttons, but the screen is black.

Have just upgraded to Ubuntu 9.04, forced install of Firefox 3.5, and even went forward with Adobe Flash 10.1 (instead of 10.0.xx), and it still doesn't work. I sent an email to CBC when it stopped working. I noticed it right away (a couple months ago) because I was in the middle of watching a new series I was into. When I had gone into my history, I noticed the URLs of the shows had changed too. Not sure if they were using "Uberplayer" before; regardless, that seems to be the issue now because all of the other flash on their site works for me.

I've tried disabling any add-ons, and even uninstalling them at one point, and that did not help at all.

I've just sent CBC a polite email too with the jist of "please make your content accessible and standardized, there is no reason for it not to be".

Tyson Whitehead (twhitehead) wrote :

Ran into this same problem. One of the show specific sites had the current episode embedded right into it though, and clicking on it worked, so I snagged the packets and (after quite a bit of mucking about) managed to figure out how to use flvstreamer with "http://www.cbc.ca/video" to view all the various shows.

It's a bit of a pain, but I don't see any other options until they fix it (maybe someone will script it all up nice like what I understand has been done for the BBC site). Anyway, here's the steps (you have to be in Canada for this to work)

1 - Right click on the video selector thumbnail under "http://www.cbc.ca/video" and copy the link (e.g., "javascript:CBC.APP.UberPlayer.playRelease('http://release.theplatform.com/content.select?pid=...")

2 - Paste the "http://release.theplatform.com/content.select?pid=..." bit in a new window (you only need up to the end of the pid)

3 - You will get an XML document that has a "<url>rtmp://cp37429.edgefcs.net/...<break>netstorage/....flv<url/> component in it

4 - Quickly run (you only have 5-10s before the url expires)

flvstreamer -y <PLAYPATH> -r <URL> -o <FILE>

where <PLAYPATH> is the bit after <break> minus the ".flv" extension from the url component, <URL> is the bit before the <break> from the url component, and <FILE> is whatever you want to save the stream as.

5 - Once it completes downloading, you can run

mplayer <FILE>

to watch it (or do whatever you do to watch .flv files).

The same is happening to me under 32-bit Ubuntu 9.10, Firefox 3.5.5 and Flash version 10.0.32.18.

Tyson, thanks, I'll be trying that. I'm no genius at this stuff, but would there be a way to script/automate that?

PaulNorth (pmsales) wrote :

It would not seem to be a technical problem at all....

I emailed CBC on behalf of us Linux users, and I got this reply.

"Dear Paul,

We have checked with our technical staff, and unfortunately, as you point out, the new Flash player we are installing does not work on Linux systems. However it
does work on almost all other systems, including Windows and Mac. The number of systems that could not see the video in our new player is likely around the 1%
or less range.

We are not in a position to develop any workaround that would prevent revenue from being generated when users watch video on cbc.ca. Funding for CBC from
the government of Canada has not been growing, and the funds from Parliament (less than $40 per Canadian taxpayer per year) only cover part of the Corporations
broadcasting operations. I'm sorry you did not get an earlier response from CBC."

Parker Bishop
Communication Assistant
CBC Audience Relations

So, this seems to mean that - as a matter of policy, they refuse to "develop any workaround" unless they can make money from it.

I sense the cold, grasping hand of our ideologically hysterical Conservative government in this.

Tarek Loubani (tareko) wrote :

Wow. This is in equal parts disappointing and infuriating.

Do we have any real idea what the incompatibility is? Perhaps if we offer a fix, that would save them the excuse of "we don't have time/money to fix it". In the meantime, I think the best way forward is to keep writing and to also try to come up with an easy-to-use workaround, such as with scriptmonkey.

tarek : )

Tarek Loubani (tareko) wrote :

Tyson: Does your system still work? When I try it, I don't get any full URLs that can be entered. I only get:

javascript:CBC.APP.UberPlayer.playRelease('1352350803');

Entering:

http://release.theplatform.com/content.select?pid=1352350803

gets an empty page with:

Media is not available

tarek : )

George Farris (george-gmsys) wrote :

Okay thats BS at best. $40 times even a conservation estimate of 15,000,000 tax payers is a LOT of money.
I guess it's time to mail some MP's

Can anyone with any pull get a story up on Slashdot?

So back to reality this is a large problem for the Linux desktop. New users try sites and it doesn't work.
The viewing of content is such a large part of whats happening that work on this is important.

I have tried to file a bug report with Adobe but as one can expect...nothing heard.

Die flash...die, die, die.

Anyone have any suggestions?

I think people should also contact the people at http://theplatform.com/contact/ as they may not even know there is a problem. I've tried to use http://www.rogersondemand.com/ which is advertised to use the same company, and have only seen advertisements (no programs).

It may be appropriate to carbon copy letters to MPs to the CRTC which is supposed to regulate interoperable standards by broadcasters. Part of the problem is that we're still waiting for HTML5 and the latest I heard is that the CODEC issue was never solved (IE: there wasn't an open interoperable common denominator set).

Tarek Loubani (tareko) wrote :

Here's a hack for now:

http://tarek.org/cbc

Please check out the source code and disseminate widely or suggest fixes:

http://tarek.org/cbc/index.phps

Also, I've attached the file here.

tarek : )

Tarek Loubani (tareko) wrote :

Please suggest patches and disseminate widely.

Thanks for the workaround, Tarek - that works fine. Could you please explain what the issue is?

Maybe the CBC is able to fix their site if they're told what to do. :)

Tarek Loubani (tareko) wrote :

The error appears to be in the java code that's wrapped around the player and the way that it's passing (or not passing) parameters to the player.

Incidentally, I think I know why the fix is a non-starter for the CBC: It appears to not honour the Canada-only region blocking, which they've obviously implemented in java/ JS before it gets to the flash player.

tarek : )

I would think fixing their code so that people would go directly to their site rather than through a wrapper would be a pretty high priority. There is now code circulating (here and likely other places now) that make it easy for less technical people to bypass the geo-blocking.

Maybe your specific fix is a non-starter, but fixing this and keeping their geo-blocking is likely quite easy.

Tarek Loubani (tareko) wrote :

Obviously agreed. Is somebody willing to contact CBC directly? I am happy to help them make their code work, so feel free to volunteer me.

tarek : )

Tarek Loubani (tareko) wrote :

p.s., I have already emailed stating the same thing previously.

Stephen Rasku (ubuntu-srasku) wrote :

Someone should call CBC audience relations. The number is 1-866-306-4636.

Just to add what to Stephen has stated:
The customer service line is available Monday to Friday from 9:00am to 5:00pm for all timezones. It is not open on statutory holidays.

Tarek, you did an awesome job!

I brought this up on the UbuntuForums if anyone cares to add to anything I said. http://ubuntuforums.org/showthread.php?t=1355461

Hopefully, this information can get to other people trying to use the cbc video website.

devere (devere15th) wrote :

Nice workaround Tarek!

While I still use Windows for office stuff, I enjoy my amd64 laptop much more knowing that I can use a 64 bit Adobe Flash for CBC, like I do for BBC, MSNBC, ABC and CTV through the Ubuntu partition.

In this respect, it is not just an o/s issue - it is also a chip issue

WayneBrady (b643142) wrote :

FWIW, someone posted a python script for watching videos from the CBC site on reddit.

http://www.reddit.com/r/linux/comments/akfx8/handy_script_for_linux_users_who_watch_the_cbc/

Tyson Whitehead (twhitehead) wrote :

Looks like there may be alternative solutions now, but in case anyone cares about an update on how to download them via flvstreamer (they changed some stuff after my previous post and I don't seem to be being emailed updates to this thread).

1- You have to get the feedPID. Goto http://www.cbc.ca/video and view the source (View -> Page Source in firefox). Scroll down a bit and you will see a line like so

var feedPID = "<a while bunch of alphanumeric garbage>"; // <some more alphanumeric garbage>

The bit in the quotes is the feedPID.

2- Then you have to query cbc.feeds.theplatform.com to get the URL that returns the player information for the show you want. To do this you construct the following URL

http://cbc.feeds.theplatform.com/ps/JSON/PortalService/2.2/getReleaseList
?PID=<feedPID>
&contentCustomField=show
&contentCustomField=seasonNumber
&contentCustomField=EpisodeNumber
&field=URL
&query=KeywordsSearch|<searchterms>
&query=ContentCustomText|seasonNumber|<seasonnumber>
&query=ContentCustomText|EpisodeNumber|<epsiodenumber>

where <feedPID> is replaced with the feedPID from above (without the quotes), <searchterms> is the comma separated list of words you want to search for (or you can use "&query=ContentCustomText|Show|<name>" if you know the name of the show), <seasonnumber> is the season number, <episodenumber> is the episode number, and everything is on one line.

3- This should uniquely locate your show and return you the URL in JSON format (it will be something like "http://release.theplatform.com/content.select?pid=<alphanumeric garbage>&UserName=Unknown&Embedded=True&Portal=All Content&Tracking=True").

4- Going to this URL, and it will return an XML document that has a "<url>...<break>...<url/> component to it (it will be something like "<url>rtmp://cp37429.edgefcs.net/ondemand/?auth=<alphanumeric garbage>&aifp=v0001&slist=netstorage<break>netstorage/<the name of the flv file></url>").

5 - Quickly run (you only have maybe up to 30s before the URL expires)

flvstreamer -y <PLAYPATH> -r <URL> -o <FILE>

where <PLAYPATH> is the bit after <break> minus the ".flv" extension from the url component, <URL> is the bit before the <break> from the url component, and <FILE> is whatever you want to save the stream as.

6 - Once it completes downloading, you can run

mplayer <FILE>

to watch it (or do whatever you do to watch .flv files).

PS: For what it is worth, there are actually a whole bunch of different items you can search on (that is what they query lines do) and information you can return (that is what the other lines do) in step 3. See the getReleaseList function and friends in the javascript running the CBC video sight at http://www.cbc.ca/video/js/CBCVideoFunctions.js for some more ideas.

Tyson Whitehead (twhitehead) wrote :

Here's a complete example. Say you missed the latest episode of the "The Hour" and wanted to watch it.

1- You go to http://www.cbc.ca/video, view the source to get the feedPID and surf around until you the other relevant information

feedPID=_DyE_l_gC9yXF9BvDQ4XNfcCVLS4PQij
searchterms=the,hour
season=6
episode=79

2- You construct the URL to query cbc.feeds.theplatform.com to return the other URL you need in JSON format

http://cbc.feeds.theplatform.com/ps/JSON/PortalService/2.2/getReleaseList?PID=_DyE_l_gC9yXF9BvDQ4XNfcCVLS4PQij&contentCustomField=show&contentCustomField=seasonNumber&contentCustomField=EpisodeNumber&field=URL&query=KeywordsSearch|the,hour&query=ContentCustomText|seasonNumber|6&query=ContentCustomText|EpisodeNumber|79

As an alternative, you can also query by the ID shown on the video link on CBC site. In this case it is javascript:CBC.APP.UberPlayer.playRelease('1386627743'), so the query URL would be

http://cbc.feeds.theplatform.com/ps/JSON/PortalService/2.2/getReleaseList?PID=_DyE_l_gC9yXF9BvDQ4XNfcCVLS4PQij&contentCustomField=show&contentCustomField=seasonNumber&contentCustomField=EpisodeNumber&field=URL&query=IDs|1386627743

3- Running either of these queries by going to the URL returns you the requested information (show, seasonNumber, EpisodeNumber, and URL) in JSON format. The URL is really the only important part here (I only included the rest to make sure that I was actually getting the show I wanted), and, in this case, it is

http://release.theplatform.com/content.select?pid=jA_D_kIw9UxRQYGjpeyVWwrjrwU4u2F4&UserName=Unknown&Embedded=True&Portal=All%20Content&Tracking=True

4- Going to this URL gets you the XML document containing the information you need for flvstreamer. Specifically

rtmp://cp37429.edgefcs.net/ondemand/?auth=daFata_dhbuazcYa_aRbrbUducsdld5bgbw-bluFLW-T-uko_JrnYzlCoAAy&aifp=v0001&slist=netstorage

and

netstorage/The_Hour-21_27_39-2010-01-14

5- Then quickly (before the link expires) run

flvstreamer -r 'rtmp://cp37429.edgefcs.net/ondemand/?auth=daFata_dhbuazcYa_aRbrbUducsdld5bgbw-bluFLW-T-uko_JrnYzlCoAAy&aifp=v0001&slist=netstorage' -y 'netstorage/The_Hour-21_27_39-2010-01-14' -o temp.flv

(note that the quotes are necessary to stop you shell from acting on the &s)

6- Once it completes, load "The_Hour-2009-12-01.flv" file up in your video player to watch it.

lunomad (damon-metapaso) wrote :

Thanks Tarek. You rock.

danguy (dans-spam) wrote :

I've been using this bookmarklet for a while. It takes the video you are tying to watch at http://www.cbc.ca/video and plays it inside the Dragons' Den player. (A few other CBC show sub-sites can work as well.) Steps to use:

1) Create a bookmark for

javascript:(function(){var%20h=window.location.hash;window.location='http://www.cbc.ca/dragonsden/video.html?'+h.substr(h.lastIndexOf('/')+1)})()

2) Go to http://www.cbc.ca/video and click on a video to watch. The page will scroll up, the location fragment will change, and the displayed metadata will update, bus the video will not play.

3) Activate the bookmarklet. You will be redirected to the Dragons' Den video website.

4) Click the play button inside the Dragon's Den player. Your chosen video will play.

Hopefully this workaround is helpful to others.

Darcy Parks (darcy-darcyparks) wrote :

danguy, your bookmarklet is great!

mgl (mgleahy) wrote :

This same problem seems to have struck GlobalTV.com. Check out http://www.globaltv.com/entertainment/videos/index.html - if you try to play any video, the same sort of issue that CBC.ca occurs. Would there be a workaround similar to Tarek's php script that would solve this?

Daniel Robitaille (robitaille) wrote :

mgl, the only workaround I found was, in Ubuntu Lucid, to install wine 1.2 + windows's firefox 3.5 + windows's flash 10. As long as you make sure that graphics acceleration is turned off in that version of Flash for Windows, videos on both Global and CBC work fine for me. And the quality is surprisingly good for an wine process, even on this underpowered 5-year-old laptop.

Global used to work fine in Ubuntu in native mode, but they semi-recently changed the way they present ads, and that's what seems to have broken it.

George Farris (george-gmsys) wrote :

Okay this problem seems to be reaching more sites. This is going to become a show stopper for a lot of people using Ubuntu and Linux in general unless we (and I'm sorry I don't include me in that, I'm not that smart:-))

Can we elevate this bug to an high or urgent level please. We just can't have web content not work in this day and age.

Thanks for considering this.

PC-load_letter (m-cohomology) wrote :

This is confirmed on Karmic both 64, and 32bit systems, running Firefox, Chromium and Opera.
This problem may be a deal breaker to a lot of people, and it definitely screws up the experience for someone like me who uses Ubuntu exclusively.

I concur the status should be moved to high.

Christopher (soft-kristal) wrote :

For what it's worth, you can also keep a tab open with this URL and just add the clip ID after the =. It works for other CBC clips as well, but you have to change the =News bit.

http://www.cbc.ca/video/player.html?category=News&clipid=

It bugs me as well, and undermines the credibility of the browser, even if it's another example of webmasters ignoring the growing popularity of Ubuntu and other Linux distros.

I also have Firefox in Wine, where there are no issues at all.

Anastasia (galoobglaz) wrote :

Thank you Tarek for identifying the source of this problem. Danguy, your bookmarklet worked for me as well. I can watch CBC videos now. Is it possible to create similar workaround for other cites that dont work. GlobalTV is the one I am particularly interested in.
It really pisses me off that CBC and GlobalTV would be so ignorant about the Linux community. I hope that they fix this issue soon. Meanwhile if someone finds an easier workaround for GlobalTV, please share it.
I agree that this is a real show stopper ... specially for new users.

I assume that this is the wrapper: www.cbc.ca/video/swf/UberPlayer.swf

I don't know much about flash. I did a swfdump (from swftools) on it. I got a set of warnings:

Warning: Invalid jump instruction "jump" from 60 to 143 (120)
Warning: Invalid jump instruction "jump" from 118 to 128 (125)
Warning: Invalid jump instruction "jump" from 152 to 182 (179)
Warning: Invalid jump instruction "jump" from 48 to 58 (55)
Warning: Invalid jump instruction "jump" from 39 to 111 (83)
Warning: Invalid jump instruction "jump" from 94 to 205 (192)
Warning: Invalid jump instruction "jump" from 642 to 756 (744)
Warning: Invalid jump instruction "jump" from 41 to 192 (171)
Warning: Invalid jump instruction "jump" from 91 to 100 (97)
Warning: Invalid jump instruction "jump" from 237 to 360 (353)
Warning: Invalid jump instruction "jump" from 12 to 133 (125)
Warning: Invalid jump instruction "jump" from 131 to 148 (142)
Warning: Invalid jump instruction "jump" from 163 to 176 (174)

I wonder if this is a bug in swfsdump or UberPlayer.

Does someone have a tool to debug Flash code?

I finally got Tyson's method using flvstreamer to work (message #34). The trick is to cut and paste
really fast. It would be handy to have a script for this.

paulfrottawa (paul-belair) wrote :

I had this problem fixed once with freebsd. The thing I did in that install was some settings in a file. Witch one I can't remember.

It was when I install gnome2-fifth-toe and one of the compile messages while it compiled said to do a certain thing. I see lots of these messages some times and cut and copied the ones I see. Well it work flawlessly that build.

Now if I can just save my compile info and read through it to find out witch port needs the fix.

paulfrottawa (paul-belair) wrote :

PS: I dought I'll remember my password here. I don't use numbers normally and only use 8 digits for my bank account.

paulfrottawa (paul-belair) wrote :

PS: I think it would be easier if I just picket CBC to fix their flash for the Free operating systems. Why is Mac and Microsoft so flawless.

I'll have you all note while posters where complaining to adobe about flash I was complaining to ctv, cbc, and anyone who offered flash to use something different or fix it.

I am running Lucid Lynx on my desktop and it's very frustrating to not be able to just click and watch a CBC video.
However, when I click on a CBC video on my netbook running Jolicloud (a netbook distro based on Ubuntu Netbook Remix), it displays perfectly. What's the difference I wonder? I'm running Firefox in both distro's with the same add-ons installed.

Tarek Loubani (tareko) wrote :

Really? If Jolicloud does it, could we test against other distros like redhat, gentoo, etc? I suspect this has to do with the java VM. Could you verify the versions of that?

tarek : )

I don't have Java installed at all in Jolicloud on my netbook. Guess I don't need it (yet) for what I do or where I go. I have it installed on my desktop computer running Ubuntu Lucid Lynx.

Tarek Loubani (tareko) wrote :

Hmm. Interesting. I think it means that my theory that the problem is due to java (and not, say java script or whatnot) is probably inaccurate. I will try to install Jolicloud on a virtual machine and see if that flies.

Are there any other distributions people can test? Redhat? etc?

tarek : )

Stephen Rasku (ubuntu-srasku) wrote :

It hangs for Firefox 3.0.2 on Red Hat/CentOS 4.7. I don't know how useful that is since it's an old version of both the OS and the browser.

Evan Huus (eapache) wrote :

Given that this has been confirmed on many different browsers on both 32 and 64 bit systems, I think it's pretty clear that this is an issue with flash, and thus not something we can really hope to fix ourselves.

Has anyone been in contact with adobe about this?

Tarek Loubani (tareko) wrote :

Actually, it's pretty clear that it's not a flash problem, or otherwise the fix wouldn't work. This is a problem in the wrapping html / javascript / java, which is why it would be nice to isolate the issue. More specifically, I think the problem code has to do with geolocating the host, since the fix also disregards those locks. However, on that note, Reinhard: which version of flash runs on jolicloud? From the website I can't tell.

I think it's obvious that CBC needs to be involved to make a definitive (and probably quite easy on their part) fix. Until then, there's nothing wrong with figuring out why one linux distro works when others don't.

tarek : )

Personally, if Flash had worked from the get go (I tried both Debian and Solaris 10 and did comment to the CBC),
I probably would not have looked so hard to find a way to watch the videos without Flash. Thanks to Tyson, I was
finally able to get flvstreamer to work. See messages #34 and #45. I have since written my own crude bash script.

Tarek Loubani (tareko) wrote :

To reiterate one last time: This is *NOT* a flash problem in any sense. The Flash player works fine once the parameters are passed to it. This is a problem of the surrounding programming that passes the parameters. Most specifically, the programming that has to do with whether you are geographically located in Canada (I think). This is why the bypass I wrote works - it passes the one changing parameter (clip ID) without any other garbage. Initially, I thought the problem had to do with the geolocation code being java-based, but Reinhard Fehling's report of a system with no Java where it works makes that very unlikely.

The new most likely candidate is poorly coded javascript.

tarek : )

Tarek:
I checked my netbook Firefox 3.6.3 Add-ons in Jolicloud and I'm running Shockwave Flash 10.1 r53 and CBC videos all display perfectly :)
I checked with a java tester site to make sure and I definitely don't have Java installed.

In my desktop Lucid Lynx Firefox 3.6.3 Add-ons I have Shockwave Flash 10.0 r45 installed. Running Java 1.6.0_18. CBC videos don't work :(

Tarek Loubani (tareko) wrote :

Eureka!

A few things to say:

1. Howard Eisenberger: I apologize. It *is* flash

2. CBC Video works with 10.1 r53! I am using it even in x64 (probably will be unstable). Installation instructions (I modified for the most recent RC4):

http://www.ubuntugeek.com/how-to-install-adobe-flash-player-10-1-beta-in-ubuntu.html

3. Bonus: Global works with 19.1 r53

Is this a total win?

tarek : )

Apologize to me? What for? It's a double whammy as far as the CBC rtmp videos go,
since they now work with Adobe Flashplayer (I'll take your word for it) as well as without
the Flashplayer using flvstreamer.

Do we have any sense when the new 10.1 r53 will be out of beta, and able to become standard with Ubuntu/etc? It is one thing for us geeks to know how to watch CBC videos. It is another to allow it to work for my mother as well (I don't want custom stuff on her machine, to make administering from remote easier).

Jack D (jdonohue654-ubuntu) wrote :

FWIW, the url http://www.cbc.ca/video now works for me. It didn't for quite some time. Not sure when it started working ... I just happened to re-try tonight.

I'm running a fully up-to-date Lucid with:

firefox 3.6.3+nobinonly-0ubuntu4
flashplugin-installer 10.1.53.64ubuntu0.10.04.1
flashplugin-nonfree 10.1.53.64ubuntu0.10.04.1

Evan Huus (eapache) wrote :

I'm going to set this to fixed, since Flash 10.1 had earlier been confirmed to fix the problem, and seems to have done so now that it is released.

Changed in firefox-3.5 (Ubuntu):
status: Triaged → Fix Released
cfriedt (chrisfriedt) wrote :

Don't feel too bad Ubuntu'ers.

Their site doesn't work on Mac OS X (Chrome,Safari,Firefox) either with Adobe Flash plugin 10.2.159.1

The only moment when the CBC video site had ever worked for me on my relatively new MBP was the day that I bought it, before any system updates were installed.

The CBC should really just hire somebody to redesign their site who has a clue.

Tarek Loubani (tareko) wrote :

The problem is sorted in Ubuntu since ~2010 May.

But of course I agree it would be nice to move from Flash to something more open.

Obviously, Ubuntu is installable on your mac.

tarek : )

Ian Ward (ian-excess) wrote :

This problem has returned.

adobe flash version: 11.2.202 on ubuntu 10.04 and 12.04 don't work with CBC videos. For some reason the bundled version of flash that comes with google chrome (have to disable the system plugin) gets a little further even though it's the same version (11.2.202)

However, an older flash version 11.1.102 on ubuntu 11.10 *does* work. Now I have to figure out how to downgrade my other flash versions.

Ian Ward (ian-excess) wrote :

Sorry for the noise. Seems to be working again in all versions. Maybe a glitch on their end?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers