firefox gives "Couldn't load XPCOM." and does not start

Bug #436190 reported by Ernst on 2009-09-24
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
firefox-3.5 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.5

I just upgraded my Jaunty 32-bit to Karmic using update-manager -d.
Now, I want to start firefox. If I type firefox in the terminal, I get:

$firefox
Couldn't load XPCOM.

And I get back to the command line.
I really don't know what to do to solve this, did some upgrade go wrong?

ProblemType: Bug
Architecture: i386
Date: Thu Sep 24 23:14:31 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: firefox 3.5.3+build1+nobinonly-0ubuntu2
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
SourcePackage: firefox-3.5
Uname: Linux 2.6.31-10-generic i686

Ernst (ernst-blaauw) wrote :
Makoto Kato (makoto-kt) wrote :

I hit same problem on AMD64 after upgrading 9.10, but, when I remove libnss3-0d package, 3.5 package works fine

Ernst (ernst-blaauw) wrote :

As I had to reinstall Karmic from scratch (resizing of my system partition failed), I can't conform this. However, I do remember I installed this package for compiling a program ( I can't remember which program it was). So, I think this was indeed my problem. Thanks!

Denny de la Haye (dennymeta) wrote :

I've just been hit by this today, I don't recall upgrading Firefox today but I presume I must have. I don't have the libnss3-0d package installed, so it's not that.

I did have Firefox open and it stopped opening links from external applications (Xchat & Evolution) in new tabs, so I closed it and attempted to start it again to see if that would help - at this point it didn't re-load. When I tried to run it from the command line I got this:
denny@serenity ~ $ firefox-3.5
Couldn't load XPCOM.
denny@serenity ~ $

Any suggestions, or requests for more info? I can still run firefox (3.0) by the way, and the rest of my system seems fine so far.

Denny de la Haye (dennymeta) wrote :

I found another bug report suggesting this is something to do with xulrunner, and suggesting that I check in /etc/gre.d for old config files.

denny@serenity ~ $ ls -lh /etc/gre.d
total 16K
-rwxr-xr-x 1 root root 78 2009-12-16 01:41 1.9.0.16.system.conf
-rw-r--r-- 1 root root 76 2009-12-16 00:15 1.9.1.6.system.conf
-rw-r--r-- 1 root root 142 2008-08-25 13:19 libxul0d.conf
-rw-r--r-- 1 root root 142 2008-08-25 13:14 xulrunner.conf
denny@serenity ~ $ xulrunner --version
Mozilla XULRunner 1.9.0.16 - 2009121601
denny@serenity ~ $

So maybe it should be using xulrunner 1.9.1 but isn't for some reason? I'm way out of my depth here :) Moving either config file aside didn't help.

Alexx Roche (ubuntu-one-alexx) wrote :

me too:
# cat /etc/issue
Ubuntu 9.10 \n \l
$ firefox %u -safe-mode
Couldn't load XPCOM.
$ firefox-3.5 %u -safe-mode
Couldn't load XPCOM.
# apt-get update && apt-get upgrade -y
<snip>

Setting up xserver-xorg-core (2:1.6.4-2ubuntu4.3) ...

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for python-support ...
Errors were encountered while processing:
 xulrunner-1.9.1
 xulrunner-1.9.1-gnome-support
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ uname -a
uname -a
Linux laptop 2.6.31-20-generic #58-Ubuntu SMP Fri Mar 12 05:23:09 UTC 2010 i686 GNU/Linux

Chrome still works.. for now.

Alexx Roche (ubuntu-one-alexx) wrote :

#I found a fix:
$ sudo aptitude remove xulrunner-1.9.1

# Then I said "n" (no) to the first three proposed solutions from aptitude, (no idea if they would have worked) and eventually was presented with

Downgrade the following packages:
xulrunner-1.9.1 [1.9.1.9+nobinonly-0ubuntu0.9.10.1 (karmic-updates,
karmic-security, now) -> 1.9.1.3+build1+nobinonly-0ubuntu6 (karmic)]

Score is -9772

Accept this solution? [Y/n/q/?] y
The following packages will be DOWNGRADED:
  xulrunner-1.9.1
The following packages will be REMOVED:
  firefox-3.5-gnome-support{a} firefox-gnome-support{a}
  xulrunner-1.9.1-gnome-support{a}
0 packages upgraded, 0 newly installed, 1 downgraded, 3 to remove and 0 not upgraded.
Need to get 7,986kB of archives. After unpacking 524kB will be freed.
Do you want to continue? [Y/n/?] y

and now firefox-3.5 (.9) works again. (Still, this isn't good news for Ubuntu or normal users. I still have no idea which update put my install in this position, or if it was something that I did.)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers