resizing "Organize Bookmarks" window returns you to the top of the bookmark list

Bug #375205 reported by Dave
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Invalid
Undecided
Unassigned
One Hundred Papercuts
Low
Unassigned
firefox-3.0 (Ubuntu)
Undecided
Unassigned
firefox-3.5 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.0

Summary: resizing "Organize Bookmarks" window returns you to the top of the bookmark list

Steps to reproduce:
1) Open "Organize Bookmarks"
2) Click on "Bookmarks Menu" and scroll to the bottom of the list of bookmarks, but DO NOT select a bookmark.
3) Resize window to "get a better view".

Actual result:
The list of bookmarks jumps back to the top.

Expected result:
The list of bookmarks should remain at the position it was in prior to resizing the window.

Revision history for this message
Bruno Girin (brunogirin) wrote :

Reproduced the bug in Jaunty with firefox-3.0 package version 3.0.10+nobinonly-0ubuntu0.9.04.1

description: updated
Changed in firefox-3.0 (Ubuntu):
status: New → Confirmed
Martin Albisetti (beuno)
Changed in hundredpapercuts:
status: New → Confirmed
Changed in hundredpapercuts:
milestone: none → round-9
Revision history for this message
Andrew (and471) wrote :

Bruno or Dave, can you reproduce this behaviour in firefox-3.5

I cannot seem to get the behaviour you say and so if I am correct, this bug has been fixed.

Revision history for this message
Vish (vish) wrote :

Unable to reproduce this in firefox3.5
This seems to have been solved

Revision history for this message
Michael Rooney (mrooney) wrote :

Since firefox 3.5 is the default in Karmic now, I think this classifies as fixed!

Changed in hundredpapercuts:
status: Confirmed → Fix Released
Revision history for this message
Michael Rooney (mrooney) wrote :

I think it is appropriate to change the firefox-3.0 task to a generic firefox task and call that fixed as well.

affects: firefox-3.0 (Ubuntu) → firefox (Ubuntu)
Changed in firefox (Ubuntu):
status: Confirmed → Fix Released
Vish (vish)
Changed in hundredpapercuts:
milestone: round-9 → round-5
Revision history for this message
Bruno Girin (brunogirin) wrote :

Sorry guys but I can definitely reproduce it in 3.5, version 3.5.2+nobinonly-0ubuntu0.9.04.1 so it doesn't look fixed for me.

Revision history for this message
Micah Gersten (micahg) wrote :

@Bruno Girin

Could you please try with a new profile? I cannot reproduce this with 3.5.2 on Jaunty.

affects: firefox (Ubuntu) → firefox-3.5 (Ubuntu)
Changed in firefox-3.5 (Ubuntu):
status: Fix Released → Incomplete
Changed in firefox-3.0 (Ubuntu):
status: New → Confirmed
Revision history for this message
Bruno Girin (brunogirin) wrote :

@Micah Gersten

I just tried with a new profile and I can definitely reproduce it.

Revision history for this message
Bruno Girin (brunogirin) wrote :

I just recorded a short video showing the bug in action. It's a 1.9MB Ogg file so should be playable without any funky codec installed.

Revision history for this message
Micah Gersten (micahg) wrote :

I'm resetting FF3.5 to new unless someone else can confirm on FF3.5. I will try to see if upstream has anything for this later. If someone else has time, maybe you can check upstream for this issue.

Changed in firefox-3.5 (Ubuntu):
status: Incomplete → New
Revision history for this message
John Vivirito (gnomefreak) wrote :

Please locate this bug upstream if you are still seeing this problem in 3.5 and leave the link to upstream bug on this bug so we can track it, however this seems to have been fixed in 3.5 by everyone but 1 or 2 users.

as per https://bugs.launchpad.net/ubuntu/+source/firefox-3.5/+bug/375205/comments/5
We dont have a general firefox package, the package "firefox" is firefox-2.0 in Launchpad

Revision history for this message
Michael Rooney (mrooney) wrote : Re: [Bug 375205] Re: resizing "Organize Bookmarks" window returns you to the top of the bookmark list

I did some testing and it seems like Firefox 3.5 has improved the
behavior a bit but not fixed the issue in all cases. This might be why
some people are saying it is fixed and other people are finding some
of the resizing cases that still cause scrolling to "jump".

Revision history for this message
David Siegel (djsiegel-deactivatedaccount) wrote :

I just tested this in Karmic and the behavior described is still present.

Changed in hundredpapercuts:
status: Fix Released → Triaged
Revision history for this message
Dave (david-ayres3) wrote :

I can also confirm that this still exists in FF 3.5.4 in Karmic.

Changed in hundredpapercuts:
milestone: round-5 → none
status: Triaged → New
Revision history for this message
Vish (vish) wrote :

This problem seems fixed in Firefox 3.6 on Lucid.

I was earlier able to reproduce the bug with the steps mentioned in the description , now this does not happen in firefox 3.6

The view does not change. Marking as fix released as Lucid will include Firefox 3.6 by default

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Fix Released
Revision history for this message
dino99 (9d9) wrote :

This is no more a supported version

Changed in firefox-3.5 (Ubuntu):
status: New → Invalid
Changed in firefox-3.0 (Ubuntu):
status: Confirmed → Invalid
Changed in firefox:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers