firefox-3.5 crashed and terminate automatically

Bug #366405 reported by Davide P. on 2009-04-24
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox-3.5 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.5

Sometimes Firefox terminate also if it is in background with only gmail opened. On restart apport doesn't recognize the crash. I don't know how I can reproduce this bug.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/lib/firefox-3.5b4pre/firefox-3.5
Package: firefox-3.5 3.5~b4~hg20090330r24021+nobinonly-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.5
Uname: Linux 2.6.28-11-generic i686

Davide P. (scaltro) wrote :
Micah Gersten (micahg) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report didn't yield the required information. Please go ahead and submit a new crash report if it crashes again with the latest available version of the package. Thanks in advance for your cooperation and understanding.

Changed in firefox-3.5 (Ubuntu):
status: New → Invalid
Davide P. (scaltro) wrote :

Tell me what log or other file I have to attach.
I've encountered this problem also today, with the last Firefox 3.5 build 20090701012740.
When Firefox crash in that way the OS doesn't regognize it as a crash and doesn't start "Report problem..." as usual.
If I try to run "Report a problem..." manually it doesn't start.

Architecture: i386
DistroRelease: Ubuntu 9.04
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
Uname: Linux 2.6.28-13-generic i686
UserGroups: adm admin audio cdrom dialout dip fuse lpadmin netdev plugdev pulse pulse-access pulse-rt sambashare scanner vboxusers video

Micah Gersten (micahg) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
1. Is this reproducible?
2. If so, what specific steps should we take to recreate this bug? Be as detailed as possible.
This will help us to find and resolve the problem.

Changed in firefox-3.5 (Ubuntu):
status: Invalid → Incomplete
Davide P. (scaltro) wrote :

1. As I wrote at the beginning, this bug is not reproducible. It happens when I'm browsing, but also when I'm not: If I keep my laptop on all the night with my browser opened, usaually when I came back in the morning Firefox doesn't be running anymore...

2. If only I knew...

Micah Gersten (micahg) wrote :

Is this still happening with Firefox 3.5.2?

Davide P. (scaltro) wrote :

No, it seems that has been solved in the last firefox-3.5_3.5.2+nobinonly-0ubuntu0.9.04.1_i386.deb.

Micah Gersten (micahg) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in firefox-3.5 (Ubuntu):
status: Incomplete → Invalid
Davide P. (scaltro) wrote :

It has just crashed. I've runned it through gdm with this parameter:
(~$ firefox-3.5 -g --g-fatal-warnings--g-fatal-warnings -no-remote)
and this was the results:

/usr/bin/gdb /usr/lib/firefox-3.5.2/firefox-3.5 -x /tmp/mozargs.VkkPYe
...
(gdb)
(gdb) Runtime destroyed, with 264 leaked EventObjects.
Runtime destroyed, with 272 leaked EventObjects.
firefox-3.5: Fatal IO error 10 (No child processes) on X server :0.0.

(gdb)
...

Florent Mertens (givre) wrote :

I also get this crash sometimes.

The only evidence of the crash i can get in all log files is :

firefox-bin: Fatal IO error 10 (No child processes) on X server :0.0.

in .xsession-errors

Changed in firefox-3.5 (Ubuntu):
status: Invalid → Confirmed
Micah Gersten (micahg) wrote :

@Florent Mertens
This is a very old bug, please file a new apport crash report.
You can enable apport for one instance like this:
sudo service apport start force_start=1

If that doesn't work, please just file a new bug with the command ubuntu-bug firefox

Changed in firefox-3.5 (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers