[MASTER] installing firefox pulls in ubufox and all gnome depends through apturl

Bug #365965 reported by Chris Puttick on 2009-04-24
60
This bug affects 7 people
Affects Status Importance Assigned to Milestone
firefox-3.5 (Ubuntu)
Medium
Unassigned
ubufox (Ubuntu)
Medium
Alexander Sack

Bug Description

Binary package hint: firefox-3.5

Or very, very weird :)

With Kubuntu Jaunty with Firefox 3 already installed, installing Firefox 3.5 gets

The following NEW packages will be installed
  apturl firefox-3.5 firefox-3.5-branding gnome-app-install libcairo-perl
  libglib-perl libgnome2-canvas-perl libgnome2-perl libgnome2-vfs-perl
  libgtk2-perl libgtkhtml2-0 libvte-common libvte9 python-gst0.10
  python-gtkhtml2 python-launchpad-integration python-sexy python-vte
  software-properties-gtk synaptic ubufox xulrunner-1.9.1

Surely not all of these are needed? Like synaptic, for example...

Interesting twist on this bug is that Firefox 3.5 recommends Firefox 3.0 through ubufox since ubufox on Jaunty won't work with FF3.5

WORKAROUND:
sudo apt-get --no-install-recommends install firefox-3.5

Micah Gersten (micahg) wrote :

Problem is ubufox, not FF3.5

ubufox depends on apturl and apturl depends on synaptic

The question is, is this necessary?

affects: firefox-3.5 (Ubuntu) → ubufox (Ubuntu)
summary: - FF3.5 dependencies wrong
+ ubufox depends on synaptic through another package

I recall this discussion when we added ubufox into Ubuntu. As i recall apturl is needed to prompt you for addons.
Example:
Go to youtube.som without flash and ubufox will prompt you to install it.
In the example ubufox and apturl are communicating.
I will see what can be done but as far i know we can not remove apturl from depends on ubufox.Now i cant recall but i though ubufox was removed from depends after checking it is not depend but suggestion see the following:
gnomefreak@Development:~$ depends firefox-3.0
firefox-3.0
  Depends: fontconfig
  Depends: psmisc
  Depends: debianutils
  Depends: xulrunner-1.9
  Depends: libatk1.0-0
  Depends: libc6
  Depends: libcairo2
  Depends: libfontconfig1
  Depends: libfreetype6
  Depends: libgcc1
  Depends: libglib2.0-0
  Depends: libgtk2.0-0
  Depends: libnspr4-0d
  Depends: libpango1.0-0
  Depends: libstdc++6
 |Depends: firefox-3.0-branding
  Depends: abrowser-3.0-branding
  Suggests: ubufox
  Suggests: firefox-3.0-gnome-support
  Suggests: latex-xft-fonts
  Suggests: libthai0
  Conflicts: firefox
  Conflicts: firefox-granparadiso
  Conflicts: firefox-libthai
  Conflicts: firefox-trunk
  Replaces: firefox
  Replaces: firefox-granparadiso
  Replaces: firefox-libthai
    firefox-3.0
  Replaces: firefox-trunk

Since it suggests it and not recommends it. Recommends are installed by default now and suggest are still user choice. I am closing this since it is not a bug. It works as expected here.

John Vivirito (gnomefreak) wrote :

Ah i fount the problem it is a recommend in 3.5 not sure why but i will have it moved to suggests if possible on next upload,
gnomefreak@Development:~$ depends firefox-3.5
firefox-3.5
  Depends: fontconfig
  Depends: psmisc
  Depends: debianutils
  Depends: xulrunner-1.9.1
  Depends: libasound2
  Depends: libatk1.0-0
  Depends: libc6
  Depends: libcairo2
  Depends: libfontconfig1
  Depends: libfreetype6
  Depends: libgcc1
  Depends: libglib2.0-0
  Depends: libgtk2.0-0
  Depends: libnspr4-0d
  Depends: libpango1.0-0
  Depends: libstdc++6
 |Depends: firefox-3.5-branding
  Depends: abrowser-3.5-branding
  Suggests: firefox-3.5-gnome-support
  Suggests: latex-xft-fonts
  Suggests: libthai0
  Recommends: ubufox
  Conflicts: firefox-3.1
  Replaces: firefox-3.1
    firefox-3.5

It is the same for 3.6:
gnomefreak@Development:~$ depends firefox-3.5
firefox-3.5
  Depends: fontconfig
  Depends: psmisc
  Depends: debianutils
  Depends: xulrunner-1.9.1
  Depends: libasound2
  Depends: libatk1.0-0
  Depends: libc6
  Depends: libcairo2
  Depends: libfontconfig1
  Depends: libfreetype6
  Depends: libgcc1
  Depends: libglib2.0-0
  Depends: libgtk2.0-0
  Depends: libnspr4-0d
  Depends: libpango1.0-0
  Depends: libstdc++6
 |Depends: firefox-3.5-branding
  Depends: abrowser-3.5-branding
  Suggests: firefox-3.5-gnome-support
  Suggests: latex-xft-fonts
  Suggests: libthai0
  Recommends: ubufox
  Conflicts: firefox-3.1
  Replaces: firefox-3.1
    firefox-3.5

summary: - ubufox depends on synaptic through another package
+ Firefox3.5 recommends ubufox but should suggest ubufox

We have all info needed to fix this.

Changed in ubufox (Ubuntu):
status: New → Triaged
Peabody (kyle-smitz) wrote :

Firefox also doesn't need all the GTK libraries to run. I'm running Firefox 3.5 from their binary distribution along with flash and I have no GTK libraries installed on my Kubuntu system. I would appreciate if the repack excludes all the GTK libraries that are unnecessary to run Firefox 3.5. If they are needed for ubufox or whatever make them dependent on that and not Firefox. I really don't like installing from binary distributions when the software is available on the repository, but I will not install gtk.

Alexander Sack (asac) wrote :

i think this is a duplicate on an old bug. for me it doesnt feel right to not recommend what we acutally recommend.

Alexander Sack (asac) wrote :

Peabody: please run your special firefox without gtk lib depends like this:

strace -eopen -f /path/to/firefox 2>&1 > /tmp/ffox.log.txt

and after using it for a moment, stop it and attach that ffox.log.txt to this bug. Thanks!

Alexander Sack (asac) wrote :

alternatively look at the output of ldd /path/to/firefox/libxul.so

Chris Puttick (cputtick) wrote :
Download full text (5.5 KiB)

Ok definitively, absolutely unquestionably a bug. Or a Gnome fan conspiracy. Or maybe an unholy alliance between the Gnome fans and the Konqueror developers...

Look, fresh untampered, updated install of Kubuntu 9.04.

sudo apt-get install firefox
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  firefox-3.0 firefox-3.0-branding libidl0 libstartup-notification0
  xulrunner-1.9
Suggested packages:
  ubufox firefox-3.0-gnome-support latex-xft-fonts
The following NEW packages will be installed
  firefox firefox-3.0 firefox-3.0-branding libidl0 libstartup-notification0
  xulrunner-1.9
0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 8804kB of archives.
After this operation, 25.2MB of additional disk space will be used.

sudo apt-get install firefox-3.5
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  apturl docbook-xml esound-clients esound-common firefox firefox-3.0
  firefox-3.0-branding firefox-3.5-branding gamin gconf2 gconf2-common gksu
  gnome-app-install gnome-icon-theme gnome-keyring gnome-mime-data gnome-mount
  gvfs gvfs-backends libaudiofile0 libavahi-glib1 libbonobo2-0
  libbonobo2-common libbonoboui2-0 libbonoboui2-common libcairo-perl
  libcanberra0 libcdio-cdda0 libcdio-paranoia0 libcdio7 libcroco3 libesd-alsa0
  libgail-common libgail18 libgamin0 libgconf2-4 libgcr0 libgksu2-0
  libglade2-0 libglib-perl libgnome-keyring0 libgnome2-0 libgnome2-canvas-perl
  libgnome2-common libgnome2-perl libgnome2-vfs-perl libgnomecanvas2-0
  libgnomecanvas2-common libgnomeui-0 libgnomeui-common libgnomevfs2-0
  libgnomevfs2-common libgnomevfs2-extra libgp11-0 libgsf-1-114
  libgsf-1-common libgtk2-perl libgtkhtml2-0 libgtop2-7 libgtop2-common
  libgvfscommon0 libidl0 liblaunchpad-integration1 libnotify1 liborbit2
  libpam-gnome-keyring libpolkit-gnome0 libproxy0 librsvg2-2 librsvg2-common
  libscrollkeeper0 libsexy2 libsoup-gnome2.4-1 libsoup2.4-1
  libstartup-notification0 libtdb1 libvte-common libvte9 libwnck-common
  libwnck22 libxres1 notification-daemon policykit-gnome python-cairo
  python-gconf python-glade2 python-gst0.10 python-gtk2 python-gtkhtml2
  python-launchpad-integration python-pyorbit python-sexy python-vte
  scrollkeeper sgml-data software-properties-gtk synaptic ubufox xulrunner-1.9
  xulrunner-1.9.1
Suggested packages:
  docbook docbook-dsssl docbook-xsl docbook-defguide firefox-3.0-gnome-support
  latex-xft-fonts firefox-3.5-gnome-support cryptsetup libbonobo2-bin
  libcanberra-gtk0 esound desktop-base libgnomevfs2-bin libgtk2-perl-doc
  librsvg2-bin python-gconf-dbg python-gtk2-doc python-gst0.10-dbg
  python-numpy python-gnome2-extras-doc python-launchpad-integration-dbg
  python-pyorbit-d...

Read more...

Micah Gersten (micahg) on 2009-07-08
summary: - Firefox3.5 recommends ubufox but should suggest ubufox
+ [MASTER] Firefox3.5 recommends ubufox but should suggest ubufox
tags: added: metabug
summary: - [MASTER] Firefox3.5 recommends ubufox but should suggest ubufox
+ Firefox3.5 recommends ubufox but should suggest ubufox
summary: - Firefox3.5 recommends ubufox but should suggest ubufox
+ [MASTER] Firefox3.5 recommends ubufox but should suggest ubufox
Changed in ubufox (Ubuntu):
importance: Undecided → Medium
Micah Gersten (micahg) on 2009-07-08
description: updated
Micah Gersten (micahg) on 2009-07-12
description: updated

Here is a debdiff on ubufox which prevents firefox-3.0 to install if firefox-3.5 is getting installed.

Thank you for the patch, but ubufox will not be updated for Firefox 3.5
on Jaunty. The fix will most likely be in changing ubufox from
recommends to suggests. This will most likely happen when the next
3.5.x release happens.

Arnaud Faucher wrote:
> Here is a debdiff on ubufox which prevents firefox-3.0 to install if
> firefox-3.5 is getting installed.
>
> ** Attachment added: "ubufox_0.7-0ubuntu2.debdiff"
> http://launchpadlibrarian.net/28937884/ubufox_0.7-0ubuntu2.debdiff
>
>

I confirm this bug Kubuntu Karmic too.

It's insane to use all this gtk\gnome dependencies for FF 3.5.

For example like: synaptic, gnome-mount, gnome-keyring, gksu, gconf2, notification-daemon policykit-gnome, ettc...

I hope it can be fixed before FF3.5 will released.

giuseppe

John Vivirito (gnomefreak) wrote :

changed package name since it needs to be changed in firefox-3.5.

i have fixed this from ubiverse archives and will post a debdiff when im finished with it.

Changed in ubufox (Ubuntu):
assignee: nobody → John Vivirito (gnomefreak)
John Vivirito (gnomefreak) wrote :

here is the debdiff from karmic build

Micah Gersten (micahg) wrote :

I think John meant to move this...
We already have Bug #132072 for the KDE support for apturl so all that's left seems to be the recommends in the firefox-3.5 package.

affects: ubufox (Ubuntu) → firefox-3.5 (Ubuntu)

On 07/19/2009 01:45 PM, Micah Gersten wrote:
> I think John meant to move this...
> We already have Bug #132072 for the KDE support for apturl so all that's left seems to be the recommends in the firefox-3.5 package.
>
> ** Package changed: ubufox (Ubuntu) => firefox-3.5 (Ubuntu)
>
I have attached the 3.5 patch but talking with Alexander he wants me to
push 3.5 to branch and merge. will do today sometime

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

"How can i get lost, if i have no where to go"
    -- Metallica from Unforgiven III

Micah: What does kde support have to do with this?
Mozilla doesnt have QT support for any apps.
The problem fixing bug #132072 they want to drop GTK libs as i understand it. we cant do that until QT support is added, however i think they stalled on it.

John Vivirito (gnomefreak) wrote :

from the above sorry i meant to add Qt supporet for apt-url. I would rather not touch apt-url if i can avoid it.

Micah Gersten (micahg) wrote :

I'm saying we already have a wishlist bug for it. There's no need to leave this bug open to solve it, that's all. Not that we have to do it now.

John Vivirito (gnomefreak) wrote :

i merged the branches already so most likely it will be fixed in next 3.5 release. However the depends on gnome for qt that is outside the scope of this bug however i do recall seeing one on this but either way this bug was about ubufox being in recommends when should be in suggests

Changed in firefox-3.5 (Ubuntu):
status: Triaged → Fix Released
status: Fix Released → Invalid
status: Invalid → Triaged
J. Sman (jsman) wrote :

The other reports about the dependency on Gnome packages are all marked as duplicates of this report. If it is outside of the scope of this bug, who will be working on resolving the issue?

Micah Gersten (micahg) wrote :

Now that apturl has a kde front end, ubufox can depend on apturl or apturl-kde and the Firefox recommends can be left in place.

summary: - [MASTER] Firefox3.5 recommends ubufox but should suggest ubufox
+ [MASTER] installing firefox pulls in ubufox and all gnome depends
+ through apturl
Changed in ubufox (Ubuntu):
assignee: nobody → Alexander Sack (asac)
importance: Undecided → Medium
milestone: none → ubuntu-9.10-beta
status: New → Triaged
Changed in firefox-3.5 (Ubuntu):
assignee: John Vivirito (gnomefreak) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.8~b1-0ubuntu1

---------------
ubufox (0.8~b1-0ubuntu1) karmic; urgency=low

  New upstream release 0.8b1 fixes:
  * fix: LP: #365965 - installing firefox pulls in ubufox and all gnome depends
    through apturl; we add alternative Depends on apturl-kde to make ubufox kde
    friendlier
    - update debian/control
  * fix LP: #423438 - ubufox can't use apturl on karmic; honour shebang by
    calling command directly rather than the python interpreter. Thx to Micah
    Gersten who provided the upstream fix.
    - update content/pluginInstallerService.js
  * fix LP: #403581 - restart required notification and button not shown
    in ffox 3.5; support multiple versions of in updateRestart.js; we use runtime
    application info from extIApplication.version
    - update content/updateRestart.js
  * fix LP: #411222 - restart required notification should be shown with
    less delay; checking for restart notification every 5 seconds (was 10 before) now
    - update content/updateRestart.js
  * fix LP: #429937 - plugin alternative wizard not available if there is no
    plugin content detected; don't disable "Manage Content Addons" initially;
    the dialog even makes sense if there is plugin content used atm.
    - update content/ubuntuAltpluginsOverlay.xul
  * fix LP: #399229 - update ubufox strings from 9.04 to 9.10 in various places
    + update releasenotes url in locale/*/ubufox.properties
    + update HOMEPAGE_ONLINE in startpage.html
    + update plugin finder service database url in ubufox-pfs.js
    + update gethelp and translate urls in overlay.js
    + update execute command to use firefox rather than firefox-3.0 in overlay.js
    + include karmic sources in plugin db creation
      - add pfs/db/sources.list.9.10
  * support firefox 3.6 and 3.7 restart required feature and set maxVersion
    to 3.7.*
    - update content/updateRestart.js
    - update install.rdf

 -- Alexander Sack <email address hidden> Tue, 15 Sep 2009 12:18:32 +0200

Changed in ubufox (Ubuntu):
status: Triaged → Fix Released
Alexander Sack (asac) wrote :

ubufox depends on apturl | apturl-kde now. no need to adjust firefox recommends anymore.

Changed in firefox-3.5 (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers