Ubuntu

[MASTER] Firefox problems with desktop-effects

Reported by Thom Pischke on 2007-04-01
830
This bug affects 74 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Confirmed
Medium
compiz (Ubuntu)
Medium
Unassigned
firefox-3.0 (Ubuntu)
Medium
Unassigned
firefox-3.1 (Ubuntu)
Undecided
Unassigned
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

If Firefox is running when Desktop Effects are enabled on my Dell Inspiron 6000 or my HP zd7000, Firefox becomes an unresponsive window with no window decorations. It's not possible to maximize, move it, or otherwise interact with it. Disabling Desktop Effects restores sanity.

I retest desktop-effects every couple weeks, and this problem persists. Since firefox is probably the single most important application used by most users, this problem pretty much guarantees no casual user will use Desktop Effects.

**Steps to reproduce :
1. Open a single instance of Firefox with no tabs open.
2. Go to http://www.htmlgoodies.com/legacy/beyond/javascript/bigsmall.html
3. Click the "Maximize" link located at the top left of this webpage.
4. Close Firefox.
5. Re-open Firefox.
6. Now the titlebar for Firefox and upper/lower panels should be missing.

Or

1. Use the bigger resolution that your computer can take and open Firefox.
2. If not already done, demaximize the Firefox window (right clic / Demaximize).
3. Close Firefox
4. Change the screen resolution for a very lower one.
5. Open Firefox

**WORKAROUNDS : more permanent
1. Install compizconfig-settings-manager
2. start ccsm
3. click on "Workarounds" plugin in the "Utility" section
4. uncheck "Legacy Fullscreen Support".
or
1. F11 twice
2. resize the windows with the mouse. Once you've set them to the right size for you then go to
3. Edit - Preferences - Content - Enable JavaScript Advanced ...
4. UNtick the top (?) option which is "Move or resize window". This should prevent javascript from being able to resize your window inconviently
thanks to <Tom>

**WORKAROUNDS : temporary
Hit F11 twice

Thom Pischke (thom-pischke) wrote :

see also bug #92369

Travis Watkins (amaranth) wrote :

Does this happen if you start firefox after enabling desktop-effects?

Changed in compiz:
status: Unconfirmed → Needs Info
Thom Pischke (thom-pischke) wrote :

Just tested now after updating from repositories. Testing on HP Pavilion zd7000. Same problem if I enable desktop-effects with Firefox already started.

Testing Further:

Close Firefox, but with IntelliJ IDEA maxmimized when desktop-effect enabled -- same problem with IDEA.

Close All programs, turn off effects.

Turn effect back on.

Start Firefox. Firefox never appears at all. I get a firefox button in the task bar, but clicking on it does not bring up the window. It seems there's no way to make the firefox window visible.

Happy to test further, just let me know what.

Travis Watkins (amaranth) wrote :
Changed in compiz:
assignee: nobody → amaranth
status: Needs Info → In Progress
Sebastien Bacher (seb128) wrote :

thank you for the work on that, change uploaded now

Changed in compiz:
status: In Progress → Fix Released
importance: Undecided → Medium
Darryl Grennan (darryl-grennan) wrote :

Re-opening this bug as I still have it. I'm running a fully patched Hardy system.

Here's how to replicate the bug. You need to have Ubuntu's "Visual Effects" enabled to trigger this.

1. Open a single instance of Firefox with no tabs open.
2. Go to http://www.htmlgoodies.com/legacy/beyond/javascript/bigsmall.html
3. Click the "Maximize" link located at the top left of this webpage.
4. Close Firefox.
5. Re-open Firefox.
6. Now the titlebar for Firefox and upper/lower panels should be missing.

You will also notice that the "Edit--> Preferences" will open under the browser instead of on top as well as the "Downloads" window.

To get Firefox back to "normal" you need to:

1. Press "F-11" twice.
2. Click the "Maximize" button at the top right of you Firefox Window.
3. Notice that your top panel disappears but the bottom one remains present.
4. Right click on the Firefox process within your bottom panel and click "Move"
5. With your mouse, drag the window down a bit so that you can manually resize it to your ideals.
6. Hit the "Maximize" button again and it should be back to "normal".

Changed in compiz:
status: Fix Released → Confirmed
Changed in compiz:
assignee: amaranth → nobody
Saivann Carignan (oxmosys) wrote :

I also confirm this bug. Other ways to reproduce this bug and a video are included in duplicate bug 235900 .

Also a important note which could explain why some people gets this bug while other people don't : This bug is not reproducible with all screen resolutions. Ex. It's not possible to reproduce it with 1680x1050, but it can be reproduced with 1280x1024.

Changed in compiz:
status: Confirmed → Triaged
loftarasa (loftarasa) wrote :

I'd like to report I've experienced this bug in a 1680x1050 resolution. I believe 1680x1050 is less common than 1280x1024 thus making it less reported, but the bug should not be considered restricted to lower or any specific resolutions.

Regards,
loftarasa.

Saivann Carignan (oxmosys) wrote :

loftarasa : Then it might not be *only* resolution related, but here's the result of my observations and test.

I have more than 10 customers that use firefox and compiz, but only one have this problem, which appears every week. His screen resolution is 1280x1024. A clean install and clean firefox profile does not fix anything.

Personally, I never had this problem with 1680x1050 (the maximum resolution of my screen) and I can't reproduce the bug with that resolution, however if I change the resolution of my screen to 1280x1024 or 1024x768, I can easily reproduce it.

Since this bug can also be reproduced when you open a firefox profile on a lower resolution than the last one firefox used, would it be a possible explanation that compiz uses his own way to deal with the resolution instead of working with the real used resolution and sometime assume a higher resolution than the "real" one?

This would explain why some people get this bug and why some people don't, depending on the match between graphic card and screen.

Franck (alci) wrote :

I also get the same kind of problems with compiz since I upgraded to Intrepid (worked fine for me with Hardy):

- when I open Firefox with desktop effects activated, I get no window borders.
- pressing F11 (full screen mode of firefox) twice (fullscreen and back) restores the window borders
- other applications than Firefox don't suffer this problem

Franck (alci) wrote :

Totally uninstalling and cleaning configurations of all compiz related stuff, then reinstalling compiz solved the issue for me...

I had a stuff in

~/.config/compiz
~/.compiz
gconf

After reinstalling, ~/.compiz didn't reappear...

Franck (alci) wrote :

Problem came back. Reinstalling compiz was not what made it dessapear... But I also replaced Firefox with Abrowser...

So after browsing the web, I think I have found the workaround: I deleted / recreated my .mozilla/firefox settings. THIS makes the problem disappear for me.

See also http://ubuntuforums.org/showthread.php?t=833714

The best workaround I've found for this in Firefox is to go "Edit"--> "Preferences"-->"Content"-->"Advanced JavaScript Settings"--> uncheck "Allow scripts to move or resize existing windows".

This is something that we "shouldn't" have to do. But it prevents the bug from occurring. I haven't really seen any big impacts from disabling it other than pop-ups not being the correct dimension on some sites. But it seems to be a rare side effect.

I'd rather my parents use this workaround than explain to them how to recover from the bug once it occurs. To recover from this bug, see the last portion of my previous post above.

asegal (aaron-drsegal) wrote :

Confirming the firefox max-size bug with Comviz on:
Ubuntu 8.0.4
running Gnome 2.22.3
with Firefox 3.0.3

on 1680x1050 resolution

arupgowda (arup-p) wrote :

Deleting / Recreating the .mozilla under home does not solve the problem. It goes away initially, but the problem reoccurs.
However what Darryl suggeted above about "unchecking Allow scripts" seems to work so far.

arupgowda wrote:
> Deleting / Recreating the .mozilla under home does not solve the problem. It goes away initially, but the problem reoccurs.
> However what Darryl suggeted above about "unchecking Allow scripts" seems to work so far.
>
>
Unchecking allow scripts to resize the window work for me.

I can confirm that this bug still occurs with desktop-effects on:

Ubuntu/8.10 (intrepid)
Gnome/2.24.1
Firefox/3.0.3

"unchecking Allow scripts" DID NOT work for me. Firefox still resizes over and obscures both panels. However, disabling desktop-effects prevents the bug from appearing.

glass.dimly (jmjohn) wrote :

I also confirm this bug with desktop effects, Ubuntu 8.10, FF 3.0.3.

glass.dimly (jmjohn) wrote :

OK,

This fixed it for me. I'm sure there are millions of ways to fix this. All I did was resize the "minimized" Firefox window.

Turn on "Expo" under compiz settings. When you see Firefox all messed up, Hit "Special Windows Key" and "e" to see Expo effect. Drag the offending window downwards. Double click to return to normal view. Resize Firefox to something small. Now maximize it. Now the problem is gone.

-glass.dimly

Hi,
That workaround is just not enough. Of course just by pressing F11 twice
your window will be correctly resized but what we are looking for is a real
fix.

Best regards,

Guillermo

On Fri, Nov 7, 2008 at 7:11 AM, glass.dimly <email address hidden> wrote:

> OK,
>
> This fixed it for me. I'm sure there are millions of ways to fix this.
> All I did was resize the "minimized" Firefox window.
>
> Turn on "Expo" under compiz settings. When you see Firefox all messed
> up, Hit "Special Windows Key" and "e" to see Expo effect. Drag the
> offending window downwards. Double click to return to normal view.
> Resize Firefox to something small. Now maximize it. Now the problem
> is gone.
>
> -glass.dimly
>
> --
> Firefox problems with desktop-effects
> https://bugs.launchpad.net/bugs/99740
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

I also have same problem here : ( .

* Ubuntu Intrepid x86
* Linux 2.6.27-7-generic
* Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)
* firefox-3.0 3.0.3+nobinonly-0ubuntu2
* Desktop effects are normal

Taipan (callsign-taipan) wrote :

I can confirm that the unchecking of 'allow scripts to resize / move windows' does seem to prevent the bug for me.

Jason Woofenden (jason210) wrote :

I get this bug without gnome

I'm using the wmii window manager.

Firefox worked fine for months, and since intrepid upgrade.

But now every time I open a firefox window it's fullscreen... really fullscreen, as described in this bug, I see now title bars, noothing except what is normally the content area of my firefox window.

If I tell wmii to remove the "fullscreen" flag from a firefox window (wmiir xwrite /client/sel/ctl Fullscreen off), it behaves as normal. But pressing ctrl-n in firefox to make a new window produces a new window which is fullscreen again.

Last time I had this problem I deleted my entire ~/.mozilla and that fixed the problem. I suspect the problem (both times) was initially caused by some spammy javascript popup thing.

My screen (flat panel on my laptop) is 1025x768.

Taipan (callsign-taipan) wrote :

To Jason Woofenden,

Just out of curiosity, since I have no experience with wmii (I assume you are using version 3 not 2), are you using compiz?

Everyone who has had this bug confirms that it only appears whilst using compiz, and given this is under the compiz bug section (now. It was originally under firefox section), one would assume that you are. But it would be helpful if you could confirm this, due to the recent tendency toward javascript.

Jason Woofenden (jason210) wrote :

Taipan,

I don't think it's possible to run compiz with wmii. To double-check here's an excerpt from my ps axf:

 5900 tty1 Ss 0:00 /bin/login --
 6153 tty1 S 0:00 \_ -zsh
 6367 tty1 S+ 0:00 \_ /bin/bash /usr/bin/startx
 6384 tty1 S+ 0:00 \_ xinit /home/jason/.xinitrc -- /etc/X11/xinit/xserverrc :0 -auth /tmp/serverauth.xxxxxxxxxxxx
 6385 tty7 Rs+ 10:50 \_ /usr/bin/X11/X -nolisten tcp
 6452 tty1 S 0:00 \_ sh /home/jason/.xinitrc
 6457 tty1 S 0:07 \_ wmii

Also here's a session in xterm:

parth ~> ps axf | grep -i compiz
zsh: done ps axf |
zsh: exit 1 grep -i compiz
parth ~> grep -i compiz /var/log/Xorg.0.log
zsh: exit 1 grep -i compiz /var/log/Xorg.0.log

If this is inconclusive, please let me know how I can check.

Chris Halse Rogers (raof) wrote :

You certainly can't run wmii with compiz - they're both window managers, and you can only run one window manager at a time.

It looks like the people who have re-opened this bug are actually experiencing a Firefox bug that curiously doesn't manifest under Metacity. If I had to make a guess, I'd say it's due to differing "legacy fullscreen" support. It might be useful for people who can reproduce this bug to attach (not inline, please!) the output of "xprop" on the firefox window.

Changed in compiz:
status: Triaged → Incomplete
Taipan (callsign-taipan) wrote :

This is an interesting development, as I'm quite sure the firefox reports were all closed down and forwarded to compiz. Perhaps this was rightly placed under firefox originally.

I have saved the xprop output of a normally functioning firefox window, and as soon as I have an malfunction occur, I will create the xprop output for it, and see if I can ascertain any differences.

Jason Woofenden (jason210) wrote :

I saved my ~/.mozilla directory from when this bug was driving me nuts. When I replace it, the bug is reproducible every time by opening a window.

I grabbed the xprop output by typing this, hitting enter, and starting firefox: sleep 10; xprop > foo.log

I did this with the .mozilla directory that exhibits the bug, and the one without. The only difference (besides the PID) was that this line was present in the buggy firefox xprops:

_NET_WM_STATE(ATOM) = _NET_WM_STATE_MAXIMIZED_VERT, _NET_WM_STATE_MAXIMIZED_HORZ

I'm attaching the output of xprop on the buggy window as an attachment.

Jason Woofenden (jason210) wrote :

I can easily enable/disable this bug by swapping between my bad .mozilla directory and my good one.

Therefore either 1) it's a firefox preference. or 2) it's a firefox bug.

Now since I (the user) didn't change my preferences or install a plugin or anything (I think it was triggered by going to a site with a javascript popup of some kind) it has to be a bug. Either a bug that this preference can be set by a website's javascript, or a bug that this behavior can be enabled at all.

There may also be a bug in compiz and wmii... An argument could easily be made that these window managers should be able to deal with whatever firefox is doing. Regardless of that, I think firefox shouldn't be doing whatever it's doing.

For now let's keep this as a single bug report and just focus on trying to figure out what's going on.

I'll run a few experiments, to see if I can locate what file/line in my bad ~/.mozilla dir is telling firefox to exhibit this annoying behavior.

Jason Woofenden (jason210) wrote :

OK, I looked through the diff between my working and buggy ~/.mozilla/firefox/ folders.

I first discovered that deleting my ~/.mozilla/firefox/xxx.default/localstore.rdf fixed firefox (and deleted my toolbar customizations).

Then I searched through that file and found the bit that was causing problems:

<RDF:Description RDF:about="chrome://browser/content/browser.xul#main-window"
screenX="-1"
screenY="-15"
width="1024"
height="768"
sizemode="maximized" />

I changed the X and Y to be 0 and the width and height to the size of the content area of the pane (1022x737) instead of my monitor, and replaced "maximized" with "normal".

Now when I open firefox with that ~/.mozilla it works as it should.

Now the really strange part... When I tried changing just the sizemode to normal, and leaving the 4 numeric settings shown above as is... it was still buggy (fullscreen).

Could other people try changing these settings to various values in metacity and compiz and see what happens?

Jason Woofenden (jason210) wrote :

I fired up gnome, and I'm happy to say that desktop-effects are now working on my computer (as of intrepid upgrade I assume).

I have steps to reproduce this issue with compiz. This produces the fullscreen bug described in the original post for this bug report when done with desktop-effects on. When following these steps without desktop-effects (but still in gnome) then firefox behaves properly. Here's the steps:

1) [re]move your ~/.mozilla so you're starting fresh

2) start firefox

3) quit firefox (wait until it's really stopped)

4) edit your ~/.mozilla/firefox/*.default/localstore.rdf

edit this tag: RDF:Description RDF:about="chrome://browser/content/browser.xul#main-window"

Set screenX and screenY to 0.

Set "width" to the width of your screen and height to the height of your screen. In my case that was 1024 and 768 respectively.

Set sizemode to "maixmized".

5) start firefox

Expected result: firefox window, which is maximized, and still has it's title bar, and I can still see gnome panels.

Actual result with desktop-effects: window covers entire screen, covering gnome panels, and window title bar is not visible. Firefox still has all it's menu bars and toolbars visible though.

Actual results with desktop-effects OFF: as expected

Taipan (callsign-taipan) wrote :

Good job Bro!!....

my settings are:

width="994"
screenX="0"
screenY="24"
height="693"

which are fine, however when I change the width and height to 1024 and 768 respectively, it produces the bug. And to be honest, since I added the mozilla launchpad repository to my sources.list I have not seen the bug, so I am not sure if it has been fixed the "upcoming" updates.

Taipan (callsign-taipan) wrote :

And just on that... I tested the 1024 x 768 setting under metacity.... and it didnt display the bug as it did under compiz. Perhaps gnome-panel is more definite under metacity than compiz.

Aha. That'll be it - setting the desired width & height to be same as
the screen size will trigger the "legacy fullscreen support" in the
Compiz workarounds plugin. Presumably Wmii also supports this
(obsolete) method of making a window fullscreen.

I'm a bit surprised that Metacity doesn't support this old fullscreen
method.

Yet another good job Bro!...

I can confirm that turning off the 'legacy fullscreen support' option in the compiz workarounds plugin stops the bug from occurring

Jason Woofenden (jason210) wrote :

Wahoo! We figured it out.

Now what do we do about it?

Makes sense to me to disable "legacy fullscreen support" by default in compiz to match metacity. If gnome's default setup doesn't support "legacy fullscreen support" (and I presume if metacity doesn't now, it probably hasn't for a long time) then I imagine most problems that normal people actually use don't need "legacy fullscreen support". I know very little about this, so I hope someone more knowledgeable can give their opinion.

Also we could hack firefox so it doesn't enable javascript to set the window (x,y) to exactly (0,0). Very few window managers will let you actually position a window so the title bar is off the screen, so allowing javascript to set y coordinates like that doesn't make sense.

maharaja (maharaja84) wrote :

Thanks guys! I simply deleted the whole ~/.mozilla directory, which seemed to do the trick for me. Now I'm running desktop-effects as normal and haven't experienced the bug since. This is what I did:

1) export firefox bookmarks

2) quit firefox

3) go to the home directory and delete the ~/.mozilla directory (don't worry, firefox recreates it later)

4) restart firefox

Antony Jones (wrh) wrote :

I would like to also confirm this as an issue.

Taipan (callsign-taipan) wrote :

**FIX FOR THIS ISSUE**

Okay... its not the proper fix, but I assume people are just going to skim over this and not identify that TURNING "LEGACY FULLSCREEN SUPPORT" IN THE COMPIZ 'WORKAROUNDS' PLUGIN OFF will cease the issue.

I apologise for using big text, but I wanted to make sure that this is noticed by people skimming.... Obviously there needs to some kind of permanent (ie, no user interaction) fix, and as my good friend Jason Woofenden suggested, having that option disabled in compiz by default is one solution, however the issue will still remain for other window managers that use legacy fullscreen support.

Having said that, I am still under the belief that firefox itself would be the most ideal place to rectify this issue due to the fact that there are a lot of window managers, and only one firefox (please no semantics about iceweasel, swiftfox, upcoming pre-betas etc) ;-)

I'm not sure of the viability of, when firefox starts, it does a quick check of the window manager, and adjusts the identified settings of "localstore.rdf" accordingly.... I have noticed that firefox does a whole lot of work before it shows up anyway, by the huge spike in cpu load. And given this is the first time I have ever been even remotely active in a bug report, I have exactly no idea where to go from here.

Jason Woofenden (jason210) wrote :

I agree that firefox should be fixed.

Perhaps it should be fixed before the values get into localstore.rdf.

I think it's absurd to let javascript set the screenY to 0 ever. Very few window managers will actually let you put the window there (because the title bar is hanging off the screen.)

My suggested fix would be to hack firefox so that if javascript tries to set the screenY parameter to 0 it sets it to 1 instead.

Do you agree? and if so how do we best suggest this to the firefox team?

description: updated
loftarasa (loftarasa) wrote :

Agreed, javascript should be unable to set screenY to 0 completely.
Congrats to everyone for accurately spotting the causes for this.

Jason Woofenden (jason210) wrote :

Firefox should not tell the window manager to put the window at (0,0) at the request of javascript, because with the width and height set ust right this triggers the "legacy fullscreen support" feature of some window managers like compiz and wmii (something javascript should not be able to do.)

Suggested fix: when javascript requests to set the windows Y coordinate to 0 set it to 1 instead.

Changed in compiz:
status: Incomplete → Confirmed
Saivann Carignan (oxmosys) wrote :

Don't forget that metacity and other WM react correctly to this, so I'm not sure that changing package to firefox is the right thing to do. After all, Firefox over gnome-panel is the result of compiz behavior.

Jason Woofenden (jason210) wrote :

Saïvann Carignan,

Can you think of any reason why javascript should be able to request that the a window be places such that the top of it's content was even with the top of the screen? (And that request should be taken seriously by firefox?)

Metacity ignores this request because it is unreasonable. I think firefox shouldn't be sending unreasonable requests on behalf of javascript, especially if it confuses some window managers.

Firefox going fullscreen because of javascript is the result of BOTH of these:

1) Firefox requests unreasonable screen coordinates if javascript asks, including the set of coordinates specifically designed to trigger fullscreen mode.

2) Compiz and wmii (and probably others) support "legacy fullscreen support" which mean's they'll put a window into fullscreen mode if you request the exact coordinates that would have it cover the whole screen.

One of those has obviously gotta give. The one that seems more like the bug to me is firefox. The "legacy fullscreen support" is there on purpose. The javascript thing is yet another case of website authors tricking the browser into doing something it should not do unless the user requests it.

Saivann Carignan (oxmosys) wrote :

Jason : Good points, well I think that at this point, it might be interesting to have Firefox developers opinion on this, so can you open a upstream bug report in https://bugzilla.mozilla.org/ and link the upstream bug to this one so we can get Firefox developers opinion?

Taipan (callsign-taipan) wrote :

just on that, I have been playing around with fvwm-crystal of late, and have noticed some interesting things.... the bug does not show up due to the window manager putting preference of the title bar over whatever the application deems fit.... however, there is a "fullscreen" button on the title bar which triggers the legacy fullscreen support function to display the application fullscreen without the title bar.... it makes sense in that window manager for the legacy fullscreen function to exist, which fuels my agreement on having firefox correct the javascript issue.... javascript can be insidious, and being that firefox claims to be a more secure browser, I believe it should have built in functions to stem javascript's reign of terror :D not that the setting of 0,0 coordintates is much of a security threat, but it might be worth while for the firefox developers to see exactly what javascript can get away with.... however I'm sure do already

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3

This problem has been extensively discussed and documented here:

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/99740

Now that we've figured out what's happening and discussed various workarounds/fixes we've decided that firefox should not allow javascript to trigger this strange full-screen mode. Please read the discussion on the ubuntu bugs page for rationale and more details.

Reproducible: Always

Steps to Reproduce:
Note that this bug does not appear in metacity, only window managers that support "legacy fullscreen support", such as compiz and wmii.

**Steps to reproduce :
0. Run compiz (gnome + desktop-effects) or wmii
1. Open a single instance of Firefox with no tabs open.
2. Go to http://www.htmlgoodies.com/legacy/beyond/javascript/bigsmall.html
3. Click the "Maximize" link located at the top left of this webpage.
4. Close Firefox.
5. Re-open Firefox.
6. Now the titlebar for Firefox and upper/lower panels should be missing.
Actual Results:
Firefox comes up covering the entire screen, panels and all, with no title bar or anything.

Some repart that that firefox's menu and panel are also missing.

Expected Results:
A firefox window with a title bar, etc, not covering gnome panels

That might describes two bugs, because it is possible to reproduce "Firefox suddenly covers the whole screen" by following these steps while compiz is enabled :

1. Use the bigger resolution that your computer can take and open Firefox.
2. If not already done, demaximize the Firefox window (right clic / Demaximize).
3. Close Firefox
4. Change the screen resolution for a very lower one.
5. Open Firefox

Not sure what javascript should or shouldn't allow, however the fact that Firefox sometime suddenly covers the whole screen is definitively wrong. Also, this is a regression over Firefox 2 on which this bug can't be reproduced.

The most useful comments seem to be:
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/99740/comments/30
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/99740/comments/42

Weird window manager feature, but it should be easy for Firefox to work around it. We should fix this even if we also fix bug 454779.

Changed in firefox:
status: Unknown → New

I am running Ubuntu 8.10 (Intrepid Ibex) Desktop and Firefox 3.0.4 on a Compaq Evo N600c laptop. My screen resolution is at the default 1024x768 for this machine. I am using Compiz in default configuration. I have not changed either my screen resolution or de-maximized the Firefox window, yet this problem occurs. Firefox will change its window so that the title bar disappears along with both of Ubuntu's panels. When this happens, I cannot minimize Firefox, I can only close it or quit. I can Alt-Tab to access another application in the live window. Following advice I found in another forum, I selected "F11" to toggle from full screen mode and back. This resolved the problem temporarily, but it does come back. This behavior only seems to occur with Firefox. If I use Opera, or if I am using another application, I do not seem to experience the problem. I am using Compiz in default configuration.

Although the F11 trick works, it is but a workaround and not really a fix.

Taipan (callsign-taipan) wrote :

Rob Smith -

Please read the actual workaround which will stop this permanently.... I have copied it from the bug description for your convenience... and modified it slightly to be easier to follow

**Workaround :
Step 1 - Install compizconfig-settings-manager (sudo apt-get install compizconfig-settings-manager)
Step 2 - Start ccsm (either from the commandline or by pushing Alt+F2 and typing ccsm)
Step 3 - Click on "Workarounds" plugin in the "Utility" section
Step 4 - Uncheck "Legacy Fullscreen Support".

Taipan,

Thank you. As it turns out, I already had ccsm installed and followed your instructions to uncheck legacy fullscreen support.

It is strange that this never happened until a couple days ago. I had originally installed Hardy Heron on this machine back in the early part of September (replacing Etch), and didn't have any problems until now. I upgraded to Intrepid through apt-get the day it was released.

Anyway, thanks again for the tip.

Rob Smith
Posted via Ubuntu GNU/Linux (v.8.10)
Because software, like people, should be allowed to exist in an open, sharing community, and not kept contained by corporate greed!

--- On Wed, 11/26/08, Taipan <email address hidden> wrote:
From: Taipan <email address hidden>
Subject: [Bug 99740] Re: Firefox problems with desktop-effects
To: <email address hidden>
Date: Wednesday, November 26, 2008, 6:03 PM

Rob Smith -

Please read the actual workaround which will stop this permanently.... I
have copied it from the bug description for your convenience... and
modified it slightly to be easier to follow

**Workaround :
Step 1 - Install compizconfig-settings-manager (sudo apt-get install
compizconfig-settings-manager)
Step 2 - Start ccsm (either from the commandline or by pushing Alt+F2 and
typing ccsm)
Step 3 - Click on "Workarounds" plugin in the "Utility"
section
Step 4 - Uncheck "Legacy Fullscreen Support".

--
Firefox problems with desktop-effects
https://bugs.launchpad.net/bugs/99740
You received this bug notification because you are a direct subscriber
of the bug.

Jesse, I take it you meant to confirm this bug as well?

Changed in firefox:
status: New → Confirmed

I uncheck Legacy Fullscreen Support

However if i go to google and search for translate the issue occur again!

Any solution?

Jonathan (jonathanmotes-gmail) wrote :

This just started happening to me about 2 days ago and now happens every time I open Firefox. I have Ubuntu 8.10 with lastest updates. Firefox always opens with no borders and covers the whole screen. I can hit F11 twice to make it show properly. Unchecking "Legacy Fullscreen Support" seems to fix the issue for me.

--> Core::DOM

A workaround is possible here, carrying over blocking flag. Not sure that it blocks, mind.

On a completely unrelated matter entirely.... I know this is not the place for it, but I have the urge to share this with the world somehow... and I love you guys here haha.... ummm... anyway

I have been playing with FreeDOS a lot lately... spending all my time on it.... and I just forgot all of my linux commands.... how much does that suck!.... i couldnt even remember if there was a "-" in apt-get dist-upgrade hahaha..... feel free to send me hate mail for posting this in a completely inappropriate place

Jeffrey Flaker (jflaker) wrote :

Same problem and unchecking Legacy Fullscreen Support stops the problem

Hew McLachlan (hew) on 2008-12-29
Changed in firefox:
status: Confirmed → Triaged
maxadamo (massimilianoadamo) wrote :

Same happens here on Ubuntu Intrepid 8.10 with:
Compiz + Gnome + FF 3.0.5 with or without Emerald.

I suspect all workaround are somehow crappy, as they have side effects. On of these workaround will not allow to properly see flash movies (maybe in full screen), other workaround don't work at all, other that I found in Internet looks more like wizardry and make no sens at all.

Taipan: I would suggest to suspend your account here. The reason would be: demonstrated and full-blown idiocy. What do you think about?

loftarasa (loftarasa) wrote :

the bug has already been confirmed and triaged, so there's no need for additional comments unless they somehow improve the odds of finding a solution. that said, please keep personal criticisms to yourselves, lest this be turned into a silly message board.

i'd much rather receive useful updates on the bug than the umpteenth comment on the week that says something like 'this also happens to me' or other useless information.

on a final note, there is no current fix. the workarounds we've presented are simply that, workarounds. you can either use them to see if you can prevent the bug from happening or deal with the bug until the code is properly adjusted. it really doesn't matter if you can "fix" it or not, as this is not a help board. there are other places were you can go for help and maybe you'll even see some of us there. we're not -here- to help you fix your personal problem, but rather avoid the issue from happening ever again.

regards,
loftarasa

Maxadamo,

Workarounds are just that, workarounds. They are not fixes, but rather a temporary way to get something to stop happening. In my case, one of those workarounds helped. I'm sorry that they didn't work for you.

That all said, please try to remember that the folks here trying to assist us are volunteers. They don't get paid for their time; they are doing us a favor, so please do keep nasty comments to yourself! They are doing what they can, the best they can. They are not God almighty. Cut 'em some slack!

Taipan, I for one appreciate your attempts to help, and I am sure that there are many more like myself, probably far more of us than the Maxadamo's.

I'm sorry to take up the bandwidth on this forum, I realize that it is not a message board, but I just could not let the comment pass without an answer from us who appreciate all the volunteer effort.

Thank you!

Rob Smith
Posted via Ubuntu GNU/Linux (v.8.10)
Because software, like people, should be allowed to exist in an open, sharing community, and not kept contained by corporate greed!

--- On Fri, 1/2/09, maxadamo <email address hidden> wrote:
From: maxadamo <email address hidden>
Subject: [Bug 99740] Re: Firefox problems with desktop-effects
To: <email address hidden>
Date: Friday, January 2, 2009, 3:03 AM

Same happens here on Ubuntu Intrepid 8.10 with:
Compiz + Gnome + FF 3.0.5 with or without Emerald.

I suspect all workaround are somehow crappy, as they have side effects.
On of these workaround will not allow to properly see flash movies
(maybe in full screen), other workaround don't work at all, other that I
found in Internet looks more like wizardry and make no sens at all.

Taipan: I would suggest to suspend your account here. The reason would
be: demonstrated and full-blown idiocy. What do you think about?

--
Firefox problems with desktop-effects
https://bugs.launchpad.net/bugs/99740
You received this bug notification because you are a direct subscriber
of the bug.

TANGUY Arnaud (geenux) wrote :

Rob Smith wrote:
> Maxadamo,
>
> Workarounds are just that, workarounds. They are not fixes, but rather a
> temporary way to get something to stop happening. In my case, one of
> those workarounds helped. I'm sorry that they didn't work for you.
>
> That all said, please try to remember that the folks here trying to
> assist us are volunteers. They don't get paid for their time; they are
> doing us a favor, so please do keep nasty comments to yourself! They are
> doing what they can, the best they can. They are not God almighty. Cut
> 'em some slack!
>
> Taipan, I for one appreciate your attempts to help, and I am sure that
> there are many more like myself, probably far more of us than the
> Maxadamo's.
>
> I'm sorry to take up the bandwidth on this forum, I realize that it is
> not a message board, but I just could not let the comment pass without
> an answer from us who appreciate all the volunteer effort.
>
> Thank you!
>
> Rob Smith
> Posted via Ubuntu GNU/Linux (v.8.10)
> Because software, like people, should be allowed to exist in an open, sharing community, and not kept contained by corporate greed!
>
>
> --- On Fri, 1/2/09, maxadamo <email address hidden> wrote:
> From: maxadamo <email address hidden>
> Subject: [Bug 99740] Re: Firefox problems with desktop-effects
> To: <email address hidden>
> Date: Friday, January 2, 2009, 3:03 AM
>
> Same happens here on Ubuntu Intrepid 8.10 with:
> Compiz + Gnome + FF 3.0.5 with or without Emerald.
>
> I suspect all workaround are somehow crappy, as they have side effects.
> On of these workaround will not allow to properly see flash movies
> (maybe in full screen), other workaround don't work at all, other that I
> found in Internet looks more like wizardry and make no sens at all.
>
> Taipan: I would suggest to suspend your account here. The reason would
> be: demonstrated and full-blown idiocy. What do you think about?
>
>
Yes, when someone try to help, we appreciate. But when someone post a
stupid comment, whitout even a relation to the bug, I understand
maxadamo's reaction about Taipan...

This bug should be really fixed, as most of the GNU/Linux users uses compiz.

--
TANGUY Arnaud (geenux).

loftarasa,
what you are not understanding about my comment?

I said:
1) not all workaround that I found in several forums are helping (they are wizardry, without any sense and not workaround). I gave a suggestion to not use some other workaround because they may have some other side effects (prevent flash player running properly).
2) I forgot to say one important thing: the only one workaround which is actually working is to press F11 twice.
3) I asked Taipan to not behave like an idiot.

What's wrong with this?

loftarasa (loftarasa) wrote :

for the sake of clarity, i think i'll reply one last time.

1) we're not here to provide workarounds. those come as a mere bonus to whoever comes across this website. this is not a forum, much less a means to provide you with help. this is where we track down bugs and find ways to fix them, period.

2) even if we for a moment admit we have deviated from that original purpose for any given reason, many users have found to be helpful some of the ideas presented here. if they don't work for you, i'm sorry. you're just one in way too many users and these workarounds are provided 'as is' (i.e. we won't give you further help) unlike in a help forum where you can complain about something not working.

3) finally, your personal comments are useless, so keep them to yourself. it's better for everyone this way. if you ask me, taipan hurt the thread less than you did, so just ignore him if you find him to be such an idiot.

i think that's enough troll feeding for just one post, so this will be my final reply.

regards,
loftarasa

maxadamo (massimilianoadamo) wrote :

loftarasa,
am I a troll because I say:
1) some workaround are better than others (this is the meaning).
2) taipan's comment sucks

??

Please understand me: I know this is a bugtrack, and not a forum or usenet group, BUT in this bug I have found many workaround and suggestions.
Workaround are anyway very welcome to me and to everybody. Of course.
I simply pointed out that some workaround are not helping, and some other workaround have side effect... and other workaround may work.

where is the troll?

Lauri Niskanen (ape3000) wrote :

I have the same problem. Disabling the mentioned workaround from Compiz works, but that cause new problems. Many games in fullscreen mode are showed in a window.

I wasn't able to reproduce this issue with Firefox 3.1b2 downloaded from here : http://www.mozilla.com/en-US/firefox/all-beta.html

Can someone else confirm if the bug is reproducible with 3.1b2?

Can someone reproduce that bug with Firefox 3.1 Beta?

lauriehudson (laurie-hudson) wrote :

An alternate solution, which some people may find easier:
This is a bug which drove me nuts for months, right from the start of intrepid. The easiest way around this is with "Custom Geometry 2.2.0" firefox plugin (google it). If you setup a geometry (in the plug preferences) with the name "Default" that is smaller than your screen resolution and with some small offsets then firefox will be forced to this size on launch instead of the dumb, massive one it some times goes to. Not an ideal solution (clearly firefox/gnome/compiz/xorg shouldn't have this behavior in the first place) however it works 100% and saves a lot of headache.

mabovo (mabovo) wrote :

I installed it on my MacBook2,1 with Intrepid and Firefox returned to its prior behaviour.

I thought this problem was an advanced feature introduced by Mozilla team as default in FF3.0.5

Thanks lauriehudson.

Saivann Carignan (oxmosys) wrote :

This problem is already confirmed and workarounds are identified, however we need to know if it is reproducible with firefox 3.1 Beta 2, can someone test it?

Hew McLachlan (hew) wrote :

I can reproduce the problem with 3.0.6+nobinonly-0ubuntu1, but not with 3.1~b3~hg20090205r23182+nobinonly-0ubuntu1.

Changed in firefox-3.1:
status: New → Fix Released

Can't reproduce it with Firefox 3.1b2

chrisolof (chrisolof) wrote :

I can confirm this bug running Intrepid and Firefox 3.06 (Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.6) Gecko/2009020911 Ubuntu/8.10 (intrepid) Firefox/3.0.6).

Disabling "Legacy Fullscreen Support" in compiz-config settings manager worked for me.

Lanoxx (lanoxx) wrote :

I can confirm this bug on Ubuntu 8.10 with firefox 3.0.6, desktop effects set to normal.

@btw, why is there no filter in launchpad to view bugs that i changed the status to "this bug affects me" even though i have not postet to the bug

Hew McLachlan (hew) wrote :

No more confirmation of this bug is needed. We know it exists with Firefox 3.0, and is fixed with 3.1.

lanoxx, please see bug 283539.

No it is not as I still have it

Hew McLachlan wrote:
> No more confirmation of this bug is needed. We know it exists with
> Firefox 3.0, and is fixed with 3.1.
>
> lanoxx, please see bug 283539.
>
>

--
--------------------------------------
Richard A. OLIVER
Hameau du Cassoulet
38450 Miribel Lanchatre
France
Tel. 0033476340962
--------------------------------------

Richard, can you confirm the problem still exists with Firefox 3.1~b3~hg20090205r23182+nobinonly-0ubuntu1 ? Please make sure of the version, we know it occurs with 3.0. Firefox 3.1 is only available in Jaunty.

Beg your pardon, I have version 3.0.6, funny because the version before,
it was changed recently, the bug had disappeared.

Hew McLachlan wrote:
> Richard, can you confirm the problem still exists with Firefox
> 3.1~b3~hg20090205r23182+nobinonly-0ubuntu1 ? Please make sure of the
> version, we know it occurs with 3.0. Firefox 3.1 is only available in
> Jaunty.
>
>

--
--------------------------------------
Richard A. OLIVER
Hameau du Cassoulet
38450 Miribel Lanchatre
France
Tel. 0033476340962
--------------------------------------

FF-2.0 has reached EOLS

Changed in firefox (Ubuntu):
status: New → Invalid
summary: - Firefox problems with desktop-effects
+ [MASTER] Firefox problems with desktop-effects
Tom (tom6) wrote :

Sorry, try one of these work-around's and possible preventative measures about the resizing issue that seems to be part of this problem
https://bugs.launchpad.net/firefox/+bug/209499/comments/21

chris_debian (cjhandrew) wrote :

I am not experiencing this problem with Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10. From my experience, I'm happy to close.

Chris.

Micah Gersten (micahg) on 2009-05-06
description: updated
Micah Gersten (micahg) on 2009-05-06
description: updated
danielesil88 (danielesil88) wrote :

Hello, everybody !!!
I actually managed to fix this problem by using CompizConfig and then at the Utilities Tab, I deselected Alternative .

Hope this works for all of you as well !!!

Changed in compiz (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Travis Watkins (amaranth) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Karmic Koala. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/. Thanks again and we appreciate your help.

Please try to reproduce with firefox-3.0 as we already know firefox-3.5 is no longer affected. Even with firefox-3.0 I can no longer reproduce with karmic.

Changed in compiz (Ubuntu):
status: Triaged → Incomplete
Saivann Carignan (oxmosys) wrote :

Travis Watkins : I can confirm that I am no longer able to reproduce the same issue, wether with firefox 3.5 and 3.0 on karmic with latest compiz installed, so I guess that you can set all statuses to fix released.

Travis Watkins (amaranth) wrote :

Alright, thanks for the update.

Changed in firefox-3.0 (Ubuntu):
status: Triaged → Fix Released
Changed in compiz (Ubuntu):
status: Incomplete → Fix Released
Jeffrey Flaker (jflaker) wrote :

I've had this issue at some point it has been fixed and isn't an issue anymore with the new versions

This can probably be closed in my opinion.

Changed in firefox:
importance: Unknown → Medium
Ghita (gheorghe-marinca) wrote :

actually this kind of issues happen in my Ubuntu 10.4 installation quite often now. After restart they get solved but every now and then appear -- very annoying indeed considering that it happens in 2-3 of 10 restarts. This one solves the issue:
metacity --replace &

It affects all application windows and not specific to firefox.

Kip Warner (kip) wrote :

I can also confirm experiencing this problem under Maverick (amd64) using Firefox 3.6.12+build1+nobinonly-0ubuntu0.10.10.1.

pdlethbridge (pdleth) wrote :

After a fresh install of 10.4 and an upgrade to 10.10 I have the panel disapear when fire fox is opened but hitting F10 takes the problem away

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.