package firefox 3.0.19 nobinonly-0ubuntu0.8.04.1 failed to install/upgrade: trying to overwrite `/usr/share/bug/firefox/presubj', which is also in package firefox-2

Bug #600022 reported by Richard Thomas on 2010-06-29
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
apturl (Ubuntu)
Undecided
Unassigned
Hardy
High
Chris Coulson
firefox-3.0 (Ubuntu)
Undecided
Unassigned
Hardy
High
Chris Coulson

Bug Description

Binary package hint: firefox-3.0

E: /var/cache/apt/archives/firefox-branding_3.6.6+nobinonly-0ubuntu0.8.04.1_i386.deb: trying to overwrite `/usr/share/pixmaps/firefox.png', which is also in package firefox-2
E: /var/cache/apt/archives/firefox_3.6.6+nobinonly-0ubuntu0.8.04.1_i386.deb: trying to overwrite `/usr/share/bug/firefox/presubj', which is also in package firefox-2

I'm using Ubuntu 8.04 Hardy Heron

ProblemType: Package
Architecture: i386
Date: Tue Jun 29 19:26:42 2010
Dependencies:
 firefox-3.0 3.6.6+nobinonly-0ubuntu0.8.04.1
 firefox 3.0.19+nobinonly-0ubuntu0.8.04.1
DistroRelease: Ubuntu 8.04
ErrorMessage: trying to overwrite `/usr/share/bug/firefox/presubj', which is also in package firefox-2
NonfreeKernelModules: nvidia
Package: firefox 3.0.19+nobinonly-0ubuntu0.8.04.1
PackageArchitecture: i386
SourcePackage: firefox-3.0
Title: package firefox 3.0.19+nobinonly-0ubuntu0.8.04.1 failed to install/upgrade: trying to overwrite `/usr/share/bug/firefox/presubj', which is also in package firefox-2
Uname: Linux 2.6.24-24-generic i686

Richard Thomas (duffus003) wrote :
Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. As a workaround, you can uninstall the firefox-2 package (you shouldn't need it, and that version has been obsolete for a long time anyway)

Changed in firefox-3.0 (Ubuntu):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Chris Coulson (chrisccoulson)
affects: firefox-3.0 (Ubuntu) → ubuntu
Changed in ubuntu:
assignee: Chris Coulson (chrisccoulson) → nobody
affects: ubuntu → firefox-3.0 (Ubuntu)
Changed in firefox-3.0 (Ubuntu):
importance: High → Undecided
status: Triaged → Invalid
Changed in firefox-3.0 (Ubuntu Hardy):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in firefox-3.0 (Ubuntu Hardy):
status: Triaged → In Progress
Chris Coulson (chrisccoulson) wrote :

I've just uploaded a fix for this to our staging PPA, and we will publish it once we've confirmed it's working.

Sorry for the inconvenience

Changed in firefox-3.0 (Ubuntu Hardy):
status: In Progress → Fix Committed
Micah Gersten (micahg) on 2010-06-30
tags: added: ffox36-hardy
Chris Coulson (chrisccoulson) wrote :

As we've moved the preferences again, apturl will need fixing too

Changed in apturl (Ubuntu):
status: New → Invalid
Changed in apturl (Ubuntu Hardy):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Chris Coulson (chrisccoulson)
buck (buckjams) on 2010-06-30
Changed in apturl (Ubuntu Hardy):
status: In Progress → Fix Released
status: Fix Released → In Progress
Changed in apturl (Ubuntu Hardy):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox-3.0 - 3.6.6+nobinonly-0ubuntu0.8.04.2

---------------
firefox-3.0 (3.6.6+nobinonly-0ubuntu0.8.04.2) hardy-security; urgency=low

  * Fix LP: #600022 - don't ship files which conflict with the Firefox 2
    package. Revert the change to install the preferences in /etc/firefox
    and add some logic to move them back again. Install the icon as
    firefox-3.0.png.
    - update debian/firefox-3.0.preinst
    - update debian/firefox-final.desktop
    - update debian/firefox-minefield.desktop
    - update debian/firefox-namoroka.desktop
    - update debian/firefox.install
    - update debian/firefox.postinst.in
    - add debian/firefox.preinst
    - update debian/rules
  * Bump the firefox-3.0 conflict on firefox - this avoids an unnecessary
    conffile prompt for users upgrading from 3.6.6+nobinonly-0ubuntu0.8.04.1
    - update debian/control
  * Clean up files left in /etc/firefox/profile by version
    3.6.6+nobinonly-0ubuntu0.8.04.1
    - update debian/firefox.preinst
 -- Chris Coulson <email address hidden> Wed, 30 Jun 2010 13:52:46 +0100

Changed in firefox-3.0 (Ubuntu Hardy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apturl - 0.2.2ubuntu1.2

---------------
apturl (0.2.2ubuntu1.2) hardy-security; urgency=low

  * Update for LP: #600022 - install preference file back in old location
    - update setup.py
    - update debian/preinst
    - update debian/postinst
 -- Chris Coulson <email address hidden> Wed, 30 Jun 2010 16:17:27 +0100

Changed in apturl (Ubuntu Hardy):
status: Fix Committed → Fix Released

It didn't work from my command line

On Jun 30, 2010 10:37am, Launchpad Bug Tracker <email address hidden>
wrote:
> This bug was fixed in the package apturl - 0.2.2ubuntu1.2

> ---------------

> apturl (0.2.2ubuntu1.2) hardy-security; urgency=low

> * Update for LP: #600022 - install preference file back in old location

> - update setup.py

> - update debian/preinst

> - update debian/postinst

> -- Chris Coulson <email address hidden>> Wed, 30 Jun 2010 16:17:27
> +0100

> --

> package firefox 3.0.19 nobinonly-0ubuntu0.8.04.1 failed to
> install/upgrade: trying to overwrite `/usr/share/bug/firefox/presubj',
> which is also in package firefox-2

> https://bugs.launchpad.net/bugs/600022

> You received this bug notification because you are a direct subscriber

> of the bug.

> Status in “apturl” package in Ubuntu: Invalid

> Status in “firefox-3.0” package in Ubuntu: Invalid

> Status in “apturl” source package in Hardy: Fix Released

> Status in “firefox-3.0” source package in Hardy: Fix Released

> Bug description:

> Binary package hint: firefox-3.0

> E:
> /var/cache/apt/archives/firefox-branding_3.6.6+nobinonly-0ubuntu0.8.04.1_i386.deb:
> trying to overwrite `/usr/share/pixmaps/firefox.png', which is also in
> package firefox-2

> E:
> /var/cache/apt/archives/firefox_3.6.6+nobinonly-0ubuntu0.8.04.1_i386.deb:
> trying to overwrite `/usr/share/bug/firefox/presubj', which is also in
> package firefox-2

> I'm using Ubuntu 8.04 Hardy Heron

> ProblemType: Package

> Architecture: i386

> Date: Tue Jun 29 19:26:42 2010

> Dependencies:

> firefox-3.0 3.6.6+nobinonly-0ubuntu0.8.04.1

> firefox 3.0.19+nobinonly-0ubuntu0.8.04.1

> DistroRelease: Ubuntu 8.04

> ErrorMessage: trying to overwrite `/usr/share/bug/firefox/presubj', which
> is also in package firefox-2

> NonfreeKernelModules: nvidia

> Package: firefox 3.0.19+nobinonly-0ubuntu0.8.04.1

> PackageArchitecture: i386

> SourcePackage: firefox-3.0

> Title: package firefox 3.0.19+nobinonly-0ubuntu0.8.04.1 failed to
> install/upgrade: trying to overwrite `/usr/share/bug/firefox/presubj',
> which is also in package firefox-2

> Uname: Linux 2.6.24-24-generic i686

> To unsubscribe from this bug, go to:

> https://bugs.launchpad.net/ubuntu/+source/apturl/+bug/600022/+subscribe

buck (buckjams) wrote :

Then why didn't I get the fix through updates.. My synaptic was broken by
the firefox updates.DOESN"T WORK ANYMORE>> commandline won't update , It
does not recognise update .. WHAT EXACT CODE DO I NEED TO TYPE??????

On Jun 30, 2010 10:37am, Launchpad Bug Tracker <email address hidden>
wrote:
> This bug was fixed in the package apturl - 0.2.2ubuntu1.2

> ---------------

> apturl (0.2.2ubuntu1.2) hardy-security; urgency=low

> * Update for LP: #600022 - install preference file back in old location

> - update setup.py

> - update debian/preinst

> - update debian/postinst

> -- Chris Coulson <email address hidden>> Wed, 30 Jun 2010 16:17:27
> +0100

> --

> package firefox 3.0.19 nobinonly-0ubuntu0.8.04.1 failed to
> install/upgrade: trying to overwrite `/usr/share/bug/firefox/presubj',
> which is also in package firefox-2

> https://bugs.launchpad.net/bugs/600022

> You received this bug notification because you are a direct subscriber

> of the bug.

> Status in “apturl” package in Ubuntu: Invalid

> Status in “firefox-3.0” package in Ubuntu: Invalid

> Status in “apturl” source package in Hardy: Fix Released

> Status in “firefox-3.0” source package in Hardy: Fix Released

> Bug description:

> Binary package hint: firefox-3.0

> E:
> /var/cache/apt/archives/firefox-branding_3.6.6+nobinonly-0ubuntu0.8.04.1_i386.deb:
> trying to overwrite `/usr/share/pixmaps/firefox.png', which is also in
> package firefox-2

> E:
> /var/cache/apt/archives/firefox_3.6.6+nobinonly-0ubuntu0.8.04.1_i386.deb:
> trying to overwrite `/usr/share/bug/firefox/presubj', which is also in
> package firefox-2

> I'm using Ubuntu 8.04 Hardy Heron

> ProblemType: Package

> Architecture: i386

> Date: Tue Jun 29 19:26:42 2010

> Dependencies:

> firefox-3.0 3.6.6+nobinonly-0ubuntu0.8.04.1

> firefox 3.0.19+nobinonly-0ubuntu0.8.04.1

> DistroRelease: Ubuntu 8.04

> ErrorMessage: trying to overwrite `/usr/share/bug/firefox/presubj', which
> is also in package firefox-2

> NonfreeKernelModules: nvidia

> Package: firefox 3.0.19+nobinonly-0ubuntu0.8.04.1

> PackageArchitecture: i386

> SourcePackage: firefox-3.0

> Title: package firefox 3.0.19+nobinonly-0ubuntu0.8.04.1 failed to
> install/upgrade: trying to overwrite `/usr/share/bug/firefox/presubj',
> which is also in package firefox-2

> Uname: Linux 2.6.24-24-generic i686

> To unsubscribe from this bug, go to:

> https://bugs.launchpad.net/ubuntu/+source/apturl/+bug/600022/+subscribe

buck (buckjams) wrote :

What part of this do I enter into command line????

On Jun 30, 2010 10:37am, Launchpad Bug Tracker <email address hidden>
wrote:
> This bug was fixed in the package apturl - 0.2.2ubuntu1.2

> ---------------

> apturl (0.2.2ubuntu1.2) hardy-security; urgency=low

> * Update for LP: #600022 - install preference file back in old location

> - update setup.py

> - update debian/preinst

> - update debian/postinst

> -- Chris Coulson <email address hidden>> Wed, 30 Jun 2010 16:17:27
> +0100

> --

> package firefox 3.0.19 nobinonly-0ubuntu0.8.04.1 failed to
> install/upgrade: trying to overwrite `/usr/share/bug/firefox/presubj',
> which is also in package firefox-2

> https://bugs.launchpad.net/bugs/600022

> You received this bug notification because you are a direct subscriber

> of the bug.

> Status in “apturl” package in Ubuntu: Invalid

> Status in “firefox-3.0” package in Ubuntu: Invalid

> Status in “apturl” source package in Hardy: Fix Released

> Status in “firefox-3.0” source package in Hardy: Fix Released

> Bug description:

> Binary package hint: firefox-3.0

> E:
> /var/cache/apt/archives/firefox-branding_3.6.6+nobinonly-0ubuntu0.8.04.1_i386.deb:
> trying to overwrite `/usr/share/pixmaps/firefox.png', which is also in
> package firefox-2

> E:
> /var/cache/apt/archives/firefox_3.6.6+nobinonly-0ubuntu0.8.04.1_i386.deb:
> trying to overwrite `/usr/share/bug/firefox/presubj', which is also in
> package firefox-2

> I'm using Ubuntu 8.04 Hardy Heron

> ProblemType: Package

> Architecture: i386

> Date: Tue Jun 29 19:26:42 2010

> Dependencies:

> firefox-3.0 3.6.6+nobinonly-0ubuntu0.8.04.1

> firefox 3.0.19+nobinonly-0ubuntu0.8.04.1

> DistroRelease: Ubuntu 8.04

> ErrorMessage: trying to overwrite `/usr/share/bug/firefox/presubj', which
> is also in package firefox-2

> NonfreeKernelModules: nvidia

> Package: firefox 3.0.19+nobinonly-0ubuntu0.8.04.1

> PackageArchitecture: i386

> SourcePackage: firefox-3.0

> Title: package firefox 3.0.19+nobinonly-0ubuntu0.8.04.1 failed to
> install/upgrade: trying to overwrite `/usr/share/bug/firefox/presubj',
> which is also in package firefox-2

> Uname: Linux 2.6.24-24-generic i686

> To unsubscribe from this bug, go to:

> https://bugs.launchpad.net/ubuntu/+source/apturl/+bug/600022/+subscribe

Richard Thomas (duffus003) wrote :

Ok after trying some of the suggestions I received ! still had no luck. The that did eventually was to boot in recovery mode and run the dpkg broken package fixer. I was then able to reboot normally and do the update. Thanks for your quick responces.

Nancy (starshine5903) wrote :

Chris I do not have answers, but I sure need to know how to fix this!!!! I am not real computer savvy!! Thanks

Download full text (4.7 KiB)

Buck, I am not the person to ask!!! I am so sorry. I logged into the sight to find out my self, thats all so how you thought I could help I do not know!!! I wish I could because I have the same problem!!! Try emailing this person I think he can help <email address hidden> I hope anyway!!! Thanks Nancy

________________________________
From: buck <email address hidden>
To: <email address hidden>
Sent: Wed, June 30, 2010 3:36:35 PM
Subject: Re: [Bug 600022] Re: package firefox 3.0.19 nobinonly-0ubuntu0.8.04.1 failed to install/upgrade: try

Then why didn't I get the fix through updates.. My synaptic was broken by
the firefox updates.DOESN"T WORK ANYMORE>> commandline won't update , It
does not recognise update .. WHAT EXACT CODE DO I NEED TO TYPE??????

On Jun 30, 2010 10:37am, Launchpad Bug Tracker <email address hidden>
wrote:
> This bug was fixed in the package apturl - 0.2.2ubuntu1.2

> ---------------

> apturl (0.2.2ubuntu1.2) hardy-security; urgency=low

> * Update for LP: #600022 - install preference file back in old
location

> - update setup.py

> - update debian/preinst

> - update debian/postinst

> -- Chris Coulson <email address hidden>> Wed, 30 Jun 2010 16:17:27
> +0100

> --

> package firefox 3.0.19 nobinonly-0ubuntu0.8.04.1 failed to
> install/upgrade: trying to overwrite `/usr/share/bug/firefox/presubj',
> which is also in package firefox-2

> https://bugs.launchpad.net/bugs/600022

> You received this bug notification because you are a direct subscriber

> of the bug.

> Status in “apturl” package in Ubuntu: Invalid

> Status in “firefox-3.0” package in Ubuntu: Invalid

> Status in “apturl” source package in Hardy: Fix Released

> Status in “firefox-3.0” source package in Hardy: Fix Released

> Bug description:

> Binary package hint: firefox-3.0

> E:
> /var/cache/apt/archives/firefox-branding_3.6.6+nobinonly-0ubuntu0.8.04.1_i386.deb:
> trying to overwrite `/usr/share/pixmaps/firefox.png', which is also in
> package firefox-2

> E:
> /var/cache/apt/archives/firefox_3.6.6+nobinonly-0ubuntu0.8.04.1_i386.deb:
> trying to overwrite `/usr/share/bug/firefox/presubj', which is also in
> package firefox-2

> I'm using Ubuntu 8.04 Hardy Heron

> ProblemType: Package

> Architecture: i386

> Date: Tue Jun 29 19:26:42 2010

> Dependencies:

> firefox-3.0 3.6.6+nobinonly-0ubuntu0.8.04.1

> firefox 3.0.19+nobinonly-0ubuntu0.8.04.1

> DistroRelease: Ubuntu 8.04

> ErrorMessage: trying to overwrite `/usr/share/bug/firefox/presubj', which
> is also in package firefox-2

> NonfreeKernelModules: nvidia

> Package: firefox 3.0.19+nobinonly-0ubuntu0.8.04.1

> PackageArchitecture: i386

> SourcePackage: firefox-3.0

> Title: package firefox 3.0.19+nobinonly-0ubuntu0.8.04.1 failed to
> install/upgrade: trying to overwrite `/usr/share/bug/firefox/presubj',
> which is also in package firefox-2

> Uname: Linux 2.6.24-24-generic i686

> To unsubscribe from this bug, go to:

>
https://bugs.launchpad.net/ubuntu/+source/apturl/+bug/600022/+subscribe

--
package firefox 3.0.19 nobinonly-0ubuntu0.8.04.1 failed to install/upgrade: trying to overwrite `/usr/share/bug/firefox/presubj', which...

Read more...

Frantz (frantz-info) wrote :

Hello,

I use Ubuntu 8.04 Hardy Heron on my servers too.

I didn't have problem whith firefox-3.0_3.6.6+nobinonly-0ubuntu0.8.04.1_all.deb,
but this morning, I've updated my servers (aptitude update ; aptitude safe-upgrade)
and I've no more firefox installed !

# aptitude search firefox | grep -v ^p

 A firefox - safe and easy web browser from Mozilla
i firefox-3.0 - dummy upgrade package for firefox-3.0 -> f

And no firefox in /usr/bin

So I think that the new package firefox-3.0_3.6.6+nobinonly-0ubuntu0.8.04.2_all.deb
broke all :(

# tail /var/log/apt/term.log

Log started: 2010-07-01 08:27:29
(Lecture de la base de données... 31297 fichiers et répertoires déjà installés.)
Préparation du remplacement de firefox-3.0 3.6.6+nobinonly-0ubuntu0.8.04.1 (en utilisant .../firefox-3.0_3.6.6+nobinonly-0ubuntu0.8.04.2_all.deb) ...
Dépaquetage de la mise à jour de firefox-3.0 ...

Chris Coulson (chrisccoulson) wrote :

This is fixed with 3.6.6+nobinonly-0ubuntu0.8.04.2 already. If you use update-manager to update then it should just upgrade you to the latest version without issues (I tested this to make sure it works). It will give you a warning about broken packages, and then proceed to update anyway.

People shouldn't still be having issues with this if they update to the latest version

On mine it left out the apturl file... I then reinstalled fire fox and the
apt url file was with that download and I have firefox..But it took 3
download attempts to finaly recive it

On Thu, Jul 1, 2010 at 2:55 AM, Chris Coulson
<email address hidden>wrote:

> This is fixed with 3.6.6+nobinonly-0ubuntu0.8.04.2 already. If you use
> update-manager to update then it should just upgrade you to the latest
> version without issues (I tested this to make sure it works). It will
> give you a warning about broken packages, and then proceed to update
> anyway.
>
> People shouldn't still be having issues with this if they update to the
> latest version
>
> --
> package firefox 3.0.19 nobinonly-0ubuntu0.8.04.1 failed to install/upgrade:
> trying to overwrite `/usr/share/bug/firefox/presubj', which is also in
> package firefox-2
> https://bugs.launchpad.net/bugs/600022
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “apturl” package in Ubuntu: Invalid
> Status in “firefox-3.0” package in Ubuntu: Invalid
> Status in “apturl” source package in Hardy: Fix Released
> Status in “firefox-3.0” source package in Hardy: Fix Released
>
> Bug description:
> Binary package hint: firefox-3.0
>
> E:
> /var/cache/apt/archives/firefox-branding_3.6.6+nobinonly-0ubuntu0.8.04.1_i386.deb:
> trying to overwrite `/usr/share/pixmaps/firefox.png', which is also in
> package firefox-2
> E:
> /var/cache/apt/archives/firefox_3.6.6+nobinonly-0ubuntu0.8.04.1_i386.deb:
> trying to overwrite `/usr/share/bug/firefox/presubj', which is also in
> package firefox-2
>
> I'm using Ubuntu 8.04 Hardy Heron
>
> ProblemType: Package
> Architecture: i386
> Date: Tue Jun 29 19:26:42 2010
> Dependencies:
> firefox-3.0 3.6.6+nobinonly-0ubuntu0.8.04.1
> firefox 3.0.19+nobinonly-0ubuntu0.8.04.1
> DistroRelease: Ubuntu 8.04
> ErrorMessage: trying to overwrite `/usr/share/bug/firefox/presubj', which
> is also in package firefox-2
> NonfreeKernelModules: nvidia
> Package: firefox 3.0.19+nobinonly-0ubuntu0.8.04.1
> PackageArchitecture: i386
> SourcePackage: firefox-3.0
> Title: package firefox 3.0.19+nobinonly-0ubuntu0.8.04.1 failed to
> install/upgrade: trying to overwrite `/usr/share/bug/firefox/presubj', which
> is also in package firefox-2
> Uname: Linux 2.6.24-24-generic i686
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/apturl/+bug/600022/+subscribe
>

Clara Smith (sclara76) on 2010-07-05
Changed in apturl (Ubuntu Hardy):
status: Fix Released → Confirmed
Changed in firefox-3.0 (Ubuntu Hardy):
status: Fix Released → Confirmed
status: Confirmed → Fix Committed
Changed in apturl (Ubuntu Hardy):
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Changed in firefox-3.0 (Ubuntu Hardy):
status: Fix Committed → Fix Released
Changed in firefox-3.0 (Ubuntu):
status: Invalid → Confirmed
Changed in apturl (Ubuntu):
status: Invalid → Confirmed
Changed in firefox-3.0 (Ubuntu):
status: Confirmed → Incomplete
Changed in apturl (Ubuntu):
status: Confirmed → Fix Released
Changed in firefox-3.0 (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers