Runescape/Jaunty incompatibility

Bug #371676 reported by Bob H on 2009-05-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Players of Runescape, an online game, can now only play in a 'crippled' mode after upgrading to Jaunty.

This has been reported on Runescape Forums by players who use Ubuntu & Kubuntu Jaunty.

The bug doesn't seem to be hardware related, it appears to be something which has appeared after an install or upgrade to Jaunty.

No players are reporting that Jaunty is working OK in this respect for them.

Some players have reported that removing Jaunty and reinstalling Intrepid solves the problem for them.

The high definition mode in Runescape, which was fully functional in Intrepid, no longer functions in Jaunty, it simply produces a browser crash.

Although I have seen this bug reported as an OpenGL bug, I do not have the expertise to confirm that.

I would be pleased to collaborate in finding a speedy solution to this problem, which has been around for at least a month now.

further details:

Browser: firefox 3.0 (though this bug has been reported by players using other browsers)
Plugin: Sun Java 6 update 13 (this bug has been reported for other versions of Sun Java
CPU: AMD Athlon dual core (this bug has also been reported for Intel processors)
GPU: nVidia GForce 9500 GT (this bug has been reported for other GPU's)

On starting the free web browser game, Runescape, at http://www.runescape.com, it is impossible to enable High Definition mode. Any attempt to enable this mode crashes the browser. This bug has occurred after an upgrade to Jaunty from Intrepid.

There was no bug before the upgrade.

This bug severely cripples gameplay.

*addition*

Jagex's Runescape issued a patch that resolved this problem. The problem appears to have been with the game's Java.

I do not know how to close a bug.

So I announce that it is closed here.

bob

Brian Murray (brian-murray) wrote :

I'm guessing this is the website http://www.runescape.com although it wasn't explicitly stated. Additionally, since the browser crashes I'm assigning it to the firefox-3.0. However, the browser being used wasn't identified either.

affects: ubuntu → firefox-3.0 (Ubuntu)

Yup - correct on both counts.

Also I'm using Sun Java 6.

In looking for answers I have noted, the crash has occurred for other users
on other browsers, with various versions of Java, with a range of hardware
configuration.

The problem did not occur in Intrepid but was immediately apparent in
Jaunty.

As far as I know this problem affects all users of Jaunty & Runescape.

If there is more information that would help I would gladly supply whatever
I know.

If you go to the web page, start up the game, enter the graphics option &
enable 'High Definition' I am confident you will experience this crash.

2009/5/15 Brian Murray <email address hidden>

> I'm guessing this is the website http://www.runescape.com although it
> wasn't explicitly stated. Additionally, since the browser crashes I'm
> assigning it to the firefox-3.0. However, the browser being used wasn't
> identified either.
>
> ** Package changed: ubuntu => firefox-3.0 (Ubuntu)
>
> --
> Runescape/Jaunty incompatibility
> https://bugs.launchpad.net/bugs/371676
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Bob H (bobbicat) on 2009-05-19
description: updated
description: updated
Ryan Macnish (nisshh) wrote :

It definitely does not affect all jaunty users, i can play runescape just fine in low/high and fullscreen.

im using the sun java 6 plugin from add/remove.

Back when i had intrepid i had a few problems getting it working, all i did for my current install was to install the sun java 6 plugin package from add/remove, run the game and accept the certificate.

Now it plays fine on all 4 of my machines.

I have not had the same problem as what is stated in the description but i do suspect that its to do with a change from intrepid to jaunty.

Richard Carter (ricket) wrote :

As you went to write the comment, you should have seen the yellow box pop up stating "Remember, this bug report is a duplicate." As you can see at the duplicate bug's post (https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/355742), we've already noticed that it's since been fixed and that bug report has been all but closed.

Thanks though. You're right in that it was something special about Jaunty, but it was apparently Jagex's fault, as one of their recent updates fixed it.

If possible, this bug report should also be closed, along with any other duplicates of the original report.

Bob H (bobbicat) on 2009-08-30
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers