Firefox and epiphany won't start. "Bus error"

Bug #367706 reported by Kubismo on 2009-04-27
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Running Ubuntu 9.04 desktop AMD64 version on a fresh install.

Firefox was running fine after I first installed. After I did the initial update it won't load. Both Firefox and epiphany give "bus error" when loading from the console.

Other browsers and apps so far have no problem. I tried renaming the .mozilla folder and uninstalling/removing Firefox with no effect.

Kubismo (lee-hunter) on 2009-05-03
tags: added: amd64 bus error firefox jaunty
has (henrik-a-schultz) wrote :

Any progress on this? An OS without a web browser is seriously un-cool!
I'll survive with Opera, but some pages work better in FF.
And what if I hadn't installed Opera prior to the fatal upgrade?
I'm about to convert a small/medium sized business to Ubuntu, and most of our systems are delivered SOA-style through Firefox. If this had happened after the switch to Ubuntu they would have gone back to WIndows immediately and for ever. No discussion.

Please mark this bug high importance.
Within a week I'll start shopping new servers and terminals, and I'd hate to add Windows Server to that order.

Micah Gersten (micahg) wrote :

Would we be able to get an strace, please?
strace -f -eopen firefox 2>&1 | tee /tmp/ffox.log.txt
Please attach the log file /tmp/ffox.log.txt when done.

affects: firefox (Ubuntu) → firefox-3.0 (Ubuntu)
Changed in firefox-3.0 (Ubuntu):
status: New → Incomplete
has (henrik-a-schultz) wrote :

Here's the strace

D.Springer (kepler1) wrote :

I'm seeing this issue on sparc64 as well.

Alexander Sack (asac) wrote :

has, can you reproduce this on a LiveCD as well?

Alexander Sack (asac) wrote :

D. Springer, sparc is a different bug; there are alignment issues that can lead to Bus Errors; however, amd64 and i386 architectures its really rare to see Bus Errors ... and those often are caused by hardware issues.

has, besides from testing liveCD, what graphics driver and chipset are you using? Also, are you sure your upgrade to jaunty finished properly? Maybe you are stuck half-through the upgrade. does running sudo apt-get update; sudo apt-get dist-upgrade bring any new packages? Also, how does your sources.list look like (please attach)? Are you using any third party archives?

has (henrik-a-schultz) wrote :

Alexander : Can I do an upgrade on a LiveCD? Don't think so?
Firefox worked flawlessly before the apt-get update/upgrade, so it was the update that killed my Jaunty system

Anyways, here is my hardware (lshw -short) attached. It's a Lenovo SL300.

has (henrik-a-schultz) wrote :

Alexander : Can I do an upgrade on a LiveCD? Don't think so?
Firefox worked flawlessly before the apt-get update/upgrade, so it was the update that killed my Jaunty system

Anyways, here is my hardware (lshw -short) attached. It's a Lenovo SL300.

has (henrik-a-schultz) wrote :

Here's the packages on my system (apt-show-versions).
Sorry about the double post above, launchpad had som kind of hiccup and I pushed reload a little to quick :-P

has (henrik-a-schultz) wrote :

And finally, my sources list. I've added backports and proposed recently to try to remedy the FF issues with spanking fresh packages. No such luck.

Alexander Sack (asac) wrote :

> Anyways, here is my hardware (lshw -short) attached. It's a Lenovo SL300.
what driver/chipset is that using?

Alexander Sack (asac) wrote :

> Alexander : Can I do an upgrade on a LiveCD? Don't think so?

So far we haven't received many complains here - so this does seem to be something corner-casish.

Thats why I think it would still be worth to check whether it works with the LiveCDs ... thats pretty much the easiest way to confirm that there is nothing messed up with your upgrade etc.

mrtvfuencxozd (mrtvfuencxozd) wrote :

I had the same problem here (Ubuntu 9.04 desktop 32bits)
I downgraded xulrunner from 1.9.0.11 to 1.9.0.8
now firefox starts

Lars Noodén (larsnooden) wrote :

I have the bus error problem also, firefox does not start.

I notice a second problem, that the error does not seem to get logged anywhere either in /var/log/ or in my home directory.

Linux mini 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"

Attached is systrace output

$ strace -f -eopen firefox 2>&1 | tee /tmp/ffox.log.txt

Gareth Jones (gareth-k-jones) wrote :

Ditto.

This is Jaunty 9.04, but this time on x86-32 (Pentium 4 with hyper-threading).

Firefox etc. used to work fine until I ran the updates this morning, having been away from the office for a week without updating. The system locked up during the kernel update (mouse not moving, Ctrl+Alt+F1 no use etc.). After magic SysRq-s,u,b, I ran dpkg --configure -a or similar, as requested by Synaptic. dpkg failed with an error (attached, as part of it at least relates to this bug).

Anyway, I have a system with no nVidia driver (kernel headers are failing to install due to an executable format error, probably not related), and no web access because the new xulrunner is giving a bus error.

Attached is the Firefox strace, command as above.

Gareth Jones (gareth-k-jones) wrote :

And here is the dpkg log. The first error is related to this bug I think.

I've tried reinstalling the packages list at the end of the log from Synaptic (after clearing the package cache), but that hasn't helped.

I'll provide more info if it'll help (but this is a work machine so I can't do anything too drastic, or put off reinstallation or such too long).

Micah Gersten (micahg) wrote :

Thank you, could you please try reinstalling Firefox and Xulrunner:
sudo apt-get --reinstall install firefox-3.0 xulrunner-1.9

Gareth Jones (gareth-k-jones) wrote :

I've already tried that here in Synaptic, but here's a log of apt-get's output when run from a terminal. The problem persists.

I'm going to try a straight reinstall and update, because at the moment I can't tell if this is a bug in the xulrunner package, or an artefact of some sort of corruption due to the crash. I suspect there may be multiple issues on this machine at the moment, so it'll be more useful if I can separate them.

Gareth Jones (gareth-k-jones) wrote :

Okay, a clean reinstall from the CD fixed all the errors. I then installed the updates, no crash this time, and they all succeeded. The latest Firefox/xulrunner now runs normally. /home is on a separate partition and was not touched by the reinstall, so I should be using the same user-configuration files as before.

In my case I think there must have been some file corruption, although which file would apparently only affect xulrunner, and yet persist across reinstalls of the Mozilla packages, I've no idea. The other possibility is that some in-between updates that were skipped this time somehow affected the update process, which could explain why some other people are seeing the bus error.

Not sure if this info is of any use to anyone, but there you go.

Micah Gersten (micahg) wrote :

@has, @kubismo
Can you try the following to see if it fixes your problem?
sudo apt-get --reinstall install firefox-3.0 xulrunner-1.9

@Gareth Jones
Well, at least we know it was a problem with the program files and not the profile.
Thanks for the update.

syntap (wrouck-syntap) wrote :

Ubuntu 9.04 desktop AMD64. mrtvfuencxozd 's solution of downgrading xulrunner from 1.9.0.11 to 1.9.0.8 fixed it for me.

This morning I had a hang in the middle of an update so that probably had a good deal to do with it. all apt-get suggestions for reinstalling firefox didn't work, but the above via synaptic package manager ended up getting it going again.

Symptoms of the problem were the same as mentioned by others... try to load Firefox normally and the load aborts with no error. Running firefox from terminal window shows "bus error."

Dimpoc (robbiewhitmore) wrote :

Thanks guys i was getting bus error in the terminal when trying to run firefox 3.5, so i reinstalled firefox 3.5 and xulrunner 1.9 (in synaptic) and firefox runs again now.

Launchpad Janitor (janitor) wrote :

[Expired for firefox-3.0 (Ubuntu) because there has been no activity for 60 days.]

Changed in firefox-3.0 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers