MASTER support to select apps without recommends in app-install-data

Bug #292403 reported by Greg Coit on 2008-11-02
92
This bug affects 8 people
Affects Status Importance Assigned to Milestone
adept (Ubuntu)
Wishlist
Unassigned
app-install-data-ubuntu (Ubuntu)
Wishlist
Unassigned
apt (Ubuntu)
Undecided
Unassigned
aptitude (Ubuntu)
Undecided
Unassigned
firefox-3.0 (Ubuntu)
Medium
Unassigned
gnome-app-install (Ubuntu)
Wishlist
Unassigned
packagekit (Ubuntu)
Undecided
Unassigned
smart (Ubuntu)
Undecided
Unassigned
synaptic (Ubuntu)
Undecided
Unassigned
update-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

Now that recommends get installed by default it would be nice to add the ability to select packages to be installed without recommends in high-level- application managers and the meta data package (apt-install-data).

This would allow distributions to provide easy installation of stripped down applications ... as in the case of gnome-support for firefox.

=======

Installing Firefox 3.03 on a new Kubuntu 8.10 install using adept requires installing some gnome files (not just gtk files). It appears that firefox has been compiled with a gnome use flag.

Alexander Sack (asac) wrote :

firefox recommends -gnome-support ... as it simply best works with it. Its not a hard depend and kde users probably dont want to install it. THis is not a bug.

Changed in firefox-3.0:
status: New → Invalid
Greg Coit (gregcoit) wrote :

Alexander, I *think* you are saying the following 2 things:

"it is not a hard depend" - one can install firefox in kubuntu 8.10 using adept without installing gnome files? If true, this is not obvious to me. Selecting Firefox Web Browser (3.0.3+nobinonly-0ubuntu2) in adept on a clean install of Kubuntu 8.10 forces the following files to be selected for install:

gnome-keyring
liblaunchpad-integration1
libglib-perl
python-gst0.10
notification-deamon
libgnomevfs2-0
libgnome2-0
gamin
libgtop2-common
libgnomeui-common
libgnome-keyring0
ubufox
xulrunner-1.9
scrollkeeper
docbook-xml
libpam-gnome-keyring
python-numeric
liubbonoboui2-0
gconf2
libwnck-common
libgnome2-perl
python-pyorbit
libnotify1
python-gconf
libgamin0
python-gtkhtml2
libwnck22
libsexy2
libgconf2-4
libxres1
libgp11-0
libgnome2-common
libstartup-notification0
libgnome2-vfs-perl
libgnomecanvas2-0
python-glade2
libpolkit-gnome0
python-sexy
python-vte
libvte9
libgnomeui-0
libgtk2-perl
libidl0
libbonobo2-0
libglade2-0
gnome-app-install
apturl
libgtkhtml2-0
libgnomecanvas2-common
python-launchpad-integration
firefox-3.0
libgnomevfs2-extra
software-properties-gtk
libgtop2-7
synaptic
gksu
gnome-icon-theme
gnome-mime-data
liborbit2
policykit-gnome
libbonobo2-common
libgksu2-0
sgml-data
libavahi-glib1
libcairo-perl
firefox-3.0-branding
gnome-mount
libvte-common
libscrollkeeper0
librsvg2-common
python-gtk2
python-cairo
libgnome2-canvas-perl
libgnomevfs-2-common

"kde users proibably don't want to install it" - Meaning firefox? Firefox is far and away the most popular web browser for linux users. While konquerer is a good web browser, there are many of us who wish to use firefox and we should not have to install gnome to get it.

Greg Coit (gregcoit) wrote :

It's a bug when the most popular web browser requires a whole different window manager!

Changed in firefox-3.0:
status: Invalid → New
Alexander Sack (asac) wrote :

I dont know what adept does when you select firefox. try to sudo apt-get install --no-install-recommends firefox on the command line. if that pulls in gnome stuff thats a bug. otherwise its adept install-data issue or something.

still incomplete. please provide me with the asked information (even though this is a MASTER now)

Changed in firefox-3.0:
status: New → Incomplete
Greg Coit (gregcoit) wrote :

The command "sudo apt-get install --no-install-recommends firefox" installs:

firefox
firefox-3.0
firefox-3.0-branding
libidl0
libstartup-notification0
xulrunner-1.9

"sudo apt-get install firefox" installs:

apturl
docbook-xml
firefox
firefox-3.0
firefox-3.0-branding
gamin
gconf2
gconf2-common
gksu
gnome-app-install
gnome-icon-theme
gnome-keyring
gnome-mime-data
gnome-mount
libavahi-glib1
libbonobo2-0
libbonobo2-common
libbonoboui2-0
libbonoboui2-common
libcairo-perl
libgamin0
libgconf2-4
libgksu2-0
libglade2-0
libglib-perl
libgnome-keyring0
libgnome2-0
libgnome2-canvas-perl
libgnome2-common
libgnome2-perl
libgnome2-vfs-perl
libgnomecanvas2-0
libgnomecanvas2-common
libgnomeui-0
libgnomeui-common
libgnomevfs2-0
libgnomevfs2-common
libgnomevfs2-extra
libgp11-0
libgtk2-perl
libgtkhtml2-0
libgtop2-7
libgtop2-common
libidl0
liblaunchpad-integration1
libnotify1
liborbit2
libpam-gnome-keyring
libpolkit-gnome0
librsvg2-common
libscrollkeeper0
libsexy2
libstartup-notification0
libvte-common
libvte9
libwnck-common
libwnck22
libxres1
notification-daemon
policykit-gnome
python-cairo
python-gconf
python-glade2
python-gst0.10
python-gtk2
python-gtkhtml2
python-launchpad-integration
python-numeric
python-pyorbit
python-sexy
python-vte
scrollkeeper
sgml-data
software-properties-gtk
synaptic
ubufox
xulrunner-1.9

So, there *is* a way to install firefox w/o installing gnome - that's great (And thanks!!!!). I wouldn't call it abvious in any way....

Alexander Sack (asac) wrote :

adept should fix its install data then.

Changed in firefox-3.0:
importance: Undecided → Medium
status: Incomplete → Triaged
Sel Goona (alieneye) wrote :

All we need is to remove "ubufox" as Firefox dependency. Ubunfox is anyway a completely unnecessary Extension.

Firefox need ubufox, ubufox need apturl, apturl need synaptic ... an so on ....

Russell Ault (russell-ault) wrote :

I'm not sure I quite understand why this is happening; ubufox is still just listed as a "recommended" and not a true dependency. Is the new apt-get default behaviour to install recommended packages as well?

Harald Sitter (apachelogger) wrote :

http://www.debian.org/doc/debian-policy/ch-relationships.html

Recommends
This declares a strong, but not absolute, dependency.
The Recommends field should list packages that would be found together with this one in all but unusual installations.

Suggests
This is used to declare that one package may be more useful with one or more others. Using this field tells the packaging system and the user that the listed packages are related to this one and can perhaps enhance its usefulness, but that installing this one without them is perfectly reasonable.

I am not sure how I should justify that I bounce this bug back to firefox, so I'll just leave you 2 possible reasons:
a) Kubuntu is _NOT_ an unusual installation - that would be the 'political' reason
b) as Alexander said himself "firefox recommends -gnome-support ... as it simply best works with it" which is exactly the usecase described for the Suggests relation (same applies for the ubufox recommends) - that would be the 'firefox-3.0-doesnt-follow-debian-policy' reason

Alexander Sack (asac) wrote :

adding adept. setting firefox 3 to wont fix. if you think adept shouldnt add a hack for kde users thats fine. Its just nothing i will change in firefox. not installing -gnome-support will make a bunch of features disappear ... suggest is not good enough. similar to ubufox. its a core ubuntu component and not just a suggest.

Changed in firefox-3.0:
status: Triaged → Won't Fix
Alexander Sack (asac) wrote :

"as it simply best works with it" ... -> recommends. its more or less essential to get a complete firefox experience ... not an optional addon.

political -> kde is an unusual install as they dont have the gnome libs. we support that by not putting gnome stuff into firefox package, but in a recommends. if kubuntu doesnt want to use that option its their choice.

Scott Kitterman (kitterman) wrote :

Since Firefox is part of the Ubuntu default install, how about (for Jaunty) dropping ubufox to suggests and seeding it directly for Ubuntu?

Harald Sitter (apachelogger) wrote :

We aren't sure about the affect on update-manager.
[18:55:05] <apachelogger> JontheEchidna: would update-manager actually install the recommends?
[18:55:22] -*- apachelogger isn't too sure about that
[18:55:28] <JontheEchidna> perhaps if firefox got dragged in as a new package that needed to be installed

I think we all need to realize there are differences between gtk as a toolkit and gnome as a desktop environment and what constitutes a reasonable "requirement" to have a strong relationship which forces one to install a gnome dep for an app which is supposed to be gtk based and desktop agnostic. If the app is not truly desktop agnostic, I would understand, but it is supposed to be.

Perhaps some meta package magic would help. For a gnome desktop experience, seeding a meta package in the gnome-desktop (or similar) to pull in the extra bits seems much better than cramming everything down the pipe to users of Xfce, KDE, etc.

Only my 2 cents though as an observer.

James Westby (james-w) wrote :

Alexander, you are proposing that every package management tool
adds a special case to not install -gnome-support and ubufox when
installing firefox and "on kde"?

I'm not sure exactly what features these provide, but I would tend to
agree with ScottK. If a KDE user installs firefox without -gnome-support
and ubufox, what do they miss out on?

Thanks,

James

The issue is that ubufox deps on apturl which in itself is a Gnome app and requires a lot of gnome deps. Instead, it would be better if ubufox had alternatives it could call for apturl (possibly install-package for KDE) and let either/or satisfy the dep in ubufox.

So, this perhaps then is not a issue specific to firefox, but rather one exposed through firefox as it deps on ubufox, which is Gnome centric (at the moment at least)

Michael Vogt (mvo) wrote :

Why is there now a open task for every package manager we have in ubuntu? What exactly is the task for them here?

Alexander Sack (asac) wrote :

all package tools that can --no-install-recommends are ok.

Changed in apt:
status: New → Invalid
Changed in aptitude:
status: New → Invalid
Alexander Sack (asac) wrote :

i assume packagekit can --no-install-recommends.

Changed in packagekit:
status: New → Invalid
Changed in synaptic:
status: New → Invalid
Changed in smart:
status: New → Invalid
Alexander Sack (asac) on 2008-11-04
Changed in adept:
importance: Undecided → Wishlist
status: New → Confirmed
Alexander Sack (asac) wrote :

apturl for KDE support bug is:

  "#227622 apturl protocol support for KDE"

Changed in update-manager:
importance: Undecided → Wishlist
status: New → Confirmed
description: updated
Changed in app-install-data-ubuntu:
importance: Undecided → Wishlist
status: New → Confirmed
Alexander Sack (asac) on 2008-11-04
Changed in gnome-app-install:
status: New → Confirmed
importance: Undecided → Wishlist
Changed in update-manager:
status: Confirmed → Triaged
Changed in gnome-app-install:
status: Confirmed → Triaged
Changed in app-install-data-ubuntu:
status: Confirmed → Triaged
Changed in adept:
status: Confirmed → Triaged
Alexander Sack (asac) wrote :

created firefox bug 293530:

  #293530 - ship gnome-support binaries in default firefox package, but without explicit gnome depends

Alexander Sack (asac) wrote :

a more specific bug for apturl file:

 bug #293533: Better KDE (non-gnome) support for apturl

Jonathan Thomas (echidnaman) wrote :

Unfortunately, Adept has been unmaintained by its original authors for several years, and nobody has stepped up to continue its development. (Though the Muon Suite is arguably its spiritual successor) As such, Adept has been removed from releases of Kubuntu from 12.10 onwards, and no additional improvements will be made to the software.

We thank you for reporting this bug all the same, and apologize for taking so long to respond to it.

Changed in adept (Ubuntu):
status: Triaged → Won't Fix
Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in gnome-app-install (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers