auto scroll icon in print preview doesn't appear at mouse position

Bug #286853 reported by cumulus007 on 2008-10-21
2
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Invalid
Medium
firefox-3.0 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: firefox-3.0

When opening a print preview in Firefox 3.03 and clicking on the scroll button, when auto scroll is enabled, the auto scroll icon appears, but not at the mouse position.

To reproduce:
Step 1: Start Firefox

If auto scroll is not enabled, do so:

Step 2: Go to Edit > Preferences

Step 3: Go to the Advanced tab and select "use auto scroll"

Now, press the middle mouse button to test auto scroll. The auto scroll icon should appear at the position of the mouse cursor.

Step 4: Go to File > Print Preview and use the auto scroll function. You'll see that the auto scroll icon won't appear at the position of the mouse cursor.

http://img133.imageshack.us/img133/8162/schermafdrukcd2.png

ProblemType: Bug
Architecture: i386
Date: Tue Oct 21 09:59:56 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: nvidia
Package: firefox-3.0 3.0.3+build1+nobinonly-0ubuntu0.8.04.1
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.24-16-generic i686

To explain, the autoscroll code was changed, to use a popup now (bug 242621), that's the reason why this bug has shown up just recently

Gavin, I looked at this yesterday, and given bug 373091 I was assuming this is not a bug in any code I touched.

*** Bug 385884 has been marked as a duplicate of this bug. ***

Created attachment 269828
Block autoscroll marker on print preview

I think this is the best we can do for now.

(In reply to comment #4)
> Created an attachment (id=269828) [details]
> Disable autoscroll on print preview
>
> I think this is the best we can do for now.
>

1) I can't get any autoscroll on print preview in SM or Fx. Does it really exist?
2) If the positioning is wrong, I'd rather fix it. I can't do that if I can't figure out how to activate it ;)

(In reply to comment #5)
> (In reply to comment #4)
> > Created an attachment (id=269828) [details] [details]
> > Disable autoscroll on print preview
> >
> > I think this is the best we can do for now.
> >
>
> 1) I can't get any autoscroll on print preview in SM or Fx. Does it really
> exist?
> 2) If the positioning is wrong, I'd rather fix it. I can't do that if I can't
> figure out how to activate it ;)
>

Well, no it doesn't really exist, see my dupe. :) The correct title really should be disable autoscroll _marker_, because when you try to autoscroll under Print Preview it will scroll the original page, not the print preview (so when you close PP, the page is at a different scroll position).

PP can't receive autoscroll commands because it isn't part of the browser widget, so just totally blocking autoscroll is the only thig I can think of.

Yeah, that's my fault :( The whole thing is a real mess, though. I was hoping to rewrite print preview to make it sane at some point, but I didn't have the time for 1.9.

(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > Created an attachment (id=269828) [details] [details] [details]
> > > Disable autoscroll on print preview
> > >
> > > I think this is the best we can do for now.
> > >
> >
> > 1) I can't get any autoscroll on print preview in SM or Fx. Does it really
> > exist?
> > 2) If the positioning is wrong, I'd rather fix it. I can't do that if I can't
> > figure out how to activate it ;)
> >
>
> Well, no it doesn't really exist, see my dupe. :) The correct title really
> should be disable autoscroll _marker_, because when you try to autoscroll under
> Print Preview it will scroll the original page, not the print preview (so when
> you close PP, the page is at a different scroll position).

You mean, start autoscroll, then somehow print preview while still scrolling? I checked whether the page scrolled if I acted like I was autoscrolling on the print preview, and it didn't... I must still be missing something.

(In reply to comment #8)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > (In reply to comment #4)
> > > > Created an attachment (id=269828) [details] [details] [details] [details]
> > > > Disable autoscroll on print preview
> > > >
> > > > I think this is the best we can do for now.
> > > >
> > >
> > > 1) I can't get any autoscroll on print preview in SM or Fx. Does it really
> > > exist?
> > > 2) If the positioning is wrong, I'd rather fix it. I can't do that if I can't
> > > figure out how to activate it ;)
> > >
> >
> > Well, no it doesn't really exist, see my dupe. :) The correct title really
> > should be disable autoscroll _marker_, because when you try to autoscroll under
> > Print Preview it will scroll the original page, not the print preview (so when
> > you close PP, the page is at a different scroll position).
>
> You mean, start autoscroll, then somehow print preview while still scrolling?
> I checked whether the page scrolled if I acted like I was autoscrolling on the
> print preview, and it didn't... I must still be missing something.
>

No: open print preview, start autoscroll, move mouse, notice that preview doesn't scroll, cancel autoscroll, close print preview, notice that original page is in different scroll position.

I can't reproduce that in FF2, SeaMonkey 1.1, or SeaMonkey trunk. In SeaMonkey, it scrolls to the top when I close print preview, whether or not I click the middle mouse button.

Comment on attachment 269828
Block autoscroll marker on print preview

I cannot this since non-native printpreview is disabled on mac. CTho (if he manages to reproduce this; mpa=me) or gavin should review this.

That said, this seems like a work around for bug 373091 which is a trunk-only regression. Please land this only if we cannot get a resolution there before beta-time.

(In reply to comment #10)
> I can't reproduce that in FF2, SeaMonkey 1.1, or SeaMonkey trunk. In
> SeaMonkey, it scrolls to the top when I close print preview, whether or not I
> click the middle mouse button.

But you didn't try in Firefox trunk, the only place I can reproduce this ;)

(In reply to comment #11)
> (From update of attachment 269828 [details])
> That said, this seems like a work around for bug 373091 which is a trunk-only
> regression. Please land this only if we cannot get a resolution there before
> beta-time.

Not really, the icon isn't the only problem. The actual scrolling doesn't work too, since the scrolling commands are sent to the original page instead of the print preview. Disabling autoscroll during print preview seems like the easiest way out especially at this stage of the schedule, and the current quality (or lack thereof) of the print codebase.

> But you didn't try in Firefox trunk, the only place I can reproduce this ;)

Ah, I can reproduce it there :) I guess we can land this as Mano specified, but could you file another bug on re-enabling it and getting it to work properly (and cc me)?

Created attachment 319871
patch?

This fixes it, but it makes the print preview page even smaller than it already is.

Created attachment 319872
this makes the print preview page a decent size again

Comment on attachment 319871
patch?

that line is there for a reason. Why do you think this is the right thing to do?

cumulus007 (cumulus-007) wrote :

Binary package hint: firefox-3.0

When opening a print preview in Firefox 3.03 and clicking on the scroll button, when auto scroll is enabled, the auto scroll icon appears, but not at the mouse position.

ProblemType: Bug
Architecture: i386
Date: Tue Oct 21 09:59:56 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: nvidia
Package: firefox-3.0 3.0.3+build1+nobinonly-0ubuntu0.8.04.1
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.24-16-generic i686

cumulus007 (cumulus-007) wrote :
Alexander Sack (asac) wrote :

please provide a step by step instruction how to reproduce. also consider to attach screenshots.

Changed in firefox-3.0:
status: New → Incomplete
cumulus007 (cumulus-007) wrote :

Okay.

Step 1: Start Firefox

If auto scroll is not enabled, do so:

Step 2: Go to Edit > Preferences

Step 3: Go to the Advanced tab and select "use auto scroll"

Now, press the middle mouse button to test auto scroll. The auto scroll icon should appear at the position of the mouse cursor.

Step 4: Go to File > Print Preview and use the auto scroll function. You'll see that the auto scroll icon won't appear at the position of the mouse cursor.

http://img133.imageshack.us/img133/8162/schermafdrukcd2.png

Alexander Sack (asac) wrote :

ok thanks.

this is best dealt upstream as its not a ubuntu specific issue. Please search in bugzilla.mozilla.org to ensure that your bug isn't filed; then open a bug in bugzilla.mozilla.org and post your bug id (or the one you found matching your issue) here. Thanks!

description: updated
Changed in firefox-3.0:
importance: Undecided → Low
status: Incomplete → Triaged
Alexander Sack (asac) wrote :
Changed in firefox:
importance: Undecided → Unknown
status: New → Unknown
Changed in firefox:
status: Unknown → Confirmed
Changed in firefox:
importance: Unknown → Medium

*** Bug 639309 has been marked as a duplicate of this bug. ***

*** Bug 850831 has been marked as a duplicate of this bug. ***

Changed in firefox:
status: Confirmed → Invalid
Changed in firefox:
status: Invalid → Confirmed
Changed in firefox:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.