Have firefox ask user to exit firefox *BEFORE* updating.

Bug #274468 reported by Derek on 2008-09-25
6
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: firefox

It would be nice if the firefox package prompted the user to quit firefox before installing itself.

Every firefox update (and seemingly more frequently) irc://irc.mozilla.org/firefox gets a few people whose profile was screwed up by the update.

Typically, this is easily solved by wiping localstore.rdf - but of course what would help prevent these in the first place seems to me to be making sure they aren't in firefox when the update is applied.

The windows updater does that - it applies the update after firefox was shut down.

Related to this is the issue that the firefox package does not create an:
Applications->Internet->Firefox (Safe Mode) desktop entry as does the windows one, so we have to explain to explain to ubuntu users how to run Safe Mode to recover their profile.

Derek (bugs-m8y) wrote :

I'd like to emphasise that this issue is not typical, but there often seem to be a few after each update.

Also, there are some people who managed to miss the informational notice, then get panicky when their browser starts causing weird errors. This would also avoid that behaviour.

Derek (bugs-m8y) wrote :

Elaboration, it'd be nice if perhaps it opened up one of those handy dialogs on install, asking the person to exit firefox, and telling them that firefox would be shut down for all users (there might be others on the machine) after they hit Next.
They hit Next, a kill is issued, the install proceeds, done.

Daniel Hollocher (chogydan) wrote :

I was talking with Derek on IRC about this, where I agreed, and I've had a change of heart regarding this issue after reading this: http://kb.mozillazine.org/Corrupt_localstore.rdf

It seems like that an update is not the only way localstore can get corrupted, and it looks like the ff people regard this as a bug on their end.

So, Im unsure. I had so many opinions on this, and they were all wrong. Yay for humility! Anyway, now I wonder why localstore is used to store so many settings. Why not store your bookmarks in... say.... bookmarks.rdf? and toolbars in toolbars.rdf? I mean, you got a whole folder for the profile. That way, if one gets corrupted, it doesnt drag down the rest.

Anyway, it looks like the best solution would be to track down the bug, and fix it.

Derek (bugs-m8y) wrote :

First off, this has been happening for a very very long time in mozilla, it seems unlikely the injection of ubuntu help will resolve things any time soon (although I could be wrong - certainly sqllite has taken over in other portions of the mozilla profile).

Secondly, I don't see this as just a localstore.rdf issue. The fact of replacing mozilla behind its back does cause the running firefox to behave oddly (File->Quit may not work, weird error dialogs may pop up) which is disconcerting to the users.
And there may be other effects. I don't see the harm in shutting it down beforehand instead of afterwards, and I see some immediate benefits.

Derek (bugs-m8y) wrote :

After reviewing bug #270303 I argue this close as duplicate was invalid.

bug #270303 was more about notification message issues, not about the more general issue of people ending up with corrupt profiles that seems related to firefox being updated out from under the existing session(s).

But. Whatever, the bug hadn't spawned much interest anyway.

Could be closed as WONTFIX just as easily I guess.

Jarno Suni (jarnos) wrote :

I agree that this is not a duplicate of #270303.

Jarno Suni (jarnos) wrote :

There is an older bug report about some problems that show up because firefox is updated while it is running: Bug 252548

Changed in firefox (Ubuntu):
importance: Undecided → Wishlist
John Vivirito (gnomefreak) wrote :

I see one problem with this feature.
What if you are in the middle of something when you start updating (multitasking)
This is one reason why we prompt you after to restart.

affects: firefox (Ubuntu) → firefox-3.0 (Ubuntu)
Changed in firefox-3.0 (Ubuntu):
status: New → Confirmed
Derek (bugs-m8y) wrote :

In response to John Vivirito's comment #9 - obviously the prompt to close *BEFORE* executing the update would have minimal impact on multitasking.
Imagine you have 9 updates, and firefox is, say, 7th of 9.
The prompt would only trigger on launch of the 7th update, the firefox one, in a similar fashion to click through license agreements for proprietary software. At that point you would indeed have to halt your "multitasking"
But in the current layout you have to do that anyway only seconds later as soon as that unpack of #7 is complete - if you don't, Firefox starts behaving unpredictably.

In short, this doesn't really improve the user experience at all, and has clear negative impacts in confusing users, and even causing profiles to fail.

Both of these make for a worse experience in Firefox updates under Ubuntu, than when Firefox updates are handled by Firefox (say under OSX or Windows or just the user launching their own Firefox)

Jarno Suni (jarnos) wrote :

I wonder what makes Firefox so special as for updating. I have not had similar problems with other software. Anyway, I guess Ubuntuzilla could be a workaround and would let you get updates sooner after their release.

Derek (bugs-m8y) wrote :

With regards to comment #11 - the idea of halting an application while updating it is not unusual for daemons.
Databases, whatever.

In this case the concept is the same. There are a number of resources on the file system referenced by the application and the profile and the profile data stores that can be made inconsistent by the current system.

Comment #11 attempts to make this a Mozilla issue. It is not. It is just common sense for any large, complex, software that may reference replaced resources while running.

In fact, if this was *NOT* the case for Firefox, a prompt message to restart it would not be needed. The whole reason a prompt is needed is that as Firefox loads things that got replaced, the application starts to degrade.

This is clearly suboptimal and I'm puzzled at the pushback over this simple solution.

Derek (bugs-m8y) wrote :

With Firefox 4 (natty), Firefox now handles much better the deletion of all its files out from under it, so this is much less of an issue. This can probably be closed now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers